Go Back   MacRumors Forums > iPhone, iPod, iPad, Apple Watch > iPod touch

Thread Tools Search this Thread Display Modes
Old Dec 2, 2010, 09:02 PM   #1
macrumors newbie
Join Date: Dec 2010
Cannot restore my iPod touch 3g "Software for this iPhone is not currently"


II have a big problem, I cannot restore my iPod touch 3G.

I cannot get anything to show on the screen, it seems stuck in DFU mode. When I connect it to my pc, iTunes show this message "iTunes has detected an iPhone in recovery mode. You must restore this iPhone before it can be used with iTunes".

"Check for update" is grayed. Capacity/serial/Software show N/A.

iTunes detects it as an iPhone but it's an iPod touch.
I tried 2 different computers.

I tried to download firmware and shift restore them, tried many, none work, telling it is not compatible.

When I click restore simply, it show this message "Software for this iPhone is not currently available".

I tried different ipod cable too, no luck.
The only way I can see something on the screen is with greenpoison (note that before this, I never tried nor wanted to jailbreak, but I tried a lot of things since 2 days including this, but no luck), so with green poison, I can get the iTunes + cable logo on the screen, but it won't restore either.
my iPod is just 1 year old, and 32gb, I'm rly frustrated and sad about all this :S, I tried lot of things, searched a lot, nothing work.

This happened when I came back from the gym, in my car, the iPod would not turn on, I tried again at home, and after some home/power, it turned on, I took a shower and when I came back, it was the same problem but since, it never turned on again.

Any help would be rly appreciated, thanks.
My os is windows 7
desort3 is offline   0 Reply With Quote
Old Dec 3, 2010, 11:00 PM   #2
macrumors regular
Join Date: Jun 2010
It could be a hardware problem, but first try these things:

If it is stuck in DFU mode, the program TinyUmbrella (google it) may be able to kick it out.

Otherwise, if you have an Apple store near you take it there and see if they can do anything with it. Of course don't mention the words "jailbreak" or "greenpois0n".
lanulos is offline   0 Reply With Quote
Old Dec 3, 2010, 11:38 PM   #3
Thread Starter
macrumors newbie
Join Date: Dec 2010
i tried tinyumbrella already, I open start ssh server but nothing come, I suspect my ipod is always in DFU, I can get it to recovery mode by using green poison and closing it at the right moment when I see itunes logo (because I can just use iRecovery while doing this, which didn't help too btw)

thanks for the answer anyway!

Last edited by desort3; Dec 4, 2010 at 03:17 AM.
desort3 is offline   0 Reply With Quote
Old Feb 2, 2011, 08:31 PM   #4
macrumors newbie
Join Date: Feb 2011
I do not know if you have resolved your problem, but I did, and had the exactly same issue... (described and screenshoted on the apple discussion forum here).
Today after about 50 days of inactivity/restoring tries (I had already given up and planned to buy a new one) i found my "unrestorable" iPod while reordering my room..
Just to do something ,I connected it to my mac.. and then....
I couldn't believe that, but the screen switched on with the red battery screen and after about 3 minutes , it just booted up, and everything was as I had left it, before that temporanydeath/crash issue..
I don't really understand how this thing can have happened , for over two months ago , when my iPod "died" i tried everything and when I say everything, I mean that.
7 Macs, 4 Windows pces ,reecboot,irecovery,tinyumbrella and many other tools but nothing worked..
On both OSX and Windows I always received a such (http://d.pr/KT5z) message on itunes and there was no way to fix it..
I do actually believe that some crash/bug into the dfu did make itunes to not recognize the iPod and as the DFU mode uses next no battery ,it just had stucked there for weeks...
And now, when finally the battery ran out, (it has been without charging aproximately 50 days) and i connected it again.. it did exit and reset from the dfu- or I don't know what, and the runned normaly..
I can't tell you how I did this as this whole thing happened without any action of mine ,but maybe try to let your ipod "stay still" for >30 days and then connect it again....

Ps: My iPod was jailbroken (4.0, jailbreakme) when it temporally "froze/died" without apparently no motive .
Pps: I cant believe to see my ipod working again, and are never been so happy before for an electronic device...
unixunderground is offline   0 Reply With Quote

MacRumors Forums > iPhone, iPod, iPad, Apple Watch > iPod touch

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
"Problem Downloading Software" when trying to Restore iPhone 5s Macinstache iPhone Tips, Help and Troubleshooting 1 Jan 2, 2014 03:46 PM
2$ USD for 4 iPhone, iPad or iPod Touch rear "Scratch Protectors" Cergman iPhone Accessories 3 Feb 25, 2013 08:22 PM
iPhone: Trying to restore, stuck on "Verifying iPhone restore with Apple" Luis2004 Jailbreaks and iOS Hacks 8 Feb 21, 2013 02:10 PM
"Set up as a new iphone" vs "Restore from backup of" curtisinoc iPhone 0 Sep 12, 2012 06:49 PM
Trying to Restore iPod Classic and Get "Can't Unmount Disk" Error mBurns iPod 4 Jun 29, 2012 10:03 AM

Forum Jump

All times are GMT -5. The time now is 05:41 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2015, MacRumors.com, LLC