Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Dec 6, 2010, 09:38 PM   #1
Satellitecentra
macrumors newbie
 
Join Date: May 2010
iPhone 4 no sound on calls

My wife's iPhone 4 (4 months old) suddenly today stopped making any sound when either making or receiving calls , what i mean to be clear is , you can make a call it connects and there is no sound from the ear piece or speaker and the called party can not hear anything.
It receives calls fine , but again , when you answer the call there is no sounds at all.
Its almost like the mic an speaker aren't working at all, but yet the phone functions perfectly in every other way , WiFi , ipod, email, everything works , and yes when its used to play music or video it works fine ?, just when making or receiving calls no sound at all
In other words Everything works BUT the actual phone , we took it to the local AT&T Store (Waste of time an effort ) just to be given the 800 number for Apple .
Spent an hour on the phone with Apple , tried all their suggestions , did a restore , but still nothing , they say it will have to sent back .
The phone is in Perfect condition , has been in a case from the min it was bought, has never been dropped or exposed to water damage , not even the slightest mark on any part, and as i said , everything works perfect , except for making an receiving calls
Just wondered has anyone else had anything like this happen ?
Satellitecentra is offline   0 Reply With Quote
Old Dec 7, 2010, 10:26 AM   #2
Satellitecentra
Thread Starter
macrumors newbie
 
Join Date: May 2010
No suggestions ?
Satellitecentra is offline   0 Reply With Quote
Old Dec 7, 2010, 10:32 AM   #3
Btrthnezr3
macrumors 6502a
 
Btrthnezr3's Avatar
 
Join Date: Aug 2010
Location: Texas
I would say do a restore.

If that doesn't help, take it to Apple.
__________________
iPhone 5, iMac, MBA
Btrthnezr3 is offline   0 Reply With Quote
Old Dec 7, 2010, 12:06 PM   #4
Satellitecentra
Thread Starter
macrumors newbie
 
Join Date: May 2010
Thanks for the reply , but that's one of the first things i did , in fact , i restored it twice now with the same result.

The unfortunate thing is i live at least 2 hours drive from the nearest Apple store :-( and between getting a day off work , a 4 hour round trip and gas its a real pain .
Local AT&T Store were completely USELESS, as expected
"Sorry don't know what to do , here is the Apple 800 number"
Satellitecentra is offline   0 Reply With Quote
Old Dec 7, 2010, 01:13 PM   #5
mikedj
macrumors newbie
 
Join Date: Nov 2010
Quote:
Originally Posted by Satellitecentra View Post
Thanks for the reply , but that's one of the first things i did , in fact , i restored it twice now with the same result.

The unfortunate thing is i live at least 2 hours drive from the nearest Apple store :-( and between getting a day off work , a 4 hour round trip and gas its a real pain .
Local AT&T Store were completely USELESS, as expected
"Sorry don't know what to do , here is the Apple 800 number"
try to restore you iphone if it dont fix the problem send to apple warranty at fast you can
mikedj is offline   0 Reply With Quote
Old Dec 25, 2010, 10:43 AM   #6
indieboy
macrumors newbie
 
Join Date: Dec 2010
Hey Satellitecentra!!!

The same thing has happened to me! Like you there has been no water damage or any other kind of damage! The mic/speaker has suddenly stopped working when making/receiving calls! I know this because last night I retrieved a voicemail before I went to bed. I woke up this morning and I had more voicemails from friends calling to wish me 'Merry Christmas' but the weird thing was I couldn't hear any connections. It was only when my partner called me I figured it was a handset issue!

I'm gonna have to take it in to the Apple store after Christmas but so annoying! What is also annoying is the amount of replies you've had saying to 'restore the factory defaults', I mean do these people not read? And they keep on posting it after you point out that you did...twice! I read wish some people would read, think, think, and think again before they reply sometimes.
indieboy is offline   0 Reply With Quote
Old Dec 25, 2010, 10:57 AM   #7
ssdeg7
macrumors 6502a
 
ssdeg7's Avatar
 
Join Date: Jul 2010
I would restore the iPhone, usually works.
__________________
wOzy Co-founder: http://wozy.co
----
MacBook Pro 15.4'', 2.53 GHz iPhone 4 16GB iPad Air 32GB iPod Touch 1G 8GB iPod Photo 20GB
ssdeg7 is offline   0 Reply With Quote
Old Dec 25, 2010, 11:19 AM   #8
indieboy
macrumors newbie
 
Join Date: Dec 2010
Quote:
Originally Posted by ssdeg7 View Post
I would restore the iPhone, usually works.
It's people like you that make forums a real pain or you just trying to be funny?
indieboy is offline   0 Reply With Quote
Old Dec 30, 2010, 05:22 PM   #9
xoselo
macrumors newbie
 
Join Date: Dec 2010
IPhone no sounds on calls

Hi guys, I have the exact problem you have with the IPhone 4. As you had this problem few days before me it is possible that you already found a solution other than restoring the factory settings or going to the Apple Store. My device is jailbroken so I would hesitate to take it to the Apple Store.
Anticipated thanks for your help in this issue.
xoselo is offline   0 Reply With Quote
Old Apr 20, 2011, 10:36 PM   #10
edwin32290
macrumors newbie
 
Join Date: Apr 2011
same problem!!

i have the same problem ! don't worry, i thought i was the only one ! i'm so glad u posted this up ! but as for me, i have my iPhone 4 jail-broken so i'm scared on taking to them !. i need a way to fix it !! and yes you're right restoring it does nothing but waste my time. some body plz help ..
edwin32290 is offline   0 Reply With Quote
Old May 17, 2011, 12:12 AM   #11
3goldens
macrumors 68000
 
3goldens's Avatar
 
Join Date: Feb 2008
same issue, obviously not a rampant problem with others. will try restore and then send to apple.
damm.
3goldens is offline   0 Reply With Quote
Old May 18, 2011, 11:39 AM   #12
raerae7979
macrumors newbie
 
Join Date: May 2011
no sound for in or outgoing calls

This just started on my phone today... The phone works perfectly except for the actually phone lol, no sound in or out... but music and all other options work fine,,,,
tried restore, going to update it when i get home... I'm hoping somebody was able to fix the problem but so far all the other posts do not end in a resolution... please let me know if there is a trick to this problem...


Thanks and Good luck to those with the same issue!
raerae7979 is offline   0 Reply With Quote
Old Sep 1, 2011, 03:10 PM   #13
jokojovani
macrumors newbie
 
Join Date: Sep 2011
Thumbs up Try the TSS server

I've tried a bunch of different so called solutions but this did the trick http://doubis.blogspot.com/2011/09/n...eakers-on.html
jokojovani is offline   0 Reply With Quote
Old Nov 30, 2011, 06:45 PM   #14
Boogsephine
macrumors regular
 
Join Date: Feb 2011
Location: Charlotte, NC
My phone just started doing this out of no where. I've had it for about a month and a half and it worked flawlessly until a few days ago.

I don't have many choices as I am using it with T-Mobile. I've rebooted the phone numerous times, tried the headphone trick and called my other phone at least 45 times trying to get this problem fixed.

The phone worked fine for the first 10 calls then started to have the issue after that and the problem happens every other time now.

I guess I'll have to go back to my Android phone for now because I can't miss important work calls or have to "call back" my DM when he calls.

It seems to be a software issue as my iPhone on 4.2x a few months back never had any issues what so ever. I'm trying to get my current device on iOS 5.x to see what happens but that isn't working out too well either.
__________________
27" iMac, 2.93GHz i7, 16GB of RAM, 1TB HD 15" MacBook Pro, 2.4 GHz i7, 8GB RAM, 750GB HD 8GB iPod Nano iPhone 5 (T-Mobile) Apple TV2 AirPort Extreme
Boogsephine is offline   0 Reply With Quote
Old Apr 4, 2012, 07:21 AM   #15
Farnzy
macrumors newbie
 
Join Date: Apr 2012
Fix

Hey there 90% of the time the issue is not software it is the audio chip on the mother board, that's why you cannot restore or update the phone to fix it. It can be fixed but u need to dismantle the phone to do so. If you feel up to pulling it apart to fix it let me know and I'll try and talk u through it I am new to this so I'm sorry if I don't respond as I didnt know if I had an email
Farnzy is offline   0 Reply With Quote
Old May 8, 2012, 02:15 PM   #16
cobunny
macrumors newbie
 
Join Date: May 2012
Red face What finally worked for me:

I posted this elsewhere (https://discussions.apple.com/thread...art=0&tstart=0) But as I had looked here for help initially I wanted to share what worked for me. Hope it helps.
I had all these same problems/symptoms. If, after receiving an incoming call or having someone pick up on an outgoing call, I hit the speakerphone button then I could complete the call with speakerphone. I spent three hours at the Apple store only to be told it was a hardware issue and that I could live with it or buy a new phone. I decided to live with it but it quickly became a pain to always have to use speakerphone with calls. If you have the same problem-I may have an answer. I tried EVERYTHING I found online and nothing worked for me until I found my answer by accident. I was trying to listen to a voice mail someone left when I realized I had the same problem for VM's as I did for calls. I hit the speaker button inside VM (upper right corner) so I could at least hear the VM. One day while listening to a VM this way I got really mad and hit the speaker button 4-5 times in a row as I was very angry! It ended on speaker off but as I went to hit the button again I could hear a little bit out of the earpiece! I quickly hit the sound up button on the side of the phone and turned the sound way up and it was working! It lasted about three calls and then stopped working again. When it stopped during a call I tried hitting the speaker button a few times on the keypad during the call but it didn't work so I finished the call on speaker. As soon as the call was over I went into VM, played an old VM and hit the speaker button there until it started working again. It took about 7 times but did work! This time it lasted over a wekk then I went through the whole process again. This third time has now lasted 2 months and is still working perfectly for me. I know this is long but if it works for anyone else it's worth it! I don't know why the speaker button on calls didn't fix it, only in VM and maybe it will be different for others, but I'm convinced it is some weird software issue and until they solve it, I have this little trick working for me. Good Luck!
cobunny is offline   0 Reply With Quote
Old May 12, 2012, 11:13 PM   #17
JohnCC
macrumors newbie
 
Join Date: May 2012
What worked for me - Cell Call, No Sound either way

I had no sound either way on cell calls (headphones, ear speaker, load speaker, external dock, bluetooth all nothing just silence) but every other sound app worked fine.
With thanks to a previous post here I focussed on the referenced audio chip. I found this link http://www.beijingiphonerepair.com/f...-other-people/
The paper/foam wedge didn't work but 5seconds heating the chip (to resolder it) did work.
JohnCC is offline   0 Reply With Quote
Old May 13, 2012, 01:25 PM   #18
tort11
macrumors newbie
 
Join Date: May 2012
Make sure the volume isnít turned down to the end and Make sure your external speakers or stereo are turned on and working properly.
tort11 is offline   0 Reply With Quote
Old Jun 8, 2012, 01:32 PM   #19
edgarinsky
macrumors newbie
 
Join Date: Feb 2011
Smile It Works!!!

Thanks! Just press the speaker button, several time. And VoilŠ!

Quote:
Originally Posted by cobunny View Post
I posted this elsewhere (https://discussions.apple.com/thread...art=0&tstart=0) But as I had looked here for help initially I wanted to share what worked for me. Hope it helps.
I had all these same problems/symptoms. If, after receiving an incoming call or having someone pick up on an outgoing call, I hit the speakerphone button then I could complete the call with speakerphone. I spent three hours at the Apple store only to be told it was a hardware issue and that I could live with it or buy a new phone. I decided to live with it but it quickly became a pain to always have to use speakerphone with calls. If you have the same problem-I may have an answer. I tried EVERYTHING I found online and nothing worked for me until I found my answer by accident. I was trying to listen to a voice mail someone left when I realized I had the same problem for VM's as I did for calls. I hit the speaker button inside VM (upper right corner) so I could at least hear the VM. One day while listening to a VM this way I got really mad and hit the speaker button 4-5 times in a row as I was very angry! It ended on speaker off but as I went to hit the button again I could hear a little bit out of the earpiece! I quickly hit the sound up button on the side of the phone and turned the sound way up and it was working! It lasted about three calls and then stopped working again. When it stopped during a call I tried hitting the speaker button a few times on the keypad during the call but it didn't work so I finished the call on speaker. As soon as the call was over I went into VM, played an old VM and hit the speaker button there until it started working again. It took about 7 times but did work! This time it lasted over a wekk then I went through the whole process again. This third time has now lasted 2 months and is still working perfectly for me. I know this is long but if it works for anyone else it's worth it! I don't know why the speaker button on calls didn't fix it, only in VM and maybe it will be different for others, but I'm convinced it is some weird software issue and until they solve it, I have this little trick working for me. Good Luck!
edgarinsky is offline   0 Reply With Quote
Old Jun 9, 2012, 06:14 AM   #20
scabioustona
macrumors newbie
 
Join Date: Jun 2012
Location: Canada
Quote:
Originally Posted by Satellitecentra View Post
My wife's iPhone 4 (4 months old) suddenly today stopped making any sound when either making or receiving calls , what i mean to be clear is , you can make a call it connects and there is no sound from the ear piece or speaker and the called party can not hear anything.
It receives calls fine , but again , when you answer the call there is no sounds at all.
Its almost like the mic an speaker aren't working at all, but yet the phone functions perfectly in every other way , WiFi , ipod, email, everything works , and yes when its used to play music or video it works fine ?, just when making or receiving calls no sound at all
In other words Everything works BUT the actual phone , we took it to the local AT&T Store (Waste of time an effort ) just to be given the 800 number for Apple .
Spent an hour on the phone with Apple , tried all their suggestions , did a restore , but still nothing , they say it will have to sent back .
The phone is in Perfect condition , has been in a case from the min it was bought, has never been dropped or exposed to water damage , not even the slightest mark on any part, and as i said , everything works perfect , except for making an receiving calls
Just wondered has anyone else had anything like this happen ?
I know this sounds obvious but have you upgraded to the latest iOS? I had the same problem but it went away when I upgraded to newest version.
scabioustona is offline   0 Reply With Quote
Old Jun 9, 2012, 08:37 AM   #21
transphasic
macrumors member
 
Join Date: Apr 2012
All these posts, and no solution - how come no one has tried to do a restore?


















Sorry, couldn't resist...
transphasic is offline   1 Reply With Quote
Old Jun 19, 2012, 08:36 PM   #22
Graue
macrumors newbie
 
Join Date: Jun 2012
This solved my problem and worked for me. Sounds weird but believe me it's true

when your iPhone is stuck in headphone mode (you can check by pressing the volume button and see if it displays "headphone volume" and if sound is only working with headphones) : Just suck the headphone jack as hard as you can and this will solve the problem.
Graue is offline   0 Reply With Quote
Old Dec 27, 2012, 02:51 AM   #23
ashutoshjack
macrumors newbie
 
Join Date: Dec 2012
No sound from earpiece while making/receiving Calls

Dear scabioustona, I also have the same problem as yours from last 2 days and while searching for a solution saw your post on the web.

I am using a iPhone 4 from last 1.5 years without any problem, recently I shifted to a new place and had to change the service provider, and then had problems with Signals coming and going at that point somebody advised me to get my iPhone factory unlocked to work with all the service providers and I did that a week back and the new service provider worked fine for a week.

I upgraded to new iOS 6.0.1 while getting it unlocked from JMunlocks.

Now since last 2 days I have this new issue where when I receive or make calls then there is no voice in earpiece as well as speaker, I connected the headphones as well but that also did not work.

Please let me know if you have been able to resolve this issue?

Thanks,
Jack..
ashutoshjack is offline   0 Reply With Quote
Old Jan 25, 2013, 03:33 PM   #24
PNutts
macrumors 601
 
PNutts's Avatar
 
Join Date: Jul 2008
Location: Pacific Northwest, US
A lot of folks have had problems taking calls via bluetooth handsfree. It depends on the make of the radio (or make of the car with the same radios depending on how you want to look at it. A solution was posted in the Apple Discussion forum and it works for me (Honda 2013 CR-V no NAVI).

Bruce2125 wrote:I have discovered a workaround for the issue which may be of use to other IOS6/iPhone5 users. I found that by going to Preferences/General/Accessibility/Physical and Motor/Incoming Calls and changing it from Default to Headset forces the iPhone to use the 'Headset' if one is available for incoming calls. As the bluetooth speaker on the handsfree is effectively a 'Headset' incoming calls are directed to the bluetooth speaker. When the phone is out of the car and the handsfree disconnects itself the phone behaves normally.
PNutts is offline   0 Reply With Quote
Old Mar 23, 2013, 10:20 AM   #25
Andrewrx
macrumors newbie
 
Join Date: Mar 2013
No restore! I fix it ! It is the noise redaction sensor and a screw. Just see my guide http://youtu.be/C_Q8GCRaWfU thanks
Andrewrx is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
No sound on Iphone 4S during calls! cap2587 iPhone Tips, Help and Troubleshooting 3 Apr 25, 2014 09:31 PM
No sound from 3GS earpiece during calls Diogones iPhone Tips, Help and Troubleshooting 0 Sep 6, 2013 09:19 PM
iPhone 5 voice calls sound like in a tunnel? Imola Ghost iPhone 19 Jun 6, 2013 03:47 PM
Swishing sound on iPhone 5 calls? Risco iPhone 2 Nov 30, 2012 04:24 PM
Brand new 4S, calls sound terrible jdzialak iPhone Tips, Help and Troubleshooting 1 Sep 20, 2012 04:30 PM

Forum Jump

All times are GMT -5. The time now is 07:48 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC