Go Back   MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 6, 2011, 02:45 AM   #1
4Geist
macrumors newbie
 
Join Date: Jan 2011
Garageband'11 Guitar Lessons Latency!!

Unfortunately the most recent update didn't fix the latency that occurs in the guitar lessons. It happens while I'm playing along with the lesson track and I'm recording my progress. I tested it by strumming the high E string and I heard a half second delay. So lets go down a check list of things that have been suggested. Hopefully apple will fix the problem quick!

My iMac:

OSX 10.6.6, 2GHz Intel Core 2 Duo, 4 GB 667 MHz DDR2 SD RAM. and about 50GB of space left.

I dont have applications running in the background, only Garageband .

I'm using a "Hosa USB Guitar Cable". I read reviews about other USB Audio interfaces like "Alesis GuitarLink AudioLink" or "Behringer UCG102" and they all report the same thing.

This is what I've done for Settings outside of Garageband'11:
(USB PnP Sound Device is my Electric Guitar.)

FileVault is OFF.

Preferences > Sound >Input> Internal Microphone>input level (slid it to 0 so that the mic wont catch the guitar sound and send it to garageband.)

Preferences > Sound > USB PnP Sound Device > input volume is 0.

Applications>Utilities>Audio Midi> USB PnP Sound Device>Master Volume 0.

Preferences > Energy Saver > "...Disk to sleep" is unchecked. same with "...reduce brightness"

Settings Inside Garageband'11:

I tried deleting com.apple.garageband.plist several times as a temporary fix, same with switching from internal mic back to USB PnP Sound Device Temporary fix, after 2 or 3 takes with the guitar lessons the latency comes back.

Garageband>How to Play>Guitar>lesson 6(that where I noticed it the most)>setup> Input lvl is 0 (I tried playing around with the slider, no dice, still comes back) Monitor is "On" with feedback protection(also tried without it, there's still latency)

Garageband>Preferences>Midi> audio output> "System Setting"
audio input>"USB PnP Sound Device"

Basically all the settings are set to a minimum to give the system as much of a boost as possible....still that $%#$ Latency comes back. I'm close to taking the best possible solution called "the window treatment" were it's all thrown down a couple of flights. Any other ideas?

Last edited by 4Geist; Jan 20, 2011 at 09:43 PM.
4Geist is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Garageband, Electric Guitar and Headphones help Sup3rknova Digital Audio 9 Jan 1, 2014 02:15 AM
Re-Downloading Artist Lessons in Garageband Mistertoad17 Digital Audio 2 Nov 5, 2013 05:36 PM
How to connect guitar through mixer to GarageBand? hudsonnkh Mac Applications and Mac App Store 0 Dec 24, 2012 09:24 PM
GarageBand & Electric Guitar marceljj Digital Audio 2 Sep 9, 2012 01:18 AM
Running GarageBand on Mountain Lion Lessons Produce No Sound TriforceofTime OS X 10.8 Mountain Lion 0 Sep 1, 2012 09:35 PM

Forum Jump

All times are GMT -5. The time now is 06:03 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC