Go Back   MacRumors Forums > Apple Hardware > Desktops > Mac Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 1, 2011, 10:53 AM   #1
madelyn
macrumors newbie
 
Join Date: Nov 2010
Youtube extremely slow on my mac pro

hi everyone since a week or two i noticed that loading video's from youtube has become extremely slow on my mac pro, sometimes takes up to 5 min. to load a 1min. movie... my main browser is Firefox but its the same story with Safari.

weird thing is that its only with my mac, my windows laptop plays the videos soon as i click on them, no waiting involved.

I'm 100% sure it has nothing to do with my internet connection being slow because i have a fibernet high speed broadband internet connection. and if it would be a youtube problem than i guess the video's would take ages to load on my windows machine as well, non of that is the case...

could someone please tell me if this is a known problem or how to fix it, anyone else experienced the same thing?

I did not do any updates in the last month...


MacPro 6 core 3,33GHZ 8GB DDR3 , OSX 10.6.6
madelyn is offline   0 Reply With Quote
Old Feb 1, 2011, 11:02 AM   #2
ECUpirate44
Banned
 
Join Date: Mar 2010
Location: NC
It is you internet connection. It's certainty isn't your Mac Pro not being able to load a web page.
ECUpirate44 is offline   0 Reply With Quote
Old Feb 1, 2011, 11:04 AM   #3
madelyn
Thread Starter
macrumors newbie
 
Join Date: Nov 2010
Quote:
Originally Posted by ECUpirate44 View Post
It is you internet connection. It's certainty isn't your Mac Pro not being able to load a web page.

if its my internet connection, than how come my windows machine has absolutely no problem with loading the exact same video's, where on my mac it takes ages to load the video.
madelyn is offline   0 Reply With Quote
Old Feb 1, 2011, 11:08 AM   #4
ECUpirate44
Banned
 
Join Date: Mar 2010
Location: NC
Is it wired or wireless? Test your connection. Look at speedtest.net. Check to make sure your mac has the latest version of flash. Run software updates. Disconnect and reconnect internet or reconfigure.
ECUpirate44 is offline   0 Reply With Quote
Old Feb 1, 2011, 11:20 AM   #5
madelyn
Thread Starter
macrumors newbie
 
Join Date: Nov 2010
Quote:
Originally Posted by ECUpirate44 View Post
Is it wired or wireless? Test your connection. Look at speedtest.net. Check to make sure your mac has the latest version of flash. Run software updates. Disconnect and reconnect internet or reconfigure.

wired, connection is tested and running as should, latest version of flash installed....again it has nothing to do with my internet connection
madelyn is offline   0 Reply With Quote
Old Feb 1, 2011, 01:26 PM   #6
jenzjen
macrumors 68000
 
Join Date: Aug 2010
Via speedtest, what speeds are you getting on your Windows vs your Mac?
jenzjen is offline   0 Reply With Quote
Old Feb 1, 2011, 01:31 PM   #7
sigamy
macrumors 65816
 
Join Date: Mar 2003
Location: NJ USA
I have been experiencing the same thing on my C2D 2.16Ghz iMac over past few days. I'm on Fios 25/15, tested and was getting 29Mbits download.

Youtube was taking forever to load, would play 10 seconds of video and stop.

Only thing I can think of is that another machine on my network is downloading torrents via Vuze. Could that be clogging my connection?
__________________
Please support our short film about child abuse.
sigamy is offline   0 Reply With Quote
Old Feb 1, 2011, 01:42 PM   #8
madelyn
Thread Starter
macrumors newbie
 
Join Date: Nov 2010
Quote:
Originally Posted by jenzjen View Post
Via speedtest, what speeds are you getting on your Windows vs your Mac?
Mac: Download 23.26 mb/s. Upload 8.11 mb/s

Windows: Download 23.04 mb/s. Upload 7.98 mb/s
madelyn is offline   0 Reply With Quote
Old Feb 1, 2011, 02:39 PM   #9
Cindori
macrumors 68040
 
Cindori's Avatar
 
Join Date: Jan 2008
Location: Sweden
Youtube is really slow now a days.

Perhaps you tested your Windows PC on a low-load time of the day.
__________________
Cindori .org - unique Mac software!
New release: Control Center for Mac!
Home of Trim Enabler, Zeus Flashing Tool and Kext Drop!
Cindori is offline   0 Reply With Quote
Old Feb 1, 2011, 02:40 PM   #10
Garamond
macrumors regular
 
Join Date: Oct 2004
This is not the fault of any computer, it's YouTube which has been slow as hell some months now. Not every day, but annoyingly often.
__________________
MacBookPro: 2,6 GHz Intel Core i7 / 16 GB 1600 MHz DDR3 / NVIDIA GeForce GT 750M 2048 MB
Garamond is offline   0 Reply With Quote
Old Feb 1, 2011, 02:44 PM   #11
bvapple
macrumors newbie
 
Join Date: Feb 2011
Its REALLY Slow for on all IOS devices with Comcast too. Even after updating the DNS to google DNS...
bvapple is offline   0 Reply With Quote
Old Feb 1, 2011, 02:53 PM   #12
jenzjen
macrumors 68000
 
Join Date: Aug 2010
Quote:
Originally Posted by madelyn View Post
Mac: Download 23.26 mb/s. Upload 8.11 mb/s

Windows: Download 23.04 mb/s. Upload 7.98 mb/s
So, if you put the Windows machine right next to the Mac Pro now and load the same video, you're still getting a slowdown via the Mac?
jenzjen is offline   0 Reply With Quote
Old Feb 1, 2011, 03:53 PM   #13
madelyn
Thread Starter
macrumors newbie
 
Join Date: Nov 2010
Quote:
Originally Posted by jenzjen View Post
So, if you put the Windows machine right next to the Mac Pro now and load the same video, you're still getting a slowdown via the Mac?
yes. i tested both systems at the same time...same video, loads immediately on the pc, it takes ages to load on my mac using firefox and/or safari.

So why is it that youtube works great on my 450$ pc but having trouble watching a simple 1 minute video on my 4500$ machine.

I'm experiencing nothing out of the ordinary for the rest, browsing goes smooth, websites open fairly quick, just for some odd reason it takes ages to open youtube movies...
madelyn is offline   0 Reply With Quote
Old Feb 1, 2011, 05:14 PM   #14
adversus
macrumors regular
 
Join Date: Sep 2009
Location: Portland, OR
Send a message via ICQ to adversus Send a message via AIM to adversus Send a message via MSN to adversus Send a message via Yahoo to adversus Send a message via Skype™ to adversus
Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 4_2_1 like Mac OS X; en-us) AppleWebKit/533.17.9 (KHTML, like Gecko) Version/5.0.2 Mobile/8C148 Safari/6533.18.5)

I run clicktoflash in Safari and YouTube loads stupidly fast. Install clicktoflash and just try loading 1 movie.

My wager is on ****** flash install.
__________________
I own stuff.
adversus is offline   0 Reply With Quote
Old Feb 1, 2011, 09:48 PM   #15
gglockner
macrumors 6502
 
Join Date: Nov 2007
Location: Bellevue, WA
Sounds like a Flash issue. Have you tried setting YouTube to H.264? Also try Google Chrome, which has its own integrated Flash.
__________________
Giving my money to Apple since 1993.
gglockner is offline   0 Reply With Quote
Old Feb 1, 2011, 09:59 PM   #16
ajsnow6234
macrumors 6502
 
Join Date: Apr 2010
I'm subscribing to this because oddly enough I'm having the same issue.

On my MacOS I'm having REALLY slow buffer times on youtube. I have tested both HTML5 and Flash on both Chrome and Firefox...it loads ridiculously slow, where as a couple weeks ago I would never even need to wait more than a couple seconds. I'm on Verizon Fios 25Mbps download and 15Mbps upload.

The clincher is that on both my Boot Camp Partition with Win7 and my wife's Win7 Netbook this is a non-issue. I know this sounds stupid, but it seems really weird to me.
ajsnow6234 is offline   0 Reply With Quote
Old Mar 1, 2011, 11:06 AM   #17
tpinto3
macrumors newbie
 
Join Date: Mar 2011
I'm experiencing the exact same issue. Anybody find a fix yet?
tpinto3 is offline   0 Reply With Quote
Old Mar 1, 2011, 11:53 AM   #18
freeman727
macrumors regular
 
Join Date: Feb 2009
Are you using a flashed video card? I had this problem when I was using a flashed 4870 card. It had something to do with the kext.
__________________
Quad Pro 2009, sell to get the 2011 iMac? No, EFI hack to the rescue!
iPhone 4, awaiting iPhone 5
2011 MBA but got the new iPad anyways

Last edited by freeman727; Mar 1, 2011 at 12:29 PM.
freeman727 is offline   0 Reply With Quote
Old Apr 27, 2011, 02:38 AM   #19
awwwyeah206
macrumors newbie
 
Join Date: Apr 2011
same problem

Systems Engineer here but noob Mac user subscribing as well because of same issue:

Windows + YouTube video loads fine.
Macbook + YouTube (or any streaming video) slow as hell.

Same wireless router. Wireless N adapter. 10Mbps cable line. it's not intermittent. I can produce this issue any time of the day any day of the week. Been like this for over a year but I just started using the Macbook heavily so I'm invested in resolving this.

Firefox, Safari, Chrome all can't stream 360p videos without pausing and coming back minutes later. 480p or higher forget about it.

any ideas please chime in! thanks!
awwwyeah206 is offline   0 Reply With Quote
Old Apr 30, 2011, 08:33 AM   #20
lavem
macrumors member
 
Join Date: Apr 2005
Try disabling IPv6 in Firefox.

Type 'about:config' in the address bar.

Type 'network.dns.disableIPv6' in the filter box then double click the only result to change the value to true.

This may or may not work as enabling IPv6 for me slows down everything, not just YouTube.
lavem is offline   0 Reply With Quote
Old Apr 30, 2011, 12:12 PM   #21
jeanlain
macrumors 6502
 
Join Date: Mar 2009
I'm sure this has nothing to do with the Mac speed or hardware, but with YouTube's bandwidth. In my experience, buffering can be slow on some videos, and fast on others (even though they are parts of the same movie).
Likewise, H.264 mp4 (accessible via clickToFlash) is always slower to download than Flash. I believe that Google sets priorities to save bandwidth. Who knows, they may give Mac OS X users lower priority.
jeanlain is offline   -1 Reply With Quote
Old Apr 30, 2011, 02:13 PM   #22
derbothaus
macrumors 601
 
derbothaus's Avatar
 
Join Date: Jul 2010
All this would make sense except I have zero issues loading any video on Win or OS X. I am also on Comcast. I use really fast DNS though (not comcast). Less than 29ms ping's. I use ClicktoFlash extension as well. You Tube is slow sometimes but it is isolated to them.
__________________
Mac Pro W3680, GTX 680, 12GB DDR3, SSD; MBP, 2.6GHz Core i7, 16GB DDR3, SSD; Eizo fs2333
derbothaus is offline   0 Reply With Quote
Old May 6, 2011, 01:12 PM   #23
Milou's Bones
macrumors newbie
 
Join Date: May 2011
Delete your Flash cookies.

Short answer: Delete your Flash cookies.

Flash keeps its own cookies (surprise!) in its own folder that can bog down your flash player. Delete them. Delete them every day. This is what works for me. But deleting cookies in your browser won't touch them. So, two ways to do this: use FLUSH (http://machacks.tv/2009/01/27/flusha...tool-for-os-x/) or use the Flash panel in your System Preferences.

Long answer:

First of all, everyone stop saying it's Madelyn's internet connection. Obviously it's not if she has no trouble with her Windows machine. As a Mac user, I can tell you that Flash butts heads with Macs in a way that Windows users never have to worry about. Mine was also slogging it to run flash video. I had given up on full-screen altogether.

My solution(s):
  1. My kludgy workaround had been to run the video in regular size and zoom in on it using the Universal Access zoom function that you can turn on in the system preferences.
  2. THEN I installed the extension clicktoflash—which I recommend for many reasons, not the least of which is that Flash can make my Mac run up to 30 degrees hotter. It also makes lots of ads invisible! (http://clicktoflash.com/)
  3. THEN I discovered the YouTube5 Safari extension (http://www.verticalforest.com/youtube5-extension/). It plays YouTube videos as HTML5, not Flash. Even seems to work on YouTube videos embedded on other websites. No more slow YouTube.
  4. THEN I discovered by accident that Flash video played perfectly well in a new user account I created for my boyfriend. (Try it!) I thought for a long time that this was my solution, especially when I hook my laptop up to my TV. This made me think that my regular user account was bogged down in some way, but I couldn't think of how, since i regularly reset Safari and had reinstalled Flash several times.
  5. THEN I stumbled on FLUSH. It ferrets out Flash cookies and gets rid of them. This seems to have fixed everything. I put it in my Login Items in the User Accounts panel in my System Preferences, so I don't forget. But I run it every so often when I think of it anyway. I don't know why cookies should have such a bad effect, but this seems to have fixed things for me. Now I run full screen Flash video with no trouble.

So that worked for me.

Last edited by Milou's Bones; May 6, 2011 at 02:44 PM.
Milou's Bones is offline   1 Reply With Quote
Old May 21, 2011, 11:57 PM   #24
Ron Adair
macrumors newbie
 
Join Date: Feb 2011
Surprised nobody has mentioned....

I'm having similar issues. It can take minutes or tens of minutes to load a video that is only a minute or two long, even on low quality (320).

However, my bigger issue (and much more prevailing) is video UPLOADS to Youtube. If I click go on a Youtube upload AND THEN start uploading the same file on Vimeo (at the same time), Vimeo will take roughly 1/30th the time. This has been the case for months. It has persisted across user accounts, browsers (Safari, Chrome, FF), different machines (all macs), and even persists after getting a brand new MBP with a fresh install (didn't migrate this time, but started fresh instead). The one thing I haven't tried, which I'm going to try now is firing up Parallels and seeing what happens there. Is it an OS sniffing thing? I've always assumed it was one of either bandwidth, DNS (using Google's DNS), or Google implementing a blanket throttle. Now with the reports that Windows machines on the same network can load at expected speeds, I am getting more suspicious.

I'm surprised nobody has brought up Google's apparent hatred for Apple in this whole "Slow Youtube" sentiment that has been plaguing the internet of late. I'm probably straddling the edge of Godwin's law here, but I think this is a viable consideration, at least.

Best case scenario: Youtube uploads and downloads are up to 30x slower than other video services because Google is killing Youtube long term by throttling the service (in the worst way possible). Worst case: something much more nefarious is motive, as mentioned above. Either way, it's not a good place for Google to be. Based on the way I've seen Google behave over the past few years, I'm not inclined to look at this as something innocuous or innocent.

Either way, getting video upload speeds of roughly 64kbps when I have 7-8mbps at my disposal is reasonably maddening for such a large scale service as YouTube.
Ron Adair is offline   0 Reply With Quote
Old Jun 18, 2011, 08:20 PM   #25
22350
macrumors newbie
 
Join Date: Nov 2004
Gotta jump in

Having the same issues on an i7 intel machine with a 20mbit connection.

Low res. youtube ok, 720 or 1080 is doa.

I made a discovery. I switched my DNS servers from OpenDNS to Google DNS and had a big jump in load speed with 720p. The speed then dropped off and it started freezing again.

I then found this utility:

NAMEBENCH

It analyzed DNS performance from my location and gave me an alternative configuration, involving my router as the primary and an arrangement of to other DNS servers as secondary and tertiary.

It gave me another 14% bump in performance. Now high def youtube loads right up.

Give it a try.
22350 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > Mac Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
2010 Macbook pro running extremely slow locolupo Mac Basics and Help 3 Mar 1, 2014 07:48 AM
MacBook Pro extremely slow?!! xriderx11 MacBook Pro 1 Apr 2, 2013 09:03 PM
2011 Macbook Pro extremely slow wake up ZolakJHS MacBook Pro 3 Dec 13, 2012 10:00 AM
MacBook Pro OSX 10.8 EXTREMELY Slow randomguyishere MacBook Pro 1 Aug 30, 2012 01:29 PM
New macbook pro EXTREMELY SLOW!!! - help please :// immalex MacBook Pro 10 Jun 2, 2012 03:19 PM

Forum Jump

All times are GMT -5. The time now is 06:57 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC