Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 2, 2011, 08:35 PM   #1
Abyssgh0st
macrumors 68000
 
Abyssgh0st's Avatar
 
Join Date: Jan 2009
Location: Norman, OK
Send a message via ICQ to Abyssgh0st
PowerPC noobie with questions..

Hi there everybody! I just bought a 1.33GHz, 768MB (going to upgrade to 1.25GB), 60GB 12" Powerbook G4 as a gift for my girlfriend.

I plan to install 10.5.8 on it, but I am very na´ve about what applications will/will not run with Leopard on a PPC machine. Is it operating system specific and processor specific, or just one of the two?

This machine will mainly be used for Office ('08), iWork ('08), iLife ('09, with no iMovie or GarageBand), etc.

Can anyone help me out here?

Thanks guys!
__________________
27" 2.93 i7 iMac
11" 1.8 i7 MBA
iPhone 5

Last edited by Abyssgh0st; Feb 2, 2011 at 09:18 PM.
Abyssgh0st is offline   0 Reply With Quote
Old Feb 3, 2011, 02:32 AM   #2
VanneDC
macrumors 6502a
 
Join Date: Jun 2010
Location: Dubai, UAE
yeah mate, on that box, id suggest office 2004... goes great, 2008 even runs like crud on osx intel..
__________________
Late 2011 Macbook Pro 15"
BUILDING: TB eGPU Sonnet Echo Express + GTX480
Wacom Cintiq 21UX 24" Sony PS3 3D display.
VanneDC is offline   0 Reply With Quote
Old Feb 3, 2011, 03:08 AM   #3
MacHamster68
macrumors 68040
 
MacHamster68's Avatar
 
Join Date: Sep 2009
no it is not caused by the hardware, mainly its just the laziness of developers to do universal versions of their software on offer now , but as you'd choosen a PPC Mac it is important for you to know they will perform the same way they did when they'd been new and there are still people out there developing software for the PPC Mac's running tiger

so i would not put leopard on it as it still cost a fair amount of cash , it kills performance
so leopard i would only put on a G4 under 1.5 ghz if i could not live without it for some strange reason ,
ok i love to play the old OS9 games and with leopard that is not possible as leopard doesn't offer classic support
even on my intel iMac i installed tiger,originally shipped with it just because of another feature called apple talk which apple forgot about in snow leopard
__________________
DANGER POST MAY CONTAIN SARCASM
Intelligence does not need Intel inside,
All it needs is good sense outside.

Last edited by MacHamster68; Feb 3, 2011 at 05:26 AM.
MacHamster68 is offline   0 Reply With Quote
Old Feb 3, 2011, 10:50 AM   #4
sparky1499
macrumors regular
 
Join Date: Oct 2008
Location: Glasgow, UK
I have a 12" G4 PB 1.33ghz with 768meg RAM.

Runs Leopard fine.

The original 80Gb 5400 rpm HD died so I replaced it with a Western Digital 250Gb 7200rpm drive.

Still get 5-6 hours on the battery....
__________________
15" MacBook Pro (Early 2011), 2.0GHz i7 Quad, 4GB RAM, 500GB iPad Mini 16GB Wifi Black iPhone 5 16GB White
sparky1499 is offline   0 Reply With Quote
Old Feb 3, 2011, 11:21 AM   #5
DSPalpatine
macrumors member
 
Join Date: Nov 2009
The additional RAM will certainly help. I installed Leopard on my old 1.33GHz G4 iBook after I gave it to my cousin, and it runs fine.

I agree with MacHam, that if you need Classic application support for old OS9 stuff, then yes, use Tiger. However, it doesn't sound like that is the case for you, and most newer applications that still support PPC require Leopard (for instance, Safari 5 or iTunes 10). If your girlfriend has an iPad or an iPhone 4, she'll definitely need Leopard in order to synch it to the computer.

You can install Safari 5, iTunes 10, Firefox 3.6, iLife '09 just fine. Office '08 is a mixed bag. You get some nice new features with it, but as VanneDC points out, Office 2004 is much more responsive. Thing is, '08 isn't just slow on PPC, it's been slow on Intel processors as well. The biggest problem was the 'bouncing icon' problem, where when you would try to open the program, the dock icon would bounce for a good 20-30 seconds before the program would ever fire up, which I observed both on PPC and Intel machines. That was fixed about a year ago, so it's better, but it's still a beast in terms of responsiveness. Stick with Office '04 if you can.

If you're going with Leopard, be a good partner and get your girlfriend a cheap Firewire-400 drive so she can run Time Machine...
__________________
MacBook (white) 2.0 GHz C2D, 4 GB RAM, 320 GB HD, Nvidia 9400m; 17" G5 iMac 2.0 GHz, 2 GB RAM, 250 GB HD; 16 GB iPhone 3GS (black); 80GB iPod Classic (black)
DSPalpatine is offline   0 Reply With Quote
Old Feb 3, 2011, 11:39 AM   #6
Abyssgh0st
Thread Starter
macrumors 68000
 
Abyssgh0st's Avatar
 
Join Date: Jan 2009
Location: Norman, OK
Send a message via ICQ to Abyssgh0st
Thanks for the advice guys. This laptop is not a permanent thing for her, just a filler for 5-6 months until her parents will buy her a much nicer Mac for college.

I've already purchased the RAM and burnt a Leopard (10.5.6) install disc. I've also already got iWork '08 and iLife '09, so I'm thinking we may hold off on Office (thanks for the heads up though, I will get '04 if we end up needing it). Depending on the cost, we may upgrade the harddrive. I was a bit confused as to which drives would work, though. Would just a 2.5" PATA drive work?

Thanks again guys!
__________________
27" 2.93 i7 iMac
11" 1.8 i7 MBA
iPhone 5
Abyssgh0st is offline   0 Reply With Quote
Old Feb 3, 2011, 12:14 PM   #7
MacHamster68
macrumors 68040
 
MacHamster68's Avatar
 
Join Date: Sep 2009
yes as it needs to be ultra ata 100 and the original HDD was only a 4200rpm drive , so certainly if you can get 7200rpm that would boost performance , and as you already plan to upgrade the ram you need in the
2005 ! iBook 12" 1.33ghz which actually holds 1.5 gb ram , 512mb are on the logicboard already and 1 gb pc2700 200 pin sodimm is what you need in that model for under the keyboard in the user upgradable slot
instead of the earlier 2004 models which could only take 1.25 gb ram pc2100
__________________
DANGER POST MAY CONTAIN SARCASM
Intelligence does not need Intel inside,
All it needs is good sense outside.

Last edited by MacHamster68; Feb 3, 2011 at 12:27 PM.
MacHamster68 is offline   0 Reply With Quote
Old Feb 3, 2011, 07:35 PM   #8
g4 powerbookboy
macrumors regular
 
Join Date: Aug 2010
i have a g4 ibook 1.2 with 512mb ram and it runs leopard fine. im planning on maxing out the ram just to do it but even if i dont, im happy with how it works on 512 mb.
g4 powerbookboy is offline   0 Reply With Quote
Old Feb 4, 2011, 11:09 AM   #9
Abyssgh0st
Thread Starter
macrumors 68000
 
Abyssgh0st's Avatar
 
Join Date: Jan 2009
Location: Norman, OK
Send a message via ICQ to Abyssgh0st
I've purchased the RAM, got a 1GB DDR PC2700 200pin for $30. I plan to sell the 256MB for $10-15. Any idea what a harddrive would cost? I'm having trouble finding any U-ATA drive for less than $100.
__________________
27" 2.93 i7 iMac
11" 1.8 i7 MBA
iPhone 5
Abyssgh0st is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone: A couple of noobie questions Reykor Jailbreaks and iOS Hacks 7 Dec 19, 2013 06:04 AM
A few questions about PowerPC (PowerBook G4) PowerPC:Oryx PowerPC Macs 8 Jun 21, 2013 02:34 PM
Some noobie questions on NAS el-John-o Mac Peripherals 15 Jan 28, 2013 01:34 AM
General iPad noobie questions. asr10 user iPad 11 Jun 14, 2012 08:24 AM

Forum Jump

All times are GMT -5. The time now is 04:05 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps