Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 17, 2011, 11:04 PM   #1
deathbyart
macrumors regular
 
Join Date: Feb 2008
Issues with DD-WRT & Atv (2g)

I bought a Dlink N router that is flashed with DD-WRT. My whole network works fantastically and my Apple TV has access to my network and Internet. I can browse through Netflix and select something to watch but it won't actually play it. The same goes for attempting to stream a tv show or movie from ITunes over the network. Although I did successfully play music.

This is in incredibly frustrating and hoping there is some setting I missed.. Maybe firewall is blocking it... I don't know...

Suggestions?
deathbyart is offline   0 Reply With Quote
Old Feb 20, 2011, 05:27 PM   #2
alenart
macrumors newbie
 
Join Date: Feb 2011
Use 8.8.8.8 DNS

Exactly the same symptoms... I found in a different post that setting a static IP on the ATV and using a Google DNS (008.008.008.008) would work... And it did!

Here's the original thread: http://discussions.apple.com/message...ageID=12363710
alenart is offline   0 Reply With Quote
Old Feb 21, 2011, 09:49 PM   #3
TheHoff
macrumors 6502
 
Join Date: Oct 2008
There are a ton of horror stories with Netflix streaming and the ATV2. Check the Apple discussion forums. I couldn't get it to work reliably so I went to a Mac Mini and Plex.
TheHoff is offline   0 Reply With Quote
Old Feb 22, 2011, 12:58 AM   #4
grawk
macrumors 6502
 
Join Date: Jan 2004
Location: Southern York County, PA
The dns change is the fix. I had the same problem...
__________________
MacBook Air 2011 11 1.6/128/4 iMac Core2Duo 21" Late 2009 new iPad 32gb Verizon iPhone 4S IBM iDataPlex M4 Supercomputer
grawk is offline   0 Reply With Quote
Old Feb 23, 2011, 10:42 AM   #5
deathbyart
Thread Starter
macrumors regular
 
Join Date: Feb 2008
Thanks for the help guys. I honestly think it has to do with the freaking dd-wrt firmware. I had everything up and running just fine with a Linksys G router.. thought having an N would be even better.
It was like inviting a Gremlin into my network..
deathbyart is offline   0 Reply With Quote
Old Feb 23, 2011, 10:44 AM   #6
grawk
macrumors 6502
 
Join Date: Jan 2004
Location: Southern York County, PA
dd-wrt is definitely the problem. I guess I should have said the dns change is the work around...once I switched my ipad and appletv to static dns 8.8.8.8 and 8.8.4.4 it started working again.
__________________
MacBook Air 2011 11 1.6/128/4 iMac Core2Duo 21" Late 2009 new iPad 32gb Verizon iPhone 4S IBM iDataPlex M4 Supercomputer
grawk is offline   0 Reply With Quote
Old Feb 23, 2011, 12:20 PM   #7
owine
macrumors member
 
Join Date: Oct 2008
I run DD-WRT, but I have ti set to the static 8.8.8.8 DNS servers and don't have issues. All of my devices get static DHCP leases.
owine is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
ATV issues Msasas Mac Basics and Help 0 Nov 14, 2013 09:34 AM
ATV 2 wired network issues - anyone else? leonk Apple TV and Home Theater 3 Dec 30, 2012 02:27 AM
Any issues reported with ATV 5.1.1? darcyjames Apple TV and Home Theater 19 Dec 5, 2012 05:14 PM
ATV 3G: Issues with slideshow, specifically B&W images carboncow Apple TV and Home Theater 0 Nov 21, 2012 03:05 PM
Any DD-WRT users here? AceGuy78 iPhone 3 Jun 2, 2012 04:51 AM

Forum Jump

All times are GMT -5. The time now is 03:21 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC