Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 23, 2011, 07:35 PM   #1
bellagio
macrumors newbie
 
Join Date: Feb 2011
"An error occurred loading this content" apple tv 2

Hi

Have had this issue since I bought my atv2 two weeks ago

I can stream my photos, my personal movies, my music from itunes on my mac ( 10.6.6) and itunes 10.1.2 but cannot play the rented movies I have purchased via itunes on the apple tv--I keep getting the "error occurred loading this content"

I have contacted apple support who suggested contacting my isp who in turn suggested I contact my wireless modem manufacturer

I am using a linksys cisco wag 160 n modem-- I have opened up all the ports apple suggests

I have contacted my isp and requested they open all the necessary ports required by itunes 10.1.2

The problem is still occurring--what do I next to play my rented ( and paid for) movies?

Thanks for any help
bellagio is offline   0 Reply With Quote
Old Feb 25, 2011, 10:17 PM   #2
jjk454ss
macrumors 68030
 
jjk454ss's Avatar
 
Join Date: Jul 2008
I'm getting the same error, the error shows up on the TV and in iTunes on my MacBook after I select the Airplay Icon in iTunes and select Apple TV. If I try to select my MacBook on the Apple TV, the screen blinks black and goes back to the main menu.

I just got a new MacBook, I had no problems with my old one. Home Sharing is on, is there something else I am not doing to setup the new computer to work with the Apple TV?
jjk454ss is offline   0 Reply With Quote
Old Feb 26, 2011, 02:05 PM   #3
nyctravis
macrumors regular
 
Join Date: Jun 2007
Location: NYC
I'm having a somewhat similar problem. I just switched from a PC to Mac and have transferred my entire library over. Everything is working fine except I can't seem to stream my movies to the ATV. I can stream music just fine without problems. But every time I try to stream a movie over to ATV I get "an error occurred loading this content" message. I can play the movie just fine in iTunes. Any thoughts/help/advice?
nyctravis is offline   0 Reply With Quote
Old Feb 26, 2011, 03:40 PM   #4
iPhone1
macrumors Demi-God
 
iPhone1's Avatar
 
Join Date: Apr 2010
Location: Honolulu, HI
Same issue here. Apple is probably blocking iTunes content from jailbroken ATV2's. They did it with iBooks on iOS.
iPhone1 is offline   0 Reply With Quote
Old Feb 26, 2011, 08:18 PM   #5
jjk454ss
macrumors 68030
 
jjk454ss's Avatar
 
Join Date: Jul 2008
Quote:
Originally Posted by iPhone1 View Post
Same issue here. Apple is probably blocking iTunes content from jailbroken ATV2's. They did it with iBooks on iOS.
Mine is not jailbroken, it was working fine with my old MacBook, but still have not got it working with my new one.
jjk454ss is offline   0 Reply With Quote
Old Feb 26, 2011, 08:56 PM   #6
criticalb
macrumors member
 
Join Date: Sep 2006
Glad it's not just me. My ATV is not jailbroken. 3 days ago everything was working fine on my 2010 MBP. Thursday I picked up one of the new MBPs, transferred all my library and settings to the new drive, but Movies and TV won't play. If I try to browse my library on the ATV using home sharing, it doesn't load anything. If I try to send a video to the ATV from itunes, I get the error message. Music seems to stream fine from iTunes to ATV, but I can't send video. And by video I mean actual, purchased videos from Apple, so no DRM issues.
criticalb is offline   0 Reply With Quote
Old Feb 26, 2011, 09:02 PM   #7
jjk454ss
macrumors 68030
 
jjk454ss's Avatar
 
Join Date: Jul 2008
Quote:
Originally Posted by criticalb View Post
Glad it's not just me. My ATV is not jailbroken. 3 days ago everything was working fine on my 2010 MBP. Thursday I picked up one of the new MBPs, transferred all my library and settings to the new drive, but Movies and TV won't play. If I try to browse my library on the ATV using home sharing, it doesn't load anything. If I try to send a video to the ATV from itunes, I get the error message. Music seems to stream fine from iTunes to ATV, but I can't send video. And by video I mean actual, purchased videos from Apple, so no DRM issues.
I've tried everything, and searched everywhere, I can't find an answer either.

At least if I sync the movies to my iPad, they will play through airplay that way.
jjk454ss is offline   0 Reply With Quote
Old Feb 26, 2011, 10:37 PM   #8
crusher372
macrumors member
 
Join Date: Jul 2010
I am having the exact same problem on all 3 of my apple tv 2's. Just picked up a new MBP and plugged in drive with my itunes library on it. All Apple tv's see my library but either I get the spinning wheel of death loading or an error no movies exist. Plays just fine in Itunes. Grrrrr. Driving me bonkers. Kids are very upset. No access to any of "their" movies.
__________________
2011 21.5" Imac 2.5ghz, 16gb ipad2, 32gb ipad2, 32gb new ipad, 32gb iPhone4, 16gb iPhone 4s, 64gb itouch tv 2 x 3 & tv 3, Apple Airport Extreme, Empty Wallet c/o
crusher372 is offline   0 Reply With Quote
Old Feb 26, 2011, 10:47 PM   #9
noripwr
macrumors member
 
Join Date: Feb 2011
try authorizing your computer in itunes?
noripwr is offline   0 Reply With Quote
Old Feb 26, 2011, 10:49 PM   #10
crusher372
macrumors member
 
Join Date: Jul 2010
We are way beyond the simple tricks like that. Every thing has been tried,
that I know to do anyway
__________________
2011 21.5" Imac 2.5ghz, 16gb ipad2, 32gb ipad2, 32gb new ipad, 32gb iPhone4, 16gb iPhone 4s, 64gb itouch tv 2 x 3 & tv 3, Apple Airport Extreme, Empty Wallet c/o
crusher372 is offline   0 Reply With Quote
Old Feb 26, 2011, 10:57 PM   #11
jjk454ss
macrumors 68030
 
jjk454ss's Avatar
 
Join Date: Jul 2008
Quote:
Originally Posted by crusher372 View Post
We are way beyond the simple tricks like that. Every thing has been tried,
that I know to do anyway
Yeah, I can't imagine what the issue is. It seems to be a problem with the new MacBook, or a problem you get after transferring the library. But I have no idea.
jjk454ss is offline   0 Reply With Quote
Old Feb 27, 2011, 07:35 AM   #12
criticalb
macrumors member
 
Join Date: Sep 2006
Hey all - found a fix that worked for me at least:

http://support.apple.com/kb/ht1451

I suspected transferring the library to the new laptop was a problem so I tried this article on rebuilding the library an it worked. My library is about 250 GB so it took about 10 minutes once the process started.

Hope this helps.
criticalb is offline   0 Reply With Quote
Old Feb 27, 2011, 08:05 AM   #13
jjk454ss
macrumors 68030
 
jjk454ss's Avatar
 
Join Date: Jul 2008
Quote:
Originally Posted by criticalb View Post
Hey all - found a fix that worked for me at least:

http://support.apple.com/kb/ht1451

I suspected transferring the library to the new laptop was a problem so I tried this article on rebuilding the library an it worked. My library is about 250 GB so it took about 10 minutes once the process started.

Hope this helps.
You are awesome! Thank you.

Last edited by jjk454ss; Feb 27, 2011 at 08:14 AM.
jjk454ss is offline   0 Reply With Quote
Old Feb 27, 2011, 09:55 PM   #14
crusher372
macrumors member
 
Join Date: Jul 2010
Tried the rebuild of the library but still not working. I am so beside myself right now. My brain might explode.
__________________
2011 21.5" Imac 2.5ghz, 16gb ipad2, 32gb ipad2, 32gb new ipad, 32gb iPhone4, 16gb iPhone 4s, 64gb itouch tv 2 x 3 & tv 3, Apple Airport Extreme, Empty Wallet c/o
crusher372 is offline   0 Reply With Quote
Old Feb 27, 2011, 10:01 PM   #15
jjk454ss
macrumors 68030
 
jjk454ss's Avatar
 
Join Date: Jul 2008
Quote:
Originally Posted by crusher372 View Post
Tried the rebuild of the library but still not working. I am so beside myself right now. My brain might explode.
I know how you feel, its strange that didn't fix it when it worked for me and criticalb.

I did have to re-add all my apps though, the had to download updates for over 150 of just over 200 apps. Thought this was weird, but oh well.
jjk454ss is offline   0 Reply With Quote
Old Feb 27, 2011, 10:02 PM   #16
crusher372
macrumors member
 
Join Date: Jul 2010
Airplay is also messed up. I can airplay my music from the Mbp to apple tv but not movies. I get an error message
__________________
2011 21.5" Imac 2.5ghz, 16gb ipad2, 32gb ipad2, 32gb new ipad, 32gb iPhone4, 16gb iPhone 4s, 64gb itouch tv 2 x 3 & tv 3, Apple Airport Extreme, Empty Wallet c/o
crusher372 is offline   0 Reply With Quote
Old Feb 28, 2011, 02:38 AM   #17
bellagio
Thread Starter
macrumors newbie
 
Join Date: Feb 2011
Unhappy still can't view movies

Hi
Since posting this thread I have contacted the modem manufacturer--am using a cisco wag160n and have opened up all the ports apple suggests
we have even today connected the atv2 directly via ethernet and still getting same error message
we even tried a different modem and still the same error message
we are in australia and do not have any jailbroken apple items so we are at a loss what the issue is
apple support have no idea either
so if it's not the modem, the isp or the appletv2 itself ( we exchanged our apple tv2 at the Genius bar at the apple shop for a new one to ensure it wasn't a faulty atv2) what exactly is it???
Cheers
bellagio is offline   0 Reply With Quote
Old Feb 28, 2011, 10:52 AM   #18
crusher372
macrumors member
 
Join Date: Jul 2010
Finally was able to rebuild the library from scratch and fix the issue. What a nightmare. My whole weekend was obssessed with trying to figure this out. Kids are happy now. I swear when I finally saw the movies showing up on the Apple Tv I jumped 15ft into the air. My wife was laughing so hard as I ran around the house sceaming as if I had won the lotto
__________________
2011 21.5" Imac 2.5ghz, 16gb ipad2, 32gb ipad2, 32gb new ipad, 32gb iPhone4, 16gb iPhone 4s, 64gb itouch tv 2 x 3 & tv 3, Apple Airport Extreme, Empty Wallet c/o
crusher372 is offline   0 Reply With Quote
Old Feb 28, 2011, 11:04 AM   #19
nyctravis
macrumors regular
 
Join Date: Jun 2007
Location: NYC
Ha! I spent my entire weekend rebuilding the library as well, and it also worked. I did a dance too when I got the movies to show on the ATV. What I still have yet to do is rebuilding my playlists, etc. which I'm dreading...
nyctravis is offline   0 Reply With Quote
Old Feb 28, 2011, 12:29 PM   #20
filthysambo
macrumors newbie
 
Join Date: Feb 2011
I was having the same beef on my new macbook pro. The fix works a treat, thanks fellas!
filthysambo is offline   0 Reply With Quote
Old Feb 28, 2011, 09:20 PM   #21
maw4bc
macrumors regular
 
Join Date: Apr 2009
Huge pain in the A$$ to do this. Majority of the stuff I got from torrents (music videos) I will have to redo.....argghhhh.

Anyways, thanks for whoever figured out this fix.
maw4bc is offline   0 Reply With Quote
Old Mar 1, 2011, 12:05 PM   #22
filthysambo
macrumors newbie
 
Join Date: Feb 2011
I spoke too soon, its still bost!! Video streams fine from my iPad and iPhone, Im having to load it from my mac to my iphone and stream it from there. Nightmare!
filthysambo is offline   0 Reply With Quote
Old Mar 2, 2011, 10:16 AM   #23
maw4bc
macrumors regular
 
Join Date: Apr 2009
Is there any word from Apple about this problem? It seems to be happening to everyone with a new MBP
maw4bc is offline   0 Reply With Quote
Old Mar 2, 2011, 11:44 AM   #24
nyctravis
macrumors regular
 
Join Date: Jun 2007
Location: NYC
Quote:
Originally Posted by maw4bc View Post
Is there any word from Apple about this problem? It seems to be happening to everyone with a new MBP
Someone started a thread at http://discussions.apple.com/thread....readID=2767177

Might be good if those of us having this problem posted there as well
nyctravis is offline   0 Reply With Quote
Old Mar 2, 2011, 03:39 PM   #25
crusher372
macrumors member
 
Join Date: Jul 2010
Spoke too soon myself as well. It is definitely a MBP 2011 issue. Mac mini works fawlessly. Hoping the new itunes software I am about to install has a fix.
__________________
2011 21.5" Imac 2.5ghz, 16gb ipad2, 32gb ipad2, 32gb new ipad, 32gb iPhone4, 16gb iPhone 4s, 64gb itouch tv 2 x 3 & tv 3, Apple Airport Extreme, Empty Wallet c/o
crusher372 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
"An error occurred loading this content" kangping Apple TV and Home Theater 2 Jan 15, 2013 02:21 PM
Apple TV 2 TV Show Sorting TheCheapGeek Apple TV and Home Theater 40 Nov 21, 2012 02:47 AM
Mac Mini, Eye TV Hybird, Handbrake, Apple TV 2 sblanford Apple TV and Home Theater 5 Jan 11, 2012 09:25 PM
Apple TV 2 guide mysteryliner Apple TV and Home Theater 25 Nov 8, 2011 04:49 PM
Error occurred loading this content Sound214 Apple TV and Home Theater 7 Oct 3, 2011 08:48 AM


All times are GMT -5. The time now is 05:56 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC