Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 9, 2011, 03:07 PM   #1
chiggah
macrumors member
 
Join Date: Mar 2011
iOS 4.3 updated but iphone4 stuck in recovery mode?

I never jailbroken my iphone4. Updated my itunes and iOS 4.3 as per normal, but now I'm stuck in recovery mode with the itunes logo and cable icon on my iphone 4. Now it's saying "itunes has detected an iphone in recovery mode. You must restore this iphone before it can be used". Wtf ??

Any help would be greatful !!
chiggah is offline   0 Reply With Quote
Old Mar 9, 2011, 03:08 PM   #2
selcouth
macrumors newbie
 
Join Date: Jul 2008
Have you used TinyUmbrella on your computer?
selcouth is offline   0 Reply With Quote
Old Mar 9, 2011, 03:09 PM   #3
chiggah
Thread Starter
macrumors member
 
Join Date: Mar 2011
No never

I'm on my work laptop. I've used tinyumbrella on my home PC but it was on my iphone 3G, not iphone 4
chiggah is offline   0 Reply With Quote
Old Mar 9, 2011, 03:10 PM   #4
jav6454
macrumors G5
 
jav6454's Avatar
 
Join Date: Nov 2007
Location: 1 Geostationary Tower Plaza
Quote:
Originally Posted by chiggah View Post
I never jailbroken my iphone4. Updated my itunes and iOS 4.3 as per normal, but now I'm stuck in recovery mode with the itunes logo and cable icon on my iphone 4. Now it's saying "itunes has detected an iphone in recovery mode. You must restore this iphone before it can be used". Wtf ??

Any help would be greatful !!
Hit Restore.
__________________
Al MacBook 2.4GHz Late '08 | 5 S⃣ | Macross Click Me
jav6454 is offline   0 Reply With Quote
Old Mar 9, 2011, 03:10 PM   #5
chiggah
Thread Starter
macrumors member
 
Join Date: Mar 2011
Should I just restore back to 4.2.1 ? -__-
chiggah is offline   0 Reply With Quote
Old Mar 9, 2011, 03:11 PM   #6
selcouth
macrumors newbie
 
Join Date: Jul 2008
Check your hosts file and make sure there is not an entry for gs.apple.com.
selcouth is offline   0 Reply With Quote
Old Mar 9, 2011, 03:12 PM   #7
chiggah
Thread Starter
macrumors member
 
Join Date: Mar 2011
Sorry don't know how to check hosts file

I just hit restore and update as that's the only thing i can do at the moment >_< ggrrr
chiggah is offline   0 Reply With Quote
Old Mar 9, 2011, 03:13 PM   #8
jav6454
macrumors G5
 
jav6454's Avatar
 
Join Date: Nov 2007
Location: 1 Geostationary Tower Plaza
Quote:
Originally Posted by chiggah View Post
Should I just restore back to 4.2.1 ? -__-
Just hit Restore dude. Hook up the iPhone, hit restore in iTunes after the prompt.
__________________
Al MacBook 2.4GHz Late '08 | 5 S⃣ | Macross Click Me
jav6454 is offline   0 Reply With Quote
Old Mar 9, 2011, 03:16 PM   #9
chiggah
Thread Starter
macrumors member
 
Join Date: Mar 2011
Just did it. At the end of the restore, error 3014 popped up. Could the update file have been corrupted or something ?

Last resort is DFU mode it ?
chiggah is offline   0 Reply With Quote
Old Mar 9, 2011, 03:17 PM   #10
jav6454
macrumors G5
 
jav6454's Avatar
 
Join Date: Nov 2007
Location: 1 Geostationary Tower Plaza
Quote:
Originally Posted by chiggah View Post
Just did it. At the end of the restore, error 3014 popped up.
Wow, that's the first time I see that error. Try changing USB ports and trying again?
__________________
Al MacBook 2.4GHz Late '08 | 5 S⃣ | Macross Click Me
jav6454 is offline   0 Reply With Quote
Old Mar 9, 2011, 03:19 PM   #11
chiggah
Thread Starter
macrumors member
 
Join Date: Mar 2011
Tried that - other 2 USB ports did not work. I am reinstalling the driver via "Device Manager". Using Windows 7 64 bit.

Edit: Nope didnt work wtf
chiggah is offline   0 Reply With Quote
Old Mar 9, 2011, 04:00 PM   #12
RonnieBarlow
macrumors newbie
 
Join Date: Mar 2011
How to Fix Error Code 1013:

Mac OS X:

Step 1 : Go to your “Applications” folder
Step 2 : Go to your “Utilities” folder
Step 3 : Launch “Terminal”
Step 4 : Type “sudo nano /etc/hosts” (without quotes) and hit return
Step 5 : Enter your password
Step 6 : Use the down arrow key to find the “gs.apple.com” entries. Once the cursor is in front, make sure you comment out the line(s) by entering “#” (no quotes) in front of the text.
Step 7 : Save the file by pressing CONTROL+O on the keyboard
Step 8 : Exit the nano editor by pressing CONTROL+X on the keyboard
Step 9 : Restore your iDevice

Windows:
Step 1. Start –> Programs –> Accessories
Step 2. Run Notepad or WordPad
Step 3. Click “Open..” from File menu.
Step 4. Browse to Windows/System32/drivers/etc
Step 5. In “files of type:” select all documents
Step 6. Open “hosts”
Step 7. Delete all line that has “gs.apple.com” or something like that
Step 8. Hit Save
Step 9. Restore your device.
RonnieBarlow is offline   0 Reply With Quote
Old Mar 9, 2011, 04:01 PM   #13
chiggah
Thread Starter
macrumors member
 
Join Date: Mar 2011
Tried to restore via DFU mode. Now my apple device is not recognized in device manager, can't locate driver..

chiggah is offline   0 Reply With Quote
Old Mar 9, 2011, 04:04 PM   #14
chiggah
Thread Starter
macrumors member
 
Join Date: Mar 2011
Quote:
Originally Posted by RonnieBarlow View Post
How to Fix Error Code 1013:
Windows:
Step 1. Start –> Programs –> Accessories
Step 2. Run Notepad or WordPad
Step 3. Click “Open..” from File menu.
Step 4. Browse to Windows/System32/drivers/etc
Step 5. In “files of type:” select all documents
Step 6. Open “hosts”
Step 7. Delete all line that has “gs.apple.com” or something like that
Step 8. Hit Save
Step 9. Restore your device.
No apple in hosts file
chiggah is offline   0 Reply With Quote
Old Mar 9, 2011, 04:14 PM   #15
jav6454
macrumors G5
 
jav6454's Avatar
 
Join Date: Nov 2007
Location: 1 Geostationary Tower Plaza
Quote:
Originally Posted by RonnieBarlow View Post
How to Fix Error Code 1013:

Mac OS X:

Step 1 : Go to your “Applications” folder
Step 2 : Go to your “Utilities” folder
Step 3 : Launch “Terminal”
Step 4 : Type “sudo nano /etc/hosts” (without quotes) and hit return
Step 5 : Enter your password
Step 6 : Use the down arrow key to find the “gs.apple.com” entries. Once the cursor is in front, make sure you comment out the line(s) by entering “#” (no quotes) in front of the text.
Step 7 : Save the file by pressing CONTROL+O on the keyboard
Step 8 : Exit the nano editor by pressing CONTROL+X on the keyboard
Step 9 : Restore your iDevice

Windows:
Step 1. Start –> Programs –> Accessories
Step 2. Run Notepad or WordPad
Step 3. Click “Open..” from File menu.
Step 4. Browse to Windows/System32/drivers/etc
Step 5. In “files of type:” select all documents
Step 6. Open “hosts”
Step 7. Delete all line that has “gs.apple.com” or something like that
Step 8. Hit Save
Step 9. Restore your device.
This won't work. Because it is not that error. Did you even read the error before giving out instructions? Error 1013 is Baseband mismatch related. And even then, this will not work.
__________________
Al MacBook 2.4GHz Late '08 | 5 S⃣ | Macross Click Me
jav6454 is offline   0 Reply With Quote
Old Mar 9, 2011, 04:38 PM   #16
markojug
macrumors regular
 
Join Date: Mar 2009
Location: In A House, Ontario, Canada
Getting the same problem. Error 1013, trying a restore now.
markojug is offline   0 Reply With Quote
Old Mar 9, 2011, 04:44 PM   #17
dread
macrumors 6502a
 
Join Date: Jun 2009
I had the same problem. Tried it on another computer and it worked. I have tiny umbrella on the computer it wouldn't work on, but was not trying to use it. Any ideas. How do I get rid of this tiny umbrella b.s. from my computer. It doesn't show up in the add remove programs in windows
dread is offline   0 Reply With Quote
Old Mar 9, 2011, 04:46 PM   #18
chiggah
Thread Starter
macrumors member
 
Join Date: Mar 2011
Quote:
Originally Posted by dread View Post
I had the same problem. Tried it on another computer and it worked. I have tiny umbrella on the computer it wouldn't work on, but was not trying to use it. Any ideas. How do I get rid of this tiny umbrella b.s. from my computer. It doesn't show up in the add remove programs in windows
It worked now ? As in you are able to update to 4.3 ?
chiggah is offline   0 Reply With Quote
Old Mar 9, 2011, 05:03 PM   #19
dread
macrumors 6502a
 
Join Date: Jun 2009
Quote:
Originally Posted by chiggah View Post
It worked now ? As in you are able to update to 4.3 ?
Yes on the second computer. My phone was jailbroken on 4.01, I updated last month to 4.2.1 and tried to preserve the baseband with tiny umbrella but I had the same problem with the 1013 error and the phone eventually updated someone including the baseband. I tried to update to 4.3 today without using tiny umbrella and got the errors. I just want to remove tiny umbrella from my computer but can't figure out how. I just can't get that program to work correctly and it is messing up itunes somehow.
dread is offline   0 Reply With Quote
Old Mar 9, 2011, 05:22 PM   #20
Sedrick
macrumors 68030
 
Sedrick's Avatar
 
Join Date: Nov 2010
Wow, so far 4.3 is looking more dangerous that a lot of jailbreaks!
Sedrick is offline   0 Reply With Quote
Old Mar 9, 2011, 05:25 PM   #21
Saberon
macrumors 6502a
 
Join Date: Sep 2008
If this was a "big" issue it would be spread everywhere. I updated an iPhone 4, 3GS, ATV2 and iPad to 4.3 without issue.
Saberon is offline   0 Reply With Quote
Old Mar 9, 2011, 05:29 PM   #22
dread
macrumors 6502a
 
Join Date: Jun 2009
In my case it may have something to do with my prior jailbreak and the fact the I have never set up my phone as new since the first iphone. I have had various jailbreaks and unlocks along the way. However, it didn't start happening until I tried to use tinyumbrella so it is related to that somehow.
dread is offline   0 Reply With Quote
Old Mar 9, 2011, 06:37 PM   #23
yegon
macrumors 68000
 
Join Date: Oct 2007
I'm having this exact problem, very annoying since it's never even been jailbroken. The only non-official thing I've ever done with it was install the 4.1 (or 4.2) GM a few days before the release. I had to use TinyUmbrella back then to get it working and updated, and seem to recall having to resort to that gs.apple.com fix.

Tried everything now, even tried going back to 4.2.1 but no luck. Very pissed off indeed, gonna give up for tonight, and I hope some kind soul will offer a solution when I get up tomorrow

I thought I may have stumbled across a fix in the latest TinyUmbrella - there appears to be option to fix the 10XX issue specifically by entering DFU mode, then using "Fix Recovery" but it's always greyed out. *sigh*

Wish I'd never even bothered, especially now it looks like the ****'s at o2 are charging for personal hotspot - they want me to pay EXTRA for their pathetic 3G coverage, which I already could have done via tethering? They can **** right off, moving carrier when my contracts up, I;ve had enough of them.

edit: Just to clarify, I've tried restoring every which way, rebooting, different usb ports, that gs.apple.com thing, pfffffft!
yegon is offline   0 Reply With Quote
Old Mar 9, 2011, 06:43 PM   #24
AndrewR23
macrumors 68020
 
AndrewR23's Avatar
 
Join Date: Jun 2010
My computer does not have TinyUmbrella installed (mac) and 4.3 works perfect. my Gf does have it installed and her phone is stuck too...very weird.
AndrewR23 is offline   0 Reply With Quote
Old Mar 9, 2011, 07:05 PM   #25
yegon
macrumors 68000
 
Join Date: Oct 2007
Working now, using said method editing hosts file. Weird how it didn't work first time but, 90 minutes later, phone now working. I need to go to bed.
yegon is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Help neded! iPhone 4S stuck in Recovery Mode in iOS 7 GM. Help recover photos! Xeyad iOS 7 45 Jun 17, 2014 10:44 PM
Ios 7.0.4 - phone stuck in recovery mode!! lamerica80 iOS 7 1 Nov 21, 2013 12:36 PM
HELP! iPhone4s stuck in recovery mode when updating to iOS 6.1.3, I want to BACKUP josehku iPhone Tips, Help and Troubleshooting 0 Mar 25, 2013 10:12 PM
iPhone: Jailbroken iPhone 4S iOS 5.1.1 messed up with iFile stuck in recovery mode thifcosta Jailbreaks and iOS Hacks 1 Jul 16, 2012 11:26 AM

Forum Jump

All times are GMT -5. The time now is 11:19 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC