Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 13, 2011, 12:23 AM   #1
KelchM
macrumors regular
 
Join Date: Aug 2007
Album art not showing up in finder / quick look

I'm not sure when this started, but I have not been able to get album art to show up in Finder or quick look recently. This applies to both album artwork downloaded by iTunes and embedded artwork.

I have tested this on two machines running 10.6.6 and iTunes 10.2.1.
KelchM is offline   0 Reply With Quote
Old Mar 14, 2011, 04:56 AM   #2
Mr.Texor
macrumors regular
 
Join Date: Apr 2007
iTunes does not embed artwork to the mp3 files if you get the artwork using the iTunes store. It only embeds the images when you manually add the artwork.

Embedding has it benefits, but it also means that your files become larger as now they have an image in it. So if the album has 12 songs and the image to embed is 300kb, then the new total size is going to be about 2.5Mb bigger. Sure, now a days it's not much, but it can add up when you send them to your ipod/iphone/ipad/etc.

Said all that , I like them embedded, and there are several ways to embedd them after itunes has downloaded the images.. the best way is using this script:
http://dougscripts.com/itunes/script...hp?sp=embedart

If you need help using it, let me know..
Mr.Texor is offline   0 Reply With Quote
Old Mar 14, 2011, 05:13 AM   #3
Mr.Texor
macrumors regular
 
Join Date: Apr 2007
I forgot to say, sometimes finder wont immediately show the embedded album when using that script. I'm not sure why. The only way to force it to show it is to either log out or restart finder.

Try to not embed the images to too many files at the same time and give it a few seconds after it's ready before you process more files.

I've used it way too many times and have had no other problems with it but the finder problem can be a little bit scary the first time it happens.
Mr.Texor is offline   0 Reply With Quote
Old Mar 14, 2011, 06:12 PM   #4
KelchM
Thread Starter
macrumors regular
 
Join Date: Aug 2007
I know how to embed album art.

As I said in my post, the problem applies to both embedded art AND art that is downloaded by iTunes.

I've narrowed the problem down to iTunesAccess.framework. (/System/Library/PrivateFrameworks/iTunesAccess.framework/)

Rolling back to an older version of iTunes (and thus an older version of iTunesAccess.framework) seems to partially fix the problem. By partially, I mean that embedded art works correctly, but tracks which have their art downloaded by iTunes only show the 'no artwork' image in Finder. This is still an improvement from the default 'MP3' icon that was being displayed before I rolled back to an older version of iTunes.

Has anyone else been able to reproduce this issue on 10.6.6 and iTunes 10.2.x?
KelchM is offline   0 Reply With Quote
Old Mar 18, 2011, 02:06 PM   #5
jasonbrennan
macrumors member
 
Join Date: Jul 2006
Yes. I've been having this problem too. Using Mac OS 10.6.6 and iTunes 10.2 and also 10.2.1 has this problem for me as well.

I don't know how to fix it yet.

Question though, are you a developer? I'm an iOS developer and I know Xcode and iTunes share some files, so I'm wondering if maybe Xcode (I'm running Xcode 4 now and no older versions) could be causing the problem. Thoughts?
jasonbrennan is offline   0 Reply With Quote
Old Mar 18, 2011, 02:08 PM   #6
GGJstudios
macrumors Westmere
 
Join Date: May 2008
Mp3 files in FINDER doesn't show COVER ART
GGJstudios is offline   0 Reply With Quote
Old Mar 18, 2011, 02:40 PM   #7
jasonbrennan
macrumors member
 
Join Date: Jul 2006
See the thing is, my MP3s or any music file where I've *manually* added the album art, that works just fine in the Finder.

The only ones that don't show up with Quicklook are the tracks that have had the "Automatically download album art" set for and iTunes downloaded the artwork itself. This happens with any kind of music file.

The artwork used to show up just fine in the Finder, no matter what kind of track or how the artwork was added. But not any longer. That thread unfortunately didn't solve anything for me. But thanks anyway.
jasonbrennan is offline   0 Reply With Quote
Old Mar 18, 2011, 02:42 PM   #8
GGJstudios
macrumors Westmere
 
Join Date: May 2008
Quote:
Originally Posted by jasonbrennan View Post
The only ones that don't show up with Quicklook are the tracks that have had the "Automatically download album art" set for and iTunes downloaded the artwork itself.
If you read the thread I posted a link to, you'll see that's because iTunes doesn't embed the artwork in the file, but stores it in a separate folder.
GGJstudios is offline   0 Reply With Quote
Old Mar 18, 2011, 02:45 PM   #9
jasonbrennan
macrumors member
 
Join Date: Jul 2006
I did read that thread and I know that's how iTunes works when it automatically downloads the artwork. But QuickLook has always been able to properly handle the artwork even so.

iTunes stores the automatically downloaded art in its AlbumArt directory, inside a mess of directories (which are actually reversed-hex codes of the song's identifier in the iTunes library file).

It used to work and now it doesn't. It's very strange.

Also, my iTunes folder is in the usual spot, not external or anything funky like that.
jasonbrennan is offline   0 Reply With Quote
Old Mar 20, 2011, 11:29 AM   #10
KelchM
Thread Starter
macrumors regular
 
Join Date: Aug 2007
Quote:
Originally Posted by jasonbrennan View Post
Yes. I've been having this problem too. Using Mac OS 10.6.6 and iTunes 10.2 and also 10.2.1 has this problem for me as well.

I don't know how to fix it yet.

Question though, are you a developer? I'm an iOS developer and I know Xcode and iTunes share some files, so I'm wondering if maybe Xcode (I'm running Xcode 4 now and no older versions) could be causing the problem. Thoughts?
For what it's worth, I have not updated to xcode 4 yet.
KelchM is offline   0 Reply With Quote
Old Apr 5, 2011, 11:51 AM   #11
KelchM
Thread Starter
macrumors regular
 
Join Date: Aug 2007
Quote:
Originally Posted by KelchM View Post
I'm not sure when this started, but I have not been able to get album art to show up in Finder or quick look recently. This applies to both album artwork downloaded by iTunes and embedded artwork.

I have tested this on two machines running 10.6.6 and iTunes 10.2.1.
Here are two more references to this problem:
http://blog.alfredapp.com/2011/03/08...s-10-2-update/
http://www.tuneupmedia.com/blogindex...h-itunes-10-2/
KelchM is offline   0 Reply With Quote
Old Jul 12, 2011, 10:49 PM   #12
papo2
macrumors member
 
Join Date: Jun 2010
I am having the same problem. The album artwork is not displaying in Finder.

However, I noticed it only happens with the mp3 files I have on my local drive. All of the mp3 files with album artwork that reside on my external HD are displayed in Finder.

I am on 10.6.8, running iTunes 10.5 Beta 3, but have the same behavior with the official release of all 10.xx versions.

This is really annoying. Can anyone provide some insight?

Thanks peeps!
papo2 is offline   0 Reply With Quote
Old Jul 26, 2011, 02:38 PM   #13
Smorgie84
macrumors newbie
 
Join Date: Jul 2011
Location: Chicago, IL
Same Problem Here - Artwork Not Appearing on Tagged Audio File

I'm glad to see someone else is experiencing the same issue as I am. For me, this happened in the last week or so, perhaps with the recent OS X 10.6.8 update? I use ID3 Editor to tag my MP3 files. When I drag in artwork and update the file, I am usually able to see that artwork on the file that resides on my desktop or somewhere else on my machine. In the last week or so, after tagging the file, I see only the default musical note image associated with audio files. Older files created before are fine.

The interesting thing is that I know these new files are being tagged properly because I use them for podcasting and when someone downloads the content, they see the image with the latest episode on their iPhone/iPod, etc. It's just an athestic thing at this point, but also frustrating because I don't know for sure whether the file has been tagged just by looking at it.

I upgraded one of my machines to Lion this morning so I plan to check to see whether this is still a problem on the new OS once I get home tonight.

Any other updates on this from those who have reported a problem? By some of the dates of these posts, it looks like this problem goes back to some older versions of the Mac OS.
Smorgie84 is offline   0 Reply With Quote
Old Jul 26, 2011, 02:50 PM   #14
Jolly Jimmy
macrumors 65816
 
Jolly Jimmy's Avatar
 
Join Date: Dec 2007
This is an iTunes 10.4 and over issue. Last time it was iTunes 9.2 IIRC. Nothing we can do except send bug reports to Apple and wait for an update, and hope it doesn't take as long as last time.
Jolly Jimmy is offline   0 Reply With Quote
Old Jul 27, 2011, 08:00 AM   #15
Smorgie84
macrumors newbie
 
Join Date: Jul 2011
Location: Chicago, IL
Jolly Jimmy is correct. This issue is not occurring on my machine that has an earlier version of iTunes. Strange, but my Lion download came with an earlier version of iTunes (10.3.1) and this issue is not happening there. It's happening only with my machine that has iTunes 10.4. I didn't know why iTunes had anything to do with this since I am not using iTunes to tag my files. I contacted the software firm that supports the ID3 Editor and this is what he said (this may not be news to anyone else, but I learned something new):

The reason for the issue with iTunes is the tight integration with QuickTime which basically runs the preview system in OS X, so the upgrade would havechanged system files that would appear to have nothing to do with iTunes. Ifyou are using 10.4 and it is happening again, then it does confirm the rumours which is annoying to say the least. Your best option is to downgradeto 10.3 as Apple took a very long time to fix the problem last time
Smorgie84 is offline   0 Reply With Quote
Old Jul 27, 2011, 03:43 PM   #16
nikicampos
macrumors 6502
 
Join Date: Jul 2011
To Smorgie84, it's not strange that your Lion download came with 10.3.1, every Lion download comes with it, the thing is not to install the update 10.4, I did that, and I couldn't create new mp3 with the artwork, so I reinstalled Lion, kept iTunes 10.3.1 and everything works, so yes, I guess it's safe to say that the problem is in iTunes 10.4 update, not in finder.

So, if you are like me, that wants everything perfect, don't update to 10.4, and just have to wait until we find out that Apple has fixed this issue in iTunes 10.XXXX
nikicampos is offline   0 Reply With Quote
Old Aug 22, 2011, 04:28 PM   #17
nikicampos
macrumors 6502
 
Join Date: Jul 2011
Update 104.1 fixes this issue, lets download it and see if it works...

Apple’s release notes are as follows:

iTunes 10.4.1 provides a number of improvements, including:

- Fixes a problem where the media keys on some third-party keyboards work inconsistently with iTunes
- Addresses issues with adding artwork to songs and videos
nikicampos is offline   0 Reply With Quote
Old Aug 22, 2011, 07:02 PM   #18
nikicampos
macrumors 6502
 
Join Date: Jul 2011
Yeah, I just tried out, I selected a song, created an mp3 version of it, and the album artwork didn't embed the cover art, 10.3 was working great for me, if only apple hadn't stated that it fixed the album art problem i would never updated to 10.4.1, *****.

Sorry all for that, so, do not update to 10.4.1, it doesn't fix the problem!!!!!!!!!!!!
nikicampos is offline   0 Reply With Quote
Old Aug 25, 2011, 11:24 AM   #19
Smorgie84
macrumors newbie
 
Join Date: Jul 2011
Location: Chicago, IL
I wish I had seen this last post before I upgraded to 10.4.1. I can also confirm that this version did not address this problem.
Smorgie84 is offline   0 Reply With Quote
Old Oct 13, 2012, 04:18 AM   #20
kidclam
macrumors newbie
 
Join Date: Mar 2008
I have the fix!!!!

I have had the same issue ever since Lion. Its been very painful not having album art preview in finder or the play button when rollover the file for so many versions of OSX. Today I worked hard in trying to solve the problem since Applecare support hasn't helped much, all they did was tell me to bring the computer in. The other main reason I got so motivated to try and fix this is because the DJ app for Mac only reads album art from the finder even if iTunes can display the album art. The other reason that got me curious is that my friends macbook pro album art worked fine, so I cross checked with his computer until I figured out a few things that helped and ultimately fixed the issue. FINALLY!

My set up:
- I have my full iTunes library folder on my external as I have over 700GB of music.
- It includes all my database files in there, which is very important as I have many playlist settings from over 7 years of iTunes activity.

SOLUTION:
1. With every new computer I have purchased, I use to just pressed option on Mac and press iTunes to locate my folder (which I have said is located on my external drive).
2. I tried today to press option again BUT locate and selected the default library in the user/music folder of my internal drive (standard setting from Apple).
3. Miraculously, all the album art appeared in both my external drive library and also today's downloaded songs on my Macbook pro. Ofcourse with the new default location I don't have any songs or data.
4. So I tried to find a way to keep this library data on my internal drive since it can help the finder display all my files properly, yes even have the play on rollover button but as well link it back to my external drive with all my 700GB songs.
5. I then went into iTunes Preferences/Advance tab and in iTunes Media folder location redirected the location to my external drive iTunes/ iTunes Media folder. If it asks to collate data, press NO.
6. Then I quit iTunes.
7. Next I copied the 4 files to my desktop from my external drive as I want to keep the data I have made with all my playlists etc. The four files are iTunes Library Extras.itdb , iTunes Library Genius.itdb , iTunes Library.itl , iTunes Library.xml
8. I then went to my internal drive User/Music/Itunes/ and dragged these 4 files I copied from my external drive into here and making sure to REPLACE the four existing files already there.
9. Next open iTunes and you will find all your presettings appear with all your music linked to your external. What this does is keep the important library files on your internal drive (that somehow makes your finder files album art appear), BUT to read also all the music mp3 files located in the external drive (action from step 5)

Presto!! All your music files whether on internal drive or external all the album art has appeared.

Hope this helps!! Let me know if there are any other questions.
I am on 10.8.1 running retina macbook pro.
kidclam is offline   0 Reply With Quote
Old Oct 18, 2012, 01:41 AM   #21
LazarusX
macrumors newbie
 
Join Date: Aug 2012
Location: Shanghai, China
Quote:
Originally Posted by kidclam View Post
I have the fix!!!!

I have had the same issue ever since Lion. Its been very painful not having album art preview in finder or the play button when rollover the file for so many versions of OSX. Today I worked hard in trying to solve the problem since Applecare support hasn't helped much, all they did was tell me to bring the computer in. The other main reason I got so motivated to try and fix this is because the DJ app for Mac only reads album art from the finder even if iTunes can display the album art. The other reason that got me curious is that my friends macbook pro album art worked fine, so I cross checked with his computer until I figured out a few things that helped and ultimately fixed the issue. FINALLY!

My set up:
- I have my full iTunes library folder on my external as I have over 700GB of music.
- It includes all my database files in there, which is very important as I have many playlist settings from over 7 years of iTunes activity.

SOLUTION:
1. With every new computer I have purchased, I use to just pressed option on Mac and press iTunes to locate my folder (which I have said is located on my external drive).
2. I tried today to press option again BUT locate and selected the default library in the user/music folder of my internal drive (standard setting from Apple).
3. Miraculously, all the album art appeared in both my external drive library and also today's downloaded songs on my Macbook pro. Ofcourse with the new default location I don't have any songs or data.
4. So I tried to find a way to keep this library data on my internal drive since it can help the finder display all my files properly, yes even have the play on rollover button but as well link it back to my external drive with all my 700GB songs.
5. I then went into iTunes Preferences/Advance tab and in iTunes Media folder location redirected the location to my external drive iTunes/ iTunes Media folder. If it asks to collate data, press NO.
6. Then I quit iTunes.
7. Next I copied the 4 files to my desktop from my external drive as I want to keep the data I have made with all my playlists etc. The four files are iTunes Library Extras.itdb , iTunes Library Genius.itdb , iTunes Library.itl , iTunes Library.xml
8. I then went to my internal drive User/Music/Itunes/ and dragged these 4 files I copied from my external drive into here and making sure to REPLACE the four existing files already there.
9. Next open iTunes and you will find all your presettings appear with all your music linked to your external. What this does is keep the important library files on your internal drive (that somehow makes your finder files album art appear), BUT to read also all the music mp3 files located in the external drive (action from step 5)

Presto!! All your music files whether on internal drive or external all the album art has appeared.

Hope this helps!! Let me know if there are any other questions.
I am on 10.8.1 running retina macbook pro.
Same issue here.

Here's my setup:
OS X 10.8.2 (clean install), iTunes 10.7
I replaced the optical drive with a SSD and set it as my startup drive. My iTunes library is located on the stock HDD drive. For every music file (inside or outside the iTunes library), the album art (which I'm sure is embedded in the music file) is not shown in finder icon or quick look.

I tried kidclam's solution, not working.
LazarusX is offline   0 Reply With Quote
Old Oct 19, 2012, 09:09 PM   #22
kidclam
macrumors newbie
 
Join Date: Mar 2008
Quote:
Originally Posted by LazarusX View Post
Same issue here.

Here's my setup:
OS X 10.8.2 (clean install), iTunes 10.7
I replaced the optical drive with a SSD and set it as my startup drive. My iTunes library is located on the stock HDD drive. For every music file (inside or outside the iTunes library), the album art (which I'm sure is embedded in the music file) is not shown in finder icon or quick look.

I tried kidclam's solution, not working.
Interesting that I suggested for you to test another easy way but you can't be bothered. Then you come in this thread and said my solution is not working without giving any real reason. Your set up is unique compared to a normal set up and that is why I asked you to try another way. But you don't reply back.

I asked you to simply open an account with admin privileges and test the iTunes from scratch. This doesn't affect your current account. You could currently have some app installed or files moved that is not working.

If you start from a clean account, its the only way you can test an issue related to the system. Did you try taking your issue to Apple Store genius person to have a look?
kidclam is offline   0 Reply With Quote
Old Oct 27, 2012, 06:40 AM   #23
LazarusX
macrumors newbie
 
Join Date: Aug 2012
Location: Shanghai, China
Quote:
Originally Posted by kidclam View Post
Interesting that I suggested for you to test another easy way but you can't be bothered. Then you come in this thread and said my solution is not working without giving any real reason. Your set up is unique compared to a normal set up and that is why I asked you to try another way. But you don't reply back.

I asked you to simply open an account with admin privileges and test the iTunes from scratch. This doesn't affect your current account. You could currently have some app installed or files moved that is not working.

If you start from a clean account, its the only way you can test an issue related to the system. Did you try taking your issue to Apple Store genius person to have a look?
Actually this was posted before that one on Apple Support Communities.

I have taken your advice and replied you there.
LazarusX is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
Album art not showing up when playing music via AirPlay duelingdragons Apple TV and Home Theater 4 Dec 23, 2012 05:40 AM
Front Row - Some Album Art not showing up? seyh OS X 0 Jun 19, 2011 05:29 PM
album does not show up in alphabetical order like all others in my library Sossity Mac Applications and Mac App Store 1 Apr 15, 2011 04:32 PM
Seagate Go drive will not show up in Finder anymore but will boot up techmonkey MacBook Pro 2 Sep 29, 2008 09:31 PM
Apps not showing up in Finder + 'Error -51' Keija Mac Applications and Mac App Store 0 May 11, 2004 10:27 PM


All times are GMT -5. The time now is 05:26 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC