Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 15, 2011, 07:28 PM   #1
shaunmorelli
macrumors newbie
 
Join Date: Dec 2010
Application Issues

Hi,

So i have my home directory on an external hard drive along with all my libraries for iphoto, aperture itunes ect... When the hard drive is plugged into my desktop computer i can open all applications fine and the libraries show up, safari saves my bookmarks ect.. However when my external HD is plugged into my macbook pro ( logged on to the same home directory) every time i open one of the above apps i have to select the library every time i open the app by holding option when i open them, otherwise a message pops up that says a library cannot be created ect... same with safari the welcome animation comes up every time and all my bookmarks will have been deleted since the last time i opened safari (Also the message that a keychain cannot be found to store "safari" frequently pops up while browsing). The same goes for every other application whenever i open them they act as if it's the first time i'm opening them. This has become very frustrating. I have checked that i have permission on the external HD and what not. Any and all help is appreciated.

Thanks in advance,
shaunmorelli is offline   0 Reply With Quote
Old Mar 15, 2011, 09:53 PM   #2
shaunmorelli
Thread Starter
macrumors newbie
 
Join Date: Dec 2010
also something that might help is that when i'm on the laptop it adds a 1 in path name of the external hard drive in all apps that try to access it. i think thtas the problem but i don't know how to get rid of it.
shaunmorelli is offline   0 Reply With Quote
Old Mar 15, 2011, 10:16 PM   #3
iThinkergoiMac
macrumors 68030
 
Join Date: Jan 2010
Location: Terra
That would be the problem. Most likely, you have a duplicate folder in the /Volumes directory because you launched an app while the external HDD was not connected and that app created the directory it was looking for (ie: /Volumes/extHDD/Library/) where "extHDD" is the name of your external HDD. So when you plug in the real one, there's already a folder of that name in /Volumes so it appends a 1 to the name so they don't conflict. The solution is to delete that folder, and you'll have to get to /Volumes directly.
__________________
13" 2009 MBP, 2.26 GHz C2D, 8 GB RAM, 320 GB HDD; 2.2 GHz C2D MB, 6 GB RAM, 160 GB HDD; 32 GB iPod Touch 3G
-FWIW, my handle is iThink_ergo_iMac. There seems to be some confusion on this issue.-
iThinkergoiMac is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Tags
applications, external hard drive, iphoto, itunes library

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Any way/application to click on application icon in dock and minimize? TheArgonaut OS X Mavericks (10.9) 3 Dec 6, 2013 08:23 PM
Help: Total mac noob (Folder and application issues) bbvip Mac Basics and Help 16 Jun 27, 2013 12:20 PM
Having issues with push in Mail application dwellsMBP OS X 10.8 Mountain Lion 2 Dec 16, 2012 12:36 AM
Issues with blutooth and new maps application (turn-by-turn)?? eroxx iOS 6 2 Sep 19, 2012 05:51 PM
Web application link application launch puzzle lancewan Mac Applications and Mac App Store 0 Jun 21, 2012 08:37 AM

Forum Jump

All times are GMT -5. The time now is 04:42 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC