Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 20, 2011, 06:10 AM   #1
or100cohen
macrumors newbie
 
Join Date: Mar 2011
Unhappy help,My iphone 3gs stuck in a white screen

trying to restore to 4.2.1 with redsn0w
It's not so worked
so i get in to redsn0w with tinyumbrella-4.30.03
and I clicked on Install cydia
and then it work
but then isee a bug,whan i traing to turn it up'it dosnt work
so i get in to redsn0w and then
"just boot..."
and it work again
after 20 m'
its turn off (i dont keno why)
so i get in to redsn0w and do "just boot..." **again**
and its whitescreen.
my Iphone
3GS
befor i resotre it was 3.1.2
05.11.07-6.4_M3S2
MC134HB/B - iPhone3GS
or100cohen is offline   0 Reply With Quote
Old Mar 20, 2011, 08:34 AM   #2
Crystal-RX
macrumors 68030
 
Crystal-RX's Avatar
 
Join Date: Dec 2008
Location: Seattle, WA USA
Your iPhone has 3.1.2. If you want to update your firmware you need to use iTunes. I don't understand about the part you use redsn0w to restore 4.2.1.

Can you elaborate more on this or tell me what you did so I know what went wrong?
Crystal-RX is offline   0 Reply With Quote
Old Mar 21, 2011, 12:36 AM   #3
islandboy
macrumors newbie
 
Join Date: Mar 2011
Stuck on white screen

I'm having the same trouble...stuck on white screen.

I ran redsn0w on my 3gs 4.2.1 stock firmware (5.15.04) and everything was fine (updated baseband to 06.15.??). Installed cydia to install ultrasn0w. rebooted iphone using redsn0w (tethered jb) and phone worked on T-Mobile.

Now, just like or100cohen, the phone turned off and I needed to boot tether. it booted right up but after I'd say 10 minutes or so, it turned off again. Tethered boot again and tried to put my wife's sim in iphone and it worked. I went to sleep and found the iphone to be turned off so I tried to tether boot again. Redsn0w does it thing...builds, "press sleep, sleep&home, home button sequence" and it says it done. But I didn't notice the pineapple logo like the boot tethers that I did earlier. It just stays on the white screen.

Tried to install custom restore but I get errors saying "can't recognize", "server update is unavailable", or error 1600 or 28 pop up. I've tried to restore back into 4.2.1 but unable to. I've tried to run Pwnage 4.2 and 4.1.3 but it says 4.2.1 (3gs) and even the 3.2.2 (ipad) ipsw's are wrong bundle.

If you have any suggestions, it will be greatly appreciated.
islandboy is offline   0 Reply With Quote
Old Jun 22, 2011, 10:01 AM   #4
JJR51
macrumors newbie
 
Join Date: Jun 2011
Smile How to fix it

What you need:

1.iPhone take apart tools (precision screw driver, suction cup etc)
2.Windows operating system (Sorry Mac users!)
3.iTunes 10.1.2 or later
4.iREB RC3
5.iPhone 3GS Custom iOS 4.2.1 Firmware (you can also build it yourself with Sn0wbreeze 2.2.1)
6.GreenPois0n RC6.1
Warning: Before you proceed, please be warned that dismantling your iPhone will void the warranty and may permanently damage your iPhone. We will not be responsible for any damage caused to your iPhone. You have been warned.


Steps:

1.Take apart your iPhone. See YouTube videos here.
2.Remove the logic board and put it to the side for at least 30 minutes (go have coffee or play your hacked PS3). Separating the logic board from the battery clears the memory that handles the boot process. Note: You can also leave your device uncharged for at least 5 days and will give you similar result.
3.Now re-assemble your iPhone.
4.iREB RC3 (right click, Run as Administrator on Windows 7). Go to Recovery Mode Loop Fixer tab and click Set-Auto Boot True.
5.Go to iREB tab and select 3GS. Your iPhone will be set to pawn DFU mode so that it can accept iPhone 3GS custom iOS 4.2.1 firmware that you just downloaded.
6.Launch iTunes and press Shift+Restore, then point to the custom IPSW. Restore will begin and wait patiently until itís finished.
7.Launch GreenPois0n RC6.1 to untether jailbreak your iPhone (this takes off the hassle of rebooting via Redsn0w after installing ultrasn0w).
8.Now you can proceed with unlocking your iPhone with ultrasn0w 1.2.
JJR51 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
3gs stuck in white screen element9633 iPhone 1 Jan 30, 2014 09:42 PM
iPhone 4 Stuck in White Screen! iMacBookPro iPhone Tips, Help and Troubleshooting 6 Mar 15, 2013 02:57 AM
Iphone 3gs stuck on activation screen wogyield iPhone 0 Jan 1, 2013 10:03 AM
iPhone: iPhone 3GS stuck on White Screen DesMir Jailbreaks and iOS Hacks 10 Dec 17, 2012 09:47 PM
iPhone screen stuck white ASannik iPhone Tips, Help and Troubleshooting 1 Jul 30, 2012 03:51 AM

Forum Jump

All times are GMT -5. The time now is 07:52 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC