Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 22, 2011, 02:26 PM   #1
Arzy
macrumors newbie
 
Join Date: Jul 2010
Unhappy Early 2011 Macbook Pro dropping Wifi Signal

I have a brand new early 2011 Macbook Pro 15" and its randomly dropping the Wifi signal. I just updated to 10.6.7 and it's still doing it.

I have an Apple Airport Extreme router and none of my other computers ever drop their wifi signal so something must be unique to this computer that I've owned for a week. I only use the Mac in OS X, I have no Windows on it.

Anyone else seeing their wifi drop off at random intervals? If I do a run thru "network diagnostics" it comes right back up instantly so something must be up.
Arzy is offline   0 Reply With Quote
Old Mar 22, 2011, 06:19 PM   #2
ddehr026
macrumors 6502
 
Join Date: May 2010
I would take it in, sounds like something wacky with the wifi chip.
ddehr026 is offline   0 Reply With Quote
Old Mar 22, 2011, 06:32 PM   #3
Evan_11
macrumors regular
 
Join Date: Feb 2004
I've had the same problem with my 2011 13" MBP (base model). Seems to only happen when I have an external monitor hooked up. I've read that display port adapters can cause wifi issues. Usually I only have to turn airport off and then back on, but today I had to do a full reboot.

Other problems that I've had: Bluetooth issues with my Magic Trackpad not being recognized...... and crappy flash performance / memory leaks in Safari. That's fine that Steve Jobs doesn't like Flash for iOS but he should give a crap about it under OS X.

These problems with this computer makes me think that this MBP update was not ready for prime time and Apple pushed them out to coincide with Intel's Thunderbolt and Sandy Bridge release.
Evan_11 is offline   0 Reply With Quote
Old Mar 22, 2011, 07:04 PM   #4
S A
macrumors member
 
Join Date: Mar 2011
Location: Midlands, UK
Hi, I too have a 2011 13" MBP and am finding the exact same problem.

I have no external displays connected. I am using a Normal Wireless N Router.

Before, I was able to just reconnect, but today I had to do a restart.



Any ideas anybody? Should I take it back to the Apple Store?
S A is offline   0 Reply With Quote
Old Mar 22, 2011, 07:14 PM   #5
bastienvans
macrumors member
 
Join Date: Feb 2011
Location: FL
I have the same mbp and router and everything works fine. Take it in.
bastienvans is offline   0 Reply With Quote
Old Mar 22, 2011, 08:42 PM   #6
ocgirl
macrumors member
 
Join Date: Feb 2011
I kind of have the same problem too, but it's my network that doesn't seem to be fully compatible with the Apple products because my iPhone as the exact same problem. (however, today oh miracle it isn't dropping [I switched off/on the router and the thing that gets the internet ])

However, when I take my MBP to public places, such as library and university, it never drops.
Maybe try to reconfigure your router/thing that gets the internet (sorry don't know the name)?
ocgirl is offline   0 Reply With Quote
Old Mar 22, 2011, 10:24 PM   #7
HawaiiMacAddict
macrumors 6502a
 
Join Date: Dec 2006
Location: On one of my Macs of course
I had somewhat the same result last Saturday. I took my Lexus RX350 in for some maintenance and was expecting to be able to use their WiFi network as I had done in the past. Three of us in the waiting area had Macintosh laptops, but I was the only one that constantly dropped the Lexus WiFi network. Another network, named Free WiFi turned out to be much more reliable, but I fail to see why the other two Macs, both of which were earlier MacBook Pro models, seemed to grab the Lexus WiFi signal when mine apparently couldn't.

That being said, that was the only WiFi network that I have found to which my new laptop has an aversion. Everything works swimmingly well at home, but I haven't had a chance to try it at grad school yet - we're on Spring Break now, so I'll have to wait until next week to try.

As it turned out, I spent most of my waiting time coding (or rather, modifying) my iOS apps, so I didn't really have a large need for internet connectivity
__________________
27" iMac , 17" MBP, 15" rMBP - OS X 10.8.4
64GB iPhone 5 - iOS 7B2
64GB iPad w/Retina Screen, 64GB iPad (original) iOS 6
HawaiiMacAddict is offline   0 Reply With Quote
Old Mar 22, 2011, 11:51 PM   #8
a-m-k
macrumors 6502a
 
Join Date: Sep 2009
I have the same problem and my MBP is 3 months shy of being two years old. I usually just log out and log back in.
a-m-k is offline   0 Reply With Quote
Old Mar 23, 2011, 12:54 AM   #9
revenire
macrumors newbie
 
Join Date: Mar 2011
Same issue here. Called Apple, they said interference was causing it and because it is Netgear router (two months old) they can't do a thing. Interference? Not sure about that as I am 3 feet from the router. Seems to be an issue with MBPs?
__________________
17" MBP, 2.2GHz i7, 4 GB RAM, 750 GB HD
revenire is offline   0 Reply With Quote
Old Mar 23, 2011, 12:45 PM   #10
Arzy
Thread Starter
macrumors newbie
 
Join Date: Jul 2010
so I ran Utorrent all night and it never dropped its connection. It only seems to drop off when it idles, and then randomly, not in a set pattern.

Brand new $3k computer...ugh.
Arzy is offline   0 Reply With Quote
Old Mar 23, 2011, 05:48 PM   #11
Advokit
macrumors newbie
 
Join Date: Jan 2011
Location: Queens, N.Y.
Same problem occurring here on 3 wk old 2011 15" MacBook Pro. Wifi signal has cut out 4 or 5 times over that period; no apparent pattern to this signal drop out is descernable, and the wifi signal is easily reestablished by turning Airport off and then back on. I'm using a new Airport Express as my router and this problem just started with the use of my new MacBook Pro. Any thoughts?
__________________
2011 15" MacBook Pro HR/AG, iMac 8,1 24" 2.8GHz, PowerMac G4 MDD, original 128k Mac (yes I still have it) and many others in between.
Advokit is offline   0 Reply With Quote
Old Mar 23, 2011, 10:31 PM   #12
DJMIKEYD
macrumors newbie
 
Join Date: Mar 2011
macbook pro 2011 15' 2.0 gzh

im having the same problem with the wifi just randomly stops working but no change in the bars of the airport?? WTF!!! lol the only fix is shutting off the airport and turning it back on should i return the mbp or could it just be my wireless router but my iphone or any of my other computers are not having any problems with it

Last edited by DJMIKEYD; Mar 23, 2011 at 10:42 PM.
DJMIKEYD is offline   0 Reply With Quote
Old Mar 23, 2011, 10:35 PM   #13
Rhyalus
macrumors 6502
 
Join Date: Mar 2011
Quote:
Originally Posted by DJMIKEYD View Post
im having the same problem with the wifi just randomly stops working but no change in the bars of the airport?? WTF!!! lol the only fix is shutting off the airport and turning it back on should i return the mbp or could it just be my wireless router but my iphone or any of my other computers are having problems with it
Search on the apple support web site....I saw a link earlier today about how to resolve this issue. Someone posted here on the forums.

Sorry - I don't have the link for you.

R
Rhyalus is offline   0 Reply With Quote
Old Mar 23, 2011, 10:41 PM   #14
squeakr
macrumors 68000
 
squeakr's Avatar
 
Join Date: Apr 2010
I think I saw that link as well, and the resolution suggested was to not use WEP encryption. Are you broadcasting the SSID, as if not that can sometimes cause issues? Are there any interfering signals nearby, if it is a 2.4 signal than lots of cordless phones and devices and bluetooth signals can cause interference? Have you scanned the area to see what neighboring signals might be causing interference if broadcasting nearby (from my house on the average night I can see 11 different routers from the neighbors, I made sure I am on channels they are not, and am the only 5 GHz so that helps as well)?
squeakr is offline   0 Reply With Quote
Old Mar 24, 2011, 07:54 AM   #15
Lucagfc
macrumors regular
 
Join Date: Sep 2008
I' ve the same problem. When I' m using wifi all works great. But when I don' t use it the wifi lost the connection randomly. I' ve only 1 Wifi network in the MBP range and My old 13" MacBook Pro (2009) works great with that network!
__________________
MacBook Pro 17" (Early 2011) iPhone 4 iPad 2 White
Lucagfc is offline   0 Reply With Quote
Old Mar 24, 2011, 02:22 PM   #16
Arzy
Thread Starter
macrumors newbie
 
Join Date: Jul 2010
Quote:
Originally Posted by Arzy View Post
so I ran Utorrent all night and it never dropped its connection. It only seems to drop off when it idles, and then randomly, not in a set pattern.

Brand new $3k computer...ugh.
I was wrong, it just dropped while I was standing at my computer with UTorrent running.

What an odd problem.
Arzy is offline   0 Reply With Quote
Old Mar 28, 2011, 01:52 AM   #17
Advokit
macrumors newbie
 
Join Date: Jan 2011
Location: Queens, N.Y.
I followed the directions from this site http://michaelhyatt.com/fix-for-wire...cbook-pro.html 4 days ago; since then the Airport dropout problem has not repeated itself. Basically, I opened the Network Prefs, reordered the network options so that Airport was the first network connection tried, hit "Apply" for this option, closed the Network Pref and then quit System Preferences. Finally, I immediately restarted my 2011 15" MacBook Pro and then zapped the PRAM when it restarted. So far so good, the Airport dropout problem, which had been occurring every 3 or 4 days, has not recurred since I tried this solution; if it happens anytime soon I will update this post.
__________________
2011 15" MacBook Pro HR/AG, iMac 8,1 24" 2.8GHz, PowerMac G4 MDD, original 128k Mac (yes I still have it) and many others in between.
Advokit is offline   0 Reply With Quote
Old Apr 13, 2011, 04:14 AM   #18
eldino
macrumors member
 
Join Date: Mar 2007
Location: Italy
Same problem here!

Macbook Pro 13' (early 2011), base model; Mac Os X 10.6.7.
Linksys-Cisco WRT160NL access point, WPA network.

Wireless connection drops every 2 minutes and to restore it,you have to both close and re-open the notebook lid (sleep-unsleep) or disable-enable Airport card!

Official thread on Apple forum (at moment no word from Apple):
http://discussions.apple.com/thread....3879&#13223879
__________________
Scripting, iTunes, Creative Commons music etc: http://eldino.wordpress.com
eldino is offline   0 Reply With Quote
Old Apr 13, 2011, 05:17 AM   #19
redant
macrumors newbie
 
Join Date: Apr 2011
I have the same problem, though with no external display connected. I've spent around 2 hours in total on the phone to apple, I created a new network location, reverted to factory settings, booted off the os x installation disc and ran a ping test outside of the OS, and it worked fine. Inside the OS, it is still dropping out. I wiped the hard drive and did a clean install of os x as instructed by apple, still no fix. The fact that the unlimited ping test ran for over 1 hour with no issues outside the OS rules out a hardware fault, but the tech said that the fact that ethernet works is indicative of a hardware fault. So 'm back to square one. either a hardware fault or a driver issue.
redant is offline   0 Reply With Quote
Old Jun 25, 2011, 01:29 AM   #20
silverf1re
macrumors regular
 
Join Date: Mar 2011
I just purchased a refurb 2010 model and I am having similar issues. My airport bars do not change but webpages become unresponsive. Its not an issue with my browser because I use an alternative and still nothing. I restart the macbook and all is good. How do I tell an apple bar tech (sorry genius is a dumb title for a tech) that I have a random problem and expect them to do anything about it? Take video? Input greatly appreciated.
silverf1re is offline   0 Reply With Quote
Old Jul 23, 2011, 01:22 AM   #21
frankieboy
macrumors regular
 
Join Date: Jun 2009
Quote:
Originally Posted by silverf1re View Post
I just purchased a refurb 2010 model and I am having similar issues. My airport bars do not change but webpages become unresponsive. Its not an issue with my browser because I use an alternative and still nothing. I restart the macbook and all is good. How do I tell an apple bar tech (sorry genius is a dumb title for a tech) that I have a random problem and expect them to do anything about it? Take video? Input greatly appreciated.
You can just tell the tech what you describe above- that the problem is intermittent- and they will do what the can to handle the situation. Since the problem goes away when you restart, arrange your visit with the tech to coincide with a lengthy interval since your last reboot.
frankieboy is offline   0 Reply With Quote
Old Jul 23, 2011, 01:23 AM   #22
adrian1480
macrumors 6502
 
Join Date: Sep 2010
I'd recommend exchanging the laptop if it's not too late.

I've been following a thread for the last 4 months of people waiting for Apple to fix it with a software update that has yet to come.

Unless you want to try a new router, take the laptop back and demand a new one. Not all 2011 MBP's have this problem, including my own.
adrian1480 is offline   0 Reply With Quote
Old Aug 4, 2011, 04:35 PM   #23
SeamusBerkeley
macrumors newbie
 
Join Date: Aug 2011
Location: Taos, NM; Berkeley, CA
Random wifi drops, disconnects

Having similar issues with a 2009 MBP.

Connection works fine for random period, drops connection, will not reconnect even manually choosing same network and entering password.

This last detail is the most curious: The saved network and password is not longer retained in Network Preferences (NP), although still retained in Keychain Access. It appears the problem is with NP.

Seamus Berkeley
Fine Art Painting
SeamusBerkeley is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
macbook pro, mid 2010: wifi dropping out scotthew1 MacBook Pro 3 Feb 18, 2014 01:35 AM
Help! Early 2011 MacBook Pro or Late 2011 MacBook Pro? PinoyAko MacBook Pro 21 Feb 11, 2013 09:03 PM
MacBook Pro (Early 2011) 10.8 Losing Wifi After Sleep Mitch444 Mac Pro 1 Dec 10, 2012 07:14 PM
Experience on moving from 2011 early macbook pro 15 to 2012 macbook pro 13 ? paulCC MacBook Pro 2 Nov 24, 2012 02:47 PM
ATV3 wifi signal dropping :( amitabhbansal Apple TV and Home Theater 12 Oct 10, 2012 01:06 AM

Forum Jump

All times are GMT -5. The time now is 03:28 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC