Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Apr 1, 2011, 08:51 AM   #1
snowleopard13
macrumors regular
 
Join Date: Apr 2010
Location: Austria
Problem with Itunes access privileges

I just installed a SSD. The HDD went into the Superdrive holder using an Obtibay. The SSD went in the original HDD spot.

All runs well after cloning the system with carbon copy cloner except iTunes. When i start iTunes i get an error: 'You do not have enough access privilieges for this operation'. This shows up a few seconds, then iTunes closes and asks me if i want to report, ignore or reopen.

I already repaired disc permissions and set the itunes folder in my home folder to read and write for all users.

Does any of you guys know what's the problem here?
__________________
MacBook Pro 13" Mid 2010 with SSD & HDD, 8GB | iPad White 32GB 3rd Generation| iPhone 4S Black 32GB
snowleopard13 is offline   0 Reply With Quote
Old Apr 1, 2011, 06:20 PM   #2
Spikestrip
macrumors member
 
Join Date: Apr 2011
Location: California
Try holding the option key as you click on iTunes in the Dock. When it opens, tell it to create a new library. It will be empty, but you can get an idea of whether iTunes works at all, or if your library is to blame.

If it works when you create a new library, the easiest option is to simply drag all the music from your Music folder (you can even drag the whole music folder) onto the running iTunes window. This will re-import all your music as if you had never heard it before. If you don't make playlists, this won't be a problem.

Otherwise, you can try to pinpoint which file(s) within the iTunes folder has incorrect permissions. It can also be hard to tell, because if the permission were incorrect from moving it the way you did, the Owner would still be you. It often has the username shown like Username(Me). If it doesn't show that(Me), it is likely still owned by the old you. You can check and change ownership and permissions in the Get Info window, -I, or Command-I for the newer Macs, or just File>Get Info. If you tell it to do this for enclosed items, and your iTunes media folder is included, it might take a while, and is not really necessary. It would be one of the files in the iTunes folder, most likely the iTunes Library itself.

Permissions on my iTunes Library file look like this.
Attached Images
 
__________________
Apple Certified ACSP, ACMT; 3 years as a Mac Genius; currently freelance Mac tech; jailbroken & repaired iEverything. Knowledge is free power. Spread the wealth.

Last edited by Spikestrip; Apr 1, 2011 at 06:48 PM. Reason: Spelling
Spikestrip is offline   0 Reply With Quote
Old Apr 2, 2011, 12:05 PM   #3
snowleopard13
Thread Starter
macrumors regular
 
Join Date: Apr 2010
Location: Austria
The first option is really the last one as i have about 50 playlists in my itunes library and i don't wanna lose them

I changed permissions of my hdd/users/name/music/iTunes folder to read&write for every of the 3 lines and it DOES say username(me). I also did apply this to all enclosed items of this folder. Are there any other folders iTunes accesses?

Another strange thing is that when i open iTunes this error displays and if i click OK fast enough i can play any song for about 4 seconds before iTunes quits. It does quit though in any case and always after the same amount of time.

Any other suggestions? I really miss my music already.
__________________
MacBook Pro 13" Mid 2010 with SSD & HDD, 8GB | iPad White 32GB 3rd Generation| iPhone 4S Black 32GB
snowleopard13 is offline   0 Reply With Quote
Old Apr 2, 2011, 08:42 PM   #4
msriotdoll
macrumors member
 
Join Date: Dec 2005
just posted this on someone elses thread....

i had the same issue with itunes.. how i solved it was go into the SSD and under your users folder do <<command i >>and make sure you have permissions set to read/write.
Do the same for your users folder on your data drive.
I have a users folder on my ssd and data drive.
Run disk utility>repair premissions and see if that works for you.
msriotdoll is offline   0 Reply With Quote
Old Apr 2, 2011, 11:59 PM   #5
Spikestrip
macrumors member
 
Join Date: Apr 2011
Location: California
Quote:
Originally Posted by snowleopard13 View Post
The first option is really the last one as i have about 50 playlists in my itunes library and i don't wanna lose them

I changed permissions of my hdd/users/name/music/iTunes folder to read&write for every of the 3 lines and it DOES say username(me). I also did apply this to all enclosed items of this folder. Are there any other folders iTunes accesses?

Another strange thing is that when i open iTunes this error displays and if i click OK fast enough i can play any song for about 4 seconds before iTunes quits. It does quit though in any case and always after the same amount of time.

Any other suggestions? I really miss my music already.
The only other things iTunes accesses would be at /Library/iTunes, and ~/Library/iTunes. There shouldn't be anything in either of those places that would cause this. If you find anything in the plugin folders in these locations, you can try temporarily moving these out of that folder while you try again to open iTunes. Did iTunes open when you told it to create a new library?

Quote:
Originally Posted by msriotdoll View Post
just posted this on someone elses thread....

i had the same issue with itunes.. how i solved it was go into the SSD and under your users folder do <<command i >>and make sure you have permissions set to read/write.
Do the same for your users folder on your data drive.
I have a users folder on my ssd and data drive.
Run disk utility>repair premissions and see if that works for you.
Your suggestion with the read/write permissions sounds like the fix, but it seems not to be working in this case. Repairing permissions doesn't touch any of the files you have installed, only parts of the OS. Downloading and installing iTunes again should replace any files that permissions repair would fix. I would reinstall iTunes, if you haven't already, before I ran permissions repair to fix this. It's mostly the specific file called "iTunes Library" with no file extension that I think would be to blame for this. Make sure that one file has the correct permissions, including who the owner is, not just who has access to it. If you don't see the(me) on that particular file, you can use a Terminal command to fix it. if your permissions look the way they do on the screenshot I included above, I'm not sure what is keeping iTunes from opening.

You can always Archive and Install whatever OS you are currently running. If you do this, please back up first. If you go through all this, and you still can't open iTunes, starting over without playlists may be your only option left.

Spike
__________________
Apple Certified ACSP, ACMT; 3 years as a Mac Genius; currently freelance Mac tech; jailbroken & repaired iEverything. Knowledge is free power. Spread the wealth.
Spikestrip is offline   0 Reply With Quote
Old Apr 3, 2011, 03:50 AM   #6
snowleopard13
Thread Starter
macrumors regular
 
Join Date: Apr 2010
Location: Austria
ok guys, so i did what msriotdoll said. I set SSD users and HDD users to read&write for everyone + for all enclosed items. The first line in both of these folders is system and not name(me). But it didn't fix the problem and caused another three:

"The folder 'iTunes' is on a locked drive or you do not have write permissions for this folder."

and

"A copy of Firefox is already open. Only one copy of Firefox can be open at a time." But there isn't!

and

I wanted to download iTunes again from apple.com but it doesn't let me download to my downloads folder (in users) and says 'Safari could not download the file “iTunes10.2.1.dmg” because there is not enough free disk space." but there ARE over 20gb free on both of the disks. must have something to do with write permissions.
I tried to copy a jpg file to the downloads folder and it asked me for my password. then it copied but i couldn't delete the file because "i don't have the permissions" to do so.


These errors even occur when i restart OSX.

Then i tried to reset the permissions as they were (to read only for everyone) + all enclosed items and repaired permissions. But the errors are still there.

damn... i think i fu**** up

edit: every one of my mp3s or any other file in hdd/users/name/ now has 'system' instead of name(me) at read&write permissions...
same for ssd/users/name/ although i don't use that users folder.

edit2: after all this i reset the users folder to the HDD in settings/accounts and now i'm on stock OSX with question marks on documents and downloads folder in the dock. what the ******* have i done??!


edit3: ok figured out how to add ownership to username(me) and am back to scratch now with the old itunes access priviliges problem from post #1
temporarily removed the one file in iTunes plugins - same error without it.
held option key at clicking iTunes in dock - iTunes ask for an existing library or create a new one. but i really want to try everything before creating a new one.

this is how one mp3 in my users/music/itunes/media/music folder looks like atm:
Attached Images
 
__________________
MacBook Pro 13" Mid 2010 with SSD & HDD, 8GB | iPad White 32GB 3rd Generation| iPhone 4S Black 32GB

Last edited by snowleopard13; Apr 3, 2011 at 06:27 AM.
snowleopard13 is offline   0 Reply With Quote
Old Apr 4, 2011, 04:10 AM   #7
snowleopard13
Thread Starter
macrumors regular
 
Join Date: Apr 2010
Location: Austria
I completely deinstalled and reinstalled iTunes - same error.

I tried the "last option" --> new library with option key - got a new library but the error at the same time.

So i really run out of alternatives...

All other Apps are running perfectly (iMovie, iPhoto,...). Why does only iTunes have this Problem?

Edit: could this be a problem? every apple application has 'wheel' as user, but not iTunes.

Please help
Attached Thumbnails
Click image for larger version

Name:	permissions2.jpg
Views:	34
Size:	85.7 KB
ID:	279622  
__________________
MacBook Pro 13" Mid 2010 with SSD & HDD, 8GB | iPad White 32GB 3rd Generation| iPhone 4S Black 32GB

Last edited by snowleopard13; Apr 4, 2011 at 10:23 AM.
snowleopard13 is offline   0 Reply With Quote
Old Apr 4, 2011, 11:04 AM   #8
snowleopard13
Thread Starter
macrumors regular
 
Join Date: Apr 2010
Location: Austria
SOLVED !!!!!!!

my users folder on the SSD had no (read or write) permissions for my username(me).

i really don't understand why it is working now, because this users folder on the SSD is NOT in use. every folder in there is empty and all the itunes media is on the 'real' users folder on the HDD.
__________________
MacBook Pro 13" Mid 2010 with SSD & HDD, 8GB | iPad White 32GB 3rd Generation| iPhone 4S Black 32GB
snowleopard13 is offline   0 Reply With Quote
Old Apr 7, 2011, 03:15 PM   #9
Spikestrip
macrumors member
 
Join Date: Apr 2011
Location: California
Quote:
Originally Posted by snowleopard13 View Post
SOLVED !!!!!!!

my users folder on the SSD had no (read or write) permissions for my username(me).

i really don't understand why it is working now, because this users folder on the SSD is NOT in use. every folder in there is empty and all the itunes media is on the 'real' users folder on the HDD.
Wow, nice find. Is your iTunes Library and other files still on the SSD, with just the iTunes media on the HDD? Or did you have all the stuff together on the SSD?

Spike
__________________
Apple Certified ACSP, ACMT; 3 years as a Mac Genius; currently freelance Mac tech; jailbroken & repaired iEverything. Knowledge is free power. Spread the wealth.
Spikestrip is offline   0 Reply With Quote
Old Apr 7, 2011, 06:39 PM   #10
snowleopard13
Thread Starter
macrumors regular
 
Join Date: Apr 2010
Location: Austria
no, that IS the strange part. i have an iTunes folder in hdd/users/username/music with all my media plus my iTunes Library.xml and other library files.

they have never been on the SSD, because i copied everything BUT the users folder to it.

really really strange, but at least it's working now and maybe this thread helps someone sometime
__________________
MacBook Pro 13" Mid 2010 with SSD & HDD, 8GB | iPad White 32GB 3rd Generation| iPhone 4S Black 32GB
snowleopard13 is offline   0 Reply With Quote
Old Apr 7, 2011, 06:50 PM   #11
Spikestrip
macrumors member
 
Join Date: Apr 2011
Location: California
Quote:
Originally Posted by snowleopard13 View Post
SOLVED !!!!!!!

my users folder on the SSD had no (read or write) permissions for my username(me).

i really don't understand why it is working now, because this users folder on the SSD is NOT in use. every folder in there is empty and all the itunes media is on the 'real' users folder on the HDD.
That is definitely strange, I would never have guessed that. But, now I'll know to look out for it. Thanks for sharing your fix!

Spike
__________________
Apple Certified ACSP, ACMT; 3 years as a Mac Genius; currently freelance Mac tech; jailbroken & repaired iEverything. Knowledge is free power. Spread the wealth.
Spikestrip is offline   0 Reply With Quote
Old Apr 18, 2011, 03:37 AM   #12
moez
macrumors regular
 
Join Date: Jun 2007
I could confirm the same thing. There were issues with access rights on Users folder on my SSD even though the user folder is stored on HDD. Changing the access rights fixed the issue.
moez is offline   0 Reply With Quote
Old Jun 6, 2012, 01:34 PM   #13
cheung
macrumors newbie
 
Join Date: Jun 2012
Thanks for this! I did the same thing the OP did; copied everything but the Users folder over to my SSD and then directed the OS to use the original Users folder on my HDD which was still in the computer in an optical bay drive caddy. I had the same issues with iTunes, which got me here (thank you Googles).

Last edited by cheung; Jun 6, 2012 at 01:40 PM.
cheung is offline   0 Reply With Quote
Old Dec 18, 2012, 09:25 PM   #14
Robbomac
macrumors newbie
 
Join Date: Dec 2008
Shared Folder in /Users

I just upgraded to an SSD on my iMac, and came across the same authorization/permissions problem with iTunes. I checked permissions everywhere on both my SSD and data hard drive, but the error persisted.

Thanks to a Google search, I found that iTunes needs the "Shared" folder in /Users. I had neglected to copy that over to my SSD, but as soon as I recovered it from my Time Machine backup, the iTunes error was fixed.
Robbomac is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Forklift error insufficient access privileges? bobright Mac Applications and Mac App Store 2 Aug 7, 2013 11:58 AM
iTunes wont import my music. Access Privileges. wolverineandrew Mac Applications and Mac App Store 2 Jul 23, 2013 06:16 PM
Can only access admin privileges at school network. RestlessPanda MacBook Pro 8 Jan 16, 2013 03:11 PM
ipad won't sync photos- access privileges espndeportes iPad Tips, Help and Troubleshooting 3 Jul 3, 2012 09:01 AM
Issues with read/write privileges on iTunes (kept on external drive) vastoholic Mac Applications and Mac App Store 1 Jun 16, 2012 09:27 AM

Forum Jump

All times are GMT -5. The time now is 03:55 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC