Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X 10.7 Lion

View Poll Results: Does Steam Work For You In 10.7 ??
Yes it works 39 49.37%
No it doesn't 25 31.65%
Wtf is steam 15 18.99%
Voters: 79. You may not vote on this poll

Reply
 
Thread Tools Search this Thread Display Modes
Old Apr 26, 2011, 12:31 PM   #51
rmbrown09
Thread Starter
macrumors 6502a
 
rmbrown09's Avatar
 
Join Date: Jan 2010
Arrow

Quote:
Originally Posted by forcenine View Post
Thanks for the heads up. Can confirm it's working for me, but I haven't as yet been prompted to update, and will prob. refuse it for now...
what was bizarre about the Steam update was that it had no description for what the update brought. It was an empty box in the description part. But it restarted none the less (After the update installer ran) and then bounced away. Ran the Terminal command and that fixed everything though, I would say go ahead and grab that update.
__________________
Had: 4 MBP's + 1 MBA
HAVE: 2600k i7 @ 4.5GHz, GTX 690 OC'd, SSD RAID 0, 16GB DDR3 @ 2400Mhz, HAF X Case, 27" 1440p Catleap, BlackWidow Ultimate, Windows 7!
rmbrown09 is offline   0 Reply With Quote
Old Apr 26, 2011, 01:18 PM   #52
emonifi
macrumors newbie
 
Join Date: Apr 2011
crash

I have a crash and i want to see if others can reproduce it. In steam go to
help->system information

my steam crashes here.
emonifi is offline   0 Reply With Quote
Old Apr 29, 2011, 03:26 PM   #53
stevemr123
macrumors member
 
Join Date: May 2010
Steam still does not work by default with the latest Lion update (11A444d).

There is a permanent fix however that will let you run Steam under Lion, including Portal 2 without problems:

1. Quit Steam
2. Go to /Applications/Steam
3. Do a "Show Package Contents"
4. Navigate to Contents/MacOS/Frameworks
5. Rename the Breakpad.framework to Breakpad.framework.x
6. Do a "Get Info" on Contents/MacOS/Frameworks
7. In the Sharing & Permissions section change everyone to "No Access", and all other entries to "Read only"
8. Launch Steam, wait until it updates, restarts and reconnects automatically

This process will eliminate the need to run the terminal command periodically (.crash file removal) and will let you play Portal 2 as well under Lion.

Good luck!

(credit for this tip goes to J and Z)

Last edited by stevemr123; Apr 30, 2011 at 05:37 AM. Reason: credits!
stevemr123 is offline   0 Reply With Quote
Old Apr 29, 2011, 06:43 PM   #54
mkhll
macrumors newbie
 
Join Date: Apr 2011
Smile @stevemr123 fix works

Just to confirm @stevemr123's fix does work for steam and more importantly Portal 2.

Thanks a million!
mkhll is offline   0 Reply With Quote
Old Apr 29, 2011, 08:08 PM   #55
Blakeasd
macrumors 6502a
 
Join Date: Dec 2009
Thanks @stevemr123
Blakeasd is offline   0 Reply With Quote
Old May 5, 2011, 07:23 PM   #56
Varigon
macrumors newbie
 
Join Date: Oct 2010
Can't get my beloved Bejeweled 3 to work under Lion. Anyone had any luck running it?
Varigon is offline   0 Reply With Quote
Old Sep 23, 2011, 09:20 PM   #57
snowbeavers77
macrumors newbie
 
Join Date: Sep 2011
Thanks to stevemr123! It works beautifully now!
snowbeavers77 is offline   0 Reply With Quote
Old Sep 24, 2011, 12:11 AM   #58
mrsir2009
macrumors 604
 
mrsir2009's Avatar
 
Join Date: Sep 2009
Location: Melbourne, Australia
Steam is fine for me.
mrsir2009 is offline   0 Reply With Quote
Old Nov 5, 2011, 12:34 AM   #59
an0nymity
macrumors newbie
 
Join Date: Jul 2011
Location: Phoenix
Does anyone's Steam update more than once a day? Mine is up to date but it keeps saying there's an update.
an0nymity is offline   0 Reply With Quote
Old Nov 5, 2011, 04:09 PM   #60
buckers
macrumors 6502
 
Join Date: Aug 2010
Location: Anglesey, UK
Quote:
Originally Posted by an0nymity View Post
Does anyone's Steam update more than once a day? Mine is up to date but it keeps saying there's an update.
Mine keeps thanking me for using the beta
__________________
Mike B
Graduate Software Developer, UK
2012 iPad Mini 16GB Nokia Lumia 620 Windows 8.1 Desktop, Intel i5 x64, 8GB RAM
buckers is offline   0 Reply With Quote
Old Nov 28, 2011, 02:03 PM   #61
llirik
macrumors member
 
Join Date: Jul 2011
sooooooooo,

my steam seems to be broken beyond any sort of repair. I've just tried literally everything that comes up anywhere online for the last 2 hours, with no success. But the game was working fine earlier today.

I'v even deleted every single instance of steam on the computer, literally everything and tried fresh install. still no luck.

In console, the errors I keep seeing are:

"failed to load Steam Service"
"ServiceStart: failed to start"
"Errors in resource/styles/steam.styles"
"Unknown key 'visible' set in style 'html-findbar' in file 'resource/styles/steam.styles'"
"Unable to create bundle with URL /Applications/Steam.app/Contents/MacOS/osx32/steam"

I've searched for all of those, and tried anything and everything that comes up, and still no luck.

I get to "Connecting Steam account: [account]..." and then it freezes and just spins indefintely. the last thing i see in consol is
"SteamID: #########, universe Public" 3 times, and then nothing. doesn't go after this point.

Help, anyone??

----------

okay.... this is the weirdest thing now... after i posted that, i went to steams forums to post about it.... and after logging in, steam opened!

on console though, i stilll get the failed to lead Steam service, as well as now failing to connect. is it possible something was wrong with my account that SOMEHOW was crashing everything?
llirik is offline   0 Reply With Quote
Old Nov 28, 2011, 02:12 PM   #62
Michaelgtrusa
macrumors 601
 
Michaelgtrusa's Avatar
 
Join Date: Oct 2008
Location: Everywhere And Nowhere
Quote:
Originally Posted by llirik View Post
sooooooooo,

my steam seems to be broken beyond any sort of repair. I've just tried literally everything that comes up anywhere online for the last 2 hours, with no success. But the game was working fine earlier today.

I'v even deleted every single instance of steam on the computer, literally everything and tried fresh install. still no luck.

In console, the errors I keep seeing are:

"failed to load Steam Service"
"ServiceStart: failed to start"
"Errors in resource/styles/steam.styles"
"Unknown key 'visible' set in style 'html-findbar' in file 'resource/styles/steam.styles'"
"Unable to create bundle with URL /Applications/Steam.app/Contents/MacOS/osx32/steam"

I've searched for all of those, and tried anything and everything that comes up, and still no luck.

I get to "Connecting Steam account: [account]..." and then it freezes and just spins indefintely. the last thing i see in consol is
"SteamID: #########, universe Public" 3 times, and then nothing. doesn't go after this point.

Help, anyone??

----------

okay.... this is the weirdest thing now... after i posted that, i went to steams forums to post about it.... and after logging in, steam opened!

on console though, i stilll get the failed to lead Steam service, as well as now failing to connect. is it possible something was wrong with my account that SOMEHOW was crashing everything?




A new client was released this month.
__________________
iMACAll life is an experiment. The more experiments you make the better.
TWITTER TUMBLR
Michaelgtrusa is offline   0 Reply With Quote
Old Dec 3, 2011, 01:40 PM   #63
llirik
macrumors member
 
Join Date: Jul 2011
aaaaaaaaand, it just started doing that again. the client was updated, as it does that automatically.
llirik is offline   0 Reply With Quote
Old Dec 3, 2011, 03:52 PM   #64
benthewraith
macrumors 68030
 
benthewraith's Avatar
 
Join Date: May 2006
Location: Miami, FL
Send a message via AIM to benthewraith Send a message via MSN to benthewraith
Quote:
Originally Posted by Michaelgtrusa View Post
A new client was released this month.
I've noticed a CPU whine when running Steam, just the interface, that occurs in no other program under similar or greater loads. Steam told me it was just my computer but I don't think so because of that reason.
__________________
Late-2013 13" rMBP, 2.4GHz, 8 GB RAM 250GB SSD; iPhone 5C 16GB
benthewraith is offline   0 Reply With Quote
Old Dec 16, 2011, 02:07 AM   #65
Michaelgtrusa
macrumors 601
 
Michaelgtrusa's Avatar
 
Join Date: Oct 2008
Location: Everywhere And Nowhere
Quote:
Originally Posted by benthewraith View Post
I've noticed a CPU whine when running Steam, just the interface, that occurs in no other program under similar or greater loads. Steam told me it was just my computer but I don't think so because of that reason.


I never heard on this.
__________________
iMACAll life is an experiment. The more experiments you make the better.
TWITTER TUMBLR
Michaelgtrusa is offline   0 Reply With Quote
Old Feb 4, 2013, 05:57 PM   #66
dwynnejr
macrumors newbie
 
Join Date: Jan 2009
Quote:
Originally Posted by Michaelgtrusa View Post
I never heard on this.
having the same problem. this is infuriating. brand new mac.

http://forums.macrumors.com/showthre...2#post16786152
dwynnejr is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X 10.7 Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Apple Releases OS X Security Update for Mavericks, Mountain Lion, and Lion Users MacRumors Mac Blog Discussion 36 Apr 23, 2014 02:54 PM
Apple Releases Security Update 2013-003 for OS X Snow Leopard, Lion and Mountain Lion MacRumors Mac Blog Discussion 28 Jul 9, 2013 08:37 PM
OS X: cannot open (run) steam on my mac after last update (27/03/2013) sradja Mac and PC Games 3 May 3, 2013 10:24 AM
OS X: Steam Installation/Update beechysmalls Mac and PC Games 2 Nov 17, 2012 07:19 AM
New update to mountain lion in software update Antoni Nygaard OS X 10.8 Mountain Lion 12 Jun 18, 2012 05:05 PM

Forum Jump

All times are GMT -5. The time now is 05:38 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC