Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Programming > Mac Programming

Reply
 
Thread Tools Search this Thread Display Modes
Old May 9, 2011, 04:18 AM   #1
kiantech
macrumors regular
 
Join Date: Jun 2007
Automator works but says fails

Hey guys, I basically have a automator do a bunch of stuff then execute a shell script to run a couple java programs I wrote. When I run the automation everything works, including executing my java files, however I get a run shell script error. Even though everything I wanted to happen...happened.

Here is my shell script...with just a change to the long folder

cd thedirectoryIwant
java NBAFileParser
java NBAWriteUSB

Thats it. Automator runs my java files, but then returns this error.

Run Shell Script failed - 1
(1)

Anyone of a clue, I would greatly appreciate it.
kiantech is offline   0 Reply With Quote
Old May 9, 2011, 05:40 AM   #2
jiminaus
macrumors 65816
 
Join Date: Dec 2010
Location: Sydney
Bash returns the exit status of the last command executed, unless a syntax error occurs, in which case it exits with a non-zero value. I can't see a syntax error, assuming thedirectoryIwant is properly encoded if it contains exotic characters.

Is NBAWriteUSB calling System.exit(1) somewhere or raising an uncaught exception?

If you put exit 0 at the last line of your shell script, does it stop the error from appearing?
jiminaus is offline   0 Reply With Quote
Old May 10, 2011, 03:46 AM   #3
kiantech
Thread Starter
macrumors regular
 
Join Date: Jun 2007
Hey thanks for the suggestion, I didn't try that, however I was able to fix it by writing an applescript instead. At first I got a similar error, but after a little googling I was got a suggestion to just do a try statement, and in that statement I run my shell script.

on run
try
do shell script "/dir/ransmit.sh"
end try
end run

that worked, but next time I have a problem I will try your method too.
kiantech is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Programming > Mac Programming

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
got new Hard drive but ical/email/quick view doesn't work & updates fail! RunnyCustard Mac Basics and Help 4 Aug 28, 2010 03:55 PM
Mighty Mouse working but says not connected cbbob iMac 6 Feb 1, 2010 08:47 PM
FLASH PLAYER 10 DOESN'T WORK (menu says it is 7 but nothing works) Ziggy401 Mac Applications and Mac App Store 0 Aug 2, 2009 01:17 PM
Aperture, files used to work, but now say unsuported benlangdon Mac Basics and Help 0 Jul 6, 2008 12:22 AM
Tried and tired to get Darwine to work but still fail Birdoftruth Mac Basics and Help 6 Jun 10, 2008 07:53 AM


All times are GMT -5. The time now is 11:55 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC