Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old May 25, 2011, 11:27 AM   #1
Hephaestus
macrumors 6502
 
Join Date: Apr 2010
Cannot send mail... username or PW incorrect... IT IS CORRECT

I've had this problem on my iPhone for a couple of days now, thought it was probably a server issue that would be resolved but it doesn't seem to be going away.

Basically, whenever I try to send mail using the Mail App I get this error message:

Cannot Send Mail. The user name or password for "SMTP: john_doe@hotmail.com@smtp.live.com" is incorrect.

I've had this phone for 7 months now and this is the first time I'm having this problem. I can receive emails perfectly fine, its just sending them that is giving me this error. I haven't changed my details at all and I know my PW and username are both correct.

Someone please help. I don't want to restore my whole phone or anything like that if its avoidable.
Hephaestus is offline   0 Reply With Quote
Old May 25, 2011, 11:36 AM   #2
iFiend
macrumors 6502a
 
Join Date: Feb 2011
Quote:
Originally Posted by Hephaestus View Post
I've had this problem on my iPhone for a couple of days now, thought it was probably a server issue that would be resolved but it doesn't seem to be going away.

Basically, whenever I try to send mail using the Mail App I get this error message:

Cannot Send Mail. The user name or password for "SMTP: john_doe@hotmail.com@smtp.live.com" is incorrect.

I've had this phone for 7 months now and this is the first time I'm having this problem. I can receive emails perfectly fine, its just sending them that is giving me this error. I haven't changed my details at all and I know my PW and username are both correct.

Someone please help. I don't want to restore my whole phone or anything like that if its avoidable.
Hate to state the obvious but have you tried deleting and re-adding your account? Usually solves problems for me...
iFiend is offline   0 Reply With Quote
Old May 25, 2011, 11:36 AM   #3
TheOriginalKi
macrumors 6502
 
Join Date: Jan 2011
Location: Belfast
Have you tried deleted and readding the account to the iPhone? By the way do you use exchange or pop3?
TheOriginalKi is offline   0 Reply With Quote
Old May 25, 2011, 11:43 AM   #4
Hephaestus
Thread Starter
macrumors 6502
 
Join Date: Apr 2010
Quote:
Originally Posted by TheOriginalKi View Post
Have you tried deleted and readding the account to the iPhone? By the way do you use exchange or pop3?
My host name says pop3.live.com so I assume its pop3. I'll try deleting the account and readding it.
Hephaestus is offline   0 Reply With Quote
Old May 25, 2011, 12:02 PM   #5
Hephaestus
Thread Starter
macrumors 6502
 
Join Date: Apr 2010
Hmm.. I feel a little foolish now, deleting and readding the account sorted the problem Thanks for the tip guys. One more thing though, in my mailboxes it is displaying "inbox" and "sent messages". The outbox is no longer there. Any suggestions?
Hephaestus is offline   0 Reply With Quote
Old May 25, 2011, 12:49 PM   #6
Givmeabrek
macrumors Demi-God
 
Join Date: Apr 2009
Location: NY
I didn't think hotmail ( sounds like that is what you have) allowed a pop3 connection anymore. Anyway you should be using an Exchange connection to set up your email. That way you can sync all the folders.

http://www.iphonedownloadblog.com/20...otmail-iphone/

I'm not sure if this is exactly how a live.com address is setup. It might be the same.
Givmeabrek is offline   0 Reply With Quote
Old May 25, 2011, 12:50 PM   #7
iFiend
macrumors 6502a
 
Join Date: Feb 2011
Quote:
Originally Posted by Hephaestus View Post
Hmm.. I feel a little foolish now, deleting and readding the account sorted the problem Thanks for the tip guys. One more thing though, in my mailboxes it is displaying "inbox" and "sent messages". The outbox is no longer there. Any suggestions?
Don't feel foolish at all bud Now you know!

I only use exchange accounts, so I am not sure if they work the same, but under my accounts I have an option to choose which folders to push and that is how I am able to see my outbox. I think that before I used push it may have just taken a bit to show the other folders within my email?

Quote:
Originally Posted by Givmeabrek View Post
I didn't think hotmail ( sounds like that is what you have) allowed a pop3 connection anymore. Anyway you should be using an Exchange connection to set up your email. That way you can sync all the folders.

http://www.iphonedownloadblog.com/20...otmail-iphone/

I'm not sure if this is exactly how a live.com address is setup. It might be the same.
^^^this

I would highly suggest using exchange. I have 2 gmail accounts and my school email pushed and it works great. And contrary to popular belief my battery life does not suck because of it. I have an iPhone 4 so YMMV
iFiend is offline   0 Reply With Quote
Old May 25, 2011, 12:58 PM   #8
TheOriginalKi
macrumors 6502
 
Join Date: Jan 2011
Location: Belfast
Quote:
Originally Posted by Hephaestus View Post
Hmm.. I feel a little foolish now, deleting and readding the account sorted the problem Thanks for the tip guys. One more thing though, in my mailboxes it is displaying "inbox" and "sent messages". The outbox is no longer there. Any suggestions?
You should use Exchange as that will give you instant notifications of emails and also your mailbox will be synced with the server so whatever you do on the phone will also be done on the serve.

http://arstechnica.com/microsoft/new...activesync.ars
TheOriginalKi is offline   0 Reply With Quote
Old May 25, 2011, 12:58 PM   #9
Interstella5555
macrumors 603
 
Interstella5555's Avatar
 
Join Date: Jun 2008
Quote:
Originally Posted by Hephaestus View Post
Hmm.. I feel a little foolish now, deleting and readding the account sorted the problem Thanks for the tip guys. One more thing though, in my mailboxes it is displaying "inbox" and "sent messages". The outbox is no longer there. Any suggestions?
I don't have an "outbox" in my mail, but in my understanding that's for messages that have been sent to send but are delayed somehow, so you may not see the folder until there's actually a message in there.
Interstella5555 is offline   0 Reply With Quote
Old May 25, 2011, 01:11 PM   #10
Hephaestus
Thread Starter
macrumors 6502
 
Join Date: Apr 2010
Thanks for all the responses guys! I'm not really savvy when it comes to Mail on the iPhone, I didn't actually know what exchange was. I'll change it to exchange right away! Thanks again.
Hephaestus is offline   0 Reply With Quote
Old May 25, 2011, 01:32 PM   #11
kicko
macrumors 65816
 
Join Date: Aug 2008
It also happens to mine once in a while, both hotmail & gmail.

I was checking the passwords and all that but simply if you power down and then back on it should fix the issue... until it happens again. It has to be a bug in iOS. I have the verizon version if your wondering.
kicko is offline   0 Reply With Quote
Old May 25, 2011, 01:45 PM   #12
Hephaestus
Thread Starter
macrumors 6502
 
Join Date: Apr 2010
I just changed it to Exchange and its so much better! I can see all the mailboxes now and it knows what has already been opened on the account. Thanks so much I can't believe I didn't have it like this before.
Hephaestus is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Mail badge incorrect whsbuss iCloud and Apple Services 0 Jan 18, 2013 09:28 AM
iPad Mini: Can't use correct e-mail for Messages/Facetime Ja Di ksw iPad 2 Jan 13, 2013 02:18 PM
MAIL - REPLY, Mail uses different email to send Milateket Mac Applications and Mac App Store 3 Dec 30, 2012 01:07 PM
Buyers Guide Incorrect - Please Correct d0nK Site and Forum Feedback 0 Nov 20, 2012 08:22 AM
Mail: Default Reply-from Incorrect AuPhalanx OS X 10.8 Mountain Lion 11 Jul 30, 2012 11:37 PM

Forum Jump

All times are GMT -5. The time now is 01:13 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC