Go Back   MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 7, 2011, 09:31 AM   #1
Mattlehat
macrumors newbie
 
Join Date: Jun 2011
iMac keeps losing internet connection

Just recently my iMac (nearly 3 years old) keeps losing connection to the internet.

It happens in both safari and firefox, but not in Mail. However when streaming live radio or downloading files from rapidshare in safari the connection does not drop and the stream/download continues despite the browser not being able to open web pages.

To correct it I have to turn off the iMac's wifi (so that the antenna symbol in the top right corner disappears) and then turn it back on.

This happens almost every half hour!
How can I correct it?

Thanks
Matt
Mattlehat is offline   0 Reply With Quote
Old Jun 7, 2011, 09:33 AM   #2
miles01110
macrumors 604
 
miles01110's Avatar
 
Join Date: Jul 2006
Location: The Ivory Tower (I'm not coming down)
It's likely a problem with your networking equipment. Does it happen if you plug into your router or modem with an ethernet cable?
__________________
Got a problem? Check here first.
miles01110 is offline   0 Reply With Quote
Old Jun 7, 2011, 09:47 AM   #3
Mattlehat
Thread Starter
macrumors newbie
 
Join Date: Jun 2011
I haven't tried that - it's a bit awkward to move the iMac down to where the router is - but I will give it a go tonight. Both my wife and my iPhones & iPad are fine and when using our work PC's there has been no issues.
Mattlehat is offline   0 Reply With Quote
Old Jun 7, 2011, 04:54 PM   #4
Mattlehat
Thread Starter
macrumors newbie
 
Join Date: Jun 2011
Have been using my mac mini on the wifi connection this evening with no problems at all so think the issue must be with the iMac.

Any suggestions?
Mattlehat is offline   0 Reply With Quote
Old Jun 9, 2011, 08:52 AM   #5
Mattlehat
Thread Starter
macrumors newbie
 
Join Date: Jun 2011
Could really do with some help on this?
Mattlehat is offline   0 Reply With Quote
Old Jun 9, 2011, 08:54 AM   #6
miles01110
macrumors 604
 
miles01110's Avatar
 
Join Date: Jul 2006
Location: The Ivory Tower (I'm not coming down)
Did you plug the iMac in?
__________________
Got a problem? Check here first.
miles01110 is offline   0 Reply With Quote
Old Jun 9, 2011, 09:06 AM   #7
AFPoster
macrumors 65816
 
Join Date: Jul 2008
Location: Charlotte, NC
Friend had this issue and he just bought a new Airport Extreme, issue resolved. So my suggestion is buy a new router.
__________________
2014 15" Retina MacBook Pro 2.5Ghz i7
iPad 2 32gb (white)
iPhone 6+ 64gb (white)
iPhone 5s 16gb
AFPoster is offline   0 Reply With Quote
Old Jun 9, 2011, 09:08 AM   #8
Mattlehat
Thread Starter
macrumors newbie
 
Join Date: Jun 2011
Yes I did and there were no problems for the short period of time that I tested it. The problem only seems to be with my iMac as my MacMini doesn't seem to be affected.
Mattlehat is offline   0 Reply With Quote
Old Jun 9, 2011, 09:12 AM   #9
miles01110
macrumors 604
 
miles01110's Avatar
 
Join Date: Jul 2006
Location: The Ivory Tower (I'm not coming down)
Is your iMac and Mac Mini co-located in the same room? How far away from the router is it? What frequency space does your network (2.4 GHz or 5 GHz) use? Are there any sources of interference (metal, thick walls) between the router and the iMac?
__________________
Got a problem? Check here first.
miles01110 is offline   0 Reply With Quote
Old Jun 9, 2011, 09:19 AM   #10
Mattlehat
Thread Starter
macrumors newbie
 
Join Date: Jun 2011
The MacMini is much nearer and goes through no walls. The iMac signal needs to go through walls and floor (though this has always been the case and the problem is recent)

Not sure about the frequency space?

There was never a problem before, and it only affects web pages loading, not radio streams or downloads such as megaupload etc.
Mattlehat is offline   0 Reply With Quote
Old Aug 11, 2011, 10:49 AM   #11
anthonybc78
macrumors newbie
 
Join Date: Aug 2011
Have you fixed this? Ive found this problem has been happening to other people. We just bought an imac (2011 model). And this problem has been happening to me for a couple months. I have to keep turning off airport and turning it back on, I cant stream movies, play games, etc. This is what we have done:

1. Called apple support (4-5 times so far).
2. Changed the frequency channel to 9 (as not to be on the same channel as my neighbors).
3. Changed frequency rate.
4. Brand new netgear router. If I hardwire an ethernet cord, I am ok. All other devices work (PS3, Ipad2, Iphones, Ipods, etc). The techs if they cant figure it out may chalk it up to other things causing interference (baby monitor, microwave, etc), but it doesn't make sense if the other devices NEVER lose connection, but the imac does every few minutes.
5. Changed DNS settings.
6. Deleted network settings manually and restart.

Once again, if I hardwire, I have connection. This is strictly a wifi/airport connection. My computer has the latest patches and all other devices work. As well it is about 20 feet from the router with nothing blocking it. I have not found a working fix to this. All I can say is that I moved a month ago, and prior to the move i didn't have problems (but I only had the imac for like a month prior to the move).

Here is what I think might be a problem:

Router incompatibility issue with imac (although Ive heard people having problems with the airport extreme).

Aliens.

DEFECTIVE airport card in my iMac. Im thinking its either cheap or just buggy. Apple is famous for implementing parts from all over the world into one product. Maybe not all models, but I feel some imacs have been having airport issues, and they need to be recalled.

EDIT, I took my imac to the store and they are replacing the aircard. I guess ill find out if it is it or not

Last edited by anthonybc78; Aug 12, 2011 at 03:42 PM.
anthonybc78 is offline   0 Reply With Quote
Old Dec 2, 2012, 07:22 PM   #12
jodave98
macrumors newbie
 
Join Date: Dec 2012
Did replacing the airport card solve the problem?
jodave98 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Mac Basics and Help

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Losing Internet Connection over Sleep? doubledee Mac Basics and Help 18 Dec 12, 2013 07:27 PM
Wifi keeps losing Internet connection nilsh32 MacBook Pro 0 Oct 28, 2013 05:45 PM
Losing Internet Connection on Sleep doubledee OS X 10.8 Mountain Lion 0 Jul 22, 2013 03:59 PM
iMac losing internet connection when checking for updates? cragga Mac Basics and Help 0 May 29, 2013 09:11 AM
Imac keeps losing internet connection? Lewb iMac 2 Jun 22, 2012 09:11 AM

Forum Jump

All times are GMT -5. The time now is 05:21 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC