Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 21, 2011, 05:20 PM   #1
sammax
macrumors newbie
 
Join Date: Oct 2009
Crashes with error EXC_BAD_ACCESS (SIGBUS)

Hi All,

I recently bought a new 27 inch iMac and I'm having a lot of EXC_BAD_ACCESS (SIGBUS) crashes when I open programs like Safari for example. Somethimes it crashes right at the start when I click to open a program and somethime it takes a few minutes but It will crash.
The same goes for Cubase and Native Instruments Complete applications. These appications are all I want use really because I bought the iMac to make music.
I copied the the error it crashes with, there is a whole lot of text but this is probably the most importen piece.

*******************************************
Exception Type: EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000010
Crashed Thread: 0 Dispatch queue: com.apple.main-thread
********************************************

I googled the error code and came across some articles. So far I tried this steps:

- Run an extended harware diagnostics check from the application DVD.
On some forums people had a similiar problem and I turned out to be bad memory. Mu test turned out to be ok.

- Boot into save mode and used the disck util program to fix permissions on my HD. I first runned a check and it came up with some permissions that apparently were not right. I used the option to reset the permissions but the problem continued after a reboot.

- Tried to run the latest Combo fix as suggested on soem forums. Im running 10.6.7 and the Combo update was also version 10.6.7.
I could not install it. At the screen where you select on what disk you want to install there was a yellow exclamation mark at my HD. I dont know why because There is over 800GB free space.

- I cleared the library cache folders as suggested on some forums

- I turned of sharing and removed my shared folders as suggested on a forum.
I dont know if it has anything to do with it but it seemed to fix it for the guy who was having the same issue.

The last thing I can think of myself is reinstall the system but since it is verry time consuming to install all the NI sound libraries I want to know if there is something else I can try.
I dont know if the problem was there from the start because I started installing my applications right after I got the imac. During the installation I had no problems.

Hope someone can help.
I have verry little Mac / OSX knowledge myself. before I bought the imac I had a MBP for a few months that was using flawlessly with the same software.
Hope I wont regrat it after all

Last edited by sammax; Jun 21, 2011 at 05:25 PM. Reason: Forgot to mention something
sammax is offline   0 Reply With Quote
Old Jun 21, 2011, 07:28 PM   #2
maflynn
Moderator
 
maflynn's Avatar
 
Join Date: May 2009
Location: Boston
Sounds like a possible hardware issue, such as bad ram. Did you try running the apple hardware test which is on your system disc that you get with your imac.
__________________
~Mike Flynn
maflynn is online now   0 Reply With Quote
Old Jun 22, 2011, 03:45 AM   #3
sammax
Thread Starter
macrumors newbie
 
Join Date: Oct 2009
Thanks for your reply.
I did run a hardware test using the disk wich is included.
Test showed no problems.

Quote:
Originally Posted by maflynn View Post
Sounds like a possible hardware issue, such as bad ram. Did you try running the apple hardware test which is on your system disc that you get with your imac.
sammax is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
SIGBUS ERROR w/ Acrobat Pro XI on OS 10.8 drivord OS X 10.8 Mountain Lion 0 Jun 18, 2013 09:19 AM
I have an encoding syntax error that crashes an app with with NSString hanuman99 iPhone/iPad Programming 4 Feb 3, 2013 12:47 PM
Please Help: EXC_BAD_ACCESS error stevegreen22 Mac Programming 4 Nov 19, 2012 07:16 PM
KOTOR crashing and SIGBUS error sarajaade Mac Applications and Mac App Store 0 Jul 6, 2012 01:48 AM
iPod touch apps always crashes no error chimmy iPod touch 1 Jun 5, 2012 03:02 PM

Forum Jump

All times are GMT -5. The time now is 06:29 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC