Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 7, 2011, 12:53 PM   #1
johneaston
Banned
 
Join Date: Dec 2010
iPhone showing "No service"... but there is.

Several times over the last couple of weeks my 3GS has had prolonged periods of "No service" even though I usually get signal in the area.

The other day, desparately needing to send a text and tried to send one - it went through. I then receieved a reply and sent another, all the time with the phone showing "No service". I restarted my phone and then had 4 bars.

Is this a bug? Anyone else had this?
johneaston is offline   0 Reply With Quote
Old Jul 7, 2011, 01:18 PM   #2
PsstGreek
macrumors 68040
 
PsstGreek's Avatar
 
Join Date: Oct 2010
Location: Tampa Bay
It could be your sim card. Swap it out for a new and see if the problem persists.
__________________
iMac + iPhone 6 (4.7) + rMini
PsstGreek is offline   0 Reply With Quote
Old Jul 7, 2011, 02:52 PM   #3
itsalexaye
Banned
 
Join Date: Jul 2011
Location: Michigan
Have u tried restoring as new?
itsalexaye is offline   0 Reply With Quote
Old Jul 7, 2011, 03:26 PM   #4
Genocide
macrumors member
 
Join Date: Jun 2011
Go to Settings --> General --> Reset --> Reset Network Settings. This will most likely provide you with a temporary fix to allow you to send a text or make a call, though your phone will probably begin to have the same issue in a few hours.

I had this problem with my phone last year and it eventually fixed itself, making me believe it was my service provider.
__________________
GπΩi∂
Genocide is offline   0 Reply With Quote
Old Jul 7, 2011, 07:33 PM   #5
awadeee
macrumors 68020
 
awadeee's Avatar
 
Join Date: Jan 2011
Location: Viper City
It happens to me very seldomly. When it happens, try turning Airplane Mode on until the "Carrier" tab underneath disappears completely. Turn Airplane Mode off and allow the phone to search for service.

If the problem happens often, try restoring your iPhone with iTunes or getting a new SIM card.
__________________
Ebb & flow.
awadeee is offline   0 Reply With Quote
Old Jul 7, 2011, 07:35 PM   #6
WillEH
macrumors 6502a
 
WillEH's Avatar
 
Join Date: Feb 2011
Location: United Kingdom
I have the same, I also have a shocking signal sometimes, even though I'm in a strong signal zone. I'm with Orange.
__________________
To avoid criticism, do nothing, say nothing, be nothing. If you take the bait, don't complain.
WillEH is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Why "no Service" then "Searching" for factory unlocked, jailbrok iPhone 3GS iOS 4.3.5 heathvc iPhone Tips, Help and Troubleshooting 29 Jun 10, 2013 05:25 AM
"No service" and "Call ended" issues on Iphone 4 6.1.3 Parisjazz iOS 6 2 Apr 23, 2013 05:49 PM
iPhone: [3GS | 6.0.1 | 05.16.07] "unable to load network list" // "no service" Moritz1 Jailbreaks and iOS Hacks 11 Jan 22, 2013 11:36 AM
iPhone 5 "Lightning" Charger Showing Wear On Chip? W/Pics Jhawkfootball06 iPhone 2 Nov 28, 2012 05:47 PM
IPhone 5 showing "No Service" Saransh iPhone 4 Oct 2, 2012 07:42 PM

Forum Jump

All times are GMT -5. The time now is 02:44 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC