Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X 10.7 Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 21, 2011, 10:56 AM   #1
RWil85
macrumors 6502
 
Join Date: Aug 2010
LION on MBP 13" - Volume greyed out.

I installed Lion on my 13" MBP yesterday - all seems to have gone well..

except for the fact that, upon a reset or shutdown/startup, the volume hardware buttons will not work..they will flash the command on the screen, but will not truly function..also, the volume icon in the top bar is greyed out.

i saw a workaround in another thread - plugging in headphones and pulling them out - that actually worked; however, i do not want to have to do that every time.

has anyone else come across this/found a fix?

thanks for the help!
__________________
13.3" MBP, 2.4 Intel C2D, 8GB RAM, 120GB OCZ Vertex2 SSD
Hackintosh: SL10.6.8/Win7 64Bit Desktop, Acer 24", Core i7-930 2.8GHz, 1TB WD Black HDD, Corsair Dominator 6GB RAM
32GB iPhone 5
RWil85 is offline   0 Reply With Quote
Old Jul 22, 2011, 01:41 AM   #2
ourfoz
macrumors newbie
 
Join Date: Jul 2011
I've got the same problem and currently using the headphone in - out as a fix. Mine was a fresh install, not an upgrade. I doubt we're alone.
ourfoz is offline   0 Reply With Quote
Old Jul 22, 2011, 01:57 AM   #3
ourfoz
macrumors newbie
 
Join Date: Jul 2011
Go into disk utility, verify disk permissions then repair disk permissions. It fixed my problem.
ourfoz is offline   0 Reply With Quote
Old Jul 22, 2011, 08:57 AM   #4
LAS.mac
macrumors 6502
 
Join Date: May 2009
Location: Mexico
well, you aren't actually alone. I got the same problem. I'll try the headphones trick, and repair permissions as well.
__________________
27" Al iMac, 8Gb RAM, i5, 2013; 13" MBA, 2014; 32Gb iPhone 5s; 32Gb wifi+3G iPad mini
LAS.mac is offline   0 Reply With Quote
Old Jul 22, 2011, 12:14 PM   #5
RWil85
Thread Starter
macrumors 6502
 
Join Date: Aug 2010
Quote:
Originally Posted by ourfoz View Post
Go into disk utility, verify disk permissions then repair disk permissions. It fixed my problem.
this did not work on my MBP..

thanks for the suggestion, though.
__________________
13.3" MBP, 2.4 Intel C2D, 8GB RAM, 120GB OCZ Vertex2 SSD
Hackintosh: SL10.6.8/Win7 64Bit Desktop, Acer 24", Core i7-930 2.8GHz, 1TB WD Black HDD, Corsair Dominator 6GB RAM
32GB iPhone 5
RWil85 is offline   0 Reply With Quote
Old Jul 22, 2011, 01:03 PM   #6
aasaeedi
macrumors newbie
 
Join Date: Jul 2010
I have the same problem. Updated from snow leopard to lion two days ago. Fixing the permissions didn't help me.

Once I booted into the safe mode and restarted my computer. It fixed the problem for a while. I booted into the safe mode once again and the issue came back when I restarted my MBP. Now the safe mode trick doesn't help anymore.
aasaeedi is offline   0 Reply With Quote
Old Jul 22, 2011, 01:12 PM   #7
LAS.mac
macrumors 6502
 
Join Date: May 2009
Location: Mexico
using an external headphone made the trick for me.
Quite annoying, though. Anyway, let's patiently wait for the first update, 10.7.1...
__________________
27" Al iMac, 8Gb RAM, i5, 2013; 13" MBA, 2014; 32Gb iPhone 5s; 32Gb wifi+3G iPad mini
LAS.mac is offline   0 Reply With Quote
Old Jul 22, 2011, 01:49 PM   #8
RWil85
Thread Starter
macrumors 6502
 
Join Date: Aug 2010
Quote:
Originally Posted by LAS.mac View Post
using an external headphone made the trick for me.
Quite annoying, though. Anyway, let's patiently wait for the first update, 10.7.1...
Seemingly, it must be a bug if users who have installed using different methods are experiencing the same problem..hopefully, it'll be fixed in a future build.
__________________
13.3" MBP, 2.4 Intel C2D, 8GB RAM, 120GB OCZ Vertex2 SSD
Hackintosh: SL10.6.8/Win7 64Bit Desktop, Acer 24", Core i7-930 2.8GHz, 1TB WD Black HDD, Corsair Dominator 6GB RAM
32GB iPhone 5
RWil85 is offline   0 Reply With Quote
Old Jul 30, 2011, 09:38 AM   #9
innominato5090
macrumors 6502
 
Join Date: Sep 2009
Location: Washington, DC
ditto
http://forums.macrumors.com/showpost...88&postcount=5
__________________
Retina MacBook Pro late 2013 | iPhone 5
innominato5090 is offline   0 Reply With Quote
Old Sep 17, 2011, 07:14 AM   #10
John Wilkie
macrumors newbie
 
Join Date: Sep 2011
Fix

There is a wee latch at the back of the port that flips it from analogue to digital. If you look in and see red it is stuck on digital. Ramming a mini jack or mini tos-link in and out usually frees it.
John Wilkie is offline   0 Reply With Quote
Old Sep 17, 2011, 02:49 PM   #11
Cougarcat
macrumors 603
 
Join Date: Sep 2003
A mod should sticky this thread, as this bug gets posted here frequently

Attached is the best workaround I've found (kudos to whoever posted it before, sorry I don't remember who you are). It's an Applescript that will restart CoreAudio. Just install it in Login Items.

Anyone with 10.7.2 installed know if Apple fixed it yet?
Attached Files
File Type: zip AudioFix.zip (22.9 KB, 313 views)
Cougarcat is offline   0 Reply With Quote
Old Sep 18, 2011, 12:03 AM   #12
dsciel
macrumors regular
 
Join Date: Jul 2011
Quote:
Originally Posted by Cougarcat View Post
A mod should sticky this thread, as this bug gets posted here frequently

Attached is the best workaround I've found (kudos to whoever posted it before, sorry I don't remember who you are). It's an Applescript that will restart CoreAudio. Just install it in Login Items.

Anyone with 10.7.2 installed know if Apple fixed it yet?
I have downgraded back to SL because of this problem.....the headphone trick does work but it is annoying that you have to do it everytime after restart.....
dsciel is offline   0 Reply With Quote
Old Sep 18, 2011, 04:46 AM   #13
Hyper-X
macrumors 6502a
 
Join Date: Jul 2011
Check my sig for the workaround to this problem.
__________________
OS X Lion speaker icon gray on Menu Bar workaround.
Hyper-X is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X 10.7 Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Volume icon is greyed out (locked) Viantef MacBook Air 12 Sep 13, 2014 01:05 PM
No Sound. Volume Greyed Out Can Inelli OS X 10.8 Mountain Lion 4 Aug 29, 2014 11:57 AM
Volume too low all of a sudden on 13" MBP gpatrick15 MacBook Pro 1 Sep 23, 2012 11:30 PM
HELP updated MBP 2010 to mountain lion VOLUME not working ipad3g MacBook Pro 4 Aug 1, 2012 05:17 PM
HELP updated MBP 2010 to mountain lion VOLUME not working ipad3g OS X 10.8 Mountain Lion 1 Jul 26, 2012 03:31 AM

Forum Jump

All times are GMT -5. The time now is 04:52 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC