Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X 10.7 Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 21, 2011, 02:40 PM   #1
senc01a
macrumors regular
 
Join Date: May 2007
Safari 5 + Lion. Please don't remember my open tabs!

Hi all,
Does anyone know how to tell Safari NOT to remember which tabs I had open before I quit last time?
I don't really like that behavior, I like it when every time I start Safari it is clean and beautiful.
Thanks!
senc01a is offline   0 Reply With Quote
Old Jul 21, 2011, 02:41 PM   #2
Stiss
macrumors 6502a
 
Join Date: Apr 2009
Location: England
Quote:
Originally Posted by senc01a View Post
Hi all,
Does anyone know how to tell Safari NOT to remember which tabs I had open before I quit last time?
I don't really like that behavior, I don't want to get caught looking at porn.
Thanks!
Thats your real query!

And no, I don't know how to fix it.
Stiss is offline   3 Reply With Quote
Old Jul 21, 2011, 02:43 PM   #3
bushido
macrumors 603
 
bushido's Avatar
 
Join Date: Mar 2008
Location: España y Germany
it's part of "resume" i dont think u can really do anything about it unless u turn off the whole feature if im not mistaken
__________________
¡No hables a menos que puedas mejorar el silencio!
Don't judge me by my user name - I was young and stupid xD
bushido is offline   0 Reply With Quote
Old Jul 21, 2011, 02:44 PM   #4
kbmb
macrumors 68030
 
kbmb's Avatar
 
Join Date: Mar 2007
Location: NH
You either have to turn off the "Resume" functionality system wide or when quitting an app....instead of Command + Q to quit, use Option + Command + Q.

-Kevin
__________________
2010 Mac Pro 2.8 Quad, 27" ACD - Mid 2012 MacBook Air
kbmb is offline   0 Reply With Quote
Old Jul 21, 2011, 02:49 PM   #5
cdembek
macrumors regular
 
Join Date: May 2008
Would also like to know the answer
cdembek is offline   0 Reply With Quote
Old Jul 21, 2011, 02:50 PM   #6
saving107
macrumors 603
 
saving107's Avatar
 
Join Date: Oct 2007
Location: San Jose, Ca
Quote:
Originally Posted by senc01a View Post
Hi all,
Does anyone know how to tell Safari NOT to remember which tabs I had open before I quit last time?
I don't really like that behavior, I like it when every time I start Safari it is clean and beautiful.
Thanks!
Uncheck this box.

saving107 is offline   0 Reply With Quote
Old Jul 22, 2011, 01:09 AM   #7
cdembek
macrumors regular
 
Join Date: May 2008
There should be an overide for the browser!
cdembek is offline   1 Reply With Quote
Old Jul 22, 2011, 07:04 AM   #8
cells
macrumors newbie
 
Join Date: Apr 2007
I found a decent application-specific solution: swapping the keybindings for Quit and Quit and Discard in the Keyboard preferences.
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2011-07-22 at 7.03.29 AM.png
Views:	166
Size:	103.9 KB
ID:	295177  
cells is offline   5 Reply With Quote
Old Jul 22, 2011, 08:31 AM   #9
solarguy17
macrumors 6502
 
Join Date: Sep 2007
i dont like this feature either. its annoying, in fact have that autocheck when you log out as restart windows when logging back in, also really annoying.
__________________
Macbook Pro (2013), Macbook (2009), Time Capsule, iPod Touch 16 Gb (gen 1), iPhone 3Gs 32 Gb (white), iPhone 4 32 Gb (black), iPhone 4S 32Gb (black), iPhone 5 32 Gb (black), iPhone 5S 32GB (black)
solarguy17 is offline   0 Reply With Quote
Old Jul 22, 2011, 04:03 PM   #10
Slov
macrumors newbie
 
Join Date: Feb 2008
Quote:
Originally Posted by saving107 View Post
Uncheck this box.

Image
unchecking this box does not solve the problem of still having the ability to "reopen all windows from last session" under history. even under private browsing, clearing cache, and resetting safari, i still have the ability to reopen windows from last session (with the resume feature unchecked).

is anyone else experiencing this problem?
Slov is offline   -1 Reply With Quote
Old Jul 22, 2011, 04:04 PM   #11
LoganT
macrumors 68020
 
Join Date: Jan 2007
If you use the private browsing feature, it doesn't remember it.
LoganT is offline   1 Reply With Quote
Old Jul 22, 2011, 04:10 PM   #12
Slov
macrumors newbie
 
Join Date: Feb 2008
Quote:
Originally Posted by LoganT View Post
If you use the private browsing feature, it doesn't remember it.
that's the problem. i'm using private browsing. but i still get presented with the option to "reopen all windows from last session" when i restart safari. i also have the resume feature unchecked - mentioned in a few posts above.
Slov is offline   0 Reply With Quote
Old Jul 22, 2011, 04:25 PM   #13
LoganT
macrumors 68020
 
Join Date: Jan 2007
Quote:
Originally Posted by Slov View Post
that's the problem. i'm using private browsing. but i still get presented with the option to "reopen all windows from last session" when i restart safari. i also have the resume feature unchecked - mentioned in a few posts above.
How do you restart Safari? If I Command+Q out of Safari, when I open it again it shows my last pages I was on. If I have private browsing on it opens the home page. It doesn't even ask me anything.
LoganT is offline   0 Reply With Quote
Old Jul 22, 2011, 04:41 PM   #14
Slov
macrumors newbie
 
Join Date: Feb 2008
Quote:
Originally Posted by LoganT View Post
How do you restart Safari? If I Command+Q out of Safari, when I open it again it shows my last pages I was on. If I have private browsing on it opens the home page. It doesn't even ask me anything.
i just go to the drop down and quit safari. yes, upon a new browsing session, mine will just open the home page as well. but i'm referring to the "history" drop down menu. Under there i still have the option to "reopen all windows from last session." if i choose it, it will in fact open the last tabs i had open.

there doesn't appear to be any rhyme or reason with its behavior. if i close all individual tabs and then exit safari, when i reopen safari i still have the option to restore tabs from a previous session to the last one under the history menu.

i've tried clearing history, resetting safari, empty cache, and the option is still there. All while surfing under private browsing and having the resume feature disabled.
Slov is offline   0 Reply With Quote
Old Jul 22, 2011, 05:11 PM   #15
cocacolakid
macrumors 65816
 
cocacolakid's Avatar
 
Join Date: Dec 2010
Location: Chicago
You can use a Terminal command to stop this on any specific App.

http://www.maclife.com/article/howto...early_problems

The last tip in that article has it:

"By default, OS X Lion now attempts to get you back to work sooner by opening the files you were last viewing upon launch. While it’s a nice feature for many apps, there may be cases where you don’t want prying eyes to see what you were last viewing. The System Preferences > General tab has an option for getting rid of the feature entirely (simply uncheck “Restore windows when quitting and re-opening apps”), but there’s a better way to handle it on an app-by-app basis, courtesy of developer Wil Shipley.

First you’ll need to know exactly which app you want to kill this feature on -- we’ll use Preview as an example, since it may not be desirable to have it restore documents in most cases. Fire up Terminal again and use the following command without quotes: “defaults write com.apple.Preview NSQuitAlwaysKeepsWindows -int 0”. For other applications, simply replace “Preview” with the name of the app -- when in doubt, visit your Preferences folder to confirm how the app name appears in the “com.apple.XXXX” file this is modifying."

---

To see the exact way an App name appears, make sure the Finder is selected so the Finder menu appears, then up left near the Apple logo on the desktop bar click Go To, then Go To Folder, and type in ~/Library. Then in the window that opens, click on Preferences. You'll see a list of files, don't click on any. Just scroll down to the com.apple.XXXX area to see how the app you want to change appears. In this case, Safari is what one would expect, Safari with a capitol S.

So the command to type or copy and paste into Terminal is:

defaults write com.apple.Safari NSQuitAlwaysKeepsWindows -int 0

Then hit enter.

Close and restart Safari, next time you restart the computer Safari (or whatever other App(s) you ran that on) should not resume automatically from the last saved state.
__________________
2012 Mini 2.3 i7 Samsung 840 250 GB SSD 16GB RAM
2012 13" MBP Samsung SSD, 16GB RAM
TBD, iPad 4, iPhone 5S and PPC's
cocacolakid is offline   1 Reply With Quote
Old Jul 22, 2011, 05:52 PM   #16
Slov
macrumors newbie
 
Join Date: Feb 2008
Thanks
Slov is offline   0 Reply With Quote
Old Jul 22, 2011, 06:36 PM   #17
greyparrot
macrumors newbie
 
Join Date: Jul 2011
Quote:
Originally Posted by cocacolakid View Post

defaults write com.apple.Safari NSQuitAlwaysKeepsWindows -int 0
Thanks for this, I was about to change my browser because of this problem.

If I want to reverse this how do I do it? My guess is to change 0 to 1.
greyparrot is offline   0 Reply With Quote
Old Jul 26, 2011, 04:11 PM   #18
AndersHP
macrumors newbie
 
Join Date: Jul 2011
Thanks - only problem: Now Safari doesn't remember to auto-fullscreen either...
AndersHP is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X 10.7 Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Safari Open tabs. bandofbrothers iOS 7 7 Jul 15, 2013 10:47 AM
iPad: Tabs, but i don't like the >> tabs in safari lanceuppercut47 Jailbreaks and iOS Hacks 0 Feb 24, 2013 03:31 AM
Safari 6 - Open in Tabs w/out closing current tabs MikeBusch2 OS X 10.8 Mountain Lion 1 Dec 12, 2012 10:33 PM
iCloud open tabs Safari MacAir to Safari iPad jpieri4 OS X 10.8 Mountain Lion 1 Sep 20, 2012 11:54 PM
Safari 6 in Mountain Lion GM crashing when I open new tabs ethana OS X 10.8 Mountain Lion 4 Jul 14, 2012 03:21 AM

Forum Jump

All times are GMT -5. The time now is 09:20 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC