Go Back   MacRumors Forums > Apple Hardware > Desktops > iMac

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 6, 2011, 07:45 PM   #1
gagneana000
macrumors newbie
 
Join Date: May 2011
Unhappy Lion Wifi Connection Timeout, Help!

After intsalling Lion I can not connect to my Wi-Fi at all. When I try to connect it just says. "Could not join <name>, a connection timeout occured" I even did a clean install of Snow Leopard and then installed Lion. Its not a problem with my router because my iPhone, iPad, MBP, and other computers still connect to it fine. The MBP also has Lion and works great. I am using a 21.5in iMac from January 2011. I have attached my system info. Any help would be greatly appreciated. Right now I'm using an ethernet cable and its working fine.


Here's a link to my System Information: http://db.tt/dWki32z
Attached Thumbnails
Click image for larger version

Name:	Screen Shot 2011-08-06 at 5.27.24 PM.jpg
Views:	2217
Size:	190.0 KB
ID:	297896  
gagneana000 is offline   0 Reply With Quote
Old Aug 6, 2011, 08:23 PM   #2
Texran
macrumors regular
 
Join Date: Mar 2011
Location: Texas
http://osxdaily.com/2011/07/22/wifi-...-x-lion-fixes/
Texran is offline   0 Reply With Quote
Old Oct 13, 2011, 09:19 AM   #3
caspervc
macrumors newbie
 
Join Date: Jun 2010
Did you find a solution? I'm experiencing the exact same problem right now. I just updated to 10.7.2. I had no problems running 10.7.1.
caspervc is offline   0 Reply With Quote
Old Oct 13, 2011, 10:51 AM   #4
SOLLERBOY
macrumors 6502a
 
Join Date: Aug 2008
Location: Manchester,UK
I'm having similar issues, the wifi drops out every thirty seconds. Only on the iMac, not the macbook. This only started with 10.7.2.
__________________
27" iMac i7 3.4 3TBF 680MX Very Late 2012
17" MacBook Pro 2.2 i7 8GB 64GB Early 2011
16GB iPhone 6+ Space Grey 32GB iPad Air
SOLLERBOY is offline   0 Reply With Quote
Old Oct 18, 2011, 10:23 PM   #5
brilliantthings
macrumors regular
 
Join Date: Feb 2011
Just upgraded to 10.7.2 and 9 times out of 10 I cant connect to my WiFi router. Really irritating. I'm going to start troubleshooting for a problem I never had before I upgraded.
brilliantthings is offline   0 Reply With Quote
Old Oct 18, 2011, 11:00 PM   #6
Funkbefgh
macrumors newbie
 
Join Date: Jun 2011
I am also plagued with this madness, though I think yours is more extreme. updated 7.2 in a hurry so i could get my ipad 5.0 before I went on vacation.. and lost remote access to my computer and files within hours of leaving home. home 4 days later and it was running with the monitor asleep as it is normally but disconnected from the wifi. that happens occasionally when the router gets reset for whatever reason (i have roomates) so i sat down at the imac (my imac, they dont touch) reset and reconnected. the drop repeated during work the last two days and again since I got home at 6 tonight. what the hell!? not even an error message or exclamation. I used it for over an hour after work and it had zero connection issues while I was on it. I would have spent more time on today it if I had an error message like that.. only this last drop of connection really signaled alarm bells for me. I'm going to try pinging it. hoping an active connection will keep it locked in.. if that doesn't help I'll likely restore 7.1 before the weekend. not enough hours in the day for this bs. anybody find a good fix?

edited for spelling.

Last edited by Funkbefgh; Oct 18, 2011 at 11:33 PM.
Funkbefgh is offline   0 Reply With Quote
Old Oct 18, 2011, 11:04 PM   #7
brilliantthings
macrumors regular
 
Join Date: Feb 2011
Quote:
Originally Posted by brilliantthings View Post
Just upgraded to 10.7.2 and 9 times out of 10 I cant connect to my WiFi router. Really irritating. I'm going to start troubleshooting for a problem I never had before I upgraded.
Might have been a false alarm. I was using the MBA outside and it had overheated. I only realised because my iPhone asked me to leave it alone until it had cooled down. Whoops.

EDIT: But I did actually add a DNS address 8.8.8.8 - the Google one. Not sure if this had any effect.
brilliantthings is offline   0 Reply With Quote
Old Oct 20, 2011, 11:34 PM   #8
Funkbefgh
macrumors newbie
 
Join Date: Jun 2011
pinging has kept mine connected for two days. sort of annoying that i have to run terminal to stay connected to the internet, but it is working. good luck with yours! hopefully my bump will let somebody who can help see this.
Funkbefgh is offline   0 Reply With Quote
Old Oct 23, 2011, 01:24 AM   #9
smith5ae
macrumors newbie
 
Join Date: Oct 2011
I'm having the same problem. After upgrading to Lion 10.7, I was having WiFi issues. So I downloaded 10.7.2 through ethernet thinking it would solve the problem, but it didn't.

After trying just about all the solutions posted on forums, I gave up and reinstalled Lion. This time I was able to connect in 10.7. But after mistakenly installing 10.7.2 (thinking I was in the clear), I am back to "a connection timeout" error.

I ordered a power supply for my spare router, hopefully it'll do the trick. This is really beginning to drive me crazy!
smith5ae is offline   0 Reply With Quote
Old Nov 1, 2011, 12:46 PM   #10
MathiasVH
macrumors regular
 
Join Date: Nov 2009
Did any of you guys find a solution to this problem? I'm having the same issue as you do.
MathiasVH is offline   0 Reply With Quote
Old Nov 2, 2011, 03:38 AM   #11
BarkingGhost
macrumors regular
 
Join Date: Oct 2011
Location: Atlanta+35 miles
I'm not aware of one being out there. If I cold boot I can guarantee that I'll get the dreaded 'Wi-Fi: No hardware installed' BUG. If I reboot/restart (as opposed to shutting down and starting cold) the problem magically disappears, but from a cold boot it will ALWAYS be there.

Not good considering I spent $2200 for this i7Mac last Friday. And this iMac came with Lion pre-installed (cannot downgrade), and attempts to remove the original Mac OS X partition via an external hard drive Recovery HD cannot be done (will not delete).

I've reinstalled Lion three times and still the problem persists. I also have a USB issue, too.
BarkingGhost is offline   0 Reply With Quote
Old Nov 2, 2011, 04:52 AM   #12
kkhair
macrumors newbie
 
Join Date: Nov 2011
Remove the network and add it manually

I just removed the network for the Preferred network list (Sys Pref->Network->Wifi->advanced ->wifi) , then added it manually (with the + sign under the list) with a wrong password and tried to connect, the password window showed up and when I entered the correct password, it worked perfectly, hope this helps
kkhair is offline   2 Reply With Quote
Old Nov 20, 2011, 08:43 PM   #13
617arg
macrumors 6502
 
Join Date: Mar 2008
This is plaguing me right now too. Can't seem to figure out how to fix the problem. Everything was working fine and now I suddenly get "connection timeout" no matter what I try.
617arg is offline   1 Reply With Quote
Old Jan 22, 2012, 08:52 AM   #14
drgorb
macrumors newbie
 
Join Date: Jan 2012
Connection timeout on Lion

Hi,

I had the same problem and noticed that disconnecting the power cord allows the Powerbook to connect.

Once it is connected, it will stay connected. At least mine does.

I noticed because I was so angry about not being able to connect to my WiFi that I yanked the laptop and all of a sudden it connected.

Every time I get the timeout message, disconnecting the power cord has resolved the problem. I find this very weird but it works.

Hope this helps someone else.

Micha
drgorb is offline   0 Reply With Quote
Old Jan 22, 2012, 02:58 PM   #15
Coltaine
macrumors member
 
Join Date: Jan 2012
Hi folks,

weird WiFi connection problems are nothing new in Lion.

In case any of you are using a FritzBox, unchecking the option for the use of 300 Mbit/s optimized channels might work.

Just this weekend we tried to connect a new iMac to a FritzBox and it simply wasn't working. The iMac wasn't assigned an IP by the FritzBox. It took 6 hours of troubleshooting and nothing worked. Then we unchecked the above setting and lo and behold, all issues were solved.
So if you own a FritzBox or if your router has this option, try disabling it, it might work in some cases.
Coltaine is offline   0 Reply With Quote
Old Jan 25, 2012, 02:25 PM   #16
busteranime
macrumors newbie
 
Join Date: Mar 2008
Solution

The solution I just found is to go to About This Mac -> More Info -> System Report -> Network -> Wi-Fi. Under Interfaces, look for supported channels. I had to go into my router settings and make sure I was on a compatible channel. The second I did that, my 5 ghz network showed up and is working perfectly!
busteranime is offline   2 Reply With Quote
Old Jan 27, 2012, 12:24 AM   #17
pratpreneur
macrumors newbie
 
Join Date: Jan 2012
I used my roommates' computer and fixed it

I went into the router settings. Changed the admin from WPA to WPA2 personal. That also helped me increase the speed limit from g to s.. and now its capable of going to 154mbps (although, honestly, it never goes above 2 mbps so i dont understand the point)
pratpreneur is offline   0 Reply With Quote
Old Jan 28, 2012, 05:28 AM   #18
TheJing
Banned
 
Join Date: Jun 2011
Location: Somewhere in Europe
Macs are excellent computers, if you don't need the internet.

I've had this problem for so long I'm thinking about giving these pieces of **** to someone else.
TheJing is offline   0 Reply With Quote
Old Jan 28, 2012, 02:59 PM   #19
mmomega
macrumors Demi-God
 
mmomega's Avatar
 
Join Date: Dec 2009
Location: DFW, TX
For those having the WiFi problems, what sort of network setup do you have? Modems and Routers..

Just asking because I have 6 Lion Macs in my home, sometimes 9 and only 1 being connected by wire. 2 MacMini's, 2 MacBooks and 2 iMacs. Various years, no 2 the same.
__________________
2013 iMac 27" i7, 32GBRAM, GTX780M, 256GB Flash, VESA, Yosemite
2012 Mac Mini Server w/ 23TB Storage
iPad Air 32GB, iPhone 6+ Gold 128GB, iPad Mini 16GB
3x AEBS 802.11ac, 5x AppleTV
mmomega is offline   0 Reply With Quote
Old Feb 16, 2012, 08:40 PM   #20
sskoutas
macrumors newbie
 
Join Date: Feb 2012
Thumbs up Wooohooo!!!! Thank you kkhair!

Quote:
Originally Posted by kkhair View Post
I just removed the network for the Preferred network list (Sys Pref->Network->Wifi->advanced ->wifi) , then added it manually (with the + sign under the list) with a wrong password and tried to connect, the password window showed up and when I entered the correct password, it worked perfectly, hope this helps
There IS a Santa Claus! Kkhair, I just wanted to let you know that I joined this forum solely to thank you for this answer above. I've been beating my head against the wall with the connection timeout error (and driving the genius bar crazy) for about a month or two. I couldn't find any solution, but yours worked flawlessly. Thank you, thank you, thank you!
sskoutas is offline   0 Reply With Quote
Old Feb 20, 2012, 04:01 AM   #21
oranabana
macrumors newbie
 
Join Date: Dec 2011
Smile ooooh... worked!

Quote:
Originally Posted by kkhair View Post
I just removed the network for the Preferred network list (Sys Pref->Network->Wifi->advanced ->wifi) , then added it manually (with the + sign under the list) with a wrong password and tried to connect, the password window showed up and when I entered the correct password, it worked perfectly, hope this helps
Also worked for me!! Thanks so much!!!
oranabana is offline   0 Reply With Quote
Old Mar 9, 2012, 08:20 AM   #22
nyeates1
macrumors newbie
 
Join Date: Nov 2009
Delete your keychain entries for the WAP



The problem for many of you is likely a corrupt entry in your keychain. To fix this, open up "Keychain Access" (in "Applications/Utilities") and search for the entry which matchs the name of your wifi network. Then, select all the matching entries (there were two in my case) and delete them.

See this discussion for more details: https://discussions.apple.com/thread/3244298
nyeates1 is offline   1 Reply With Quote
Old Mar 10, 2012, 08:13 PM   #23
Tim Taylor
macrumors newbie
 
Join Date: Mar 2012
Lightbulb Simple Solution

A very simple trick that worked for me:
Just change the WLAN password of the router.
When lion try to connect just enter the new password.
Hope that helps.
Tim Taylor is offline   0 Reply With Quote
Old Mar 16, 2012, 07:03 PM   #24
snow-white tan
macrumors newbie
 
Join Date: Dec 2010
this will work..

I had the same problem with my Mac Pro/Airport Extreme combo and I figured it out. The problem is the laws of physics don't allow radio transmission between multiple transceivers all broadcasting/receiving at the same frequency without interference. Here's the fix..

Go to About this Mac > More Info > System Report > Network > Wi-Fi. Scroll down to Local Wi-Fi Networks. You will see a list of all the networks in your neighbourhood/hall of residence/prison cell complex etc.. 10 or more if you're unlucky. You will also see your one. Look at the Channel numbers. Chances are, yours will be the same as the guy next door, or at least someone nearby (mine was shared by two others!). Now just pick a number no-one is using (from 1 to 13) and remember it.

Now go to your router and change the channel to your chosen number. The procedure will vary according to the make. If you have an Airport extreme you just go to Airport Utility, click on your router and go to 'Wireless options'. It will take a few seconds to update, then you'll be back in business. I've had a full strength signal ever since.
snow-white tan is offline   0 Reply With Quote
Old Mar 17, 2012, 06:22 AM   #25
forty2j
macrumors 68030
 
forty2j's Avatar
 
Join Date: Jul 2008
Location: NJ
Quote:
Originally Posted by nyeates1 View Post

The problem for many of you is likely a corrupt entry in your keychain.
Oh, how badly I wanted this to work. Alas, no combination of deleting keychain entries, forgetting networks, and reconnecting could get my iMac to connect to the 5 Ghz network broadcasting from 3 feet below it for longer than it takes to get an IP address. It picks up the 2.4 Ghz band just fine, but I like to avoid that as it interferes with the Turtle Beach wireless headsets.

Quote:
Originally Posted by snow-white tan View Post
I had the same problem with my Mac Pro/Airport Extreme combo and I figured it out. The problem is the laws of physics don't allow radio transmission between multiple transceivers all broadcasting/receiving at the same frequency without interference.
I have the only 5 Ghz network in range.

I *do* have a repeater, which is doing what it's supposed to and running at the same frequency in a different room, on a different floor.
__________________
 2012 iMac 3.2GHz 27" 680MX Fusion  iPhone 6  Apple TV 2  iPad Air 
forty2j is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Desktops > iMac

Tags
connection, imac, lion, timeout, wifi

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
MBA 2014, Wifi connection timeout ReelAction MacBook Air 0 May 19, 2014 09:33 PM
Wifi Connection Timeout dankfire Mac Basics and Help 1 May 12, 2013 09:23 PM
Wifi connection timeout issue Serban iMac 5 Apr 16, 2013 02:35 AM
Connection timeout on wifi Maggot FF Mac Peripherals 0 Jan 29, 2013 08:46 PM
Wifi connection Timeout ReservedName Mac Basics and Help 0 Jun 29, 2012 05:29 PM

Forum Jump

All times are GMT -5. The time now is 07:59 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC