Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Programming > iPhone/iPad Programming

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 9, 2011, 10:00 AM   #1
sagarshivam
macrumors member
 
Join Date: May 2011
UISplitViewController problem

Hello!!

After few successful simple GUI for iPhone, I am trying to make split-view based GUI for iPad (without using xib).

In the appdelegate.h, I am using below code

Code:
- (BOOL)application:(UIApplication *)application didFinishLaunchingWithOptions:(NSDictionary *)launchOptions {    

	//window = [[UIWindow alloc] initWithFrame:[[UIScreen mainScreen] bounds]];
	window = [[UIWindow alloc] init];
        splitViewController = [[UISplitViewController alloc] init];
	rootViewController = [[[RootViewController alloc] initWithStyle:UITableViewStylePlain] autorelease];
	detailViewController = [[[DetailViewController alloc] init] autorelease]; 
	UINavigationController *rootNav = [[UINavigationController alloc] initWithRootViewController:rootViewController ];
	UINavigationController *detailNav = [[UINavigationController alloc] initWithRootViewController:detailViewController ] ;
	splitViewController.viewControllers = [NSArray arrayWithObjects:rootNav, detailNav, nil];
	splitViewController.delegate = detailViewController;
	[window addSubview:splitViewController.view];
	[window makeKeyAndVisible];
	return YES;  
	
}

RootViewController.m is intended to populate the table with 10 rows (row 0, row1..row9) and clicking on either will simply display as detail view.

But On running on simulator, there is no GUI at all except one white bar at the top. Rest screen is completely black and there is no message even on console.

Where am I making mistake?

Plz guide.
sagarshivam is offline   0 Reply With Quote
Old Aug 10, 2011, 01:52 AM   #2
jnoxx
macrumors 65816
 
jnoxx's Avatar
 
Join Date: Dec 2010
Location: Aartselaar // Antwerp // Belgium
Does your RootView/Detailview have any code in them, that u can check it's relevant? have u tried Logging in your viewDidload, maybe your class gets loaded, but there is no visual to show..
jnoxx is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Programming > iPhone/iPad Programming

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
GoodPlayer Problem - Never mind. Problem solved. BasicGreatGuy iPad Apps 0 Mar 14, 2014 01:18 PM
iTunes DRM problem? Or, HD Versions of Movie on ATV1 Problem? Aqueous Apple TV and Home Theater 5 Feb 9, 2014 07:54 AM
UISplitViewController in iPhone mikezang iPhone/iPad Programming 8 Feb 28, 2013 01:29 AM
MacBook Pro Problem! Booting up problem! Legolasas MacBook Pro 2 Jan 21, 2013 09:54 AM

Forum Jump

All times are GMT -5. The time now is 12:07 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC