Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Aug 13, 2011, 09:55 PM   #1
qqisvip
macrumors newbie
 
Join Date: Aug 2011
Wifi on but no internet connection? MB pro

I have a Macbook pro OSX version 10.6.8. Recently my brother bought an ethernet cable and connected it to his Xbox for XBoxlive. Soon after, my internet stopped working. AirPort says that I am still connected to my Wifi network, but I can't search the web. Additionally, the wifi symbol on the top right corner of my screen has an exclamation mark on it. My router is a Westell Versalink 327W Model# D90-327W15-06.

On my iPhone4, I am connected to Wi-fi on the same router, and I'm able to access the internet (going on any website).

These are the resolutions that I tried.
-Rebooting the router
-Restarting my MB
-Manually removing and re-adding the IP address
-Manually deleting and re-adding the IPv4 Address, Subnet Mask and Router.
-Manually deleting and re-adding the DNS server and Search Domains.
-Removing ethernet cable from xbox and from router

How can I fix this "wifi on, but no internet" problem?

Last edited by qqisvip; Aug 13, 2011 at 09:56 PM. Reason: Forgot to add something.
qqisvip is offline   0 Reply With Quote
Old Aug 13, 2011, 11:35 PM   #2
skiltrip
macrumors 68020
 
Join Date: May 2010
Location: New York
This happened to me today after I had plugged my Ethernet into an Airport Express to configure it.

Just add a "new" network, choose your router and re-enter the password. That's what worked for me.
__________________
MacBook Pro 15" 2GHz Quad i7 8GB RAM 750GB HD iPad mini retina 32GB iPod classic 160GB iPod touch 4 8GB
skiltrip is offline   0 Reply With Quote
Old Aug 14, 2011, 03:24 PM   #3
qqisvip
Thread Starter
macrumors newbie
 
Join Date: Aug 2011
Quote:
Originally Posted by skiltrip View Post
This happened to me today after I had plugged my Ethernet into an Airport Express to configure it.

Just add a "new" network, choose your router and re-enter the password. That's what worked for me.
It doesnt work. I ran my diagnostics and this is what came up on my Network status:

Airport: Green
Airport settings:Green
Network settings: Orange
ISP: Green
Internet: Red
Server: Red

I might have to call my ISP and see what's going on.
qqisvip is offline   0 Reply With Quote
Old Nov 7, 2011, 02:59 PM   #4
jrfive0
macrumors member
 
Join Date: Mar 2011
OP: did you find a resolution or the cause of the problem? I'm having the same issue
__________________
MBP 13/8 GB/1 TB(mid 2010) iPad 1 16 GB WiFi Verizon iPhone 4s 64 GB iPod Classic 120 GB (6th Gen) ATV2 2011 Mac Mini 2.3
jrfive0 is offline   0 Reply With Quote
Old Nov 7, 2011, 03:30 PM   #5
Adamantoise
macrumors 6502a
 
Join Date: Aug 2011
Quote:
Originally Posted by jrfive0 View Post
OP: did you find a resolution or the cause of the problem? I'm having the same issue
As am I.

I notice that turning Wi-Fi off and turning it on again fixes the problem.

However, the problem resumes the minute you wake the computer from standby/sleep.

Very irritating problem.
__________________
iPhone 4 16GB (White)
Macbook Pro (2011) 2.3 GHz i5 8GB RAM 500GB Momentus XT HDD
Adamantoise is offline   0 Reply With Quote
Old Dec 23, 2011, 04:27 PM   #6
MacNOW2
macrumors newbie
 
Join Date: Dec 2011
self assigned IP


OK, had the same problem, here my fix:
Check Keychain and delete the Network you want to connect to. Then start again and hopefully it will work without any problm
MacNOW2 is offline   0 Reply With Quote
Old Apr 3, 2013, 01:13 PM   #7
Bazza90036
macrumors newbie
 
Join Date: Apr 2013
Just figured it out....it's the Airport Password

Was having similar problems to the above thread. Wifi Network was showing it was connected but I could not connect to Internet. Airport Extreme was flashing AMBER.

Modem signal was fine.
Network Prefs showed:

Airport: Green
Airport Settings: Green
Network Settings: Green
ISP: Green
Internet: RED
Server: Red

After checking with ISP and connecting to the internet via Ethernet my ISP told me that there was something wrong with my wireless router (the Airport Extreme).

I ran Airport Utility and and it came back reporting problems.

(IMPORTANT: A few days earlier I had re-set my email password.)

As soon as I updated my "new" password in the Airport Utility...the airport restarted and I was good to go.

It was as simple as entering my new password!!

Hope that helps!!
Bazza90036 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Sharing Internet wifi connection spanners70 MacBook Air 2 Apr 29, 2014 09:13 AM
iPhone 5S wifi connected but no internet connection blitzwing iPhone Tips, Help and Troubleshooting 2 Nov 21, 2013 10:06 AM
Wifi keeps losing Internet connection nilsh32 MacBook Pro 0 Oct 28, 2013 04:45 PM
Losing internet while still showing full wifi connection Burton321 iPhone Tips, Help and Troubleshooting 1 Jul 16, 2013 10:38 PM
Wifi connection to Mac using Internet Sharing pjdavids2123 iPhone 3 Apr 5, 2013 05:55 PM

Forum Jump

All times are GMT -5. The time now is 02:10 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC