Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 5 and earlier

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 14, 2011, 03:52 PM   #1
daihard
macrumors 6502a
 
daihard's Avatar
 
Join Date: Feb 2008
Location: Seattle, WA
Send a message via AIM to daihard
Question iMessage needs time to be activated?

Hi.

I just activated my wife's 4S. Everything went smoothly except that iMessage does not always work correctly. She can send an iMessage to me, both at my iPhone number and e-mail address. However, I cannot send her one at her iPhone number. I _am_ able to use her e-mail address, though.

So the only problem seems to be that she can't receive an iMessage at her phone number. I checked the Messages settings to make sure iMessage is enabled. Her phone number shows up under "Receive At."

Does it just take time for iMessage to be activated? Mine has been active for a while (since Beta) so I can't compare my settings with hers.

TIA!
__________________
Mobile: Google Nexus 4 / CM 11 (4.4.2) 12-26-2013 Nightly
Laptop: 13" Retina MacBook Pro (2.6/16/512) / Mac OS X 10.9.1

Last edited by daihard; Oct 14, 2011 at 07:07 PM.
daihard is offline   0 Reply With Quote
Old Oct 14, 2011, 04:02 PM   #2
Moi un Mouton
macrumors 68000
 
Join Date: Mar 2008
Location: Bracknell UK
I have exactly the same situation. She can iMessage me at my phone number but I can only iMessage her at her email. Her phone number still gives the green send button
Moi un Mouton is offline   0 Reply With Quote
Old Oct 14, 2011, 04:13 PM   #3
mastakilla48
macrumors newbie
 
Join Date: Jun 2010
i have this same problem for a few contacts, girlfriends phone picks up any imessage users from phone numbers mine only from email. both phones settings are exactly the same
mastakilla48 is offline   0 Reply With Quote
Old Oct 14, 2011, 04:15 PM   #4
daihard
Thread Starter
macrumors 6502a
 
daihard's Avatar
 
Join Date: Feb 2008
Location: Seattle, WA
Send a message via AIM to daihard
Thanks guys. Kinda good to know I'm not alone, though the best scenario would be that the problem will be solved for all of us soon.

If this persists through the end of the day, I will take her phone to Genius tomorrow.
__________________
Mobile: Google Nexus 4 / CM 11 (4.4.2) 12-26-2013 Nightly
Laptop: 13" Retina MacBook Pro (2.6/16/512) / Mac OS X 10.9.1
daihard is offline   0 Reply With Quote
Old Oct 14, 2011, 04:18 PM   #5
josielinnea
macrumors regular
 
Join Date: Dec 2007
Location: Stockholm
Check the country chosen under:
Settings -> Messages -> Receive at -> click "AppleID: xxx" -> Change location.
This should be set to the correct country so that you're phone can use the correct country-code as prefix for the phone number, even if the number is not written with country code in your phonebook.

Could it be your wife entered your number to her phonebook as "+1xxxxx" and you've only entered hers as "xxxxx"?
__________________
Previously:iPhones: 1gen 4GB, 3G 16GB white, 3Gs 32GB white, 4 16GB black, 4s 16gb White. 5 64GB black. Macs: iMac508.
Currently: iPhone 5s 64GB black, iMac 13,2, MBA 11".
josielinnea is offline   0 Reply With Quote
Old Oct 14, 2011, 07:07 PM   #6
daihard
Thread Starter
macrumors 6502a
 
daihard's Avatar
 
Join Date: Feb 2008
Location: Seattle, WA
Send a message via AIM to daihard
Quote:
Originally Posted by josielinnea View Post
Check the country chosen under:
Settings -> Messages -> Receive at -> click "AppleID: xxx" -> Change location.
This should be set to the correct country so that you're phone can use the correct country-code as prefix for the phone number, even if the number is not written with country code in your phonebook.

Could it be your wife entered your number to her phonebook as "+1xxxxx" and you've only entered hers as "xxxxx"?
Thanks for the reply.

Both our phones have the country code set to United States. Both our phone numbers start with +1 (206) xxx-xxxx.

Interestingly, iMessage works for her phone number now. They must have taken some time to enable it on her account...
__________________
Mobile: Google Nexus 4 / CM 11 (4.4.2) 12-26-2013 Nightly
Laptop: 13" Retina MacBook Pro (2.6/16/512) / Mac OS X 10.9.1
daihard is offline   0 Reply With Quote
Old Oct 15, 2011, 10:05 AM   #7
Moi un Mouton
macrumors 68000
 
Join Date: Mar 2008
Location: Bracknell UK
It's resolved itself here as well, without any settings being changed. It seems to be just a question of waiting a few hours for the iMessage server to update itself with the phone number.
Moi un Mouton is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 5 and earlier

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
3.0 2g froze and needs to be activated... sk2sep2304 iPhone Tips, Help and Troubleshooting 4 Jun 25, 2009 03:26 AM
iPhone online order from Apple need to be activated at Apple Store? filmfanatic24 iPhone 4 Jun 24, 2009 09:59 AM
Does 1st gen iPhone need to be activated before quickpwn unlock? snook911 Jailbreaks and iOS Hacks 2 Nov 24, 2008 04:29 PM


All times are GMT -5. The time now is 03:39 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC