Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 15, 2011, 02:15 PM   #1
unlimitedx
macrumors 6502a
 
Join Date: Jun 2010
"Cannot Send Mail" the user name or password is incorrect ??

I'm unable to send any email on my iphone 4s. i already had this problem on the iphone 4 but it seems to persist despite getting a new phone. i know that my username and password is correct...

anyone else got this error before?
unlimitedx is offline   0 Reply With Quote
Old Oct 15, 2011, 02:33 PM   #2
daaneel
macrumors regular
 
Join Date: Jul 2011
.. are you sure your username and password are correct? lol
daaneel is offline   0 Reply With Quote
Old Oct 15, 2011, 02:35 PM   #3
unlimitedx
Thread Starter
macrumors 6502a
 
Join Date: Jun 2010
yes in fact, the mail app is able to fetch my mail, but i am unable to send any..
unlimitedx is offline   0 Reply With Quote
Old Oct 15, 2011, 02:51 PM   #4
AluminumMonster
macrumors newbie
 
Join Date: Jan 2011
Is this via iCloud? Saw the same error yesterday... had to enter a different address from the SMTP server rather than the default iCloud smtp that it gave me. smtp.me.com rather than smtp-7.mobile.me.com (or something similar) worked in my case.
AluminumMonster is offline   0 Reply With Quote
Old Oct 15, 2011, 03:15 PM   #5
citrate
macrumors 6502
 
Join Date: Sep 2008
Just because you can receive means nothing because you can specify a different server, username and password for outgoing mail.
citrate is offline   0 Reply With Quote
Old Oct 16, 2011, 02:13 AM   #6
asleep
macrumors 68020
 
Join Date: Sep 2007
Same problem here: receive/no send

All settings same as with iPhone 4.

Last edited by asleep; Oct 16, 2011 at 11:04 AM.
asleep is offline   0 Reply With Quote
Old Oct 16, 2011, 02:48 AM   #7
cinek
macrumors 6502
 
Join Date: Mar 2011
if it's icloud - I had this issue throughout the beta testing period - it'll go away after a while - not ideal, but nothing you can do about it - try submitting a bug report to apple.
__________________
13" Early 2011 Macbook Pro | i7 | 4GB RAM | 128GB SSD
cinek is offline   0 Reply With Quote
Old Oct 16, 2011, 03:06 AM   #8
FredV
macrumors member
 
Join Date: Oct 2011
I've been having the same problem with my yahoo business emails.
now my phone wont even connect to my emails. this is frustrating..
FredV is offline   0 Reply With Quote
Old Oct 16, 2011, 11:36 AM   #9
asleep
macrumors 68020
 
Join Date: Sep 2007
Found a fix for mine...

When going from 4 to 4S, you have to enter 2 passwords:

Incoming Mail Server is one the first mail account page, the one where you can toggle the account On or Off.

Scroll down to Outgoing Mail Server .... see the arrow to the right?

Clicking it brings you to a SMPT page, where you can activate one or more outgoing servers by clicking on, for instance:

smtp.att.yahoo.com
or
smtp.gmail.com

and entering your password again for that account.

Account will be verified & voila!
asleep is offline   0 Reply With Quote
Old Oct 16, 2011, 02:16 PM   #10
unlimitedx
Thread Starter
macrumors 6502a
 
Join Date: Jun 2010
Quote:
Originally Posted by asleep View Post
Found a fix for mine...

When going from 4 to 4S, you have to enter 2 passwords:

Incoming Mail Server is one the first mail account page, the one where you can toggle the account On or Off.

Scroll down to Outgoing Mail Server .... see the arrow to the right?

Clicking it brings you to a SMPT page, where you can activate one or more outgoing servers by clicking on, for instance:

smtp.att.yahoo.com
or
smtp.gmail.com

and entering your password again for that account.

Account will be verified & voila!

It isn't working for me..

i input host name as smtp.att.yahoo.com
user name and pass as my email id and pass
set SSL to on,
authentication to password
and server port to 587

still doesn't work..
unlimitedx is offline   0 Reply With Quote
Old Oct 16, 2011, 02:52 PM   #11
FredV
macrumors member
 
Join Date: Oct 2011
My solution was to keep deleting it, and adding it again, it worked after a couple times. and that's what yahoo suggests to do. keep trying
FredV is offline   0 Reply With Quote
Old Oct 16, 2011, 07:35 PM   #12
asleep
macrumors 68020
 
Join Date: Sep 2007
Quote:
Originally Posted by unlimitedx View Post
It isn't working for me..

...and server port to 587

...
Try 465
asleep is offline   0 Reply With Quote
Old Oct 17, 2011, 08:32 PM   #13
unlimitedx
Thread Starter
macrumors 6502a
 
Join Date: Jun 2010
Quote:
Originally Posted by asleep View Post
Try 465
Still failed.. i brought my iphone to the genius bar. the genius was not able to help to fix this either.
unlimitedx is offline   0 Reply With Quote
Old Aug 3, 2012, 11:49 AM   #14
CUDACOR
macrumors newbie
 
Join Date: Aug 2012
try this

Ok I think I may have a solution..this is what I tried and it worked.

go to :settings
then Mail,Contacts,Calenders
then to the email account thats unable to send
then at the bottom ADVANCED
then near the bottom there should be a S/MIME turn it on

this is what I did and it worked !

----------

By the way I was having problems with my hotmail account. I never had a problem with my Gmail
CUDACOR is offline   0 Reply With Quote
Old Aug 3, 2012, 11:55 AM   #15
BuckeyeMac
macrumors 6502
 
Join Date: Jun 2012
I was getting this message with my osu.edu email account (who goes through outlook)...this was happening about 3 times a week and would come and go

Here's how I fixed it:

When in your mail settings, for the outgoing server, even though it says username/password is optional, type your username and password in.

I haven't had an issue since (about 3 weeks)
BuckeyeMac is offline   0 Reply With Quote
Old Sep 8, 2012, 05:14 PM   #16
snoipme
macrumors newbie
 
Join Date: Sep 2012
hi,

i was able to solve this with iphone 4, iOS 5.1.1 by re-entering my hotmail account password on the following screen:

"Settings" -->
"Mail, Contacts, Calendars" -->
<select affected mail account, e.g. myname@hotmail.com> -->
select SMTP server (scroll down to "Outgoing Mail Server" section; the SMTP server for hotmail is 'smtp.live.com') -->
select SMTP server again (under "Primary Server" section at top; this should be marked as 'On') -->
on this screen, delete whatever is entered under "Password" and re-enter your login password for the account; when you click "Done" at the top of the keyboard, it will show a series of checkmarks next to each field to let you know the outgoing smtp server configuration is correct. -->
done!

send a test message from your account to another account to verify that all is well.

cheers!
snoipme is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Anyone able to fix "Incorrect Password" wifi problem with iPhone 5? Ant.honey iPhone Tips, Help and Troubleshooting 3 Nov 28, 2012 12:58 PM
Gmail Problems - "Incorrect Password" Fugue iPhone 7 Oct 6, 2012 09:42 PM
Incorrect Mail usage stats in "Storage & Backup" easybreezy iCloud and Apple Services 2 Jul 29, 2012 08:31 PM
Exchange "Incorrect Password" fix moonman239 iOS 5 and earlier 0 Jul 4, 2012 11:23 AM

Forum Jump

All times are GMT -5. The time now is 01:07 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC