Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Reply
 
Thread Tools Search this Thread Display Modes
Old Oct 29, 2011, 08:40 AM   #1
hae4
macrumors newbie
 
Join Date: Sep 2011
Can't control volume on macbook pro

Hi,

Neither the keys on the keyboard or the volume control on the menu bar have any effect on the volume. I still get the icons when I press the keyboard volume keys.
The only way I can change the volume is through the sound options in system preferences.

I googled the problem and somebody mentioned that deleting some plist files and restarting. I've done that and it fixed the problem but on the next restart the problem reappeared.

I'm running Snow Leopard on a late 2008 unibody macbook pro.

Could anybody please help get rid of this problem permanently?

Thanks
hae4 is offline   0 Reply With Quote
Old Oct 29, 2011, 09:44 AM   #2
randomrazr
Banned
 
Join Date: Jan 2011
Quote:
Originally Posted by hae4 View Post
Hi,

Neither the keys on the keyboard or the volume control on the menu bar have any effect on the volume. I still get the icons when I press the keyboard volume keys.
The only way I can change the volume is through the sound options in system preferences.

I googled the problem and somebody mentioned that deleting some plist files and restarting. I've done that and it fixed the problem but on the next restart the problem reappeared.

I'm running Snow Leopard on a late 2008 unibody macbook pro.

Could anybody please help get rid of this problem permanently?

Thanks
times for new computer!!
randomrazr is offline   -6 Reply With Quote
Old Oct 29, 2011, 11:05 AM   #3
crimton
macrumors member
 
Join Date: Sep 2011
----------

I had a similar problem on my 11 13" mbp and reset the pram and it started working again. http://guides.macrumors.com/Zapping_The_PRAM
crimton is offline   1 Reply With Quote
Old Oct 29, 2011, 02:00 PM   #4
hae4
Thread Starter
macrumors newbie
 
Join Date: Sep 2011
Quote:
Originally Posted by crimton View Post
----------

I had a similar problem on my 11 13" mbp and reset the pram and it started working again. http://guides.macrumors.com/Zapping_The_PRAM
That fixed it! Thanks
hae4 is offline   1 Reply With Quote
Old Oct 30, 2011, 10:27 AM   #5
hae4
Thread Starter
macrumors newbie
 
Join Date: Sep 2011
The problem reappeared after a restart. Any ideas what may be causing it and how to fix it?
hae4 is offline   0 Reply With Quote
Old Nov 2, 2011, 11:31 PM   #6
hae4
Thread Starter
macrumors newbie
 
Join Date: Sep 2011
Still have the problem... bump
hae4 is offline   0 Reply With Quote
Old Nov 3, 2011, 10:44 PM   #7
hae4
Thread Starter
macrumors newbie
 
Join Date: Sep 2011
Problem comes and goes, help please
hae4 is offline   0 Reply With Quote
Old Nov 3, 2011, 10:56 PM   #8
GuitarG20
macrumors 65816
 
GuitarG20's Avatar
 
Join Date: Jun 2011
i am at a loss for what this is... is there a apple store you can take it to somewhere near you?
__________________
MBP 8,3 (17")|| HTC One X (LTE) || iPhone 3GS || iPod Classic || iPod Video || iPod Shuffle
GuitarG20 is offline   0 Reply With Quote
Old Nov 3, 2011, 10:59 PM   #9
hae4
Thread Starter
macrumors newbie
 
Join Date: Sep 2011
Quote:
Originally Posted by GuitarG20 View Post
i am at a loss for what this is... is there a apple store you can take it to somewhere near you?
It's quite far, but I guess it's my only option. I hope they won't charge me loads of money for the service..
hae4 is offline   0 Reply With Quote
Old Nov 3, 2011, 11:00 PM   #10
GuitarG20
macrumors 65816
 
GuitarG20's Avatar
 
Join Date: Jun 2011
Quote:
Originally Posted by hae4 View Post
It's quite far, but I guess it's my only option. I hope they won't charge me loads of money for the service..
if you schedule your appointment, i don't think they would. I took a original iphone into one not two months ago and they were happy to help me.
__________________
MBP 8,3 (17")|| HTC One X (LTE) || iPhone 3GS || iPod Classic || iPod Video || iPod Shuffle
GuitarG20 is offline   0 Reply With Quote
Old Nov 4, 2011, 11:30 AM   #11
jvlopes
macrumors newbie
 
Join Date: Nov 2011
Can't control volume on macbook pro

I have exactly the same problem. When I press the keys (F10,F11,F12) to change the sound volume the symbol appears in the display and the bar volume change as it should be but the sound volume doesn't change.

The only way to control the volume is throught the System Preferences Audio Pane.

After a reset of PRAM I can control again the volume.

Cheers
Joćo
jvlopes is offline   0 Reply With Quote
Old Nov 6, 2011, 10:21 PM   #12
hae4
Thread Starter
macrumors newbie
 
Join Date: Sep 2011
Quote:
Originally Posted by GuitarG20 View Post
if you schedule your appointment, i don't think they would. I took a original iphone into one not two months ago and they were happy to help me.
Great. I'll do that if I find time in the week
hae4 is offline   0 Reply With Quote
Old Nov 6, 2011, 10:36 PM   #13
Prodo123
macrumors 68020
 
Prodo123's Avatar
 
Join Date: Nov 2010
Also, an upgrade to Lion might help.
__________________
MacBook Pro 15" 2.2Ghz hi-res glossy, 16GB RAM, Logitech G700, Das Keyboard, Seagate Momentus XT 750GB iPhone 5 White 32GB Audiophile Photographer, videographer, audio engineer
Prodo123 is offline   0 Reply With Quote
Old May 13, 2013, 04:39 PM   #14
Borkabork
macrumors newbie
 
Join Date: May 2013
Solution?

Hey people, I had this problem myself.

The issue was in fact that I had interfered with the headphones socket by pulling my headphones out too fast.

All I had to do get it back to normal was plug in my headphones again and realign whatever was out of place; now it works as normal with headphones in and with the speakers.

Hope this helps.
Borkabork is offline   0 Reply With Quote
Old May 13, 2013, 05:34 PM   #15
johnnnw
macrumors 6502a
 
johnnnw's Avatar
 
Join Date: Feb 2013
Quote:
Originally Posted by Borkabork View Post
Hey people, I had this problem myself.

The issue was in fact that I had interfered with the headphones socket by pulling my headphones out too fast.

All I had to do get it back to normal was plug in my headphones again and realign whatever was out of place; now it works as normal with headphones in and with the speakers.

Hope this helps.
This was in 2011, I'm sure it's solved now
johnnnw is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Pro

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
Old Apple HD Cinema Display on Macbook Pro? veo321 MacBook Pro 3 Sep 26, 2011 08:14 PM
Fishy battery life/ CPU Usage on Macbook Pro njsa04playa MacBook Pro 8 Aug 27, 2011 06:03 PM
No automatic hibernate on MacBook Pro when battery runs low iwnz MacBook Pro 2 Mar 11, 2011 12:51 PM
Dual HD Monitors on MacBook Pro 15" - 2010 mbmobile MacBook Pro 8 Mar 10, 2011 02:11 PM
Having some bad flickering, and starting problems on macbook pro Big-Viscera MacBook Pro 0 Nov 9, 2010 06:21 AM


All times are GMT -5. The time now is 11:38 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC