Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X 10.7 Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 3, 2011, 04:01 PM   #1
Clodey
macrumors member
 
Join Date: Aug 2011
Location: Wales, UK
Angry The folder canít be opened because you donít have permission to see its contents!

Hi,

I am having a problem with my DLink DIR-685 router which has an internal hard drive. It works flawlessly with my windows machine, however I am having no such luck with my Macbook Air running Lion.

So this hard drive inside the router is in EXT3 format which is probably causing the problem. However I can access it through a little app called muCommander, which is like an alternative to finder. But since I want to access the hard drive through finder so I can refer to the folders on the hard drive through applications, it has to be done through finder.

I have tried two apparent work arounds which have both failed. These are MacFUSE and Paragon ExFS.

So to help explain what I am doing I have attached some images:

Firstly I click on the hard drive in finder, under shared:


Then I proceed to the first folder:


The 'no entry' icons in the corner of the folders signify that I cannot access them and the following message pops up if I try to do so:



Is it even possible to access these files on my Mac. There are no permission restrictions assigned to the folders since I can access them no problem on my windows machine and I have set the storage access setting on the router to open which means anyone can access the files.
Clodey is offline   0 Reply With Quote
Old Nov 3, 2011, 08:00 PM   #2
NoHomeDirectory
macrumors newbie
 
Join Date: Nov 2011
Select the folder you do not have sufficient permissions for and hit command i

after that you will see a window pop up and towards the bottom you will see a sharing and permissions-click on that arrow and make sure your user account is set to read and write privileges. LMK if that doesn't resolve the issue and we can try some other things, best o luck
NoHomeDirectory is offline   1 Reply With Quote
Old Nov 3, 2011, 08:21 PM   #3
mainstay
macrumors 6502
 
Join Date: Feb 2011
Location: BC
1. update firmware on the device: ftp://ftp.dlink.com/Gateway/dir685/F...5_fw_200NA.zip

2. create a user inside the administration panel for your Mac and ensure you have r/w permissions (page61+ of your manual)

3. You may also need to use Mac Share Port: ftp://ftp.dlink.com/Gateway/sharepor...tility_300.zip
__________________
mainstay is offline   0 Reply With Quote
Old Nov 4, 2011, 07:55 AM   #4
Clodey
Thread Starter
macrumors member
 
Join Date: Aug 2011
Location: Wales, UK
Quote:
Originally Posted by NoHomeDirectory View Post
Select the folder you do not have sufficient permissions for and hit command i

after that you will see a window pop up and towards the bottom you will see a sharing and permissions-click on that arrow and make sure your user account is set to read and write privileges. LMK if that doesn't resolve the issue and we can try some other things, best o luck
Didn't work, here is what it says under get info:



Quote:
Originally Posted by mainstay View Post
1. update firmware on the device: ftp://ftp.dlink.com/Gateway/dir685/F...5_fw_200NA.zip

2. create a user inside the administration panel for your Mac and ensure you have r/w permissions (page61+ of your manual)

3. You may also need to use Mac Share Port: ftp://ftp.dlink.com/Gateway/sharepor...tility_300.zip
This didn't work either. My firmware is up to date, I have read and write permissions and MacShare port is for USB devices connected through the router, not the hard drive itself.
Clodey is offline   0 Reply With Quote
Old Nov 4, 2011, 10:42 AM   #5
yawns
macrumors member
 
Join Date: Oct 2011
The filesystem doesn't matter when you're accessing network storage (Windows doesn't have native support for EXT3 either). Because you're having the problem only with Finder and not mucommander from the same computer, I think you're running into this Finder bug:

http://hints.macworld.com/article.ph...00405023255445

If that's the case, the only way to fix it is to SSH into the router and edit the smb.conf file (I don't know if that's possible, incidentally). You can try to find and write to the file from Windows or through mucommander, but I doubt it's accessible that way.
__________________
I like that the email automatically says, "Sent from a MacBook Wheel." That way people know you have one.
yawns is offline   0 Reply With Quote
Old Nov 4, 2011, 12:23 PM   #6
Clodey
Thread Starter
macrumors member
 
Join Date: Aug 2011
Location: Wales, UK
Quote:
Originally Posted by yawns View Post
The filesystem doesn't matter when you're accessing network storage (Windows doesn't have native support for EXT3 either). Because you're having the problem only with Finder and not mucommander from the same computer, I think you're running into this Finder bug:

http://hints.macworld.com/article.ph...00405023255445

If that's the case, the only way to fix it is to SSH into the router and edit the smb.conf file (I don't know if that's possible, incidentally). You can try to find and write to the file from Windows or through mucommander, but I doubt it's accessible that way.
I can't see any files named smb.conf. I have no idea if it exists or if it is accessible if it does exist.
Clodey is offline   0 Reply With Quote
Old Nov 4, 2011, 12:49 PM   #7
yawns
macrumors member
 
Join Date: Oct 2011
Quote:
Originally Posted by Clodey View Post
I can't see any files named smb.conf. I have no idea if it exists or if it is accessible if it does exist.
I don't know either, sorry. Google searches aren't very fruitful. If you can't SSH into the router from the terminal (ssh admin-name@dir-685), I'm not sure what to do.

A workaround: This router apparently has ftp. So you can maybe try using Fuse to mount the storage device via FTP. (Previously I think you could do go-> connect to server-> ftp://path/to/storage in Finder, but that was dropped in Lion. Not positive, I have no FTP to test with here.)
__________________
I like that the email automatically says, "Sent from a MacBook Wheel." That way people know you have one.
yawns is offline   1 Reply With Quote
Old Nov 4, 2011, 01:07 PM   #8
yawns
macrumors member
 
Join Date: Oct 2011
This might help.

http://frankleng.me/2011/07/21/conne...on-workaround/
__________________
I like that the email automatically says, "Sent from a MacBook Wheel." That way people know you have one.
yawns is offline   0 Reply With Quote
Old Nov 6, 2011, 05:17 PM   #9
Clodey
Thread Starter
macrumors member
 
Join Date: Aug 2011
Location: Wales, UK
Quote:
Originally Posted by yawns View Post
I don't know either, sorry. Google searches aren't very fruitful. If you can't SSH into the router from the terminal (ssh admin-name@dir-685), I'm not sure what to do.

A workaround: This router apparently has ftp. So you can maybe try using Fuse to mount the storage device via FTP. (Previously I think you could do go-> connect to server-> ftp://path/to/storage in Finder, but that was dropped in Lion. Not positive, I have no FTP to test with here.)
SOLUTION FOR THOSE WITH THE SAME ROUTER/PROBLEM!

Finally. I solved this by using the FTP feature. For anyone else reading this in the future, here is what I did:
Log into your router and create a user.
Allow this user permission to the root of the storage device under FTP settings and enable FTP
Then go to https://www.dlinkddns.com/ and register.
Sign in and create a host. Copy the IP Address which shows into the 'new' IP address box and save.
Now to connect to this server go into finder and go to Go -> Connect to server..
Type in ftp://<host name here>.dlinkddns.com and log in with the user details you created on the router earlier.
Now this should allow you to view all folders and copy from.
To write to the hard drive you will need 3rd party software as explained here

I can finally allow a program to refer to a folder on the routers hard drive through FTP
Clodey is offline   0 Reply With Quote
Old Aug 24, 2013, 09:28 PM   #10
gregmax
macrumors newbie
 
Join Date: Aug 2013
One more step to take .....

Quote:
Originally Posted by NoHomeDirectory View Post
Select the folder you do not have sufficient permissions for and hit command i

after that you will see a window pop up and towards the bottom you will see a sharing and permissions-click on that arrow and make sure your user account is set to read and write privileges. LMK if that doesn't resolve the issue and we can try some other things, best o luck
==============
Now in the bottom-right corner of that Information box, you will see a lock that is, um, locked. Click on it. It will ask for your administrative password. (I assume you're the administrator of your computer.) At that point the lock will un-lock, and you may change the privileges to "Read & Write".
Done!
gregmax is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X 10.7 Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Don't have permission on folder MoodyM OS X 10.8 Mountain Lion 0 Dec 15, 2012 05:03 PM
iPad Mini: so you've gotten your mini and opened it up, what don't you like? tbk3191 iPad 45 Dec 11, 2012 06:59 PM
"X" can't be opened because you don't have permission to view it ... WTF?! eroxx iMac 1 Nov 1, 2012 11:51 PM
You don't have permission to use keychain accesss.. Squirrelflight MacBook Pro 3 Oct 28, 2012 12:36 PM
Folder permission issues jhmccullough OS X 0 Jun 14, 2012 02:48 PM

Forum Jump

All times are GMT -5. The time now is 03:34 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC