Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Nov 7, 2011, 03:42 PM   #1
Lioncrazz
macrumors member
 
Join Date: Dec 2009
iPhone 4 Won't Charge Past 4% - Anyone else ever experience this?

I just started having this issue with my iPhone 4 last night. The iPhone is about a year old. I did not realize that my iPhone was doing this until I woke up this morning. When I plug the iPhone into the charger, it responds as if it is plugged in, and then goes back and forth between "charging" and "fully charged" for a few seconds until a "Charging with this accessory" appears on the screen. Then, it does not charge it at all, acting as if nothing is plugged into it.

I am using my original charger and I have tried 3 other chargers. When the phone dies, it will recognize the charger and charge it enough for it to turn back on and go to 4% but then it dies after a few minutes again and I have to go through the waiting period for it to turn back on and charge up to 4% again. Same thing happens whether it is in the car, plugged into the wall, or the computer.

Anyone else ever experience this? Please help!
Lioncrazz is offline   0 Reply With Quote
Old Nov 7, 2011, 06:41 PM   #2
Rocko1
macrumors 68000
 
Rocko1's Avatar
 
Join Date: Nov 2011
What happens when you leave it plugged in to the computer? Same thing?

Have you done a hard reset? Hold down the home and power button for 10 seconds or so until it reboots? If that fails the battery is probably shot.
Rocko1 is offline   0 Reply With Quote
Old Nov 8, 2011, 03:42 PM   #3
hizzaah
macrumors 6502
 
Join Date: Oct 2011
You could also try plugging it in, then shutting the phone off.. See if it charges without the phone running.

If not, I'd suggest a restore. If an apple store is close, you could try popping in there to see what they say. Even if it's not under warranty, they might still replace it as this isn't a very common issue. Can't hurt to try anyways
hizzaah is offline   0 Reply With Quote
Old Nov 9, 2011, 12:25 AM   #4
scottjua
macrumors newbie
 
Join Date: May 2011
Is there any possibility the phone is liquid damaged near the dock connector?

This is the first thing the apple store will check. If so, you'll be on your own to finance a replacement @ $149 for a service part. If not and you're still in warranty you may be in luck.

That said, a restore will be the first order of business in either case, so IF you can get it backed up... do so, and try a Restore as new device on your own... NOT FROM BACKUP. Then take it in and see...

how to check for liquid damage externally:



even slightly pink will be a YES... so get a light and check it out.
scottjua is offline   0 Reply With Quote
Old May 25, 2013, 10:48 AM   #5
ganeshkumar
macrumors newbie
 
Join Date: May 2013
@lioncrazz i too have the same problem with my iphone today!!!
can u help me ?
actually what was the problem ? did u repair it?

----------

Quote:
Originally Posted by Lioncrazz View Post
I just started having this issue with my iPhone 4 last night. The iPhone is about a year old. I did not realize that my iPhone was doing this until I woke up this morning. When I plug the iPhone into the charger, it responds as if it is plugged in, and then goes back and forth between "charging" and "fully charged" for a few seconds until a "Charging with this accessory" appears on the screen. Then, it does not charge it at all, acting as if nothing is plugged into it.

I am using my original charger and I have tried 3 other chargers. When the phone dies, it will recognize the charger and charge it enough for it to turn back on and go to 4% but then it dies after a few minutes again and I have to go through the waiting period for it to turn back on and charge up to 4% again. Same thing happens whether it is in the car, plugged into the wall, or the computer.

Anyone else ever experience this? Please help!
i too have the same problem can u help me
ganeshkumar is offline   0 Reply With Quote
Old May 25, 2013, 11:24 AM   #6
Lioncrazz
Thread Starter
macrumors member
 
Join Date: Dec 2009
Best buy sent it back to refurb it. They told me that there was an issue with one of the internal components.
Lioncrazz is offline   0 Reply With Quote
Old May 27, 2013, 05:43 AM   #7
MrMacMack
macrumors 6502a
 
Join Date: Oct 2012
That's great news. And as long as they don't detect anything considered accidental you'll get a replacement. Keep us posted.
MrMacMack is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
Iphone 4 Wrong IMEI/Unlock Code - Apple sent me 2 iphones by mistake brunoecker iPhone Tips, Help and Troubleshooting 12 Dec 17, 2011 09:45 PM
iPhone 4 CHARGING stalk mount car kit ehmyerson iPhone Accessories 5 Apr 7, 2011 07:41 PM
Huge mess up! Did anyone else ever do this? chrono1081 Mac Programming 4 Jul 11, 2010 01:08 AM
iPhone 4 won't charge with car charger shanew21 iPhone 1 Jun 24, 2010 11:25 AM
Anyone else ever have this problem? pound4pound30 iPhone Tips, Help and Troubleshooting 3 Feb 26, 2010 01:47 PM


All times are GMT -5. The time now is 06:13 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC