Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 5, 2012, 06:01 AM   #1
kikinecka
macrumors newbie
 
Join Date: Jan 2012
Angry iPhone 4S - App Store,iTunes, iBooks, not working via Wi-Fi,only 3G

My new iPhone 4S (week old) can't connect to iTunes, App Store or iBooks via Wi-Fi (and some other apps e.g. Hollister but most of the other apps like Safari or ebay work fine). There is no problem with those apps loading via 3G network. When I turn off the wi-fi, it runs over 3G and i can access App store without any problem. When i turn off the 3G network and turn the Wi-Fi on, those apps like App Store won't work, other apps work fine. When i turn on both Wi-Fi and 3G, the App store (and so on) is also not working, other apps are.

I also found out that when the Wi-fi is on and I sign out my apple ID, the App store starts working! But when I log in again, it will imediatelly stop working. I've tried logging in with others apple IDs, still with the same result. There is no problem with my apple ID account, because it works on my iPad, even via Wi-Fi.

When i first set up my iPhone, there were no complications using App store ia Wi-fi with exactly the same account. I don't know if it has anything to do with it, but this problem started when i logged in with my UK account and then wanted to log back in with my Czech account.

I tried turning it off, hard reset and deleting my iPhone several time (even without back up). Nothing worked since then.

Does anyone have any idea how to fix this?

I would really appreciate ANY help. This is driving me crazy!
kikinecka is offline   0 Reply With Quote
Old Jan 5, 2012, 08:00 AM   #2
dotme
macrumors 6502a
 
Join Date: Oct 2011
Location: Iowa
I would start by eliminating the WiFi network as the cause. Go hop on someone else's WiFi (Friend, coffee house etc) and see if the problem goes away.
dotme is offline   0 Reply With Quote
Old Jan 5, 2012, 08:10 AM   #3
MTShipp
macrumors 6502
 
Join Date: Mar 2009
Location: Raleigh, North Carolina
Quote:
Originally Posted by kikinecka View Post
There is no problem with my apple ID account, because it works on my iPad, even via Wi-Fi.

...but this problem started when i logged in with my UK account and then wanted to log back in with my Czech account.
I may have missed it but did you try both the UK and Czech accounts since the initial switch?
__________________
Macbook Pro Retina 2.7/16/768 ; iPhone 6 16GB ; iPad Air 128GB silver AT&T
MTShipp is offline   0 Reply With Quote
Old Jan 5, 2012, 02:10 PM   #4
kikinecka
Thread Starter
macrumors newbie
 
Join Date: Jan 2012
Yes, I tried both of them. And neither will work via Wi-fi...In both accounts only the "featured" icon will display the app store while logged in, but when i press any app on that page, it won't open anymore. The other icons like "Top 25" or "Search" won't load.

I also forgot to add,that this problem started after i switched accounts, but also at that time I was synchronising it with iTunes.

I didn't try connecting to any network other than home yet. I'll do that soon.
kikinecka is offline   0 Reply With Quote
Old Mar 8, 2012, 10:38 AM   #5
Edge21
macrumors newbie
 
Join Date: Mar 2012
Same problem

Im from the Philippines and I am experiencing everything you just mentioned. Everything is working on wifi except for app store and itunes. When I turn off the wifi and switch to 3g, app store and itunes seems to be working perfectly. I have tried connecting thru a number of different wifi's and its app store and itunes arent having any problems. Its as if my modem or router has blocked app store's access to the internet in my home, so to speak. This has been frustrating me for days. I live alone and no one could have tweaked settings inside my modem or router. I wouldnt assume that it has something to do with multiple id accounts because my gf and i has been sharing both our accounts for about a month already and this ordeal only started 4 days ago. Sharing meaning sometimes i use hers and sometimes she uses my apple id, together wih card details of course. I tried every reset there is as well and i think it just got worse. Now when I open app store, it diesnt even show the tabs at the bottom (featured, purchased, top, etc.) I'm abit dissappointed with this new gadget as everything is working so perfectly until this. I also have done alot if research and as it turns out, alot of people are experiencing this same incident. If anyone from apple or any genius out there could help us out, we would deeply appreciate it. Thanks.
Edge21 is offline   0 Reply With Quote
Old Apr 24, 2012, 03:33 AM   #6
Qwikk
macrumors newbie
 
Join Date: Apr 2012
I'm in Canada and experiencing the same thing.. I call my ISP to try and figure it out and they said they have no idea.. It's really frustrating.. Still no fix for this?
Qwikk is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Safari, App Store, and iTunes Stopped Working on iMac -iKris- OS X 2 Jan 12, 2014 01:55 PM
'Apple Store' iOS App Update Coming Tuesday with Free iTunes Store, App Store, and iBookstore Deals MacRumors MacRumors.com News Discussion 77 Jul 31, 2013 03:48 AM
App Store not working on iPhone 5 Ren4 iPhone 68 Oct 16, 2012 04:43 PM
App store/ Ibooks JoeShades iPad Tips, Help and Troubleshooting 2 Jun 29, 2012 06:56 AM
Software Update, App Store, and iTunes Store not working laserbeam273 Mac Applications and Mac App Store 0 Jun 24, 2012 06:48 AM

Forum Jump

All times are GMT -5. The time now is 04:57 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC