Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 5 and earlier

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 6, 2012, 11:20 AM   #1
ceek
macrumors member
 
Join Date: May 2008
Location: NY
Question iCloud is ON but contacts from devices still won't sync

I have iCloud on and signed in on my iPhone, iPad, and MacBook Pro (all updated, running Lion and iOS 5).

Not only are my devices not sharing contacts, but iCloud (web) is not showing new contacts added from any device.

#frustrated

Thanks for any advice.

ceek
ceek is offline   0 Reply With Quote
Old Jan 6, 2012, 12:45 PM   #2
ceek
Thread Starter
macrumors member
 
Join Date: May 2008
Location: NY
Update

Just keeping any would-be helpers posted on progress:

I created 2 contacts, each respectively entered on the device as noted in order to track them: CONTACT - "Created on iPhone," and, "Created on Mac."

Suddenly I see both listed on my Contacts on MacBook Pro, but iCloud and iPhone only show "Created on iPhone."

So confused.

ceek
ceek is offline   0 Reply With Quote
Old Jan 6, 2012, 01:01 PM   #3
FSMBP
macrumors 68020
 
FSMBP's Avatar
 
Join Date: Jan 2009
Go to your iPhone. Then go to the CONTACTS app. Next, while viewing the list of contacts, click the upper left hand corner button called GROUPS. Then select either ALL CONTACTS or ALL ICOULD (also, click the upper left hand corner button to resync the list).

Personally, I never show use the ALL ON MY IPHONE because it won't store it on the cloud. Just use ALL ICOULD view for your contacts, so that whatever is on your iCloud is on all your devices.
__________________
Still don't get why I can't save a Word File from an email on my iPhone without some third-party app.
FSMBP is offline   0 Reply With Quote
Old Jan 6, 2012, 04:31 PM   #4
ceek
Thread Starter
macrumors member
 
Join Date: May 2008
Location: NY
Thank you for the easy to follow tip: my only problem (and may be THE problem) is I don't see a "All iCloud" option listed. View here:

http://www.christopherhopper.com/wp-...e-Contacts.png

Thanks!

ceek
ceek is offline   0 Reply With Quote
Old Jan 7, 2012, 09:40 AM   #5
FSMBP
macrumors 68020
 
FSMBP's Avatar
 
Join Date: Jan 2009
Quote:
Originally Posted by ceek View Post
Thank you for the easy to follow tip: my only problem (and may be THE problem) is I don't see a "All iCloud" option listed. View here:

http://www.christopherhopper.com/wp-...e-Contacts.png

Thanks!

ceek
Sorry, I dunno why it wouldn't be there. I'm assuming your phone is jailbroken - maybe that could be an issue with some tweaks that you're using?
__________________
Still don't get why I can't save a Word File from an email on my iPhone without some third-party app.
FSMBP is offline   0 Reply With Quote
Old Jan 7, 2012, 08:04 PM   #6
Hamiltonian
macrumors member
 
Join Date: Sep 2008
Go Settings>Mail, contacts, calendars
Scroll down to the contacts section and makes sure the default is set to iCloud
Hamiltonian is offline   0 Reply With Quote
Old Jun 2, 2012, 08:10 PM   #7
whsbuss
macrumors 68000
 
Join Date: May 2010
Location: SE Penna.
Quote:
Originally Posted by Hamiltonian View Post
Go Settings>Mail, contacts, calendars
Scroll down to the contacts section and makes sure the default is set to iCloud
I don't have that option under Contacts. When I update a contact on my Mac, it gets sent to iCloud (verified on iCloud.com) but it never gets pushed to my iPhone. However if I make an update on the iPhone it shows in my Mac's address book.
whsbuss is offline   0 Reply With Quote
Old Jun 3, 2012, 04:32 PM   #8
Arelunde
macrumors Demi-God
 
Arelunde's Avatar
 
Join Date: Jul 2011
Location: CA Central Coast
If you have iCloud contacts activated on all your iDevices, on the iPad and iPhone, you have to open contacts and hit the circle arrow on the screen to sync. It doesn't do it otherwise. Took me forever to figure that out.
__________________
Always learning...
Arelunde is offline   1 Reply With Quote
Old Jun 4, 2012, 08:50 AM   #9
CosmoPilot
macrumors 65816
 
CosmoPilot's Avatar
 
Join Date: Nov 2010
Location: South Carolina
Wirelessly posted

Since you know your Mac pushes updates to the cloud, I recommend the following.

1. Settings > iCloud. Turn off iCloud contacts on your iPhone.
2. If prompted, delete all contacts from your iPhone (do not select the option to keep them on your phone, or it will create a non-iCloud group).
3. If your contacts are not deleted on the iPhone, manually do so now. Ensure you have zero contacts/groups. Completely remove anything in contacts on your iPhone. (**NOTE** ensure you did step #1. By turning off iCloud deleting your iPhone contacts will not affect the contacts in the Cloud).
4. Log onto iCloud.com from your Mac. Make sure your contacts are still there.
5. On iPhone, Settings > iCloud turn contacts back on. If prompted, select "Merge Contacts" from the cloud to your phone.

This should now sync everything up.

If the thought of deleting all your contacts is unnerving, perform a time machine backup of your Mac before doing any of the above steps so you'll have piece of mind.
__________________
2011 27" 2.7GHz iMac 2012 2.5GHz 13" MBP iPhone 6 / iPhone 5S / iPhone 5 iPad Air AppleTV / AEBS 802.11ac
CosmoPilot is offline   2 Reply With Quote
Old Jun 4, 2012, 11:41 AM   #10
whsbuss
macrumors 68000
 
Join Date: May 2010
Location: SE Penna.
Quote:
Originally Posted by Arelunde View Post
If you have iCloud contacts activated on all your iDevices, on the iPad and iPhone, you have to open contacts and hit the circle arrow on the screen to sync. It doesn't do it otherwise. Took me forever to figure that out.
I do have iCloud contacts activated on my iPhone (and Mac). Where do I find the circle arrow? I don't have it in the Contacts app.

----------

Quote:
Originally Posted by CosmoPilot View Post
Wirelessly posted

Since you know your Mac pushes updates to the cloud, I recommend the following.

1. Settings > iCloud. Turn off iCloud contacts on your iPhone.
2. If prompted, delete all contacts from your iPhone (do not select the option to keep them on your phone, or it will create a non-iCloud group).
3. If your contacts are not deleted on the iPhone, manually do so now. Ensure you have zero contacts/groups. Completely remove anything in contacts on your iPhone. (**NOTE** ensure you did step #1. By turning off iCloud deleting your iPhone contacts will not affect the contacts in the Cloud).
4. Log onto iCloud.com from your Mac. Make sure your contacts are still there.
5. On iPhone, Settings > iCloud turn contacts back on. If prompted, select "Merge Contacts" from the cloud to your phone.

This should now sync everything up.

If the thought of deleting all your contacts is unnerving, perform a time machine backup of your Mac before doing any of the above steps so you'll have piece of mind.
Thanks for the tips. However rather than do all this on my iPhone, I just edit one of the contacts and it syncs all of my changes. You would think changes should be pushed just like iCloud mail and calendar.

----------

AH the circle icon under Groups.... got it!
whsbuss is offline   0 Reply With Quote
Old Jun 4, 2012, 02:43 PM   #11
CosmoPilot
macrumors 65816
 
CosmoPilot's Avatar
 
Join Date: Nov 2010
Location: South Carolina
Quote:
Originally Posted by whsbuss View Post

Thanks for the tips. However rather than do all this on my iPhone, I just edit one of the contacts and it syncs all of my changes. You would think changes should be pushed just like iCloud mail and calendar.

----------

AH the circle icon under Groups.... got it!
What groups do you have? This is what's causing your problems. You need to flush your group tied with th iPhone and force it to use iCloud. When you do that, everything will be automatic as you are wanting. However, you have to flush your contacts on the iPhone first to start with a clean slate. This is done by following my post above.
CosmoPilot is offline   0 Reply With Quote
Old Sep 24, 2012, 06:53 AM   #12
rogadodga
macrumors newbie
 
Join Date: Nov 2010
Location: United Kingdom
Send a message via Skype™ to rogadodga
Contact syncing issues

I have having the problem that al my contacts where on my phone, but not assigned to an account, not mac, not on iCloud. I had to search for a contact using the home right swipe search feature before I found my contact.

Problem was quickly solved by the 3rd party app, "my contacts backup".
It found all the contacts on my phone, and then emailed them as a vCard to my email account. I then opened it on my mac, and it synced every contact to my mac address book and my iCloud.

Fantastic app and will solve the majority of syncing problems people are having.
rogadodga is offline   0 Reply With Quote
Old Mar 29, 2013, 05:52 AM   #13
MixiMera
macrumors newbie
 
Join Date: Jan 2006
Excellent, this worked also for my Mac

Quote:
Originally Posted by CosmoPilot View Post
Wirelessly posted

Since you know your Mac pushes updates to the cloud, I recommend the following.

1. Settings > iCloud. Turn off iCloud contacts on your iPhone.
2. If prompted, delete all contacts from your iPhone (do not select the option to keep them on your phone, or it will create a non-iCloud group).
3. If your contacts are not deleted on the iPhone, manually do so now. Ensure you have zero contacts/groups. Completely remove anything in contacts on your iPhone. (**NOTE** ensure you did step #1. By turning off iCloud deleting your iPhone contacts will not affect the contacts in the Cloud).
4. Log onto iCloud.com from your Mac. Make sure your contacts are still there.
5. On iPhone, Settings > iCloud turn contacts back on. If prompted, select "Merge Contacts" from the cloud to your phone.

This should now sync everything up.

If the thought of deleting all your contacts is unnerving, perform a time machine backup of your Mac before doing any of the above steps so you'll have piece of mind.
I did this corresponding actions for my MacBook Pro and now my addresses are coming back into synch mode. It seems like that my updates in the Contacts of the Mac might have bee lost, but that was expected.
I did a BackUp of Contacts if somehow they would be needed.
/Claes "miximera" "MacCollector"
MixiMera is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 5 and earlier

Tags
contacts, ios 5, lion, syncing

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Mavericks: iTunes won't sync Contacts & Calendar from iOS Devices YahonMaizosz OS X Mavericks (10.9) 3 Oct 25, 2013 11:18 AM
Contacts made on iOS 7 not synced to (older) iCloud connected devices Galatian iOS 7 1 Sep 13, 2013 08:25 AM
Gmail contacts sync and Icloud contacts backup wannabelean iOS 6 4 May 17, 2013 03:19 AM
iCloud and Notes/Contacts won't sync trlyka iPhone Tips, Help and Troubleshooting 1 Dec 4, 2012 08:07 AM
Contacts on MBP won't sync to iCloud skaupert iCloud and Apple Services 2 Oct 13, 2012 06:05 AM

Forum Jump

All times are GMT -5. The time now is 09:15 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC