Go Back   MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 13, 2012, 09:56 PM   #1
Yardley
macrumors newbie
 
Join Date: Oct 2010
Excel File Reservation Read Only Problem

Hi all, I'm getting a prompt when trying to open some Excel files on my local hard drive that says "File Reservation, file name is being modified by another user. Open as read-only, or choose notify to be alerted when it is available." See image below.



The folder where the files reside is being shared with another computer. I have tried restarting both computers and also leaving the other computer off, but the message still comes up. I made sure I have read/write permissions and also tried repairing permissions with disk utility but that didn't work. I also tried making a copy of the file, and the copy had the same issues.

Any suggestions? Thanks in advance!
Yardley is offline   0 Reply With Quote
Old Jan 13, 2012, 10:10 PM   #2
Papanate
macrumors regular
 
Join Date: Jul 2011
Location: North Carolina
Did you open as read only and then save it under a different name?

Also try to save it as a earlier excel format.
Papanate is offline   0 Reply With Quote
Old Jan 13, 2012, 10:49 PM   #3
Yardley
Thread Starter
macrumors newbie
 
Join Date: Oct 2010
Quote:
Originally Posted by Papanate View Post
Did you open as read only and then save it under a different name?

Also try to save it as a earlier excel format.

No, I'll have to try that. If that works what then? Is there something I can do to fix all of the files with this problem or would I have to save each one with a new name? Thanks
Yardley is offline   0 Reply With Quote
Old Jan 14, 2012, 04:35 PM   #4
Papanate
macrumors regular
 
Join Date: Jul 2011
Location: North Carolina
Quote:
Originally Posted by Yardley View Post
No, I'll have to try that. If that works what then? Is there something I can do to fix all of the files with this problem or would I have to save each one with a new name? Thanks

Each file unless you do the following;

By any chance did you us "command I' (for Info)on the folder that holds the file(s) and insure you have read/write priviledges? And then did you click the drop down file under the little 'wheel' at the bottom and choose "Apply To Enclosed Items'? Then click Apply.

BTW You can only execute the commands when you have 'Administrator Rights'.
Otherwise they won't take.
Papanate is offline   0 Reply With Quote
Old Apr 12, 2012, 05:22 PM   #5
1foolish1
macrumors newbie
 
Join Date: Apr 2012
Location: Las Vegas, NV
@Yardley
I found that using a / in the file name results in the file being saved as read-only. I saved a file titled A/C Filters.xlxs which saved as read-only. This issue lead me to this forum. After I removed the / from A/C Filters (AC Filters.xlxs) the file saved as a working workbook.

I noticed from your screen shot that you included a / in your file name. Try omitting the /.
1foolish1 is offline   2 Reply With Quote
Old Jun 1, 2012, 11:20 PM   #6
mrtrsharp
macrumors newbie
 
Join Date: Jun 2012
You are exactly right! the "/" sign is the culprit

Thank you so much for that posting - I had the exact same problem as the original poster, and copying or saving as new name, etc. wasn't working. It is the "/" in my title, and as soon as I took that away, it opens up perfectly normal. I'd be curious to know why this glitch occurs?

But Thanks for solving an annoyance. I just wouldn't have ever thought it was in my name, and was looking all around for permissions and multiple users, etc. So Simple....
mrtrsharp is offline   1 Reply With Quote
Old Jun 26, 2012, 11:10 AM   #7
7gav2
macrumors newbie
 
Join Date: Jun 2012
Location: NJ
Wow, wish I had know this for the past 2 years! What a simple solution; and I might add that dashes in the title of a doc also creates the same 'read-only' problem. Thanks for posting.[COLOR="#808080"]
7gav2 is offline   0 Reply With Quote
Old Jan 5, 2013, 09:55 AM   #8
Iviking2
macrumors newbie
 
Join Date: Feb 2009
solution not correct

I think this solution must be an accident.
I've had this problem with a few files which now cannot be accessed from another machine because it thinks someone else is currently modifying it. I've removed all non alphabet characters (/ - _ ) and the problem remains. 10.6.8 machine trying to access a .xls file stored on a 10.8.2 iMac.
I've checked permissions are ok.
Only workround is to save as a new file on the client machine, but as it's a file a number of us work on it's not a viable solution.
Iviking2 is offline   0 Reply With Quote
Old Jan 24, 2013, 08:54 PM   #9
zgoalieman
macrumors newbie
 
Join Date: Jan 2013
Excel File Reservation Read Only Problem

If you open Terminal and go to the folder where the file is located, enter "ls -la" and you'll see that there is a file with the same filename preceded by a tilda and dollar sign"~$". Delete that file and your problem is solved.

Use the following: rm "~\$filename" to delete the file.
zgoalieman is offline   1 Reply With Quote
Old Apr 4, 2013, 11:20 AM   #10
WayneH1
macrumors member
 
Join Date: Apr 2010
Brilliant!! I looked everywhere for the solution to this and this is the only definitive cure I've found. Some have had success with renaming files to eliminate slashes, but my files have simple names to begin with.

Background: After Migration Assistant moved all my files onto my shiny new Macbook Pro, I got the read-only warning dialog when trying to open most (but not all) of my Excel 2011 .xlsx files.

In Finder's Get Info panel, I tried everything but I was already listed as having Read-Write access. Changing the extension from .xlsx to .xls allowed the file to open normally and was a quick, imperfect fix. Strange, but that isolated the problem to Excel itself. Trashing Excel preferences .plist did not make a difference.

In Excel, there was no indication that a password or read-only restriction had been applied or could be changed. The exception was at File:Properties:General, where the Read-only box was ticked but greyed out so it could not be changed.

I was flummoxed until I found the post above. Using Terminal to list and then delete the "~" files solved the problem completely. I suppose making hidden files visible would allow the bogus files to be trashed from the Finder, but I haven't tried that.
WayneH1 is offline   0 Reply With Quote
Old Apr 5, 2013, 12:26 PM   #11
WayneH1
macrumors member
 
Join Date: Apr 2010
I just discovered another very easy fix that doesn't require Terminal:

1. Move the files you want to keep, including the Excel files you cannot open, into a new folder.

2. This leaves the "~" files behind and thereby allows the spreadsheet to open normally in their new location. Check to confirm that your Excel files now open normally.

3. Delete the old, apparently empty folder containing the hidden "~" files.
WayneH1 is offline   0 Reply With Quote
Old Feb 17, 2014, 10:58 AM   #12
sgasch01
macrumors newbie
 
Join Date: Feb 2014
Excel File Reservation Read Only Problem

Thanks for the solution to find and remove the files with ~ in front. I have faced this problem for a while, but never looked it up on the net.

Shirley Gasch
sgasch01 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Applications > Mac Applications and Mac App Store

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
A Curious Excel 2008 file Problem.. Cairbreo Mac Applications and Mac App Store 7 Mar 6, 2013 04:32 AM
Old Excel file pachou Mac Basics and Help 2 Dec 18, 2012 10:25 AM
Excel file from dropbox jackiewal Mac Basics and Help 1 Dec 15, 2012 02:33 PM
Excel file saving in iCloud schnarkle iCloud and Apple Services 2 Nov 28, 2012 12:26 PM
Excel 2011 files from network drives open in read-only mode chipperd Mac Basics and Help 0 Oct 28, 2012 01:56 PM

Forum Jump

All times are GMT -5. The time now is 06:02 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC