Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Jan 25, 2012, 04:31 AM   #1
Texxy
macrumors regular
 
Join Date: Aug 2011
BMW Bluetooth/iDrive system not working well with iPhone 4s CHIME IN iDrive OWNERS!

So I set up my bluetooth in my BMW with iDrive. My friend also has basically the same car.

In his car when his iphone is connected it shows all the recieved calls/missed calls and when you search for a name it pops/sorts out between all contacts by the letters you select on screen.

BUT in my car with my iphone none of the above happens. I try to search for names and when I press a letter to narrow a search for a contact nothing changes on screen. No recieved calls or missed calls either.

I was curious if it was the car or the phone so I took my fathers iphone (same as mine iPhone 4s with same update) and it worked PERFECTLY! Any ideas what could be wrong?

I am sure many of you will be like "your phone is the problem" and the only reason I doubt my phone is the problem is because I LITERALLY replaced it last week for a new one.
Texxy is offline   0 Reply With Quote
Old Jan 25, 2012, 04:36 AM   #2
mulo
macrumors 68020
 
mulo's Avatar
 
Join Date: Aug 2010
Location: Behind you
Send a message via MSN to mulo
I think your phone is the problem, both my dads 4s and my 4 work flawlessly in his 2011 520d
__________________
iPhone 5 Black 64GB.
17" MBP 2.2GHz i7, 16GB RAM.
Canon 7D + grip, 24-70mm f/2.8L USM, 70-200mm f/2.8L IS USM.
mulo is offline   0 Reply With Quote
Old Jan 25, 2012, 04:39 AM   #3
Texxy
Thread Starter
macrumors regular
 
Join Date: Aug 2011
Quote:
Originally Posted by mulo View Post
I think your phone is the problem, both my dads 4s and my 4 work flawlessly in his 2011 520d
Tell me this, when you look on your contacts list, are your contacts just through iCloud or also syncd through your computer? I know a very random question but that is literally the only difference I could think of between my phone and my fathers.
Texxy is offline   0 Reply With Quote
Old Jan 25, 2012, 06:46 AM   #4
mulo
macrumors 68020
 
mulo's Avatar
 
Join Date: Aug 2010
Location: Behind you
Send a message via MSN to mulo
Quote:
Originally Posted by Texxy View Post
Tell me this, when you look on your contacts list, are your contacts just through iCloud or also syncd through your computer? I know a very random question but that is literally the only difference I could think of between my phone and my fathers.
mine are synched through iCloud only, his through his computer and microsoft exchange
__________________
iPhone 5 Black 64GB.
17" MBP 2.2GHz i7, 16GB RAM.
Canon 7D + grip, 24-70mm f/2.8L USM, 70-200mm f/2.8L IS USM.
mulo is offline   0 Reply With Quote
Old Jan 25, 2012, 04:38 PM   #5
Texxy
Thread Starter
macrumors regular
 
Join Date: Aug 2011
Quote:
Originally Posted by mulo View Post
mine are synched through iCloud only, his through his computer and microsoft exchange
Hmm...I have no idea then honestly. I have restarted my phone many times, disconnected bluetooth and whatnot.

Some people were saying it could be because my contacts are syncd through iCloud but apparently not the case since you are syncd that way.

Also people saying gmail accounts are through Microsoft xchange set to PUSH and I was like...HOW DOES THAT HAVE ANYTHING TO DO WITH THIS?

Texxy is offline   0 Reply With Quote
Old Jan 26, 2012, 03:08 PM   #6
Texxy
Thread Starter
macrumors regular
 
Join Date: Aug 2011
Anyone else?
Texxy is offline   0 Reply With Quote
Old Jan 26, 2012, 03:12 PM   #7
theman510
macrumors 6502
 
Join Date: May 2009
I have an '07 328xi with idrive and i have no trouble with my contacts, etc showing up on the navigation screen. It's worked fine for my 3GS, iphone 4, and now my 4S
theman510 is offline   0 Reply With Quote
Old Jan 28, 2012, 11:44 PM   #8
Texxy
Thread Starter
macrumors regular
 
Join Date: Aug 2011
Quote:
Originally Posted by theman510 View Post
I have an '07 328xi with idrive and i have no trouble with my contacts, etc showing up on the navigation screen. It's worked fine for my 3GS, iphone 4, and now my 4S
Great for you but obviously there is some problem with my phone. My fathers and my friends iPhone 4s same specs except there's are 16GB work perfectly. Only difference of our phones is that I have a 32GB. ANYONE ELSE?!Please chime in!
Texxy is offline   0 Reply With Quote
Old Jan 29, 2012, 06:17 AM   #9
Namji
macrumors 6502a
 
Join Date: Aug 2010
2010 535i and all my contacts, missed call syncs and works fine.
Either your phone or your car is defective. Btw new products can be defective, since your fathers phone worked fine and yours didn't that should narrow down the reasons it is not working .....
__________________
2013 iPhone 5S Space Gray on VZW - 64GB
2010 15" Macbook Pro, 2.4GHz, Intel Core i5, 4GB Memory, 320GB hard drive.
2012 Apple TV. 2012 iPad Mini Silver 32GB. 2010 iPhone 4 Black on VZW - 32GB
Namji is offline   0 Reply With Quote
Old Jan 30, 2012, 02:05 PM   #10
Texxy
Thread Starter
macrumors regular
 
Join Date: Aug 2011
Quote:
Originally Posted by Namji View Post
2010 535i and all my contacts, missed call syncs and works fine.
Either your phone or your car is defective. Btw new products can be defective, since your fathers phone worked fine and yours didn't that should narrow down the reasons it is not working .....
Well I am 100% sure it is something with my settings/phone. I got another replacement from Apple and still same problem. It is not the car because the car works perfect with other iPhone 4s' I am sure I know what I am talking about. Any other thoughts?
Texxy is offline   0 Reply With Quote
Old Jan 31, 2012, 02:44 PM   #11
Texxy
Thread Starter
macrumors regular
 
Join Date: Aug 2011
FINALLY FIGURED IT OUT! Alright so the iPhone 4s brought along STANDARD emoji option unlike before in 4 and below you would download an emoji app. So since it was standard I started using some emojis on my contacts which I guess BMW search could not recognize.

Once I took off all the emojis in my contacts it worked PERFECTLY! Just stating my solution for the next person who needs help with this problem! My fathers phone had no Emojis on contacts so that is why his worked.

But since I replaced my old phone, now the problem with this new phone is the BATTERY SUCKS!
Texxy is offline   1 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Late 2009 iMac SSD Options for DIY IDrive? Qwerty11 iMac 3 Nov 10, 2013 04:36 PM
BMW iDrive adds Siri and S Voice support to 2014 cars AutoUnion39 Alternatives to iOS and iOS Devices 1 Jun 7, 2013 10:12 PM
Pair iPhone 5 with 2006 BMW 325 iDrive MacLovin78 iPhone 4 Jan 2, 2013 07:27 PM
iPod Out in BMW iDrive dlbmacfan iPod touch 0 Sep 17, 2012 03:44 PM
Weird USB behaviour using CD's ripped from iTunes when played on BMW iDrive (2012) snerkler Mac Applications and Mac App Store 0 Jul 27, 2012 11:13 AM

Forum Jump

All times are GMT -5. The time now is 10:36 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC