Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 16, 2012, 02:15 PM   #1
gmanist1000
macrumors 68020
 
gmanist1000's Avatar
 
Join Date: Sep 2009
Incoming iMessages not going to iPhone

Hey all,

I have three devices setup using iMessages with my associated email address. My Mac, iPad and iPhone.

Everything works properly when sending messages, the conversations stay in sync across all devices, but when I receive messages they only go to my Mac and iPad, not my iPhone.

I tried deleting my iMessage email from my iPhone then reattaching it, but that didn't solve the problem.

Any suggestions, or anyone else having this issue?
gmanist1000 is offline   0 Reply With Quote
Old Feb 16, 2012, 02:21 PM   #2
boy-better-know
macrumors 65816
 
boy-better-know's Avatar
 
Join Date: Jun 2010
Location: England
My girlfriend just developed this issue today, however, she doesn't have an iPad or mac so now she isn't receiving any iMessages, this developed today. Any help?
My iPhone, iPad and Mac are working fine though
boy-better-know is offline   0 Reply With Quote
Old Feb 16, 2012, 04:16 PM   #3
gmanist1000
Thread Starter
macrumors 68020
 
gmanist1000's Avatar
 
Join Date: Sep 2009
I solved my problem, if anyone else has this problem try this method.

Settings > Messages > Receive at > Caller ID > (Chose your email, not your Phone Number)

I now receive on all the correct devices!
gmanist1000 is offline   0 Reply With Quote
Old Feb 16, 2012, 04:29 PM   #4
cbrad82
macrumors newbie
 
Join Date: Jan 2012
Good 2 know!!!!
__________________
21.5" IMac, AT&T iPhone 3G,AT&T IPhone 4, Verizon Iphone 5, IPad & Ipad2
cbrad82 is offline   0 Reply With Quote
Old Feb 17, 2012, 08:07 AM   #5
kicko
macrumors 65816
 
Join Date: Aug 2008
a few weeks ago on my wife's phone it would only pick imessage using her email. I checked the settings and it said some error under her apple ID. I logged her back in and it was fine but it took a while for it to identify with the phone number & email. This was with an iphone and ipad. Currently it will pick up the phone number & email for imessage without issue. I think it was some odd bug because it was fine since last october and only noticed it resently.
kicko is offline   0 Reply With Quote
Old Feb 17, 2012, 08:31 AM   #6
Diode
macrumors 68020
 
Diode's Avatar
 
Join Date: Apr 2004
Location: Washington DC
Send a message via AIM to Diode
I've noticed that if you take the sim out you have to reactivate iMessage sometimes by sliding it off and back on.
__________________
16GB iPhone 4; 2.4 GHZ C2D iMac 4GB Ram; 32GB iPad2; AppleTV2
Diode is offline   0 Reply With Quote
Old Feb 17, 2012, 08:44 AM   #7
Fynd
macrumors regular
 
Join Date: Aug 2010
Quote:
Originally Posted by gmanist1000 View Post
I solved my problem, if anyone else has this problem try this method.

Settings > Messages > Receive at > Caller ID > (Chose your email, not your Phone Number)

I now receive on all the correct devices!
This would be it. Wish it would default to that. Annoying, really. I was having this issue as well, but everything is good now and incoming messages go to all my devices like they should.
__________________
2012 27" iMac (i7, 680MX, Fusion)
16GB Black & Slate iPhone 5
16GB LTE Black & Slate iPad Mini
Apple TV 3
Fynd is offline   0 Reply With Quote
Old Feb 17, 2012, 08:52 AM   #8
Ratatapa
macrumors 6502a
 
Join Date: Apr 2011
Quote:
Originally Posted by Fynd View Post
This would be it. Wish it would default to that. Annoying, really. I was having this issue as well, but everything is good now and incoming messages go to all my devices like they should.
I did that part but when i send a text from example my iMac to my iPhone

The messages icon has a 1 for half a sec then disappear and does no sound, then the 1 auto disappear, so if i don't check my phone i can miss messages.

While if i send from my phone to my mac i get a pop up until i click it
Ratatapa is offline   0 Reply With Quote
Old Feb 17, 2012, 08:56 AM   #9
nfl46
macrumors 601
 
nfl46's Avatar
 
Join Date: Oct 2008
Quote:
Originally Posted by gmanist1000 View Post
I solved my problem, if anyone else has this problem try this method.

Settings > Messages > Receive at > Caller ID > (Chose your email, not your Phone Number)

I now receive on all the correct devices!
This works.
__________________
| 16GB Apple iPhone 5 | 13" Macbook Pro | Apple TV 2 | 16GB Nexus 5 |
nfl46 is offline   0 Reply With Quote
Old Feb 17, 2012, 12:03 PM   #10
gmanist1000
Thread Starter
macrumors 68020
 
gmanist1000's Avatar
 
Join Date: Sep 2009
Quote:
Originally Posted by Ratatapa View Post
I did that part but when i send a text from example my iMac to my iPhone

The messages icon has a 1 for half a sec then disappear and does no sound, then the 1 auto disappear, so if i don't check my phone i can miss messages.

While if i send from my phone to my mac i get a pop up until i click it
This happens to me as well, but only if I have Messages on the Mac currently selected. It seems it knows you checked the message, so it just disappears from my iPad and iPhone automatically.
gmanist1000 is offline   0 Reply With Quote
Old Feb 17, 2012, 02:20 PM   #11
SAD*FACED*CLOWN
macrumors 65816
 
SAD*FACED*CLOWN's Avatar
 
Join Date: Apr 2010
Location: Houston, TX
Quote:
Originally Posted by gmanist1000 View Post
I solved my problem, if anyone else has this problem try this method.

Settings > Messages > Receive at > Caller ID > (Chose your email, not your Phone Number)

I now receive on all the correct devices!
but is it possible to recieve at both? so it can be sent as SMS?
__________________
"people like to feed pigeons, but try to shoot eagles"
SAD*FACED*CLOWN is offline   0 Reply With Quote
Old Feb 17, 2012, 02:49 PM   #12
newyorksole
macrumors 68000
 
Join Date: Apr 2008
Location: LongIsland/NYC
yeah I put Messages on my Mac, but I don't get messages to my iPhone AND Mac unless I initiated the convo on the Mac first.
__________________
iPhone 5S 32GB Gold.
iMac 21.5" Mid-2010 1TB/8GB/i5.
newyorksole is offline   0 Reply With Quote
Old Feb 17, 2012, 03:24 PM   #13
gmanist1000
Thread Starter
macrumors 68020
 
gmanist1000's Avatar
 
Join Date: Sep 2009
Quote:
Originally Posted by SAD*FACED*CLOWN View Post
but is it possible to recieve at both? so it can be sent as SMS?
It should send as an SMS if it's to a non-iPhone, so no worries there.
gmanist1000 is offline   0 Reply With Quote
Old Feb 17, 2012, 04:15 PM   #14
Ratatapa
macrumors 6502a
 
Join Date: Apr 2011
Quote:
Originally Posted by gmanist1000 View Post
This happens to me as well, but only if I have Messages on the Mac currently selected. It seems it knows you checked the message, so it just disappears from my iPad and iPhone automatically.
So your saying i need to send a message and ASAP close it so my iPhone can show me it's on?
Ratatapa is offline   0 Reply With Quote
Old Feb 17, 2012, 04:28 PM   #15
newyorksole
macrumors 68000
 
Join Date: Apr 2008
Location: LongIsland/NYC
Quote:
Originally Posted by Fynd View Post
This would be it. Wish it would default to that. Annoying, really. I was having this issue as well, but everything is good now and incoming messages go to all my devices like they should.
Are people sending iMessages to your email address or phone number?
__________________
iPhone 5S 32GB Gold.
iMac 21.5" Mid-2010 1TB/8GB/i5.
newyorksole is offline   0 Reply With Quote
Old Feb 18, 2012, 08:27 AM   #16
ajobes
macrumors newbie
 
Join Date: Aug 2009
Similar problem

So I went into the iPhone and changed the caller ID from phone number to email address.. I use the same email address on the mac software and it all works pretty well: If I send a message from mac I see that sent if I check on the iPhone and vice-versa....

HOWEVER...

If I switch user on the mac it doesn't receive any messages nor does it download them once switched back. I changed all the settings in the iMessage mac app (to not log out, not change status etc.) and nothing seems to work - if I'm not the active user I never get any messages sent by me or received on my iPhone to the email address.

Is everyone else the same?
ajobes is offline   0 Reply With Quote
Old Feb 19, 2012, 08:15 PM   #17
gmanist1000
Thread Starter
macrumors 68020
 
gmanist1000's Avatar
 
Join Date: Sep 2009
Quote:
Originally Posted by ajobes View Post
So I went into the iPhone and changed the caller ID from phone number to email address.. I use the same email address on the mac software and it all works pretty well: If I send a message from mac I see that sent if I check on the iPhone and vice-versa....

HOWEVER...

If I switch user on the mac it doesn't receive any messages nor does it download them once switched back. I changed all the settings in the iMessage mac app (to not log out, not change status etc.) and nothing seems to work - if I'm not the active user I never get any messages sent by me or received on my iPhone to the email address.

Is everyone else the same?
This is glitched for me too. The messages download after like 5 minutes of waiting, and then they aren't even in the correct order. It is a beta, so I don't expect it to be perfect.
gmanist1000 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Save iMessages from iPhone jason.siegel iPhone Tips, Help and Troubleshooting 2 Feb 13, 2014 04:00 PM
iMessages without an iPhone? kat.hayes Alternatives to iOS and iOS Devices 10 Jun 25, 2013 01:48 PM
Incoming imessages showing up on iPad but not MacBook Pro Firefly06 iPhone Tips, Help and Troubleshooting 0 Nov 3, 2012 07:59 PM
Mac Reading out all my incoming imessages. mattpreston11 OS X 10.8 Mountain Lion 2 Oct 22, 2012 05:37 AM
iPhone 5 and iMessages Stefan Hitzke iPhone 1 Sep 24, 2012 03:58 AM

Forum Jump

All times are GMT -5. The time now is 05:08 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC