Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 5 and earlier

Reply
 
Thread Tools Search this Thread Display Modes
Old Feb 20, 2012, 01:16 PM   #1
lewys
macrumors 6502
 
Join Date: Jun 2010
Location: London
iMessage won't verify my phone number

A few days ago i restored through iTunes using a back up and ever since iMessage will only work with my email and not my number as it says it can't verify it.

i have tried numerous clean installs and trying to install the previous backup again even wiped it through the remote wipe in iCloud (don't ask me why i thought to try this but nothing else was working so i thought i may as well try) but nothing works. I have even been on the phone to apple for over two hours today and they didn't have a clue.

Does anyone have any idea what i could do to fix this? its an iPhone 4s on the latest firmware.
__________________
iMac 21.5 inch 2.5 Ghz i5
Black iPhone 4 16GB
iPad 64GB WIFI/3G
lewys is offline   0 Reply With Quote
Old Feb 20, 2012, 01:45 PM   #2
misterjrw
macrumors member
 
Join Date: Jul 2010
Check to see if your timezone is set to automatic or not. My wife had this issue the other day, and after scouring the web, finally got it to work by toggling the 'set automatically' toggle within 'date & time' in settings, general.

Verified a few mins after doing that.

Hope this helps
misterjrw is offline   0 Reply With Quote
Old Feb 20, 2012, 02:01 PM   #3
lewys
Thread Starter
macrumors 6502
 
Join Date: Jun 2010
Location: London
it didn't work but i tried to restore from backup again and now it doesn't say it needs to be verified it says my phone number but its all grey. is it supposed to be like that?

it still won't let me send as i message though
__________________
iMac 21.5 inch 2.5 Ghz i5
Black iPhone 4 16GB
iPad 64GB WIFI/3G
lewys is offline   0 Reply With Quote
Old Mar 17, 2012, 10:20 PM   #4
violetgoose
macrumors member
 
Join Date: Mar 2011
Location: Texas
Quote:
Originally Posted by lewys View Post
A few days ago i restored through iTunes using a back up and ever since iMessage will only work with my email and not my number as it says it can't verify it.

i have tried numerous clean installs and trying to install the previous backup again even wiped it through the remote wipe in iCloud (don't ask me why i thought to try this but nothing else was working so i thought i may as well try) but nothing works. I have even been on the phone to apple for over two hours today and they didn't have a clue.

Does anyone have any idea what i could do to fix this? its an iPhone 4s on the latest firmware.
BUMP! I am having the same issue. And I even tried to set the date and time and that is set to automatic too.

----------

Quote:
Originally Posted by misterjrw View Post
Check to see if your timezone is set to automatic or not. My wife had this issue the other day, and after scouring the web, finally got it to work by toggling the 'set automatically' toggle within 'date & time' in settings, general.

Verified a few mins after doing that.

Hope this helps
I did that as well... Isn't working. So frustrating, I guess I don't need Imessage then lol
violetgoose is offline   0 Reply With Quote
Old Mar 18, 2012, 06:40 AM   #5
misterjrw
macrumors member
 
Join Date: Jul 2010
Not sure what else to suggest. As stated previously, my wife's phone timezone was still set to Prague after a recent works trip, even though she was now back in the UK.

The last iMessage was sent and received just before she left, and all other iMessages after that were sent as normal SMS's.

So i checked in date & time and changed the timezone back to London, and made sure it was set to automatic, and within a few minutes, iMessage was verified.

Sorry i can't help any further.
misterjrw is offline   0 Reply With Quote
Old Mar 18, 2012, 06:49 AM   #6
NJFP
macrumors regular
 
Join Date: Feb 2009
Friend of mine had the same issue. I turned off iMessage, turned it back on, then did a reboot. (Hold power and home button until screen goes black and the apple comes back on, then let go) After a few minutes, his was accepting iMessages again.
NJFP is offline   1 Reply With Quote
Old Mar 18, 2012, 12:42 PM   #7
violetgoose
macrumors member
 
Join Date: Mar 2011
Location: Texas
Quote:
Originally Posted by NJFP View Post
Friend of mine had the same issue. I turned off iMessage, turned it back on, then did a reboot. (Hold power and home button until screen goes black and the apple comes back on, then let go) After a few minutes, his was accepting iMessages again.
So holding the power and home button is different than just sliding the power off button? I just did that and it's still activating... However, iMessage would only work through email, and not my number, which is so strange. When I go to "receive at my email" my cell phone number has "verifying" besides it and I can't seem to press that. Ugh
violetgoose is offline   0 Reply With Quote
Old Apr 27, 2012, 04:22 PM   #8
ndpitch
macrumors regular
 
Join Date: Jun 2010
bump. Having this same issue after restoring my iphone 5 as new. Only works through my email now, and the phone number is stuck on "verifying". Anyone else get it working somehow?!
ndpitch is offline   0 Reply With Quote
Old Apr 27, 2012, 09:53 PM   #9
thomasfrdavis
macrumors member
 
Join Date: Oct 2011
last week i had the same issue. didnt know my credit was almost out. after i recharged my prepaid simcard, iMessage got verified 5 minutes later.

hope it helps
thomasfrdavis is offline   1 Reply With Quote
Old Apr 27, 2012, 10:00 PM   #10
NiftyMac
macrumors newbie
 
Join Date: Mar 2012
Location: BOSTON, MA
I've ran into this issue a couple of times. What seems to fix this is a factory restore via iTunes. If you are unlucky with the first restore try again as the second time should definiately fix the issue and your number should be displayed but greyed out & iMessage using your number as your caller id again.
__________________
vzw iPhone 4 32gb : MacBook Pro (early 2011) 16GBram@1333MHZ : iPad (3rd generation)
NiftyMac is offline   0 Reply With Quote
Old Apr 30, 2012, 01:37 AM   #11
ndpitch
macrumors regular
 
Join Date: Jun 2010
I was able to fix it. I gave it a rest for a day because I heard it has to do with how long the servers will accept an activation request. I let it be for 36 hours. Turned iMessage off. Rebooted the phone. Turned iMessage back on. My phone number is now activated so that's good.
ndpitch is offline   0 Reply With Quote
Old Jun 15, 2012, 03:03 PM   #12
rebeccapullen89
macrumors newbie
 
Join Date: Jun 2012
please help !!
i had same issue, my imessage would not register my number at all, it would only work through email. after trying EVERYTHING and growing old talking to the incompetents in apple, i decided to buy a new sim card from a different phone network. the problem that i have now is that the number is listed but is greyed out and will not verify. i have been having this problem solidly for the last 4 months so please if anyone can help me fix this i would be eternally grateful!!!!
rebeccapullen89 is offline   0 Reply With Quote
Old Aug 7, 2012, 11:54 PM   #13
blakforest
macrumors newbie
 
Join Date: Aug 2012
I had the same problem.
I read in another site that you should reset your Network Settings, so.


Go to Settings > Messages>Turn off iMessage.
Go to General > Reset > Reset Network Settings.
Once the iPhone is open.
Go to Settings > Messages>Turn ON iMessage.

Then it should verify your number.
It worked for me.

However when I was sending messages through iMessage the other side would receive it through my e-mail rather then my number, in other words he the other side had two messaging threads for me. One as my number and the other with my e-mail address.

What I did was I Restored (clean, no backup) my phone. At the start up Menu I passed the option to put in my AppleID. Continued through. Opened the Settings app and turned off iMessage.

(Used iCloud to get my contacts back)

Messaged my friend to delete my threads on his phone. Sent another message so he has my number as a thread. Turned on iMessage but didn't put an email address(apple ID) and waited for my number to be verified. Sent an iMessage and it worked. Now I added my e-mail address and its still under the same thread on my friends phone. So it's not showing up as being sent through my e-mail.

A tad tedious and I don't know if this is a solution for other people but it worked for me. I honestly don't know if the other end needs to delete your message thread, it's just a precaution.

Hope this helps
blakforest
blakforest is offline   0 Reply With Quote
Old Sep 14, 2012, 08:51 AM   #14
absolutetwoddle
macrumors newbie
 
Join Date: Sep 2012
Location: Bath, UK
Smile

Quote:
Originally Posted by NJFP View Post
Friend of mine had the same issue. I turned off iMessage, turned it back on, then did a reboot. (Hold power and home button until screen goes black and the apple comes back on, then let go) After a few minutes, his was accepting iMessages again.
This worked for me. I turned the iMessage off and then on again. I then held down the power and home button, it showed the off slider and I let go. I then held them down again and it turned off. I let go and then held the power button to turn on. Went back into the messages setting and it had sorted itself
absolutetwoddle is offline   0 Reply With Quote
Old Nov 12, 2012, 01:00 AM   #15
Originalbossman
macrumors newbie
 
Join Date: Nov 2012
All u have to do is delete your email that is associated with ur iMessage then ur phone will b forced to use ur number. Then just re add ur email. If u had a conversation already started you will have to delete the convo and start a new one
Originalbossman is offline   1 Reply With Quote
Old Dec 16, 2012, 09:06 PM   #16
cdrinkwine
macrumors newbie
 
Join Date: Apr 2012
Quote:
Originally Posted by Originalbossman View Post
All u have to do is delete your email that is associated with ur iMessage then ur phone will b forced to use ur number. Then just re add ur email. If u had a conversation already started you will have to delete the convo and start a new one
U da man. Simplest solution is usually correct.
cdrinkwine is offline   0 Reply With Quote
Old Apr 30, 2013, 01:03 AM   #17
Terry508
macrumors newbie
 
Join Date: Apr 2013
verification

I had exactly the same problem
It was my card had expired on my billing details with iTunes
I updated the new card details and immediately my mobile number was verified
Hope that works for you all too
Terry508 is offline   0 Reply With Quote
Old Jun 1, 2013, 03:57 PM   #18
pjki
macrumors newbie
 
Join Date: Dec 2012
Wink toggling auto date/time

Quote:
Originally Posted by misterjrw View Post
Check to see if your timezone is set to automatic or not. My wife had this issue the other day, and after scouring the web, finally got it to work by toggling the 'set automatically' toggle within 'date & time' in settings, general.

Verified a few mins after doing that.

Hope this helps
Wow, I SCOURED the web too. Have been working on this for a couple hours. Asked Google every question every which way possible, and FINALLY came upon THIS post! THAT DID IT.

My iphone 5 has been verified for MONTHS, but someone tried to send a message and they were receiving a message that my iMessage was not set up. Only way I knew that the phone number was supposed to be checked is I looked at our iPhone 4, and the phone number under iMessage IS checked. On iPhone 5 it was not.

So all those other posts that want you to go through a nightmare of reinstallation, rebooting and going to another device and reinstalling Apple accounts, reactivating, deleting, restoring iPhone to factory settings, on and on and on and on -- and here all it took was just TOGGLING the auto date/time!

Thanks for posting this! I'm glad I found it!
pjki is offline   0 Reply With Quote
Old Jun 3, 2013, 09:54 PM   #19
keepaheadback
macrumors newbie
 
Join Date: May 2013
Originally Posted by misterjrw View Post

Check to see if your timezone is set to automatic or not. My wife had this issue the other day, and after scouring the web, finally got it to work by toggling the 'set automatically' toggle within 'date & time' in settings, general.

Verified a few mins after doing that.

Hope this helps
keepaheadback is offline   0 Reply With Quote
Old Jul 8, 2013, 01:37 AM   #20
sugar iphone
macrumors newbie
 
Join Date: Jul 2013
Talking Make imessage activate faster AND with imessage with your number

Quote:
Originally Posted by lewys View Post
A few days ago i restored through iTunes using a back up and ever since iMessage will only work with my email and not my number as it says it can't verify it.

i have tried numerous clean installs and trying to install the previous backup again even wiped it through the remote wipe in iCloud (don't ask me why i thought to try this but nothing else was working so i thought i may as well try) but nothing works. I have even been on the phone to apple for over two hours today and they didn't have a clue.

Does anyone have any idea what i could do to fix this? its an iPhone 4s on the latest firmware.
Well i guess i fixed it
1)turn off imessage
2) go to contacts and create your own contact with only your own number, no email
3)go to settings-phone-my number, and type in your number without the +61
4)go to settings-general-date and time. make sure the 'set automatically' is on
5)go to settings-mail,contacts,calenders, then in my info, select your own contact.
6)forget your wifi network and then join again
7) turn on imessage.
it should work. it worked for me. step 3-6 doesnt necessarily have to be in that order.

Last edited by sugar iphone; Jul 8, 2013 at 01:45 AM. Reason: forgot to put in title
sugar iphone is offline   0 Reply With Quote
Old Nov 26, 2013, 11:37 PM   #21
axy60
macrumors newbie
 
Join Date: Sep 2012
Location: near equator
I had the same issue...

Just toggled the on/off button in my iPhone settings>Messages>iMessage and after a few seconds I receive the questions whether to add my phone number to FaceTime and iMessage.
axy60 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 5 and earlier

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
iMessage Help - Incorrect phone number stored in iMessage setting The Great Boony iPhone 9 Jul 8, 2013 01:47 AM
iMessage won't read my phone number...help sosinsurr iPhone Tips, Help and Troubleshooting 5 Jul 8, 2013 01:46 AM
How to remove my phone number from iMessage? The Highlander iOS 5 and earlier 10 Jul 2, 2013 10:22 PM
Wife can't send me iMessage by my phone number, I can to her number? RollTide1017 iOS 5 and earlier 14 Apr 17, 2012 10:49 AM
iMessage Phone Number/Email Jakerz iOS 5 and earlier 3 Oct 26, 2011 02:06 PM


All times are GMT -5. The time now is 02:19 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC