Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 1, 2012, 10:45 PM   #1
BBQ BOY
macrumors regular
 
Join Date: Feb 2010
Camera's do not work after replacing screen

Took my wife's iPhone4 to have her broken black front screen. i went ahead and had the front and back replaced with white. The camera did not work, the tech wiped the phone and that seemed to fix the problem. I took the phone home and restored it. All is good until 2 days later and about 12 photos later.
Back to square one. The camera will not work, the screen had the shutter on the front but now the screen is black. I can see all of the correct screen icons, such as, video selector option and shutter button, but the video/camera option has a faint blink to it.
So, can anyone offer me any sound insight? I really do not want to take it back where I got it repaired. To be honest, the guy who fixed it and owns the shop is my friend and he took 4 days to fix it and I just didn't feel like he knew what he was doing. Sad, I know.
BBQ BOY is offline   0 Reply With Quote
Old Mar 1, 2012, 10:50 PM   #2
Macman45
macrumors G5
 
Macman45's Avatar
 
Join Date: Jul 2011
Location: Somewhere Back In The Long Ago
Sounds to me like your best option here is to take it to Apple...Your buddy may have pinched a cable in the process...If it's a relatively easy fix and you grab a friendly genius in a slack moment, you might just get lucky.

I wouldn't tell them you had the screen done though..
__________________
..That's All Folks
Macman45 is offline   0 Reply With Quote
Old Mar 1, 2012, 10:54 PM   #3
zigzagg321
macrumors 6502
 
Join Date: Oct 2011
Location: the wire
Quote:
Originally Posted by Macman45 View Post
Sounds to me like your best option here is to take it to Apple...Your buddy may have pinched a cable in the process...If it's a relatively easy fix and you grab a friendly genius in a slack moment, you might just get lucky.

I wouldn't tell them you had the screen done though..
the serial number is entered on every phone that goes in for service. The system says if it is white or black. He brings in the white phone that is supposed to be black and gets put at a disadvantage for any coverage for any of the issues.
zigzagg321 is offline   0 Reply With Quote
Old Mar 27, 2012, 10:17 AM   #4
Codyormoe
macrumors member
 
Join Date: Apr 2011
Location: Western Mass
I had the same issue, I bought a used iphone 4(I knew of the camera not working issue prior to buying it) and whoever replaced the screen had knocked a capacitor loose. It was still on the board, but not making good contact. Once I soldered it back in place both cameras worked fine and the slight flickering of the camera/video icon in the camera app went away.

Mine was a Verizon(cdma) iPhone 4. I know if you search on google you can find a post and picture refering to the gsm capacitor that often gets knocked off during a screen replacement. The one I had to fix(for cdma) was under the connector for the rear camera, at the bottom right edge of the connector. Teeny, tiny black capacitor. I had to use a fairly good magnifying lens to even see it.
Codyormoe is offline   0 Reply With Quote
Old Aug 15, 2012, 05:23 AM   #5
Richard Bfd
macrumors newbie
 
Join Date: Aug 2012
Newby

Hi All,

I'm not sure if this has been mentioned, I too changed the screen on my 4s and found that the camera didn't work, I also had a problem with the home button needing a hard press to work, I reopened it all and firstly put a small square of 3m tape behind the home button which now works perfectly.

More importantly, I checked the camera and the only thing I could see wrong were the two gold prongs next to the cable, on a hunch that I'd been too heavy handed I gently prised them open a fraction further as I presumed these were the power contacts for the camera, put it all back together and the camera is working front and back with no issues.

Just thought I'd pass it along, I have pictures of the prongs if needed.

Richard
Richard Bfd is offline   0 Reply With Quote
Old Sep 3, 2012, 02:12 AM   #6
Danishbhai
macrumors newbie
 
Join Date: Sep 2012
Hello,
Would you be able to send me that picture?
Thank you!
Danishbhai is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone > iPhone Tips, Help and Troubleshooting

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
MagSafe won't work, then works after 6 hours? MJNBGA MacBook Pro 4 Jul 10, 2011 04:44 AM
Iphone 3gs screen dim/not working after replacement Lowman905 iPhone 1 Apr 23, 2011 03:49 PM
Keyboard and pkgbackup not working after replacing iP4 from Apple is300guy Jailbreaks and iOS Hacks 2 Feb 27, 2011 08:01 PM
Apps do not work after 3.1 update Opodomus iPhone Tips, Help and Troubleshooting 3 Sep 25, 2009 12:04 PM
Help: Exchange email not working after replacing Iphone drme iPhone 0 Nov 14, 2008 12:09 PM


All times are GMT -5. The time now is 10:40 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC