Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > Mac OS X 10.7 Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 4, 2012, 09:01 PM   #1
PABSOUL
macrumors newbie
 
Join Date: Mar 2012
Location: Argentina
Question OS X LION 10.7.3 System Preferences

Hello everybody, I am new in the Forum. Forgive my English, but is my second language. I hope I am posting this thread in the right place, If not, please forgive me. I am having problem loading some System Preferences Apps. They are actually three, "Desktop & Screen Saver", "Spotlight" and "Energy Saver". I tried fixing permissions, reinstalling system preferences using an app called Pacifist. I tried reinstalling OS X Lion, but everything seems to fail. The only thing that didn't fail was a clean reinstall of the OS, but I don' want to have to reinstall everything again. I have everything backed up in Time Machine, So when I reinstalled the OS I transferred all my DOCS and Apps from time machine. I am not good with terminal but if someone could guide me in right direction to fix this I will appreciate it.
Here is a log from console with the errors and what I think it seems to be wrong. Please help me out to fix this. Thank you

Desktop & Screen Saver

3/4/12 7:28:41.670 PM System Preferences: Error loading /System/Library/PreferencePanes/DesktopScreenEffectsPref.prefPane/Contents/MacOS/DesktopScreenEffectsPref: dlopen(/System/Library/PreferencePanes/DesktopScreenEffectsPref.prefPane/Contents/MacOS/DesktopScreenEffectsPref, 265): Symbol not found: _OBJC_CLASS_$_NSObject
Referenced from: /System/Library/PrivateFrameworks/iLifeMediaBrowser.framework/Versions/A/iLifeMediaBrowser
Expected in: /usr/lib/libobjc.A.dylib
in /System/Library/PrivateFrameworks/iLifeMediaBrowser.framework/Versions/A/iLifeMediaBrowser

Spotlight

3/4/12 7:30:09.217 PM System Preferences: Error loading /System/Library/PreferencePanes/Spotlight.prefPane/Contents/MacOS/Spotlight: dlopen(/System/Library/PreferencePanes/Spotlight.prefPane/Contents/MacOS/Spotlight, 265): Symbol not found: _OBJC_CLASS_$_NSObject
Referenced from: /System/Library/PrivateFrameworks/iLifeMediaBrowser.framework/Versions/A/iLifeMediaBrowser
Expected in: /usr/lib/libobjc.A.dylib
in /System/Library/PrivateFrameworks/iLifeMediaBrowser.framework/Versions/A/iLifeMediaBrowser

Energy Saver

3/4/12 7:31:06.506 PM System Preferences: [NSPrefPaneBundle instantiatePrefPaneObject] (/System/Library/PreferencePanes/EnergySaver.prefPane): principalClass is nil.

Last edited by PABSOUL; Mar 4, 2012 at 09:21 PM.
PABSOUL is offline   0 Reply With Quote
Old Mar 4, 2012, 10:26 PM   #2
pgiguere1
macrumors 68000
 
pgiguere1's Avatar
 
Join Date: May 2009
Location: Montreal, Canada
Most of the time this kind of problem is caused by a corruption in the System Preferences property list. You can simply delete their .plist file to reset it. When the OS will detect the .plist file is gone, it will reinstall the original (uncorrupted) .plist.

Go to ~/Library/Preferences/ and delete the com.apple.systempreferences.plist file.

~ is your username, make sure your Library folder is visible as it is hidden by default in Lion.

If your Library folder is hidden, you can use the following code in Terminal to make in visible:

Code:
chflags nohidden /Users/[username]/Library/
Just replace [username] with your actual username before pressing enter.

Alternatively, you can simply delete the file directly with the Terminal without making the Library folder visible by typing:

Code:
cd ~/Library/Preferences/
sudo rm --f com.apple.systempreferences.plist
You will have to type your account password (even though it's not showing) and press enter.

Chances are that this will do the trick.

Last edited by pgiguere1; Mar 4, 2012 at 10:35 PM.
pgiguere1 is offline   0 Reply With Quote
Old Mar 4, 2012, 10:59 PM   #3
PABSOUL
Thread Starter
macrumors newbie
 
Join Date: Mar 2012
Location: Argentina
OS X LION 10.7.3 System Preferences

Thank you very much for your time and patience to explain me what to do. I followed your instructions and deleted the com.apple.systempreferences.plist
but still not working.
I want to upload some screen shots but I don't know how to do that. There must be something else wrong because I can't even open Mail, I just realized that too. So I don't know what to do from here.
PABSOUL is offline   0 Reply With Quote
Old Nov 17, 2012, 03:46 PM   #4
ron.stephens
macrumors newbie
 
Join Date: Nov 2012
I'm having the same exact problem with Mail, Energy Saver, etc. A solution?
ron.stephens is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > Mac OS X 10.7 Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
System preferences cool11 OS X Mavericks (10.9) 1 Apr 17, 2014 12:11 PM
System preferences jennytisme Mac OS X 10.7 Lion 1 Mar 15, 2013 01:13 PM
System preferences verithingeoff OS X 10.8 Mountain Lion 0 Feb 3, 2013 05:19 PM
Mountain Lion installed but no sound, system preferences or sound related apps. rickmusik OS X 10.8 Mountain Lion 3 Aug 2, 2012 01:55 PM
System Preferences Freezing brimoody OS X 10.8 Mountain Lion 2 Aug 1, 2012 09:06 AM

Forum Jump

All times are GMT -5. The time now is 12:21 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC