Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 5 and earlier

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 16, 2012, 01:54 AM   #1
LWP777
macrumors member
 
Join Date: Sep 2010
Voicemail issue with iOS 5.1

Ever since I updated to iOS 5.1 I've had some new voicemails that I was unable to play without rebooting my iPhone 4S. I will see the new voicemail in my visual voicemail but it will show 0:00 and not let me play the message. When I reboot, it will notify me of a new voicemail and I'm able to listen. This has happened 4-5 times. It also happened today on my wife's 4S so it's not just exclusive to my phone. I am on the Sprint network.

I tried searching the forums but didn't find any posts with a similar issue.

Any ideas of how to resolve this? Thank you!
LWP777 is offline   0 Reply With Quote
Old Mar 18, 2012, 07:52 PM   #2
indiefilmguy
macrumors newbie
 
Join Date: Mar 2012
Location: Chicago, IL USA
Voicemail Issue

Were you ever able to resolve this? I am having the same issue is iOS 5.1 on the 4S, on Sprint. Mine is so bad that I have to reboot my phone EVERY time i receive a voicemail.
indiefilmguy is offline   0 Reply With Quote
Old Mar 20, 2012, 01:35 AM   #3
LWP777
Thread Starter
macrumors member
 
Join Date: Sep 2010
No, I have not resolved this. I'm shocked that nobody has really responded to this post! I also am having to reboot my phone each time.

When you upgraded to 5.1, was it interrupted at all? I think I went from wifi to 3G. I wonder if that had something to do with it.
LWP777 is offline   0 Reply With Quote
Old Mar 20, 2012, 06:46 AM   #4
pdqgp
macrumors 68000
 
pdqgp's Avatar
 
Join Date: Mar 2010
AT&T works fine here. Sprint thing?
__________________
Family Currently uses: iP3g, (2) iPH4s, iPad Mini Retina, iPad Air 2 Latest Generation, Kindle Paper white, Fire & my Galaxy Note 3, Gear S & an iPhone 6
pdqgp is offline   0 Reply With Quote
Old Mar 20, 2012, 07:09 AM   #5
hottrkc
macrumors newbie
 
Join Date: Mar 2012
Quote:
Originally Posted by indiefilmguy View Post
Were you ever able to resolve this? I am having the same issue is iOS 5.1 on the 4S, on Sprint. Mine is so bad that I have to reboot my phone EVERY time i receive a voicemail.
I am having the same issue is iOS 5.1 on the 4S, on Sprint. Mine is so bad that I have to reboot my phone EVERY time
hottrkc is offline   0 Reply With Quote
Old Mar 20, 2012, 07:40 AM   #6
ah123
macrumors regular
 
Join Date: Jul 2011
FWIW I'm on o2 (UK) and have been able to listen to voicemails without any issue. Hope your issue gets fixed!
ah123 is offline   0 Reply With Quote
Old Mar 20, 2012, 06:59 PM   #7
indiefilmguy
macrumors newbie
 
Join Date: Mar 2012
Location: Chicago, IL USA
I have not been able to resolve this as of yet. I can't seem to find any solution online either, haven't called Apple yet because I know their first suggestion is going to be to erase my phone and start over...
indiefilmguy is offline   0 Reply With Quote
Old Mar 20, 2012, 08:03 PM   #8
antseg
macrumors member
 
Join Date: Mar 2012
Location: New Jersey
Try this, from:
https://discussions.apple.com/thread...art=0&tstart=0


Quote:
I did a backup to iCloud, restore & backup from iCloud.... voicemail etc is running great now
antseg is offline   0 Reply With Quote
Old Mar 21, 2012, 12:41 AM   #9
Arelunde
macrumors Demi-God
 
Arelunde's Avatar
 
Join Date: Jul 2011
Location: CA Central Coast
Wirelessly posted (Mozilla/5.0 (iPhone; CPU iPhone OS 5_1 like Mac OS X) AppleWebKit/534.46 (KHTML, like Gecko) Version/5.1 Mobile/9B176 Safari/7534.48.3)

With Vz and my iPhone4, no problems.
__________________
Always learning...
Arelunde is offline   0 Reply With Quote
Old Mar 28, 2012, 11:29 PM   #10
Durum
macrumors newbie
 
Join Date: Mar 2012
Same

My wife and I both have iPhone 4s with Sprint. iOS 5.1 update has done same thing to our voicemail. I have to reboot phone nearly every time. I have a 32 GB phone. I have not tried the back up and restore. Is this confirmed as a solution?
Durum is offline   0 Reply With Quote
Old Apr 5, 2012, 01:13 PM   #11
DarrenBTX
macrumors newbie
 
Join Date: Apr 2012
Iphone voicemail issue

My wife and I both have Iphone 4S's on sprint and are experiencing the exact same problem. Ever since we upgraded to IOS 5.1, when voicemails come in, they are displayed but with 0:00 as if the person didn't leave a message. We never had this problem on 5.0, but we've asked a Genius Bar tech and he had no knowledge of the problem.

Any hints on how to fix it or get it fixed?

Iphone 4S 32gb
DarrenBTX is offline   0 Reply With Quote
Old Apr 5, 2012, 01:15 PM   #12
bluedoggiant
macrumors 68020
 
bluedoggiant's Avatar
 
Join Date: Jul 2007
Location: MD & ATL,GA
not on AT&T 64gb iphone 4s
__________________

Haswell MacBook Pro 15" - 16GB - 2.3GHz - 512GB - dGPU
Mid-2007 iMac 24" - 4GB - 2.8GHz - .5TB
Gold 64GB iPhone 5s
bluedoggiant is offline   0 Reply With Quote
Old Jul 5, 2012, 09:54 AM   #13
Diana Prince
macrumors member
 
Join Date: Oct 2011
Has anyone in this thread (or anyone else experiencing this issue) been able to resolve this voice-mail problem?

I contacted Sprint (and this only affects Sprint iPhones AFAIK) and they are aware of the problem and said they were currently working w/ Apple to resolve it but that was over a month ago. The rep told me they thought the latest iOS release was going to resolve the problem but it does not. Sprint can "reset" your voice mail temporarily fixing the problem but the problem resurfaces for me within days (sometimes hours).

So far the only thing that works for me is deleting the voice mail and then going into deleted messages and undeleting it. I can then listen to the message. I really hope this is resolved soon or this could affect my next iPhone purchase. I gotta get my voice mails!
Diana Prince is offline   0 Reply With Quote
Old Jul 11, 2012, 07:40 PM   #14
visitor123456
macrumors newbie
 
Join Date: Jul 2012
1. Exit out of the phone app and go to the home screen
2. Tap twice on the home button to bring up currently running apps
3. End the Phone App process by continuing to hold that icon until a minus sign appears. Tap the phone icon again to end it.
4. Tap the home button again to return the device to the regular home screen
5. Re-launch the phone app
6. Wait a few seconds. This will prompt the device to re-connect to the Voicemail server and download all messages. The messages will all be playable.
visitor123456 is offline   1 Reply With Quote
Old Jul 12, 2012, 03:14 PM   #15
mds
macrumors 6502
 
Join Date: Oct 2006
Quote:
Originally Posted by visitor123456 View Post
1. Exit out of the phone app and go to the home screen
2. Tap twice on the home button to bring up currently running apps
3. End the Phone App process by continuing to hold that icon until a minus sign appears. Tap the phone icon again to end it.
4. Tap the home button again to return the device to the regular home screen
5. Re-launch the phone app
6. Wait a few seconds. This will prompt the device to re-connect to the Voicemail server and download all messages. The messages will all be playable.
I've had this problem as well and following the steps above solves the problem. My guess is it will reappear, but it isn't too difficult just to kill the phone app once in awhile. Thanks!
mds is offline   0 Reply With Quote
Old Jul 12, 2012, 08:52 PM   #16
Macman756
Banned
 
Join Date: Sep 2008
Location: Atlanta, GA
Send a message via AIM to Macman756
It just hasn't downloaded yet. Carrier issue. Reset your network settings
Macman756 is offline   0 Reply With Quote
Old Aug 20, 2012, 09:18 PM   #17
bsimp
macrumors newbie
 
Join Date: Aug 2012
Quote:
Originally Posted by LWP777 View Post
Ever since I updated to iOS 5.1 I've had some new voicemails that I was unable to play without rebooting my iPhone 4S. I will see the new voicemail in my visual voicemail but it will show 0:00 and not let me play the message. When I reboot, it will notify me of a new voicemail and I'm able to listen. This has happened 4-5 times. It also happened today on my wife's 4S so it's not just exclusive to my phone. I am on the Sprint network.

I tried searching the forums but didn't find any posts with a similar issue.

Any ideas of how to resolve this? Thank you!
Funny how I'm reading your complaint about this "known issue" you posted in March 2012 and It's August and this is still an issue. I can't get a voicemail from Sprint unless I turn the phone off then back on. I wonder how many more months will go by before they fix it.
bsimp is offline   0 Reply With Quote
Old Sep 22, 2012, 10:28 AM   #18
LWP777
Thread Starter
macrumors member
 
Join Date: Sep 2010
Quote:
Originally Posted by bsimp View Post
Funny how I'm reading your complaint about this "known issue" you posted in March 2012 and It's August and this is still an issue. I can't get a voicemail from Sprint unless I turn the phone off then back on. I wonder how many more months will go by before they fix it.
Yeah, it's ridiculous. Have you updated to iOS 6 yet? I haven't had the problem since I updated. (knock on wood)
LWP777 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 5 and earlier

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iOS 7 and Visual Voicemail campingsk8er iOS 7 13 Sep 28, 2013 02:14 PM
ios7 issue with voicemail greeting imacadoo iPhone 0 Sep 23, 2013 10:52 AM
Disable Voicemail button on ios 6.0.1 w/o JB liteshow iPhone 8 Jan 9, 2013 12:24 PM
iOS 7 - Visual Voicemail 2.0 Shadyriley iOS 7 13 Dec 8, 2012 08:25 AM
iOS 6 - O2 and visual voicemail - not working? Risco iOS 6 2 Jun 18, 2012 05:34 AM

Forum Jump

All times are GMT -5. The time now is 04:36 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC