Go Back   MacRumors Forums > Apple Hardware > PowerPC Macs

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 18, 2012, 08:07 PM   #1
brandoncampbell
macrumors newbie
 
Join Date: Mar 2012
PowerMac G5 (2004)

Hey guys, pretty new to mac. My wife got one from work they were no longer using and I was wanting to upgrade it to a newer OS. Right now it is on 10.3.11. It had 512 of ram before I looked around the house and happen to find some old ram from one of my old pcs to throw in there.. seems to have picked it up and is wrking so now it has 4gigs. It has the 2.5 processor which should be enough I would think to run a newer OS.

questions.. hope someone can help.

1. It has only an AGP slot for a video card. Currently ATI 128 MB video card. I know AGP is pretty outdated but can someone suggest a better video card?

2. What would be the latest OS I can use on this?
brandoncampbell is offline   0 Reply With Quote
Old Mar 18, 2012, 08:27 PM   #2
Hrududu
macrumors 68000
 
Hrududu's Avatar
 
Join Date: Jul 2008
Location: Wichita KS
It'll run Leopard version 10.5.8 quite nicely. Depending on which card you have, its probably about as good as you're gonna get without paying too much.
__________________
Quad 2.5 G5, MBP 2.6 17", DP 2.0 G5, DP 1.42 MDD, 17 PowerBook 1.67, 12" PowerBook 1.5, TiBooks 867 & 667, iMac G3 500, Cubes 500 & 450, B&W G3 450 & 350, iBook 300's & 366, Beige G3 350, PDQ G3 233
Hrududu is offline   0 Reply With Quote
Old Mar 19, 2012, 11:14 AM   #3
brandoncampbell
Thread Starter
macrumors newbie
 
Join Date: Mar 2012
Quote:
Originally Posted by Hrududu View Post
It'll run Leopard version 10.5.8 quite nicely. Depending on which card you have, its probably about as good as you're gonna get without paying too much.
Thanks, any suggestions on the video card I should get?
brandoncampbell is offline   0 Reply With Quote
Old Mar 19, 2012, 11:45 AM   #4
pistooli
macrumors regular
 
Join Date: Feb 2009
Location: Hungary
Quote:
Originally Posted by brandoncampbell View Post
Thanks, any suggestions on the video card I should get?
Why would you need to upgrade the video card? Do you plan to use the machine for anything particular or "just" casual browsing, internet, email, photos, videos, etc?

With the mentioned 4GB memory, this machine will play with Leopard nicely.

If you have 10.5 Leopard install disks, then do not hesitate to install it.
__________________
MacBook Air, 13", Mid 2012, Mountain Lion
Mac Mini, Late 2006, upgraded to 2GHz, 2GB, Lion 10.7.5
iBook G4, 1.42 MHz, 1.5 GB, 160 GB, Leopard
PowerBook 5300cs, 3400c, G3 Pismo, Mac Mini G4 1,33
pistooli is offline   0 Reply With Quote
Old Mar 19, 2012, 11:51 AM   #5
brandoncampbell
Thread Starter
macrumors newbie
 
Join Date: Mar 2012
Quote:
Originally Posted by pistooli View Post
Why would you need to upgrade the video card? Do you plan to use the machine for anything particular or "just" casual browsing, internet, email, photos, videos, etc?

With the mentioned 4GB memory, this machine will play with Leopard nicely.

If you have 10.5 Leopard install disks, then do not hesitate to install it.
My wife wants to install Adobe CS 5 and I am assuming it will be a graphics hog...
brandoncampbell is offline   0 Reply With Quote
Old Mar 19, 2012, 11:57 AM   #6
pistooli
macrumors regular
 
Join Date: Feb 2009
Location: Hungary
Quote:
Originally Posted by brandoncampbell View Post
My wife wants to install Adobe CS 5 and I am assuming it will be a graphics hog...
If I were you, I would try it with the existing card, then if you feel like upgrading, you can get an nvidia 6800 Ultra 256MB 8xAGP (you need the mac version!)

(as far as I know the fastest card your machine can get is a flashed nvidia 7800 GS)
__________________
MacBook Air, 13", Mid 2012, Mountain Lion
Mac Mini, Late 2006, upgraded to 2GHz, 2GB, Lion 10.7.5
iBook G4, 1.42 MHz, 1.5 GB, 160 GB, Leopard
PowerBook 5300cs, 3400c, G3 Pismo, Mac Mini G4 1,33
pistooli is offline   0 Reply With Quote
Old Mar 19, 2012, 12:12 PM   #7
Goftrey
macrumors 68000
 
Goftrey's Avatar
 
Join Date: May 2011
Location: Wales, UK
Quote:
Originally Posted by brandoncampbell View Post
My wife wants to install Adobe CS 5 and I am assuming it will be a graphics hog...
CS5 won't run on PowerPC unfortunately... CS4 is the newest version that'll run on your G5.

And I +1 6800 Ultra. A friend of mine also has a dual 2.5 with 4gb RAM & it was a really nice card.
__________________
Hackintosh 2x3.5GHz, 4GB, 500GB, GTX660 | 13" MacBook Air 2x2.13GHz, 4GB, 256GB, 320M | 23" Cinema Display
PowerMac G4 Cube 1.2GHz, 1.5GB, 160GB. 6200 | iPhone 5 16GB | Canon EOS M 18-55mm, 22mm
Goftrey is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > PowerPC Macs

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Unreal 2004 hobx OS X Mavericks (10.9) 0 Jan 26, 2014 03:59 PM
Imac g5 20, 2004 problem Grazhve PowerPC Macs 1 Apr 5, 2013 12:52 PM
iMac G5 2004 dhalgren13 PowerPC Macs 7 Oct 27, 2012 09:30 AM
How to get unreal tournament 2004 for Mac? ugr Mac and PC Games 6 Oct 1, 2012 12:17 AM

Forum Jump

All times are GMT -5. The time now is 07:12 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC