Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 5 and earlier

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 22, 2012, 02:43 PM   #1
Pokernut
macrumors member
 
Join Date: Mar 2009
iMessage - '!' Not Delivered

I've recently ran into an annoying problem with iMessage. At first I thought it was just a network problem, but now I'm not sure what it is now.

About 90% of my messages being sent through iMessage are getting a red (!) and saying 'Not Delivered'. But my messages are being delivered. I'm currently have a conversation with someone right now, the other person is receiving all my messages, but I'm still getting the red exclamation point beside every message. Yet sometimes I'll have a conversation with someone, I'll get the red exclamation point and they won't receive my message. So I'll have to click on it and 'Send as a Text Message'.

Is anyone else having this problem?? Any help would be appreciated, its driving me crazy. I use Rogers and live in Toronto.

Thanks!
Pokernut is offline   1 Reply With Quote
Old Mar 22, 2012, 02:47 PM   #2
VicTheBerg
macrumors newbie
 
Join Date: Feb 2012
I've had exactly the same problem these last few days. My father as well. It's harmless but freakin' annoying.

Anyone knows what can fix it? Is it and iOS 5.1 bug, and a reinstall is necessary, or is it some kind of iMessage bug?
VicTheBerg is offline   1 Reply With Quote
Old Mar 22, 2012, 02:48 PM   #3
map1978
macrumors 68020
 
map1978's Avatar
 
Join Date: Feb 2006
Location: Jacksonville, FL
Having the problem today as well

Don't think it's 5.1 because I'm no 5.0.1

They are being sent as text messages

Prob a apple server that took a dump
map1978 is offline   1 Reply With Quote
Old Mar 22, 2012, 04:33 PM   #4
oli356
macrumors 6502
 
Join Date: Sep 2010
Getting this all the time with only 1 person.. annoying because it takes a while before it goes "ok lets try MMS"
oli356 is offline   1 Reply With Quote
Old Mar 22, 2012, 06:15 PM   #5
beady
macrumors newbie
 
Join Date: Oct 2011
I had the same problem.
I signed out of my apple id in message settings, turned off imessage, restarted phone and re-signed back in. Seemed to do the trick.

Yeah maybe server issues with all the new ipad users maybe?
beady is offline   1 Reply With Quote
Old Mar 22, 2012, 07:07 PM   #6
VicTheBerg
macrumors newbie
 
Join Date: Feb 2012
Quote:
Originally Posted by beady View Post
I had the same problem.
I signed out of my apple id in message settings, turned off imessage, restarted phone and re-signed back in. Seemed to do the trick.

Yeah maybe server issues with all the new ipad users maybe?
That seemed to do the trick. I actually only had to turn iMessage off and then back to on without restarting.
VicTheBerg is offline   1 Reply With Quote
Old Mar 22, 2012, 07:32 PM   #7
jimthing
macrumors regular
 
Join Date: Apr 2011
Location: UK
That fix didn't work for me.

What's happening:

- message goes out over iMessage (BLUE), showing as sent OK. I'm left thinking 'good iMessage worked'.
- then whilst watching the screen, 3 minutes later the message turns GREEN (meaning it's actually gone as a normal SMS!!).
- the person receiving it gets it shortly after the time it turns GREEN on my device (ie. 3 minutes after it showed wrongly as a correctly sent iMessage) as an SMS not iMessage!

WTF?!
Why is it showing as sent via iMessage, when it then (after THREE MINUTES!) goes over SMS (seen changing from blue to green in the process)??

...unreliable = useless, as far as most people are concerned.
__________________
MBP 17" 2.93GHz C2D/10.9.x Mav/8GB RAM/256GB SSD Mac Mini 2.6GHz i7 QC/10.9.x Mav/16GB RAM/256GB SSD T.Caps 5th gen/3TB ATV 3
iP5S 64GB/gold/7.x iPad Mini 2 128GB/grey/WiFi+4G/7.x

wiki:Apple.

Last edited by jimthing; Mar 22, 2012 at 07:39 PM.
jimthing is offline   1 Reply With Quote
Old Mar 22, 2012, 09:26 PM   #8
VicTheBerg
macrumors newbie
 
Join Date: Feb 2012
Crap... the problem is back. Hopefully a someone comes up with a fix soon.
VicTheBerg is offline   1 Reply With Quote
Old Mar 23, 2012, 02:35 AM   #9
liquidsuns
macrumors 6502
 
Join Date: Jun 2009
I was having this problem off and on. It started when I installed the messages beta for OS X. As soon as I deleted that, everything has been working fine.
liquidsuns is offline   2 Reply With Quote
Old Mar 23, 2012, 03:03 AM   #10
Cell-666
macrumors 6502
 
Join Date: May 2011
I'm having the same issues since yesterday. Maybe worth mentioning I'm in the uk see if this is a specific carrier problem ? If not it does seem to be a Apple server issue.

I've tried all the other suggestions above but to no avail. I have a couple of friends using iMessage and they are having the same problems. I've tried sending from iPad, iPhone, Mac. With varying degrees of send failure.
Cell-666 is offline   1 Reply With Quote
Old Mar 23, 2012, 01:59 PM   #11
Pokernut
Thread Starter
macrumors member
 
Join Date: Mar 2009
Quote:
Originally Posted by liquidsuns View Post
I was having this problem off and on. It started when I installed the messages beta for OS X. As soon as I deleted that, everything has been working fine.
This is the only thing that worked for me. I uninstalled Messages beta for OS X on both my macs, and now all my iMessages seem to be going though.
Pokernut is offline   1 Reply With Quote
Old Mar 24, 2012, 05:03 PM   #12
bconeill
macrumors newbie
 
Join Date: Feb 2009
Having the same problem. I also am running the Messages Beta. It had been synching fine for a few weeks, sans some minor bugs here and there. My GF has the same set up and we both starting running into problems at the same time (yesterday). People sending me texts to me are getting the same error message but I'm still having the problem.

I'm going to try to uninstall the messages beta. Apple has a long way to go on that app. Very buggy (dropping conversations, synching with iphones, etc.). Hopefully they realize these bugs and do something about it before Moutain Lion is released.
bconeill is offline   1 Reply With Quote
Old Mar 24, 2012, 06:14 PM   #13
SteveJobs2.0
macrumors 6502
 
Join Date: Mar 2012
iMessage in general is a bit of a mess other than using it to message other people's iPhones.
SteveJobs2.0 is offline   1 Reply With Quote
Old Mar 24, 2012, 06:31 PM   #14
VicTheBerg
macrumors newbie
 
Join Date: Feb 2012
I just deleted the Messages beta from my computer and all the problems with messages displaying as "Not Delivered" disappeared.
VicTheBerg is offline   2 Reply With Quote
Old Mar 25, 2012, 12:24 PM   #15
beady
macrumors newbie
 
Join Date: Oct 2011
Wirelessly posted

The problem has come back for me after being ok for a few days. IMessage is becoming a bit of a joke. I don't own a mac so it's nothing to do with that.
beady is offline   1 Reply With Quote
Old Mar 25, 2012, 01:35 PM   #16
fruitycups
macrumors 6502
 
Join Date: Jun 2011
Wirelessly posted

I get that problem only when i have good service. You shoild chek that first
fruitycups is offline   1 Reply With Quote
Old Mar 26, 2012, 02:59 PM   #17
Fuzzy.Dunlop
macrumors regular
 
Join Date: Jan 2010
Location: London
Same problem here (UK user) - will send an iMessage the status bar will crawl to 75% then fail, or will send, then will re check the phone and its down as not being sent, seems to happen more over wifi

Also have iMessage installed on my Mac
__________________
iPhone 5 64gb - 13" Mac Pro 1TB 8gb - 160gb Ipod Classic - iPad 3 64gb - Gamecentre fuzzy.dunlop
Fuzzy.Dunlop is offline   1 Reply With Quote
Old Mar 27, 2012, 01:33 PM   #18
benboyd5
macrumors newbie
 
Join Date: Mar 2011
List of 10 fixes for iMessages issues

Here's a list of 10 fixes for iMessage not working issues:


http://www.sinatranetwork.com/wordpr...not-delivered/
benboyd5 is offline   1 Reply With Quote
Old Mar 27, 2012, 01:43 PM   #19
swordfish5736
macrumors 65816
 
Join Date: Jun 2007
Location: Belle View
Send a message via AIM to swordfish5736
Quote:
Originally Posted by benboyd5 View Post
Here's a list of 10 fixes for iMessage not working issues:


http://www.sinatranetwork.com/wordpr...not-delivered/
trying to get some more views on your article are we?
__________________
swordfish5736 is offline   0 Reply With Quote
Old Mar 27, 2012, 06:52 PM   #20
Applepi
macrumors 6502a
 
Join Date: Aug 2007
Location: East Valley
Quote:
Originally Posted by benboyd5 View Post
Here's a list of 10 fixes for iMessage not working issues:


http://www.sinatranetwork.com/wordpr...not-delivered/
Did you really need to bump four of the same threads with your spam?
Applepi is offline   0 Reply With Quote
Old Mar 27, 2012, 06:53 PM   #21
xraydoc
macrumors Demi-God
 
xraydoc's Avatar
 
Join Date: Oct 2005
Location: Top left corner
The only times this has happened to me is when either I have a sketchy Internet connection (like at work where sometimes the wifi stops communicating with the outside Internet but still works for the intranet) or if the recipient has a suboptimal Internet connection.

If you're having trouble, try turning off wifi and resending your message. It may be your connection's firewall or limited connectivity.
__________________
3.5GHz i7 27" iMac 1.8GHz i7 11" MacBook Air 2.5GHz i5 Mac mini + 27" Thunderbolt display
4TB RAID 10 8TB RAID 0 6TB RAID 0 2TB Time Capsule ac White/silver iPhone 5S & iPad Air
xraydoc is offline   0 Reply With Quote
Old Mar 28, 2012, 02:01 AM   #22
Cell-666
macrumors 6502
 
Join Date: May 2011
I was having the same problems a few days ago. I uninstalled the OSX beta and they stopped having problem.
Cell-666 is offline   0 Reply With Quote
Old Mar 28, 2012, 04:28 AM   #23
aoifeee
macrumors member
 
Join Date: Aug 2011
I've been receiving imessages like 10 hours late the last few days. It's very annoying, I've had no problems with imessage until now.
aoifeee is offline   0 Reply With Quote
Old Mar 28, 2012, 07:31 AM   #24
swordfish5736
macrumors 65816
 
Join Date: Jun 2007
Location: Belle View
Send a message via AIM to swordfish5736
Quote:
Originally Posted by Applepi View Post
Did you really need to bump four of the same threads with your spam?
Dudes not coming back till he has another article he needs to boost views on
__________________
swordfish5736 is offline   0 Reply With Quote
Old Mar 28, 2012, 11:02 AM   #25
TonyC28
macrumors 6502a
 
Join Date: Aug 2009
I've been noticing the "message not sent error" a lot since 5.0. But, I don't use iMessage. I don't remember this ever happening prior to 5.0 but now I'd say I see it happen about twice a day. I text a lot, but I did before too. So it seems like the only thing that's changed in my experience is 5.0. Of course it could be an AT&T problem I suppose.
TonyC28 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 5 and earlier

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
thread Thread Starter Forum Replies Last Post
iMessage 'Activation Failed' guyht iOS 5 and earlier 5 Nov 22, 2011 06:30 AM
Youtube not working in Safari? Hyde244 Mac Applications and Mac App Store 12 Nov 16, 2011 11:12 PM
iMessages occasionally sent as SMS? kockgunner iOS 5 and earlier 3 Oct 15, 2011 02:08 AM
iMessage Rasta4i iPhone 1 Sep 28, 2011 05:47 AM
Weird Exchange Issue - Outside Emails not delivered unless Outlook is open polisciguy12 iPhone Tips, Help and Troubleshooting 1 Sep 5, 2008 12:49 PM


All times are GMT -5. The time now is 12:17 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC