Go Back   MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 26, 2012, 09:26 AM   #1
mic j
macrumors 68020
 
Join Date: Mar 2012
Lost Movie Art

I moved about 150 mp4's into my iTunes library yesterday. Some show up with cover art but most don't. I have found that if I "Get Info", the movie art loads into iTunes. My HD containing the movie files is networked and it can be a little slow in communicating with my MBP. Is there any way to get it to load the artwork with having to go to each iTunes entry and "Get Info"?
mic j is offline   0 Reply With Quote
Old Mar 27, 2012, 07:33 AM   #2
slothrob
macrumors 6502
 
Join Date: Jun 2007
You could try Select All, then Get Info. That should open everything into 1 window. Close the window without making any changes. Maybe that will kick-start the images to load.
slothrob is offline   0 Reply With Quote
Old Mar 27, 2012, 09:15 AM   #3
mic j
Thread Starter
macrumors 68020
 
Join Date: Mar 2012
Quote:
Originally Posted by slothrob View Post
You could try Select All, then Get Info. That should open everything into 1 window. Close the window without making any changes. Maybe that will kick-start the images to load.
Thanks for responding. I actually fixed the problem. If I just selected it and brought up the Get Info window the metadata loaded. So I just did, Next, Next, Next until I was done. I think the problem might have come from my loading iTunes by directly connecting my usb HDD to the mac to do the drag and drop. (I did that because it was fast vs transfer over wifi) Then I reconnected the HDD to my TC. So iTunes file path was all messed up.
mic j is offline   0 Reply With Quote
Old Mar 27, 2012, 10:34 AM   #4
techchallenger
macrumors newbie
 
Join Date: Nov 2010
Quote:
Originally Posted by mic j View Post
I moved about 150 mp4's into my iTunes library yesterday. Some show up with cover art but most don't. I have found that if I "Get Info", the movie art loads into iTunes. My HD containing the movie files is networked and it can be a little slow in communicating with my MBP. Is there any way to get it to load the artwork with having to go to each iTunes entry and "Get Info"?
I have been having this problem as well. I think it happens whenever I disconnect or power down my external HD that houses all of my iTunes files. The 'get info' fix works for me as well.
techchallenger is offline   0 Reply With Quote
Old Mar 27, 2012, 10:42 AM   #5
mic j
Thread Starter
macrumors 68020
 
Join Date: Mar 2012
Quote:
Originally Posted by techchallenger View Post
I have been having this problem as well. I think it happens whenever I disconnect or power down my external HD that houses all of my iTunes files. The 'get info' fix works for me as well.
I have started closing iTunes before I do any movie transfer work. I transfer lossless files to my MBP for transcode/metadata, then transfer back to original location. Then I open iTunes back up and add the files to the library over wifi. A little slow but doable if I do small chunks (5 or 6 at a time).
mic j is offline   0 Reply With Quote
Old Mar 29, 2012, 09:55 AM   #6
Flyfrnk1624
macrumors member
 
Join Date: Jan 2009
Location: Buffalo, NY
I'm having this same issue as well. I have all of my movies stored on an external hard drive connected directly to my iMac. Every time I seem to power down my iMac, the next time I go into iTunes most of my movie cover art is missing. Yes, going through each movie and selecting "Get Info" brings back the cover art, but there has to be a better solution than doing this for 200+ movies every time. Any other thoughts or fixes?
Flyfrnk1624 is offline   0 Reply With Quote
Old Mar 29, 2012, 10:42 AM   #7
mic j
Thread Starter
macrumors 68020
 
Join Date: Mar 2012
Quote:
Originally Posted by Flyfrnk1624 View Post
I'm having this same issue as well. I have all of my movies stored on an external hard drive connected directly to my iMac. Every time I seem to power down my iMac, the next time I go into iTunes most of my movie cover art is missing. Yes, going through each movie and selecting "Get Info" brings back the cover art, but there has to be a better solution than doing this for 200+ movies every time. Any other thoughts or fixes?
I have stopped having this problem. Once I do the "Get Info" to load the cover art it has been stable. I have changed the way I have edited the metadata however (including adding/changing cover art). I have started using Subler to always edit the metadata and not do it in iTunes. I read somewhere that for files Optimized using Subler, iTunes has to do some re-writing of the file if you edit in iTunes. And it is slow. Yesterday, I started to do the edits using Subler and it is much faster. Seems like my iTunes art work is more stable too. One thing I learned yesterday, is if I do edit using iTunes, I get the spinning beach ball for a long time and if I go to the Activity Monitor, is shows iTunes is unresponsive. It's not, it is slowly transferring data to the remote HDD. If you wait long enough, it will eventually finish it's edit. However, if you interrupt the process, you can possible corrupt the file.
__________________
17" MBP '09, 2.66 GHz, 8GB RAM; 13" MBP (Retina) '12, 2.5GHz, 8GB RAM; iPad 2, 32GB; iPhone 5s; AE; AppleTV 3; AEBS w 1TB Seagate HDD; 65" Mits DLP, Sony STR-DB1070 AVR
mic j is offline   0 Reply With Quote
Old Mar 29, 2012, 12:57 PM   #8
Flyfrnk1624
macrumors member
 
Join Date: Jan 2009
Location: Buffalo, NY
Quote:
Originally Posted by mic j View Post
I have stopped having this problem. Once I do the "Get Info" to load the cover art it has been stable. I have changed the way I have edited the metadata however (including adding/changing cover art). I have started using Subler to always edit the metadata and not do it in iTunes. I read somewhere that for files Optimized using Subler, iTunes has to do some re-writing of the file if you edit in iTunes. And it is slow. Yesterday, I started to do the edits using Subler and it is much faster. Seems like my iTunes art work is more stable too. One thing I learned yesterday, is if I do edit using iTunes, I get the spinning beach ball for a long time and if I go to the Activity Monitor, is shows iTunes is unresponsive. It's not, it is slowly transferring data to the remote HDD. If you wait long enough, it will eventually finish it's edit. However, if you interrupt the process, you can possible corrupt the file.
Thanks for the response, certainly informative. Most (if not all) of my cover is done either using iFlicks or Subler, which is why I was rather perplexed why this issue was still occurring.
Flyfrnk1624 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Apple TV and Home Theater

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Movie Cover Art ZeRoLiMiT Apple TV and Home Theater 4 Aug 6, 2013 03:44 PM
iTunes Disappearing Movie Art Aragornii Mac Applications and Mac App Store 4 May 2, 2013 08:04 PM
Movie Art In Video Menu Allanb1985 iPad Tips, Help and Troubleshooting 5 Apr 5, 2013 06:09 PM
movie cover art in iTunes 11 dlegend Apple TV and Home Theater 1 Dec 9, 2012 05:54 PM
iTunes lost movie art? Daniel97 Mac Applications and Mac App Store 0 Sep 8, 2012 04:57 AM

Forum Jump

All times are GMT -5. The time now is 04:51 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC