Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X

Reply
 
Thread Tools Search this Thread Display Modes
Old Mar 31, 2012, 08:06 PM   #1
rsherid
macrumors member
 
Join Date: Jul 2009
Why won't Safari's security certificates for Facebook and Twitter verify on my connec

At least once every day a box pops up that says Safari can't verify the identity of Facebook.com or Twitter.com. I click OK or adjust it so say "Always Trust" and then Facebook.com goes blank. The blank page will say access denied, page cannot be found, etc. etc.

All the fixes I've found online seem to be Windows-based and suggest making sure the clock/time is accurate. Mine has always been up to date so that's not an option for me. I've also disabled pop-ups as per a suggestion and that didn't do anything.

So if there's any Mac users with knowledge of security certificates, it'd be a huge help.

Using:
SAFARI 5.1.2
SNOW LEOPARD 10.6.8
WIRELESS VIA ROUTER
rsherid is offline   0 Reply With Quote
Old Apr 1, 2012, 12:18 AM   #2
rsherid
Thread Starter
macrumors member
 
Join Date: Jul 2009
This is currently happening when I go to YouTube.com
rsherid is offline   0 Reply With Quote
Old Apr 2, 2012, 01:05 AM   #3
rsherid
Thread Starter
macrumors member
 
Join Date: Jul 2009
This is the site I get redirected to after clicking "Continue" on the security certificate:

https://s-static.ak.fbcdn.net/connec...ud.com&https=1
rsherid is offline   0 Reply With Quote
Old Apr 2, 2012, 02:22 AM   #4
nataliathespy
macrumors newbie
 
Join Date: Apr 2012
Just got this to work for me

I am sorry that no one has responded to you! I have had the same question, and was finally able to get something to work (at least, I have not had any further errors....yet). I am running Snow Leopard (OS X 10.6.8) and Safari 5.1.4.

Follow the "Network Preferences" instructions found in this thread: https://discussions.apple.com/message/15663396#15663396
Open Network Preferences.
Click the active network card (wired or wireless).
Click Advanced...
Click Proxies tab.
Enable "Auto Proxy Discovery" (probably enabled already) and enable "Automatic Proxy Configuration".
Click OK
Click Apply
Close Network Preferences
Restart your MAC
If that doesn't work, give these instructions a try: http://forums.macrumors.com/showthread.php?t=1168976. I did not have the "com.apple.security.revocation.plist" file in that directory--I only had "com.apple.security.plist", so I left it as is.

Hope that helps.
nataliathespy is offline   0 Reply With Quote
Old Apr 7, 2012, 06:00 PM   #5
rsherid
Thread Starter
macrumors member
 
Join Date: Jul 2009
Hey, thanks. I tried your first suggestion, which worked until today. I didn't have ~/Library/Preferences/com.apple.security.revocation.plist, but I have deleted the regular .plist file before (as suggested) and still doesn't work.

This is becoming a major problem - what if I wiped my hard drive and started a new OS X user account?
rsherid is offline   0 Reply With Quote
Old Apr 11, 2012, 07:31 PM   #6
rsherid
Thread Starter
macrumors member
 
Join Date: Jul 2009
This is what the error looks like:

rsherid is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 08:07 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC