Go Back   MacRumors Forums > iPhone, iPod and iPad > iPhone

Reply
 
Thread Tools Search this Thread Display Modes
Old Apr 4, 2012, 06:09 PM   #1
Mick89
macrumors newbie
 
Join Date: Jun 2010
iPhone 4S SMS Issue

Hi all,

Recently I've been having an issue with SMS messaging on my iPhone 4S. The progress bar along the top will fill to about 80% full, and then stop for a good minute/minute and a half. At this point the red '!' icon appears, to indicate the message has not been sent.

Tapping the '!', and then tapping 'Try Again' does nothing, and I'm instantly presented with the red '!' icon again. It happens so quickly that it appears the iPhone didn't even attempt to send the message again.

This has been happening on and off since I got my iPhone in October, but recently the problem has been getting much worse. I've never had an issue with O2 signal before. Has anyone else had this problem, and if so, does anyone know a way to rectify this issue?

The image below shows a screenshot of the issue:



Thanks in advance,
Michael
Mick89 is offline   0 Reply With Quote
Old Apr 4, 2012, 06:11 PM   #2
Shadowbech
macrumors 65816
 
Join Date: Oct 2011
Location: Central U.S.
Have you tried rebooting your device?
__________________
iPhone 6 Plus Space Gray 128 GB; White iPad rMini 128 GB (iOS 7.1.2); iPhone 3G -> 3GS -> 4 -> 4S -> Galaxy S4 -> S5 -> iPhone 6 Plus Gold 128 GB <- Current. I can't decide on what color to get. Ugh.
Shadowbech is offline   0 Reply With Quote
Old Apr 5, 2012, 09:19 AM   #3
Mick89
Thread Starter
macrumors newbie
 
Join Date: Jun 2010
Hi Shadowbech,

Thanks for your prompt response! I've restarted my device numerous times and I've also updated my iPhone to the latest software (iOS 5.1). The issue comes and goes, so I'm not sure what is causing the issue!! Just wondering had anyone else had the same issue?

Thanks,
Michael
Mick89 is offline   0 Reply With Quote
Old Apr 5, 2012, 09:38 AM   #4
lear45xr
macrumors newbie
 
Join Date: Jun 2009
Quote:
Originally Posted by Mick89 View Post
Hi Shadowbech,

Thanks for your prompt response! I've restarted my device numerous times and I've also updated my iPhone to the latest software (iOS 5.1). The issue comes and goes, so I'm not sure what is causing the issue!! Just wondering had anyone else had the same issue?

Thanks,
Michael
hi i had same problem when i changed from iphone to 4s i took it to a o2 shop & got a new sim card which helped but it still done it from time to time. if you switch on airplane mode for a few seconds & switch it off again you should be able to send & recieve txts my problem has been fixed from i downloaded 5.1
lear45xr is offline   0 Reply With Quote
Old Apr 5, 2012, 10:51 AM   #5
TonyC28
macrumors 6502a
 
Join Date: Aug 2009
Same problem here. iPhone 4S with 5.1. Has been happening since I got my 4S so I can't say if it's iOS 5 or the 4S.
TonyC28 is offline   0 Reply With Quote
Old Apr 5, 2012, 11:00 AM   #6
Old Smuggler
macrumors 6502a
 
Old Smuggler's Avatar
 
Join Date: Sep 2006
Not really sure
Old Smuggler is offline   0 Reply With Quote
Old May 21, 2012, 07:36 PM   #7
TonyC28
macrumors 6502a
 
Join Date: Aug 2009
This seemed to be happening more and more for me lately. I restored my phone today to see if that helps. It's definitely getting old.
TonyC28 is offline   0 Reply With Quote
Old May 21, 2012, 07:57 PM   #8
DroidRules
Banned
 
Join Date: Aug 2010
Go get a new sim from your provider. I have done it before and paid nothing.
DroidRules is offline   0 Reply With Quote
Old May 21, 2012, 08:06 PM   #9
Nonono
macrumors newbie
 
Join Date: Mar 2012
That almost seems like your service provider is having problems.
Nonono is offline   1 Reply With Quote
Old May 21, 2012, 08:13 PM   #10
Troneas
macrumors 65816
 
Troneas's Avatar
 
Join Date: Oct 2011
Location: At the hacks section.
does it happen with everyone?

i couldn't help but notice your weak wifi reception.

if you are sending these to another iPhone with iOS 5 your iPhone will attempt to send an iMessage instead over your wifi i think.
Troneas is offline   0 Reply With Quote
Old May 21, 2012, 08:37 PM   #11
Applejuiced
macrumors Nehalem
 
Applejuiced's Avatar
 
Join Date: Apr 2008
Location: At the iPhone hacks section.
Quote:
Originally Posted by Nonono View Post
That almost seems like your service provider is having problems.
I agree.
Never had that prob with AT&T.
Call up your carrier, maybe they need to update or reset something on their end.
Applejuiced is offline   0 Reply With Quote
Old May 21, 2012, 08:46 PM   #12
Gav2k
macrumors 601
 
Gav2k's Avatar
 
Join Date: Jul 2009
Settings > general > reset > reset networks settings usually solves this
Gav2k is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iPhone

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
SMS Issue In iPhone 4 CDMA In India pankajbiswas iPhone Tips, Help and Troubleshooting 18 Oct 9, 2013 02:29 PM
Issue with name in SMS/iMessage lordofthereef iPhone 3 May 22, 2013 12:51 AM
New SMS Scrolling Bug/Issue MCalhoun23 iPhone Tips, Help and Troubleshooting 1 Sep 26, 2012 11:30 PM
Apple Pitches Security of iMessage in Response to SMS Spoofing Issue MacRumors MacRumors.com News Discussion 91 Aug 22, 2012 05:41 PM
iPhone Security Issue Opens Door to SMS Spoofing MacRumors MacRumors.com News Discussion 59 Aug 20, 2012 07:45 AM

Forum Jump

All times are GMT -5. The time now is 01:59 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC