Go Back   MacRumors Forums > Apple Systems and Services > Programming > Mac Programming

Reply
 
Thread Tools Search this Thread Display Modes
Old Apr 22, 2012, 09:22 AM   #1
Laggi
macrumors newbie
 
Join Date: Apr 2012
Problems with embedded lua in C

I have a program written on C which compiling without problems on Linux
and Snow Leopard.
Some days ago I embedded lua and after that I got some prolems.

On Linux I compile now with LDFLAGS = -llua in makefile.

I also added the same for Makefile on Mac. But now on Mac I got this errors:

Code:
> CC=gcc-4.0 make arch=i386
Undefined symbols: 
....
ld: symbol(s) not found
collect2: ld returned 1 exit status
Whats the problem? Lua compiled from sources for i386 arch. (Compiled for x86_64 - same problems)

Thanks, any help is much appreciated.
Laggi is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Programming > Mac Programming

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Embedded URLS and Georiot SaSaSushi Site and Forum Feedback 3 Mar 5, 2014 12:38 PM
Note 3 with 64 GB embedded? Twixt Alternatives to iOS and iOS Devices 2 Dec 20, 2013 12:01 PM
Should I learn any other language before learning LUA? quantic iPhone/iPad Programming 6 Jun 27, 2013 02:09 AM
iPad: Embedded Documents/frames JP89Hornet iOS 6 0 Oct 16, 2012 07:00 PM

Forum Jump

All times are GMT -5. The time now is 12:58 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC