Go Back   MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Reply
 
Thread Tools Search this Thread Display Modes
Old May 27, 2012, 07:01 PM   #1
thetrumanator
macrumors newbie
 
Join Date: Apr 2011
Macbook Air not updating, errors

Ok, so earlier today I was trying to update to 10.7.4, and multiple times I got the error the Mac OSX update could not be expanded, and corrupted during download. PLease try again. I tried over and over to get it to work, manually downloading it, resetting pram, smc, and repairing the disk and disk permissions in recovery mode. All of this to no avail. So I was trying to partition the hard drive to find out what was going on and accidentally deleted my entire hard drive. I didn't have anything important on it so Im not sad there, but when it was time to install lion, I went through all of the steps and license agreement, and tried to download it. I did this twice and it got stuck in an eternal download loop, not downloading anything. This is odd because I have 40 mBits internet. It was not my internet as I could use it on every other computer. So I broke out my old snow leopard install usb drive, and now have snow leopard. But now it won't install updates either. I performed hard drive checks and it all says it's all right. I also completed a quick hardware scan and nothing came back. RIght now Im running an extended test. I NEED SOMEONE TO HELP ME!!!! I have no idea whats wrong and my warranty ran out because I couldn't afford it at the time.
Thanks to anyone,
Truman

----------

the extended test just finished and found no problems. I can use the computer just fine for internet and stuff but cannot download updates, and now Im stuck in snow leopard
__________________
Anyone wanna buy my crappy Dell?
thetrumanator is offline   0 Reply With Quote
Old May 28, 2012, 04:53 AM   #2
Puevlo
macrumors 6502a
 
Join Date: Oct 2011
Well it looks like there is definitely an issue with it connecting to the Internet as both errors relate to the integrity of the downloaded data. I'd suggest trying another wifi connection otherwise might be your airport card is busted.
Puevlo is offline   0 Reply With Quote
Old May 28, 2012, 07:10 PM   #3
thetrumanator
Thread Starter
macrumors newbie
 
Join Date: Apr 2011
oddly enough i downloaded a torrented lion and it installed fine, and i just updated it to 10.7.4 from a torrent with no errors. I am thinking apple doesn't recognize the device as an apple so it won't verify downloads. If this is the problem how is it fixable. I always get solid downloads and had no interruptions downloading the lion torrents
__________________
Anyone wanna buy my crappy Dell?
thetrumanator is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Hardware > Notebooks > MacBook Air

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPad Air: Rented movie failed to download and errors Zmanbaseball2 iPad Tips, Help and Troubleshooting 4 May 25, 2014 08:04 AM
Updating to iTunes 11.1 gave me a ton of disk permissions errors Akuratyde Mac Applications and Mac App Store 19 Jan 3, 2014 01:24 PM
Problem with 2012 Macbook air after updating Redrum509 MacBook Air 5 Nov 4, 2013 08:55 AM
Adobe Creative Cloud still showing errors when updating? petrucci666 OS X Mavericks (10.9) 0 Oct 24, 2013 01:13 PM
Late 2010 MacBook Air...updating to ML byziphone4 MacBook Air 12 Jun 27, 2012 08:25 PM

Forum Jump

All times are GMT -5. The time now is 07:14 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC