Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Reply
 
Thread Tools Search this Thread Display Modes
Old May 14, 2012, 08:10 PM   #1
brasskey
macrumors regular
 
Join Date: Jul 2008
Emails send from wrong address - Mail version 5.2 (1257)

I hope this is not too confusing. I am not new to OSX, but I finally decided to use the Mail app for the first time. Setup was easy and I have been on it for about a month. I have the following accounts on it:

Microsoft Exchange Account
Gmail Account #1
Gmail Account #2
Yahoo Account #1
Yahoo Account #2

Today I sent an email to ~30 recipients from Gmail account #1. The email shows up in my sent folder as being sent from Gmail account #1. But, when people started replying, it came to Gmail account #2. I verified with people I sent it to that it came from Gmail account #2. Any ideas what the problem could be?
brasskey is offline   0 Reply With Quote
Old May 14, 2012, 08:21 PM   #2
Carlanga
macrumors 601
 
Carlanga's Avatar
 
Join Date: Nov 2009
Location: PR
I think you just sent the msjs w/ Gmail 2 instead of 1. Check again your sent folder on G1 to see if they are in there or if they are in the G2 sent folder.

Not posible to be replied to G2 if sent from G1, did you check the google accounts in your phone or using the web, maybe the mail app itself is messed up.
__________________
☻ "A dream you dream alone is only a dream...
... A dream you dream together is reality." ☻
Carlanga is offline   0 Reply With Quote
Old May 14, 2012, 08:42 PM   #3
brasskey
Thread Starter
macrumors regular
 
Join Date: Jul 2008
Quote:
Originally Posted by Carlanga View Post
I think you just sent the msjs w/ Gmail 2 instead of 1. Check again your sent folder on G1 to see if they are in there or if they are in the G2 sent folder.

Not posible to be replied to G2 if sent from G1, did you check the google accounts in your phone or using the web, maybe the mail app itself is messed up.

May sound not possible but it's exactly what happened. I just tested again. I sent a test email from Gmail Account #1 to my Yahoo Account #1. First picture below is what I see when I am sending the email. Second picture under that is my sent folder after the email went through.

Draft Email




Sent Folder







When the email was received from Yahoo Account #1, it was shown as sent from Gmail Account #2.

Received Email


Last edited by brasskey; May 14, 2012 at 09:08 PM.
brasskey is offline   0 Reply With Quote
Old May 14, 2012, 09:26 PM   #4
Carlanga
macrumors 601
 
Carlanga's Avatar
 
Join Date: Nov 2009
Location: PR
Again, did you check/test the google accounts in your phone or using the website, maybe the mail app itself is messed up in where the msj appear and not necessarily on the server side.
__________________
☻ "A dream you dream alone is only a dream...
... A dream you dream together is reality." ☻
Carlanga is offline   0 Reply With Quote
Old May 14, 2012, 09:47 PM   #5
brasskey
Thread Starter
macrumors regular
 
Join Date: Jul 2008
Quote:
Originally Posted by Carlanga View Post
Again, did you check/test the google accounts in your phone or using the website, maybe the mail app itself is messed up in where the msj appear and not necessarily on the server side.
Sorry, didn't check that initially. Yes, the mail app on the website is showing something different (shows email from Gmail Account #2). What does that mean? I don't understand.
brasskey is offline   0 Reply With Quote
Old May 14, 2012, 10:57 PM   #6
Carlanga
macrumors 601
 
Carlanga's Avatar
 
Join Date: Nov 2009
Location: PR
Quote:
Originally Posted by brasskey View Post
Sorry, didn't check that initially. Yes, the mail app on the website is showing something different (shows email from Gmail Account #2). What does that mean? I don't understand.
that something is wrong w/ the mail app (try reinstalling it) or something w/ the OS itself.
__________________
☻ "A dream you dream alone is only a dream...
... A dream you dream together is reality." ☻
Carlanga is offline   0 Reply With Quote
Old May 22, 2012, 08:41 AM   #7
eugenem
macrumors newbie
 
Join Date: May 2012
I am having an exact same issue.

I reply to emails from one email address. It shows that this is the address the emails is being sent from. The emails show up in the correct sent folder BUT whenever someone replies, the email goes to another inbox...

I have checked and rechecked everything. Nothing seems to be working. Any advice would be appreciated.

It started a while ago; however it was only happening sporadically. I would reply from one email address and the reply from the recipient would go to another mailbox but then it would stop and not happen again for a while. Now it happens with every email I send...
eugenem is offline   0 Reply With Quote
Old May 22, 2012, 09:29 AM   #8
eugenem
macrumors newbie
 
Join Date: May 2012
I figured it out!

Go into preferences and check the outgoing mail server for the address that you've having issues with. It will be shown as offline. Put a checkmark next to it where it says use only this server only. It will ask you to confirm the password for this account and take it back online.

It seems that something happened and the outgoing server was taken offline so the mail client has been using other outgoing servers from other accounts to send your messages which is why the replies were going to the wrong place.

Now that it's using the correct server and you're forcing it to use it, it should work just fine!
eugenem is offline   0 Reply With Quote
Old May 22, 2012, 04:38 PM   #9
PWS
macrumors newbie
 
Join Date: Feb 2008
Not only 10.8

This is happening in a client's Mail app as well in Lion. Very frustrating. I thought I had it licked last week doing something similar with editing the smtp servers but it didn't stick: today it is back to doing the wrong reply to address...it even changed an email address in the sig file from the one it should have been to the one it was using as a reply to! That behaviour is very bizarre!

Any other ideas?

Thanks, Peter
PWS is offline   0 Reply With Quote
Old Jul 30, 2012, 10:09 PM   #10
claidheamdanns
macrumors newbie
 
Join Date: Feb 2008
Location: Memphis, TN
Send a message via AIM to claidheamdanns Send a message via MSN to claidheamdanns Send a message via Yahoo to claidheamdanns
Same thing with Mountain Lion

I am getting the same problem with Mountain Lion.

Even though I have my personal website's email address set to reply with only that SMTP, all accounts are still replying with my gmail account in the Mountain Lion version of the Mail App.

I was able to resolve it by deleting the Gmail account from the Mail app's accounts list (in preferences) and rebuilding it. Since mine was initially set up using the older POP Gmail setup, I made sure to save all of my emails from that account that were still in the Inbox into a separate folder within Mail (probably an unnecessary step, but better safe than sorry). When I reset up the Gmail account it automatically configured as an IMAP account, and I have had no trouble since.
__________________
Gavin Anderson
Sterling Studios
3.06 GHz Intel Core 2 Duo iMac | 8 GB 1067 MHz DDR3 | OS X Mountain Lion 10.8.x
AT&T iPhone 4
| iOS 6

Last edited by claidheamdanns; Jul 30, 2012 at 10:19 PM. Reason: additional info, and a solution
claidheamdanns is offline   0 Reply With Quote
Old Aug 7, 2012, 03:06 PM   #11
brayhite
macrumors 6502a
 
Join Date: Jun 2010
Location: N. Kentucky
I too was having this issue. I migrated to Postbox to test it out, and noticed it was doing the same thing. So I deleted the account and rebuilt it as one person suggested, and all is working fine.

One thing I think was different was the Outgoing mail Port. However, I can't find how to change it again in Postbox to see what it was and update it on Mail and see if that's the case.

FWIW, deleting the account and rebuilding it will probably solve your problem.

UPDATE: Using this:

Quote:
Originally Posted by eugenem View Post
Go into preferences and check the outgoing mail server for the address that you've having issues with. It will be shown as offline. Put a checkmark next to it where it says use only this server only. It will ask you to confirm the password for this account and take it back online.
and adding on to it, I went to Preferences>Accounts>(account that IS NOT being replied to) and clicked the Outgoing Mail Server and clicked Edit from the drop down.

This brings up a box showing the servers being used to send mail. If you're having issues, you'll probably see all email accounts on one line next to a single server. To check it, click that server and look at the User Name under Advanced. The User Name should be the email that all replies are being sent to.

To fix this, follow eugenem's directions. Most likely the account it's supposed to be using is offline, like he said. By default, I think, if you're using Gmail accounts they're all named Gmail. Change that in the Edit menu and match the server name with the email addy to avoid confusion.
__________________
Feasog Rua

Last edited by brayhite; Aug 7, 2012 at 03:15 PM.
brayhite is offline   0 Reply With Quote
Old Apr 16, 2013, 09:15 AM   #12
Designandgrace
macrumors newbie
 
Join Date: Apr 2013
Quote:
Originally Posted by eugenem View Post
I figured it out!

Go into preferences and check the outgoing mail server for the address that you've having issues with. It will be shown as offline. Put a checkmark next to it where it says use only this server only. It will ask you to confirm the password for this account and take it back online.

It seems that something happened and the outgoing server was taken offline so the mail client has been using other outgoing servers from other accounts to send your messages which is why the replies were going to the wrong place.

Now that it's using the correct server and you're forcing it to use it, it should work just fine!
Thanks for that advice. I was having the same issues as in this thread and your solution worked perfectly!
Designandgrace is offline   0 Reply With Quote
Old Apr 17, 2013, 02:59 PM   #13
joec1101
macrumors 6502
 
Join Date: Jun 2010
Location: So Cal, USA
I had the same problem and this solution worked for me as well.

To take it a step further, I don't believe there is a setting for this in ios mail.app; so, if I sync my mail accounts to iPhone and iPad, will the ios mail.app function the same way (restrict the outgoing smtp server)?
joec1101 is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > OS X > OS X 10.8 Mountain Lion

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Can't send messages with Gmail address in Mail.app DramaLLama Mac Applications and Mac App Store 0 Apr 20, 2014 09:22 PM
Mail App - Send response from different address mrmeister OS X Mavericks (10.9) 3 Mar 4, 2014 07:47 PM
mail won't send group address Franny4321 Mac Applications and Mac App Store 0 Jan 30, 2014 09:40 AM
I can send but I am not receiving emails on Mac Mail (Hotmail account) CRIB Mac Applications and Mac App Store 5 Jan 25, 2014 04:36 AM
Getting mail to send with the same address... itsjustmeee Mac Applications and Mac App Store 1 Jan 13, 2013 09:58 PM

Forum Jump

All times are GMT -5. The time now is 07:01 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC