Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > Jailbreaks and iOS Hacks

Reply
 
Thread Tools Search this Thread Display Modes
Old Jun 18, 2012, 03:54 AM   #1
KJmoon117
macrumors 6502a
 
Join Date: Jun 2007
Location: NC
Finally! iPhone 3GS Baseband Downgrade Available!

Finally the iPhone Dev-Team or Musclenerd has finally released the 6.15 baseband downgrade for us iPhone 3GS users who screwed up upgrading to the iPad baseband.

http://blog.iphone-dev.org/post/25350690843/0615-fun

Now we can downgrade to a unlockable baseband while being able to use our GPS... or we can now sell our phones
KJmoon117 is offline   1 Reply With Quote
Old Jun 18, 2012, 04:03 AM   #2
occamsrazor
macrumors 6502
 
Join Date: Feb 2007
This is great news. One thing I'm not clear about though - my 3GS is currently on baseband 05.16.05 (therefore not unlockable). Can I use this to downgrade to 05.13.04? If so can I do this directly, or must I "upgrade" to 06.15 first as an intermediary step?
__________________
MacBook Pro 13" 2.9Ghz i7
MacBook Pro 13" 2.26Ghz C2D
Mac Mini 2009/2.26Ghz, Mac Mini PPC/1.42Ghz
iPhone 5S, 4S
occamsrazor is offline   0 Reply With Quote
Old Jun 18, 2012, 04:07 AM   #3
KJmoon117
Thread Starter
macrumors 6502a
 
Join Date: Jun 2007
Location: NC
Quote:
Originally Posted by occamsrazor View Post
This is great news. One thing I'm not clear about though - my 3GS is currently on baseband 05.16.05 (therefore not unlockable). Can I use this to downgrade to 05.13.04? If so can I do this directly, or must I "upgrade" to 06.15 first as an intermediary step?
Yes you'll have to first upgrade to 06.15. However, be very careful to see if that baseband is compatible. Read the instructions FULLY or else you may fry your radio.
KJmoon117 is offline   0 Reply With Quote
Old Jun 18, 2012, 04:10 AM   #4
occamsrazor
macrumors 6502
 
Join Date: Feb 2007
Quote:
Originally Posted by KJmoon117 View Post
Yes you'll have to first upgrade to 06.15. However, be very careful to see if that baseband is compatible. Read the instructions FULLY or else you may fry your radio.
Thanks... I'll check the baseband compatibility with 06.15 in detail later. Can I use the same RedSnow latest 0.9.14b1 to do the upgrading to 06.15?
__________________
MacBook Pro 13" 2.9Ghz i7
MacBook Pro 13" 2.26Ghz C2D
Mac Mini 2009/2.26Ghz, Mac Mini PPC/1.42Ghz
iPhone 5S, 4S
occamsrazor is offline   0 Reply With Quote
Old Jun 18, 2012, 06:40 AM   #5
aziatiklover
macrumors 68020
 
aziatiklover's Avatar
 
Join Date: Jul 2011
Location: 8.8.8.8 and 8.8.4.4
Quote:
Originally Posted by occamsrazor View Post
Thanks... I'll check the baseband compatibility with 06.15 in detail later. Can I use the same RedSnow latest 0.9.14b1 to do the upgrading to 06.15?
Yes u can use the latest to upgrade or downgrade baseband.
__________________
ppleholic
aziatiklover is offline   0 Reply With Quote
Old Jun 18, 2012, 12:27 PM   #6
PrayForDeath
macrumors 6502
 
Join Date: Jan 2012
I tried downgrading several times, and my baseband still shows as 06.15

Any ideas?
PrayForDeath is offline   -1 Reply With Quote
Old Jun 18, 2012, 12:35 PM   #7
bjornm
macrumors member
 
Join Date: Jun 2008
Does this work on bricked iPhones as well

Curious to know if this will work on my bricked iPhone as I wont be able to do a controlled shutdown.
bjornm is offline   0 Reply With Quote
Old Jun 18, 2012, 01:29 PM   #8
PrayForDeath
macrumors 6502
 
Join Date: Jan 2012
Quote:
Originally Posted by bjornm View Post
Curious to know if this will work on my bricked iPhone as I wont be able to do a controlled shutdown.
Sadly, no
PrayForDeath is offline   0 Reply With Quote
Old Jun 18, 2012, 09:16 PM   #9
KJmoon117
Thread Starter
macrumors 6502a
 
Join Date: Jun 2007
Location: NC
Quote:
Originally Posted by bjornm View Post
Curious to know if this will work on my bricked iPhone as I wont be able to do a controlled shutdown.
Actually I was able to downgrade my phone that was in a perpetual DFU mode. Not sure if that counts as bricked.
KJmoon117 is offline   0 Reply With Quote
Old Jun 19, 2012, 11:27 AM   #10
occamsrazor
macrumors 6502
 
Join Date: Feb 2007
Dev-team says:

Quote:
The iPad baseband is not compatible with 3GS units manufactured week 34 of 2011 or later. If you have an iPhone3GS and if digits 3-5 of its Serial Number are 134 or later (xx134…), then you should NOT try to install the 06.15 baseband on your 3GS! It will brick your radio, preventing both the downgrade from working and normal iPhone software from using it as a phone! Be warned!
This doesn't make sense to me. My serial is 889431xxxxx which would imply it is not compatible with 06.15. However my 3GS was bought much earlier than week 34 of 2011, I think it was sometime in early 2010. Or am I reading the wrong serial? I'm looking at Settings > General > About > "Serial Number"

EDIT: This useful website decodes my serial as:
Production year: 2009
Production week: 43 (October)
__________________
MacBook Pro 13" 2.9Ghz i7
MacBook Pro 13" 2.26Ghz C2D
Mac Mini 2009/2.26Ghz, Mac Mini PPC/1.42Ghz
iPhone 5S, 4S

Last edited by occamsrazor; Jun 19, 2012 at 11:33 AM.
occamsrazor is offline   -1 Reply With Quote
Old Jun 19, 2012, 12:39 PM   #11
BlueRaider
macrumors regular
 
Join Date: Mar 2012
You need to check your 3GS and make sure it doesn't also have the old BootROM. It's right within the zone were they started being changed to the new BootROM
BlueRaider is offline   0 Reply With Quote
Old Jun 19, 2012, 01:24 PM   #12
occamsrazor
macrumors 6502
 
Join Date: Feb 2007
Quote:
Originally Posted by BlueRaider View Post
You need to check your 3GS and make sure it doesn't also have the old BootROM. It's right within the zone were they started being changed to the new BootROM
Bootrom is 359.3.2, which I believe makes it NEW BootROM - so where does that leave me?
__________________
MacBook Pro 13" 2.9Ghz i7
MacBook Pro 13" 2.26Ghz C2D
Mac Mini 2009/2.26Ghz, Mac Mini PPC/1.42Ghz
iPhone 5S, 4S
occamsrazor is offline   0 Reply With Quote
Old Jun 19, 2012, 01:53 PM   #13
dZp
macrumors 6502a
 
Join Date: Mar 2006
nvm
__________________
ɹɐǝddɐ ʎǝɥʇ uɐɥʇ ɹǝsolɔ ǝɹɐ ɹoɹɹıɯ uı sʇɔǝɾqo
dZp is offline   0 Reply With Quote
Old Jun 19, 2012, 04:10 PM   #14
occamsrazor
macrumors 6502
 
Join Date: Feb 2007
Wow... Had to be very patient over about 2 hours... but it worked! First I upgraded to 06.15 then redid the whole process and downgraded, then installed Ultrasnow, and voila... my 3GS that had been useless for the last 6 months is now a phone again. Big kudos to musclenerd for getting this working. I was waiting the last six months hoping a solution would be found, have to say I was sceptical it would ever happen, but he delivered.
__________________
MacBook Pro 13" 2.9Ghz i7
MacBook Pro 13" 2.26Ghz C2D
Mac Mini 2009/2.26Ghz, Mac Mini PPC/1.42Ghz
iPhone 5S, 4S
occamsrazor is offline   0 Reply With Quote
Old Jun 20, 2012, 12:31 PM   #15
cubian
macrumors regular
 
Join Date: Dec 2010
just like to make sure if my serial for my 3gs is XX929XXXXXX then i can't downgrade my baseband? and i should not try to unlock with new redsnow?

Just dig a little more deeper...and found out my iphone info..

according to the website above.

which showed my iphone is
Production year: 2009
Production week: 29 (July)

but accroding to the news post where it stated " The iPad baseband is not compatible with 3GS units manufactured week 34 of 2011 or later"

at this point it looks like i can install ipad baseband.but it went on with

"If you have an iPhone3GS and if digits 3-5 of its Serial Number are 134 or later (xx134), then you should NOT try to install the 06.15 baseband on your 3GS! It will brick your radio, preventing both the downgrade from working and normal iPhone software from using it as a phone! Be warned!"


so wit my ser number is XX929XXXXXX am i able to downgrade my 3gs without brick your radio, preventing both the downgrade from working and normal iPhone
cubian is offline   0 Reply With Quote
Old Jun 20, 2012, 06:53 PM   #16
haroldsoto
macrumors newbie
 
Join Date: Jun 2012
Question Need some help on this.

Hey there, i got a 3GS, with BB 06.15 with an sn0wbreeze hacktivated ISPW. I unlocked it with ultrasn0w but notifications didn't work, and managed to install SAM when it worked, unlocked it with it and notifications and GPS are working correctly since then, even though there are still some battery issues, (ultrasn0w and SAM on this).

I'm looking forward to sell this phone, and i was wondering if i downgrade the baseband will i lose my notifications (wich SAM fixed back then) when i install ultrasn0w again?. What i want, is to be able to restore with an original IPSW, unlock it with ultrasn0w and have notifications fully working (if its possible). Is it safe to go for it?, or what should i do in this case?. Please let me know. Thanks.
haroldsoto is offline   0 Reply With Quote
Old Aug 29, 2012, 09:49 PM   #17
IanCO
macrumors newbie
 
Join Date: Mar 2012
Location: Trinidad & Tobago
Quote:
Originally Posted by KJmoon117 View Post
Yes you'll have to first upgrade to 06.15. However, be very careful to see if that baseband is compatible. Read the instructions FULLY or else you may fry your radio.
Is it that the only way to downgrade to 05.13.04 is to upgrade to 06.15? Does this mean that ppl with iphone 3gs's after week 34 of 2011 with 05.16.05 bb are screwed??
IanCO is offline   0 Reply With Quote
Old Aug 29, 2012, 09:53 PM   #18
dhlizard
macrumors G3
 
dhlizard's Avatar
 
Join Date: Mar 2009
Location: The Jailbreak Community
Quote:
Originally Posted by IanCO View Post
Is it that the only way to downgrade to 05.13.04 is to upgrade to 06.15? Does this mean that ppl with iphone 3gs's after week 34 of 2011 with 05.16.05 bb are screwed??
Actually any 3GS made after the 27th week of 2011 is likely to be damaged if the iPad baseband flash is attempted.

Without the baseband flash, the downgrade cannot occur.
__________________
iPhone 6+ iPhone 5S
iPad Air2 iPad Air AppleTV 2
MacBook Pro Two iMacs

Look for me here
dhlizard is offline   0 Reply With Quote
Old Aug 29, 2012, 10:51 PM   #19
IanCO
macrumors newbie
 
Join Date: Mar 2012
Location: Trinidad & Tobago
then I'm screwed!
IanCO is offline   0 Reply With Quote
Old Aug 29, 2012, 11:06 PM   #20
Applejuiced
macrumors Nehalem
 
Applejuiced's Avatar
 
Join Date: Apr 2008
Location: At the iPhone hacks section.
Quote:
Originally Posted by IanCO View Post
then I'm screwed!
Pretty much.
Applejuiced is offline   0 Reply With Quote
Old Aug 30, 2012, 08:19 AM   #21
dhlizard
macrumors G3
 
dhlizard's Avatar
 
Join Date: Mar 2009
Location: The Jailbreak Community
But you can get a carrier or grey market dealer IMEI unlock.
__________________
iPhone 6+ iPhone 5S
iPad Air2 iPad Air AppleTV 2
MacBook Pro Two iMacs

Look for me here
dhlizard is offline   0 Reply With Quote
Old Jan 6, 2013, 04:56 PM   #22
Beddufigghiu
macrumors newbie
 
Join Date: Jan 2013
Quote:
Originally Posted by occamsrazor View Post
Wow... Had to be very patient over about 2 hours... but it worked! First I upgraded to 06.15 then redid the whole process and downgraded, then installed Ultrasnow, and voila... my 3GS that had been useless for the last 6 months is now a phone again. Big kudos to musclenerd for getting this working. I was waiting the last six months hoping a solution would be found, have to say I was sceptical it would ever happen, but he delivered.
I would like to try your trick but I can't find out how to upgrade to 06.15 first...having already everything I need to downgrade to the iPad baseband. Some help would be really appreciated since I've been stuck for over 2 hours already! Thanks
Beddufigghiu is offline   0 Reply With Quote
Old Jan 6, 2013, 05:43 PM   #23
dhlizard
macrumors G3
 
dhlizard's Avatar
 
Join Date: Mar 2009
Location: The Jailbreak Community
There is a step by step tutorial on iClarified.com
__________________
iPhone 6+ iPhone 5S
iPad Air2 iPad Air AppleTV 2
MacBook Pro Two iMacs

Look for me here
dhlizard is offline   0 Reply With Quote
Old Jul 17, 2013, 01:36 PM   #24
ShriksR
macrumors newbie
 
Join Date: Jul 2013
Quote:
Originally Posted by dhlizard View Post
But you can get a carrier or grey market dealer IMEI unlock.
I have 3gs new bootrom in iOS 5.0.1 BB 6.15.00 i contact to the imei unlocker they said that iphone must be have 5.13.04 to factory unlock so if i downgrade bb so it will brick my radio
ShriksR is offline   0 Reply With Quote
Old Jul 17, 2013, 02:09 PM   #25
dhlizard
macrumors G3
 
dhlizard's Avatar
 
Join Date: Mar 2009
Location: The Jailbreak Community
New bootrom does not mean you cannot downgrade the baseband.
Any 3GS made before the 27th week of 2011 can be safely downgraded.

If you are getting IMEI unlock, no need to preserve baseband.
__________________
iPhone 6+ iPhone 5S
iPad Air2 iPad Air AppleTV 2
MacBook Pro Two iMacs

Look for me here
dhlizard is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > Jailbreaks and iOS Hacks

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone: Downgrade baseband in 3GS ahdhulla Jailbreaks and iOS Hacks 6 Mar 22, 2013 08:38 AM
iPhone: Iphone 3GS Baseband Downgrade astray003 Jailbreaks and iOS Hacks 27 Jan 15, 2013 08:17 PM
downgrade 3GS 5.1 baseband? andybno1 Jailbreaks and iOS Hacks 6 Jun 22, 2012 12:55 PM
iPhone 3g-3GS 6.15.00 baseband downgrade Samad Malik Jailbreaks and iOS Hacks 1 Jun 10, 2012 10:59 AM

Forum Jump

All times are GMT -5. The time now is 09:30 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC