Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 6

Reply
 
Thread Tools Search this Thread Display Modes
Old Sep 27, 2012, 10:28 AM   #26
pman555
macrumors newbie
 
Join Date: Apr 2012
Quote:
Originally Posted by KaPOWitsCHRIS View Post
This worked great for me. I managed to recheck contacts and it didn't come back, although we'll wait and see for whoever has a birthday next.
I did all of this and the birthdays reappeared in my notification center.

So am I to assume its either keep all the birthdays in the notification center or have ZERO Facebook contact integration?

Has anyone figured out a workaround?
pman555 is offline   0 Reply With Quote
Old Oct 7, 2012, 09:44 AM   #27
Adam-
macrumors member
 
Join Date: Mar 2011
Quote:
Originally Posted by gforce216 View Post
I had that problem and I turned Contacts and Calendar for Facebook both off then enabled Calendar again so that it only gave me birthdays of people in my phone contacts list.
This worked for me thanks!
Adam- is offline   0 Reply With Quote
Old Oct 13, 2012, 08:27 AM   #28
malaka
macrumors newbie
 
Join Date: Oct 2012
Default Alert Times: disable birthday notifications without disabling contacts

Okay, so after a month of being frustrated, I finally discovered that you can disable just the birthday notifications by going to settings>mail, contacts, and calendars>Calendar: Default Alert Times>birthdays: select 'none'

Works for me and keeps my Facebook contact info intact. This should have been more straightforward than going to "default alert times," but at least now I don't get notifications every morning in class for random acquaintance birthday reminders.
malaka is offline   0 Reply With Quote
Old Oct 16, 2012, 10:06 PM   #29
Emt080027
macrumors newbie
 
Join Date: Oct 2012
A lot of people seem to be having this problem. I deleted my Facebook Account from my Settings and then logged back in and turned calendar and contacts off. Everything was deleted from my calendar except what I had added to my calendar. No events, no annoying birthdays.
Emt080027 is offline   0 Reply With Quote
Old Oct 19, 2012, 06:22 AM   #30
JKtheOREO
macrumors newbie
 
Join Date: Oct 2012
I created an account just to give you guys the solution.

Settings > FaceBook > Allow these apps to use your: Calendars (off)
JKtheOREO is offline   1 Reply With Quote
Old Oct 19, 2012, 01:09 PM   #31
Oridus
macrumors regular
 
Join Date: Oct 2012
Quote:
Originally Posted by JKtheOREO View Post
I created an account just to give you guys the solution.

Settings > FaceBook > Allow these apps to use your: Calendars (off)
This has been proven not to work, as seen below:



__________________
|2.7gHz, 16GB Ram, 512SSD Retina Macbook Pro (June 2013) | Black 32 GB iPad 4th Gen | 16gb Black iPhone 5s |3rd Gen Apple TV|

Last edited by Oridus; Oct 19, 2012 at 01:19 PM.
Oridus is offline   0 Reply With Quote
Old Oct 19, 2012, 05:25 PM   #32
JKtheOREO
macrumors newbie
 
Join Date: Oct 2012
Works for me
JKtheOREO is offline   0 Reply With Quote
Old Nov 5, 2012, 09:17 AM   #33
L-U-R-C-H
macrumors regular
 
Join Date: Mar 2007
Location: Iowa
I have tried everything and eventually the annoying facebook birthdays end up showing up in notification center. This has to be a bug.
__________________
www.mattrittman.com
L-U-R-C-H is offline   0 Reply With Quote
Old Nov 6, 2012, 03:22 PM   #34
kevinspellman
macrumors newbie
 
Join Date: Jan 2010
Not Facebook

The issue is not facebook at all. It's just if you have ANY contacts that have the birthday field filled in. The trouble is that within notification center, you do not have the ability to specify which calendars will appear on your notification center, hopefully this is fixed with a software update soon!!
kevinspellman is offline   0 Reply With Quote
Old Nov 11, 2012, 10:52 PM   #35
Ayaz
macrumors newbie
 
Join Date: Nov 2012
For contacts whose birthdays I need to track I add their birthdays manually to the iCloud version of the unified contact. This then shows up in the Notification Centre under Calendar. However, entries for birthdays for FB contacts started appearing in the Notification Centre as well. I had FB Calendar disabled and I only had the Birthday calendar for contacts available within Calendar. While for birthdays entered manually, events would show up inside the Calendar, for FB Contacts, they wouldn't yet they would still appear in the notification centre. And if you clicked on them from the notification centre, you would be taken to the Calendar app with the FB birthday calendar automatically activated.

What I did was follow someone's advice here to disable Contacts integration from FB's settings inside Settings > Facebook. I had to then load up the Calendar app to see the new settings. After that the FB calendar entries disappeared from the notification centre.

I hope this helps someone.
Ayaz is offline   0 Reply With Quote
Old Nov 12, 2012, 12:41 PM   #36
asdfghjkl13
macrumors newbie
 
Join Date: Nov 2012
I was having this same problem and read through as well as followed the directions to each of the ideas stated before me, but none of them worked so I just went through all of the different sections that used Facebook and Calendars and found that turning it off in the iCloud section worked. Just thought that might help you guys out.
asdfghjkl13 is offline   0 Reply With Quote
Old Nov 18, 2012, 11:44 AM   #37
RJ7bb
macrumors newbie
 
Join Date: Nov 2012
Real Solution

Go to Settings/Mail, Contacts, Calendars then Calendars section: Default Alert Times/Birthdays. Switch it to None.
RJ7bb is offline   0 Reply With Quote
Old Nov 20, 2012, 11:18 AM   #38
tangomarty
macrumors newbie
 
Join Date: Oct 2012
Facebook birthdays

Quote:
Originally Posted by KaPOWitsCHRIS View Post
This worked great for me. I managed to recheck contacts and it didn't come back, although we'll wait and see for whoever has a birthday next.
Dont see any choice called facebook birthdays in Calendar app.
tangomarty is offline   0 Reply With Quote
Old Nov 20, 2012, 12:33 PM   #39
brylliant
Banned
 
Join Date: Jul 2012
Location: United Kingdom
Quote:
Originally Posted by parkm13 View Post
I am running iOS 6, when I logged into my account it began syncing all my friends birthdays to my calendar. This is not a big deal, as i can simply hide that calendar so they will not show up. However hiding the calendar will not remove the birthdays from the notification center. Having them there is very annoying and I would love to find out how to remove, only the events that came with Facebook, from notification center. Any help would be great!
Settings > Facebook > Allow These Apps to Use Your Account section > Turn 'Contacts' and 'Calendar' OFF. Leave Facebook ON.
brylliant is offline   0 Reply With Quote
Old Dec 1, 2012, 04:12 AM   #40
sainsburys
macrumors member
 
Join Date: Jun 2012
Location: Poland
Quote:
Originally Posted by KaPOWitsCHRIS View Post
This worked great for me. I managed to recheck contacts and it didn't come back, although we'll wait and see for whoever has a birthday next.
worked for me also!

Thanks!

P.S
Unfortunately, I realized that all conctacts from FB (in Contacts app) dissappeared.
__________________
MacBook Pro@2012. My first Mac.
iPhone 4. My first iPhone.
iPhone 5S.

Last edited by sainsburys; Dec 1, 2012 at 04:46 AM.
sainsburys is offline   0 Reply With Quote
Old Jan 10, 2013, 08:07 AM   #41
mikerudolph22
macrumors regular
 
Join Date: Jul 2008
Location: DC Metro Area
Quote:
Originally Posted by malaka View Post
Okay, so after a month of being frustrated, I finally discovered that you can disable just the birthday notifications by going to settings>mail, contacts, and calendars>Calendar: Default Alert Times>birthdays: select 'none'

Works for me and keeps my Facebook contact info intact. This should have been more straightforward than going to "default alert times," but at least now I don't get notifications every morning in class for random acquaintance birthday reminders.
YES!! Thank you!!!!
mikerudolph22 is offline   0 Reply With Quote
Old Jan 27, 2013, 12:51 PM   #42
elijahmetcalf
macrumors newbie
 
Join Date: Jan 2013
Hotmail was my culprit!

I had to go to hotmail.com and sign in thru safari, go to my calendars and delete my birthdays calendar all together to get rid of all the birthdays in my NC besides the ones in my phone i actually wanted.
elijahmetcalf is offline   0 Reply With Quote
Old Feb 2, 2013, 02:27 PM   #43
parkm13
Thread Starter
macrumors regular
 
Join Date: Aug 2010
I have tried everything on this form and nothing has worked so far. Anyone find a way to make it work?
parkm13 is offline   0 Reply With Quote
Old Mar 12, 2013, 06:02 AM   #44
laz91
macrumors newbie
 
Join Date: Jun 2012
Thought I had a solution but it failed
Only way that seems to work is turning off contacts in Facebook settings. Have to turn it back on and update every so often to get new contact pics which is annoying for us with OCD...
laz91 is offline   0 Reply With Quote
Old Mar 19, 2013, 07:30 PM   #45
C DM
macrumors G3
 
Join Date: Oct 2011
Quote:
Originally Posted by laz91 View Post
Thought I had a solution but it failed
Only way that seems to work is turning off contacts in Facebook settings. Have to turn it back on and update every so often to get new contact pics which is annoying for us with OCD...
You can also use an app like Sync.ME (http://www.sync.me/) instead for those kind of purposes.
C DM is offline   0 Reply With Quote
Old Apr 5, 2013, 08:38 AM   #46
breynol01
macrumors newbie
 
Join Date: Apr 2013
iphone 4s iOS 6.1.2 fix

No need to touch the Settings app, Calendar app, or Contacts app.
  1. Facebook app
  2. Pull out the left-side menu
  3. Account Settings
  4. Notifications
  5. Mobile Push
  6. Birthday Reminder

Worked for me, anyone else?
breynol01 is offline   0 Reply With Quote
Old May 1, 2013, 02:40 AM   #47
NotMyCupOfTea
macrumors newbie
 
Join Date: Jun 2011
Location: New Mexico
Finally!

I thought I had the answer below but by the time I finished writing it I noticed the problem was back. You can try it, but it just deletes the Birthdays temporarily.

There must be a problem with iCloud pushing it to the Calendar/Notifications. Has been no way for me to turn it off thus far. Another thing Apple needs to fix ASAP.

Even after deleting the Facebook app, it still does not work. For me, the only way it will work is to delete the Birthdays from the iCloud Contacts (merged from Facebook), but there is no way i'm doing for each individual contact...

-------------------

Ok, I've tried a bunch of things and this is what worked for me.

First do some of the things listed above i.e...

1. Settings/ Mail, Contacts, Calendars; turn off all calendars and Contacts in all of your accounts. It will ask you if you want to delete from phone, yes, do that too but be sure to have everything backed up in the Cloud first. Next go Default Alert Times and set it to None.
2. Delete the Facebook app.
3. In the Facebook Settings: turn off Contacts and Calendar.

Ok, now there should be no birthdays in your Calendar or in the Notifications pull-down menu. If there are birthdays there, then you probably didn't turn something off.

4. Now, Reinstall the Facebook app but do not turn on your Facebook Calendars or Contacts. Unfortunately this means you can't sync your Facebook Contacts with your iPhone.
5. Go back to Settings/ Mail, Contacts, Calendars. Turn on Contacts and Calendars.

You should have just about everything you want except Birthday notification.

This has worked for me when nothing else did. I'll check back to see if it worked for others.

--------------------

Again, did not work for me, but may be worth a try for others setup differently.

Last edited by NotMyCupOfTea; May 1, 2013 at 04:17 AM.
NotMyCupOfTea is offline   0 Reply With Quote
Old Aug 12, 2013, 01:52 AM   #48
domer2016
macrumors newbie
 
Join Date: Aug 2013
Notification Center Events Pulled Directly

https://discussions.apple.com/thread...art=0&tstart=0

As Kento Ito says, the events are pulled directly to the Notification Center, so nothing can change that. Seeing as disabling the Facebook contacts has been well addressed, I will answer the other question: contacts on the phone via manual input or syncing from an online email account (I only address Gmail) and also from your Mac Address Book.

There are two areas to address, your Mac Address Book and the email account.

GMAIL ACCOUNT
Use your iPhone to go to https://m.google.com/sync/settings and deselect "contact's birthdays and events" from the calendars that sync to your phone and click update. Your other calendars from Gmail will remain intact on your phone. You may have to turn calendars off and on from settings to refresh.

MAC ADDRESS BOOK
Go to iTunes with your iPhone plugged in. Click the iPhone button and then the Info tab. Deselect "Sync Calendars" and click update.

Now the only birthdays that show up are those directly from your contacts, which are entered manually or synced from your online email. No repeats should show up.
domer2016 is offline   0 Reply With Quote

Reply
MacRumors Forums > iPhone, iPod and iPad > iOS > iOS 6

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
iPhone: Birthdays stuck in notification center?! NickyLanzz iOS 7 3 Mar 4, 2014 02:54 PM
iPhone: Birthdays stuck in notification center?! NickyLanzz Jailbreaks and iOS Hacks 2 Mar 4, 2014 01:42 PM
Facebook birthdays in notification center GIZBUG OS X 10.8 Mountain Lion 6 Oct 13, 2012 08:33 AM
Birthdays in the notification center's calendar section iPhone Russ iPhone 4 Sep 28, 2012 12:06 PM
Remove Facebook birthdays from notification center wmitch iOS 6 2 Sep 23, 2012 02:29 PM

Forum Jump

All times are GMT -5. The time now is 05:00 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC