Go Back   MacRumors Forums > Special Interests > Digital Audio

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 2, 2012, 11:41 AM   #1
NBarnes21
macrumors member
 
Join Date: Apr 2010
Pro Tools 10 and processing power on my MacBook Pro- constant overloads

Figured I'd post this in the audio area rather than Mac Apps.

So I've been having regular issues with my MacBook Pro and ProTools 10. I bought the top of the line store model 15" MBP in January 2011, it was shortly before they had a refresh with newer chips. It has a Quad Core i7 2.8 GHZ intel chip, 4 GB RAM, and a 500 GB hard drive, running the most recent version of Lion.

I used to work in Logic as I do a lot of composing in my basement studio with virtual instruments, but I recently made the switch to PT10 in January because I want to get familiar with the industry standard DAW as I get more into tracking at studios and mixing projects. At home I am usually using a couple tracks of Amplitube 3, a vocal track or 2, and one track of EZ drummer in my composing sessions (maybe one or two tracks of a built in PT synth)- I constantly get CPU overloads and glitchy noises during playback/ MIDI editing. Up until now I've attributed these overloads to PT not being able to handle virtual instruments efficiently.

However, I'm now getting these overloads all the time, even today where I was laying a simple 2 mic drum track down to an existing backing track on it's own channel (RME Babyface interface, typically recording at 48k). I am using minimal plugins here, some parallel compression and a bit of EQ on the drums, not more than 5 or so plugins simultaneously.

Is this normal given my CPU's supposed processing power? I have PT set to only use 3 cores of the CPU, with a max of 80% (I read in the latest protools update read me that you can overload your comp if you allow more). Buffer size of 512. Would more RAM help this? I can install up to 8 GB, 4 GB installed currently. I've also been getting drive errors, even though I'm running off of an external 7200 RPM drive formatted in MaxOSX Extended (Journaled). I also had a bouncing to disk error today and had to up the buffer size to be able to bounce a simple 3 track mix. Something doesn't seem right here, any suggestions?
NBarnes21 is offline   0 Reply With Quote
Old Jul 2, 2012, 06:52 PM   #2
Soundburst
macrumors 6502a
 
Join Date: Oct 2006
Quote:
Originally Posted by NBarnes21 View Post
Figured I'd post this in the audio area rather than Mac Apps.

So I've been having regular issues with my MacBook Pro and ProTools 10. I bought the top of the line store model 15" MBP in January 2011, it was shortly before they had a refresh with newer chips. It has a Quad Core i7 2.8 GHZ intel chip, 4 GB RAM, and a 500 GB hard drive, running the most recent version of Lion.

I used to work in Logic as I do a lot of composing in my basement studio with virtual instruments, but I recently made the switch to PT10 in January because I want to get familiar with the industry standard DAW as I get more into tracking at studios and mixing projects. At home I am usually using a couple tracks of Amplitube 3, a vocal track or 2, and one track of EZ drummer in my composing sessions (maybe one or two tracks of a built in PT synth)- I constantly get CPU overloads and glitchy noises during playback/ MIDI editing. Up until now I've attributed these overloads to PT not being able to handle virtual instruments efficiently.

However, I'm now getting these overloads all the time, even today where I was laying a simple 2 mic drum track down to an existing backing track on it's own channel (RME Babyface interface, typically recording at 48k). I am using minimal plugins here, some parallel compression and a bit of EQ on the drums, not more than 5 or so plugins simultaneously.

Is this normal given my CPU's supposed processing power? I have PT set to only use 3 cores of the CPU, with a max of 80% (I read in the latest protools update read me that you can overload your comp if you allow more). Buffer size of 512. Would more RAM help this? I can install up to 8 GB, 4 GB installed currently. I've also been getting drive errors, even though I'm running off of an external 7200 RPM drive formatted in MaxOSX Extended (Journaled). I also had a bouncing to disk error today and had to up the buffer size to be able to bounce a simple 3 track mix. Something doesn't seem right here, any suggestions?
Have you tried the usual trashing preferences etc instructions that the avid forum FAQ would suggest?

Do you have the latest version of Pro Tools? (10.2)

I have NEVER messed around with setting my own core usage etc - I always let pro tools decide what's best and stick with the default.

I run Pro Tools 10 on a December 2011 13 inch MBP with an i5 and 4gb ram so you shouldn't be having problems.

Take a trip to the DUC AVID forums and in the troubleshooting thread there are instructions on how to trash preferencees and do a couple of other things that usually do resolve most of the problems you bump into.

If those couple of things don't fix your problem then post in the avid forums. The folk are extremely helpful (though they'll get annoyed if you don't follow the instuctions in the FAQ first!!).

Good luck mate

Edit: Here is the article which may help you. Follow these instructions and if you still have problems have an ask in the forum.

--------

Deleting Pro Tools Databases and Preferences

These are important steps in order to resolve various issues, such as assertion errors, graphic or display problems, and other intermittent issues that are not specifically hardware or compatibility related. Listed below are the paths to all the database and preference files installed by Pro Tools. Once you have deleted these files, you should empty the trash and restart your computer. These files will be recreated when Pro Tools is launched.

Pro Tools Databases

Double-click on the Macintosh HD icon on your desktop. *(This would be your system drive if you have renamed it to something else.)
Go to the Library folder.
Go to the Application Support folder.
Go to the Avid folder.
Go to the Pro Tools folder.
Find the folder called Databases and drag it to your trash.
NOTE: If you are using Pro Tools HD or Complete Production Toolkit, you will want to backup your Catalogs folder before deleting the Databases folder.
Pro Tools Preferences

From the Finder, click on the 'Go' menu at the top of your screen.
Press and hold the Option key on your keyboard and choose 'Library'.
Go to the Preferences folder.
Delete the following files:
com.digidesign.ProTools.plist
com.digidesign.ProTools.plist.lockfile
DAE Prefs
DigiSetup.OSX
Pro Tools*Prefs
--------
http://avid.force.com/pkb/articles/e...em_Preferences
__________________
13" MBP, 27" iMac.

Last edited by Soundburst; Jul 2, 2012 at 06:58 PM.
Soundburst is offline   1 Reply With Quote
Old Jul 3, 2012, 02:57 AM   #3
NBarnes21
Thread Starter
macrumors member
 
Join Date: Apr 2010
Thanks a ton for the info, I really appreciate it! Deleted the files and also read through the optimization article for Lion, was able to bring up a project and not have any playback issues but we'll see how it holds up over time. I definitely need to start using the DUC more, this migration from Logic has been quite the process! Thanks again
NBarnes21 is offline   0 Reply With Quote

Reply
MacRumors Forums > Special Interests > Digital Audio

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Constant Macbook Pro Kernel Panics? MrFluffums MacBook Pro 2 Mar 25, 2014 10:21 AM
MacBook Pro Constant lockups, worse than windows... FreudianSlap Mac Basics and Help 1 Sep 2, 2012 08:27 PM
Baseline Macbook Pro 13" For HD Video Editing, Pro Tools, Photoshop and more. trialsjames MacBook Pro 6 Aug 25, 2012 03:48 AM
Avid's Pro Tools X and Retina Macbook Pro Santiago17a Digital Audio 11 Jul 31, 2012 01:15 PM
ProTools 10 and processing power on my Mac Book Pro- constant overloads NBarnes21 Mac Applications and Mac App Store 0 Jul 1, 2012 10:17 PM

Forum Jump

All times are GMT -5. The time now is 11:24 AM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC