Register FAQ / Rules Forum Spy Search Today's Posts Mark Forums Read
Go Back   MacRumors Forums > Apple Systems and Services > Windows, Linux & Others on the Mac

Reply
 
Thread Tools Search this Thread Display Modes
Old Jul 10, 2012, 11:03 PM   #1
The Afroman
macrumors regular
 
Join Date: Jul 2009
Location: Austin,Tx
Exclamation Unable to install Windows 7 to 2nd Drive on 2012 Macbook Pro

Replaced my Superdrive with another HDD (500gb 7200RPM)
I launched Boot Camp Assistant and ran through the process of making a USB install of Windows 7 using an ISO.

Then proceeded to do the install..


After this the machine reboots and starts the setup..


I select the Boot Camp partition created by the Boot Camp Assistant..


Proceed to format it.


After the format it still says "Windows can't be installed on Disk 1 Partiton 2"


If i hit OK and try to continue i get this..


Am i missing something here? I have done windows 7 boot camp installs before but i have never seen this.. i can't seem to find a fix.. is it my windows 7? it has SP1.. has anyone with a new 2012 Macbook Pro 2012 seen this?
The Afroman is offline   0 Reply With Quote
Old Jul 11, 2012, 04:40 PM   #2
PhixionFilms
macrumors 6502
 
Join Date: Dec 2008
Location: Deployed atm
Send a message via AIM to PhixionFilms Send a message via Skype™ to PhixionFilms
Quote:
Originally Posted by The Afroman View Post
Replaced my Superdrive with another HDD (500gb 7200RPM)
I launched Boot Camp Assistant and ran through the process of making a USB install of Windows 7 using an ISO.

Then proceeded to do the install.. Image
Image

After this the machine reboots and starts the setup..
Image

I select the Boot Camp partition created by the Boot Camp Assistant..
Image

Proceed to format it.
Image

After the format it still says "Windows can't be installed on Disk 1 Partiton 2"
Image

If i hit OK and try to continue i get this..
Image

Am i missing something here? I have done windows 7 boot camp installs before but i have never seen this.. i can't seem to find a fix.. is it my windows 7? it has SP1.. has anyone with a new 2012 Macbook Pro 2012 seen this?
Click the format button then it would work. Problem is you probably used bootcamp assistant which uses GUID. You need it to be Master boot in order for it to work. Just click on the partition in that selection, hit format then it will format it. Then you should be good to go.
__________________
Think Different.
PhixionFilms is offline   0 Reply With Quote
Old Jul 12, 2012, 02:59 PM   #3
ugp
macrumors 65816
 
ugp's Avatar
 
Join Date: Jan 2008
Location: Inverness, Florida
Send a message via AIM to ugp Send a message via Yahoo to ugp Send a message via Skype™ to ugp
I plan on installing Windows on my second HDD tomorrow when I swap the Optical out. I will report my problems if I have any.
__________________
15" MBP Mid-2012, 2.6 i7, 16GB, Crucial M4 256GB, 1GB 650m
iPhone 5 16GB Black
2nd Gen 16GB iPad Mini
ugp is offline   0 Reply With Quote
Old Jul 12, 2012, 06:00 PM   #4
The Afroman
Thread Starter
macrumors regular
 
Join Date: Jul 2009
Location: Austin,Tx
i would totally like to see if it does.. because.. it doesn't work.. i EVEN wiped my drive. Started from scratch.. wiped ML, and did a clean install. Then started Boot Camp ran through process and pointed it to the clean 500GB in my 2nd bay. Then it formatted and restarted.. same issue. I had to do a partition on my main drive which i DID NOT want to do. But i worked on this at EVER angle.. for 2 days, even downloaded the Windows 8 Preview.. and it did the same thing.

Windows 7 or Windows in general does not WANT to be installed on a second drive.. which makes no SENSE.
The Afroman is offline   0 Reply With Quote
Old Jul 13, 2012, 11:29 AM   #5
monstercactus
macrumors newbie
 
Join Date: Jul 2012
I have the exact problem and error with my 2012 MPB 13. The only difference is that the second drive is an SSD. Weird thing is I was able to install Win 7, no sweat, on my older, 2010 MBP 13, same scenario.

Sadly, on the 2012 I wasn't able to make it boot on the first disk either - though it completed installation. I get the black screen with the blinking cursor.
These events are new to me :|
monstercactus is offline   0 Reply With Quote
Old Jul 14, 2012, 02:08 PM   #6
antimpaaman
macrumors newbie
 
Join Date: Jul 2012
I'd like to report the same problem. I have a MacBook Pro 2012 (non-retina) with an Apple SSD and a second Samsung SSD in the optical bay.

After a lot of effort I managed to find out how to get Windows 7 installed by removing the Apple SSD and just leaving the Samsung in the bay.

With just that single drive, the machine will boot to Windows 7 as expected... however when I add the Apple SSD back in, it caused the above symptoms.

I believe the issue is coming from Windows trying to load itself from the wrong drive and the key to fixing this is going to be in the MBR/GPT setup or the BCD setup for windows.

One other odd occurrence that I observed was with actually installing Windows 7. Windows 7 seems to enumerate the first and second differently on occasion and I have no idea why. Sometimes it will show up as the Samsung as being Drive 0 and sometimes Drive 1.

If anyone knows someone with a background in fixing boot loader issues and wants diagnostic data then please let me know. I'm happy to run commands and tinker on this for the time being.
antimpaaman is offline   0 Reply With Quote
Old Jul 14, 2012, 11:47 PM   #7
arashb
Banned
 
Join Date: May 2009
@The Afroman, is EFI boot supported on your Windows 8 preview? I heard Windows 8 will have support for it but I'm not sure if it already does. If so create an extra partition using disk utility. Then install rEFIt/rEFInd and try to boot up the Windows 8 disk by holding alt/option and install Windows like that.

I'm guessing the computer is having issues since the main disk is GUID while the secondary will be MBR. Not sure if that should effect it but you never know, this may be why antimpaaman is having issues when he reinstalls his GUID drive.
arashb is offline   0 Reply With Quote
Old Jul 15, 2012, 07:26 AM   #8
Sincci
macrumors regular
 
Join Date: Aug 2011
Location: Finland
Some Macs are unable to install and boot Windows from drives that are installed in the optibay. The only way to get it working to install that drive in the mainbay and the OS X disk in the optibay since OS X doesn't care where it's installed.
Sincci is offline   0 Reply With Quote
Old Jul 15, 2012, 03:11 PM   #9
antimpaaman
macrumors newbie
 
Join Date: Jul 2012
@Sincci, Can you point to another thread or some documentation about why that happens? It has to be something to do with the weird GPT/MBR setup that Apple uses to trick Windows into booting.

I want to find some more documentation about this before I go swapping drives around again. I'll give it a try though and see what happens. I think it has something to do with the way the machine is enumerating the drives and setting up the MBR but I'm not quite sure what.
antimpaaman is offline   0 Reply With Quote
Old Jul 15, 2012, 06:20 PM   #10
arashb
Banned
 
Join Date: May 2009
try to install mac os x on the optibay drive without moving it and then bootcamp windows while using the mac on the optibay. Then just delete OS X off that drive.
arashb is offline   0 Reply With Quote
Old Jul 15, 2012, 08:02 PM   #11
antimpaaman
macrumors newbie
 
Join Date: Jul 2012
Quote:
Originally Posted by arashb View Post
try to install mac os x on the optibay drive without moving it and then bootcamp windows while using the mac on the optibay. Then just delete OS X off that drive.

No luck with that one. Same problem when Windows trys to boot.
antimpaaman is offline   0 Reply With Quote
Old Jul 15, 2012, 08:19 PM   #12
antimpaaman
macrumors newbie
 
Join Date: Jul 2012
Quote:
Originally Posted by Sincci View Post
Some Macs are unable to install and boot Windows from drives that are installed in the optibay. The only way to get it working to install that drive in the mainbay and the OS X disk in the optibay since OS X doesn't care where it's installed.
Swapping the drives definitely fixes the problem it would seem. I'd still really like to know why and how to avoid doing it.
antimpaaman is offline   0 Reply With Quote
Old Jul 15, 2012, 11:49 PM   #13
The Afroman
Thread Starter
macrumors regular
 
Join Date: Jul 2009
Location: Austin,Tx
I tried it all.. Windows 8 and 7.. Same issues. When i pulled my main drive out.. it allowed it to install. as soon as the drive was placed back in.. errored out, and would no longer boot windows. rEFIit did not work at all. it wouldn't even see the windows install.

What i found weird is.. with the install that came with the Mac i was also UNABLE to install windows 7 on a partition on drive 0 (main drive) it would give me a GPT error.. which is stupid because the whole point of boot camp is too allow this.. SO...

I wiped my main drive.. and started again from scratch WITH a clean Mountain Lion install. Once ML was up and running i tried to install again on second drive.. and failed.. BUT it did allow me to install to a 250GB partition on main drive.

I don't know what the deal is.. but his should not be an issue.
The Afroman is offline   0 Reply With Quote
Old Jul 16, 2012, 12:52 AM   #14
tatt
macrumors newbie
 
Join Date: Jul 2012
Quote:
Originally Posted by The Afroman View Post
I tried it all.. Windows 8 and 7.. Same issues. When i pulled my main drive out.. it allowed it to install. as soon as the drive was placed back in.. errored out, and would no longer boot windows. rEFIit did not work at all. it wouldn't even see the windows install.

What i found weird is.. with the install that came with the Mac i was also UNABLE to install windows 7 on a partition on drive 0 (main drive) it would give me a GPT error.. which is stupid because the whole point of boot camp is too allow this.. SO...

I wiped my main drive.. and started again from scratch WITH a clean Mountain Lion install. Once ML was up and running i tried to install again on second drive.. and failed.. BUT it did allow me to install to a 250GB partition on main drive.

I don't know what the deal is.. but his should not be an issue.
nothing seems to work for me too...from Mountain Lion, SSD shows disk0s2 however from windows 7 installer SSD shows disk1s2.

i cant seem to get my ssd to be disk0 apart from when the SATA is unplugged.

Macbook Pro 13" mid-2012
Mountain Lion GM
tatt is offline   0 Reply With Quote
Old Jul 16, 2012, 07:50 AM   #15
antimpaaman
macrumors newbie
 
Join Date: Jul 2012
As I said, I finally got mine working by swapping the drives around. I'm going to post exactly what I did below in case it is useful to someone else.

Start with both drives in the machine. Boot into OS X and run the bootcamp assistant on the second drive as though you are going to kick off an install. The machine will reboot. Don't install Windows yet. Shut the machine down with the power button.

With the machine off, remove the OS X drive from the system. Power the machine back on and install Windows 7 on the system as you normally would for a bootcamp install.

Let the install for Windows 7 finish and install the Apple software for Windows 7. You don't need to install that at this point but you might as well since you're probably going to install it later anyway.

Turn the machine off. With the machine off, swap the drives. Put the OS X drive in the optibay and put the Windows 7 drive in the regular disk slot. If you swapped the drives previously then you don't need to worry about doing it again. The bottom line is that you want to end up with the OS X drive in the optibay and the Windows 7 drive in the regular disk slot.

At this point, you can boot the machine and you should be able to select between the two different operating systems.

Please be on the lookout for gorillas while taking your computer apart. There are a bunch of posts from people who have cracked plastic and stripped screws trying to replace drives. I don't know how or why anyone would allow a gorilla to work on a laptop or be near a laptop while it is being worked on but do yourself a favor and be watchful.
antimpaaman is offline   0 Reply With Quote
Old Jul 16, 2012, 09:13 AM   #16
Sincci
macrumors regular
 
Join Date: Aug 2011
Location: Finland
Quote:
Originally Posted by antimpaaman View Post
Swapping the drives definitely fixes the problem it would seem. I'd still really like to know why and how to avoid doing it.
I guess it's just an limitation in the way bootcamp works that the Windows installation needs to be on disk0 to work properly. Sadly after all these years, Apple hasn't done anything about it since the "normal way" for people to install bootcamp is just to install it on the same disk0 with OS X (I mean, the optibay's are not supported by Apple anyway, so why would they support installing Windows on them).

However, the only people who might do this "legitimately" are the Mac Pro and Mac Mini server users and they have been reporting exactly the same issue.

Anyway, here's how my installation went with my 128GB Samsung 830 Series SSD and 1TB Samsung M8 Series HDD.

I first installed the SSD in the mainbay and the HDD in the optibay (both drives were empty with no partitions at all), then booted my Lion installation DVD with an external usb dvd-drive, partitioned my HDD to something like 128GB HFS+ for OS X and the rest as exfat. I proceeded by installing OS X normally and went to bootcamp assistant after the installation was finished. I picked my SSD drive for the installation and continued the installation with my Windows 7 x64 dvd. Finally, after the Windows installation was done, I reformated the exfat drive to NTFS and installed the bootcamp drivers.

After that I quickly booted into both of the operating systems to check that they are working and that's it.
Sincci is offline   0 Reply With Quote
Old Jul 17, 2012, 01:39 AM   #17
tatt
macrumors newbie
 
Join Date: Jul 2012
Quote:
Originally Posted by Sincci View Post
I guess it's just an limitation in the way bootcamp works that the Windows installation needs to be on disk0 to work properly. Sadly after all these years, Apple hasn't done anything about it since the "normal way" for people to install bootcamp is just to install it on the same disk0 with OS X (I mean, the optibay's are not supported by Apple anyway, so why would they support installing Windows on them).

However, the only people who might do this "legitimately" are the Mac Pro and Mac Mini server users and they have been reporting exactly the same issue.

Anyway, here's how my installation went with my 128GB Samsung 830 Series SSD and 1TB Samsung M8 Series HDD.

I first installed the SSD in the mainbay and the HDD in the optibay (both drives were empty with no partitions at all), then booted my Lion installation DVD with an external usb dvd-drive, partitioned my HDD to something like 128GB HFS+ for OS X and the rest as exfat. I proceeded by installing OS X normally and went to bootcamp assistant after the installation was finished. I picked my SSD drive for the installation and continued the installation with my Windows 7 x64 dvd. Finally, after the Windows installation was done, I reformated the exfat drive to NTFS and installed the bootcamp drivers.

After that I quickly booted into both of the operating systems to check that they are working and that's it.

i manage to get it to work

steps:

1. using windows 7 installer, partition the SSD (primary partition) into 2 (1st for OSX and 2nd for W7)
2. now with 2 partitions, install w7
3. install OSX and it should create a recovery disk then complete installation.
4. now during start up, hold down alt, and you should see 3 partitions, OSX, W7 and recovery disk (for OSX)

works for me
tatt is offline   0 Reply With Quote
Old Jul 17, 2012, 04:24 PM   #18
NMF
macrumors 6502a
 
Join Date: Oct 2011
Quote:
Originally Posted by tatt View Post
i manage to get it to work

steps:

1. using windows 7 installer, partition the SSD (primary partition) into 2 (1st for OSX and 2nd for W7)
2. now with 2 partitions, install w7
3. install OSX and it should create a recovery disk then complete installation.
4. now during start up, hold down alt, and you should see 3 partitions, OSX, W7 and recovery disk (for OSX)

works for me
Is your SSD in the optical bay? Also, how did you go about getting the boot camp drivers/software in your Win7 install?

I have my SSD I. The optical bay and my stock Apple HDD in the main bay. I'd ideally like to have both OSX and Windows 7 installed on the SSD (and keep it in the optical bay), but I'm getting the same errors as the OP when I try to install Windows via bootcamp.
__________________
MacBook Air 13" (2013) Mac mini (2011) OS X Server + Drobo 5D
AirPort Time Capsule (2013) iPhone 5 TV 3
NMF is offline   0 Reply With Quote
Old Jul 17, 2012, 09:43 PM   #19
tatt
macrumors newbie
 
Join Date: Jul 2012
Quote:
Originally Posted by NMF View Post
Is your SSD in the optical bay? Also, how did you go about getting the boot camp drivers/software in your Win7 install?

I have my SSD I. The optical bay and my stock Apple HDD in the main bay. I'd ideally like to have both OSX and Windows 7 installed on the SSD (and keep it in the optical bay), but I'm getting the same errors as the OP when I try to install Windows via bootcamp.
SSD in HDD Bay, orignal apple HDD in Optical bay caddy.

HDD already partitioned, so no problem.
SDD partitioned with W7, install then only install OSX which will create recovery partition. didn't use bootcamp.

not all drivers are working. used windows support set of drivers. apparantly does not quite support ivy bridge.

no sound, VGA - no hardware acceleration, mostly okay. still searching for VGA.
tatt is offline   0 Reply With Quote
Old Jul 20, 2012, 08:45 PM   #20
ugp
macrumors 65816
 
ugp's Avatar
 
Join Date: Jan 2008
Location: Inverness, Florida
Send a message via AIM to ugp Send a message via Yahoo to ugp Send a message via Skype™ to ugp
I tried installing Windows 7 to my HDD in the Optical Bay and it was a no go.
__________________
15" MBP Mid-2012, 2.6 i7, 16GB, Crucial M4 256GB, 1GB 650m
iPhone 5 16GB Black
2nd Gen 16GB iPad Mini
ugp is offline   0 Reply With Quote
Old Jul 21, 2012, 07:56 PM   #21
poppakristof
macrumors newbie
 
Join Date: Oct 2010
You cannot have two drives visible during the Windows 7 install.
For my 2012 MBP15, I have my original 500 GB hard drive and the 80 GB SSD in the opti drive bay.
This is what I did to get it installed and I have installed on both drives, opti and hdd bay.
I had Win7 installed to the HDD but I dumped that and installed again to the SDD, I like the speed.

1) Create a working BOOTABLE Installation flash drive of Windows 7 (if you don't know what this is, google it to find out how to create one)
2) Decide which drive you want to install windows too
3) From Mac OS X, Plug in the flash drive with the Win7 installer on it
4) Run Boot Camp and start the installation
5) After partition OS X will reboot automatically, do not let it reboot, when the screen goes dark, hold the power button to turn off the machine, do not start the Win7 installer
6) Unplug the flash drive and all cables
7) Take off the back cover of the MBP and disconnect the ribbon to the drive that Windows is NOT being installed to
8) Put a piece of paper between the ribbon and the connector on the logic board so it does not make a contact. This will define the drive as drive0 for the install process.
9) Put the back cover on but do NOT screw it closed
10) Plug the flash drive back in and power cable
11) Boot the computer holding down the OPTION key
12) Select the flash drive, it is orange in color, NOT Macintosh HD or Recovery HD
13) Windows 7 installer starts... format the BOOTCAMP partiton... and install windows to that just formatted partition
14) The Win7 install may reboot once or twice do not do anything, let it do its thing
15) When Win7 is installed, running windows, desktop and programs can be ran, shut down the computer *you cannot install the apple drivers just yet, be patient*
16) Unplug all cables and the flash drive
17) Take cover off and reattach the ribbon you disconnected earlier, you dont need the paper either
18) Screw down the cover
19) Reconnect the power cable and start up the computer, holding OPTION, and boot to Mac OS X
20) Take a 2GB flash drive, formatted in Disk Utility using FAT
21) Run Boot Camp, download the latest drivers from Apple, save it to the external drive which is the 2GB flash drive
22) You will need to install an utility to allow Mac OS X to be able to write to NTFS partitions. Google it to find a couple of shareware/trial utilities, don't buy it as you will only use it once. *There is a terminal command but it is unreliable and could cause data loss*
23) After installing the utility, copy the folder WindowsSupport to the Windows 7 hard drive, it should be called Untitled by default. If you copy it directly to there, the folder will be located at the root of C:
24) Install the utility, not needed anymore
25) Restart you machine, hold Option and boot to Windows
26) Go to the WindowsSupport folder and start the driver installation *I did not have any issues with unrecognized drivers after the complete driver install. It complained once during the install but after the reboot I checked Devices and all are ok, no exclamation marks for unknown hardware*

I rarely post here, so if you have any questions I'm sorry in advance when I don't reply.

Last edited by poppakristof; Jul 21, 2012 at 08:04 PM. Reason: Added note about drivers
poppakristof is offline   0 Reply With Quote
Old Jul 24, 2012, 09:15 PM   #22
NMF
macrumors 6502a
 
Join Date: Oct 2011
Quote:
Originally Posted by poppakristof View Post
You cannot have two drives visible during the Windows 7 install.
For my 2012 MBP15, I have my original 500 GB hard drive and the 80 GB SSD in the opti drive bay.
This is what I did to get it installed and I have installed on both drives, opti and hdd bay.
I had Win7 installed to the HDD but I dumped that and installed again to the SDD, I like the speed.

1) Create a working BOOTABLE Installation flash drive of Windows 7 (if you don't know what this is, google it to find out how to create one)
2) Decide which drive you want to install windows too
3) From Mac OS X, Plug in the flash drive with the Win7 installer on it
4) Run Boot Camp and start the installation
5) After partition OS X will reboot automatically, do not let it reboot, when the screen goes dark, hold the power button to turn off the machine, do not start the Win7 installer
6) Unplug the flash drive and all cables
7) Take off the back cover of the MBP and disconnect the ribbon to the drive that Windows is NOT being installed to
8) Put a piece of paper between the ribbon and the connector on the logic board so it does not make a contact. This will define the drive as drive0 for the install process.
9) Put the back cover on but do NOT screw it closed
10) Plug the flash drive back in and power cable
11) Boot the computer holding down the OPTION key
12) Select the flash drive, it is orange in color, NOT Macintosh HD or Recovery HD
13) Windows 7 installer starts... format the BOOTCAMP partiton... and install windows to that just formatted partition
14) The Win7 install may reboot once or twice do not do anything, let it do its thing
15) When Win7 is installed, running windows, desktop and programs can be ran, shut down the computer *you cannot install the apple drivers just yet, be patient*
16) Unplug all cables and the flash drive
17) Take cover off and reattach the ribbon you disconnected earlier, you dont need the paper either
18) Screw down the cover
19) Reconnect the power cable and start up the computer, holding OPTION, and boot to Mac OS X
20) Take a 2GB flash drive, formatted in Disk Utility using FAT
21) Run Boot Camp, download the latest drivers from Apple, save it to the external drive which is the 2GB flash drive
22) You will need to install an utility to allow Mac OS X to be able to write to NTFS partitions. Google it to find a couple of shareware/trial utilities, don't buy it as you will only use it once. *There is a terminal command but it is unreliable and could cause data loss*
23) After installing the utility, copy the folder WindowsSupport to the Windows 7 hard drive, it should be called Untitled by default. If you copy it directly to there, the folder will be located at the root of C:
24) Install the utility, not needed anymore
25) Restart you machine, hold Option and boot to Windows
26) Go to the WindowsSupport folder and start the driver installation *I did not have any issues with unrecognized drivers after the complete driver install. It complained once during the install but after the reboot I checked Devices and all are ok, no exclamation marks for unknown hardware*

I rarely post here, so if you have any questions I'm sorry in advance when I don't reply.
So just to confirm, using this method you were able to install Windows on to an SSD in the optical bay, yes? If so then this is great news. Basically all you need to do is disconnect the HDD to do it.

However, do you have a link to a guide on how to make a bootable Win7 USB in OSX? I currently don't have any access to Windows at all.
__________________
MacBook Air 13" (2013) Mac mini (2011) OS X Server + Drobo 5D
AirPort Time Capsule (2013) iPhone 5 TV 3

Last edited by NMF; Jul 24, 2012 at 09:20 PM.
NMF is offline   0 Reply With Quote
Old Jul 24, 2012, 10:40 PM   #23
AfzalivE
macrumors member
 
Join Date: Jun 2012
Try installing Refit and boot from each of the listed USB drives (shows something like 3 options for the same bootable windows usb).

I tried removing the original drive and everything and this is the only way it's worked for me. Only one of them (not the EFI one) worked.
__________________
MacBook Pro late 2012, 15.4" Hi-res Anti-glare
2.6 Ghz, 8 GB RAM, 750GB 7200rpm HD & 128GB OCZ Vertex 4
AfzalivE is offline   0 Reply With Quote
Old Aug 10, 2012, 08:03 PM   #24
Macusercom
macrumors newbie
 
Join Date: Aug 2012
I got exactly the same issues with my 15-inch MacBook Pro Mid 2012. Here is what I could figure out:

- The error occurs no matter which drive you select. I'm using the internal optical drive (in an external case connected via USB) and I have a Windows 7 Upgrade DVD (32 and 64 bit) and a 64 bit refurbished DVD from Dell. I was also using a Windows 7 Home Premium ISO image on a USB flash drive. I always get the 0x80300024 error. Windows keep saying that the controller is not activated in the BIOS.

- If you disconnect the primary hard drive (the "normal" bay for hard drives) and try to install Windows on the secondary, it works. It won't boot if you connect the primary hard drive again.

- Installing Windows on the primary hard drive works with no issues. So if you have a SSD and you want Windows on the HDD, you will have to put the SSD to the secondary connector, which is originally provided for the optical drive. According to my local Apple Authorised Service Provider the can cause issues with the hibernate mode, but I can't confirm this, since I didn't test it (Windows is more important for me than the hibernate mode).

- Partitioning all drives and leave it without a partition (so it's just empty) doesn't let the BIOS message disappear, but it will install on the secondary drive even if two hard drives are connected. You will get an error after the first reboot with the error "0xc000000e" and something about winload.exe.

- Partitioning all drives with the Master Boot Record and FAT in OS X' Disk Utility ends up with the same error mentioned above. I did this, because other users reporting this problem said that it worked again. This may apply to the Mac mini 2011 and the Mac Pro, but didn't work with the MacBook Pro Mid 2012.

- Installing Windows on the primary drive and then switching it on the secondary drive does not work. It says that "no bootable drive" has been found.

The best solution is to put the SSD to the secondary connector (the one from the optical drive) and install Windows on the HDD connected via the primary connector (the "normal" one). Again: this may cause some issues with the hibernate mode and the SSD, but this may not be an information, which is up-to-date. Maybe this doesn't apply to the newest models and there is no other solution I can find. I can't even say if it's a Windows problem or one from Apple. Since the original Windows 7 installation DVDs have the same issue as the USB flash drives created by the Boot Camp helper application it could only be a hardware problem or a wrong setting so that the secondary connector is not working properly. Nevertheless, Windows is more important than a working hibernate mode.

Both hard drives without a partition and installing Windows 7 Home Premium on the second drive works. However, you get this message during the installation after the first reboot (sorry, it's in German):



The error before the Windows 7 Home Premium installation:

Last edited by Macusercom; Aug 10, 2012 at 08:18 PM.
Macusercom is offline   0 Reply With Quote
Old Oct 25, 2012, 11:53 PM   #25
noodile
macrumors regular
 
Join Date: Aug 2012
anyone end up finding another solution to this? all i want is SSD with OSX in primary and HDD with Win7 in secondary. i was hoping someone would've found a solution by now
noodile is offline   0 Reply With Quote

Reply
MacRumors Forums > Apple Systems and Services > Windows, Linux & Others on the Mac

Tags
0x80300024, 2nd hdd, boot camp, mbp 2012, windows 7 install

Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes

Similar Threads
thread Thread Starter Forum Replies Last Post
Late 2012 iMac - Boot camp windows unable to see mac partition as a drive Leonavice iMac 12 Sep 4, 2013 08:30 PM
Mid 2012 MacBook Pro in for repair for the 2nd time Elmzeh MacBook Pro 1 Jun 22, 2013 05:15 PM
Resolved: Unable to install Windows 8 on iMac 2012 mac.rumors Windows, Linux & Others on the Mac 6 Feb 27, 2013 01:35 PM
Late 2006 MacBook Pro trying to install Windows 7 using a flash drive mobci Windows, Linux & Others on the Mac 0 Feb 2, 2013 07:57 AM
Install Windows on MacBook Pro using External Hard Drive Rover-dude Mac OS X 10.7 Lion 1 Nov 29, 2012 03:59 AM

Forum Jump

All times are GMT -5. The time now is 02:46 PM.

Mac Rumors | Mac | iPhone | iPhone Game Reviews | iPhone Apps

Mobile Version | Fixed | Fluid | Fluid HD
Copyright 2002-2013, MacRumors.com, LLC